Funzione SOMMA.SE

Importante :  Il presente articolo è stato tradotto automaticamente, vedere la dichiarazione di non responsabilità. Per visualizzare la versione inglese dell'articolo, fare clic qui.

È possibile usare la funzione SOMMA.SE per sommare i valori di un intervallo che soddisfano i criteri specificati. Supponiamo ad esempio di voler sommare in una colonna contenente numeri solo i valori maggiori di 5. In tal caso, usare la formula seguente: =SOMMA.SE(B2:B25;">5")

Il browser in uso non supporta le funzionalità video. Installare Microsoft Silverlight, Adobe Flash Player o Internet Explorer 9.

Questo video fa parte di un corso di formazione intitolato Sommare numeri in Excel 2013.

Suggerimenti : Se si vuole, è possibile applicare i criteri a un intervallo e sommare i valori corrispondenti in un altro intervallo. Ad esempio, la formula =SOMMA.SE(B2:B5; "Luca"; C2:C5) sommerà solo i valori dell'intervallo C2:C5 per cui il contenuto delle celle corrispondenti nell'intervallo B2:B5 è uguale a "Luca".

Per sommare le celle in base a più criteri, vedere la funzione SOMMA.PIÙ.SE.

Sintassi

SOMMA.SE(intervallo; criteri; [int_somma])

Gli argomenti della sintassi della funzione SOMMA.SE sono i seguenti:

  • intervallo   Obbligatorio. Intervallo di celle da valutare in base ai criteri. Le celle di ogni intervallo devono contenere numeri oppure nomi, matrici o riferimenti che includono numeri. Le celle vuote e i valori di testo verranno ignorati. L'intervallo selezionato può contenere date nel formato standard di Excel (vedere gli esempi di seguito).

  • criteri   Obbligatorio. Criteri in forma di numero, espressione, riferimento di cella, testo o funzione che definisce le celle che verranno sommate. Ad esempio, è possibile esprimere i criteri come 32, ">32", B5, "32", "mele" oppure OGGI().

    Importante : Qualsiasi criterio di testo o di altro tipo comprendente simboli logici o matematici deve essere racchiuso tra virgolette doppie ("). Se il criterio è numerico, le virgolette doppie non saranno necessarie.

  • int_somma   Facoltativo. Celle effettivamente da sommare, se si vogliono sommare celle diverse da quelle specificate nell'argomento intervallo. Se l'argomento int_somma è omesso, verranno sommate le celle specificate nell'argomento intervallo, ovvero le stesse celle a cui vengono applicati i criteri.

  • Nell'argomento criteri è possibile usare i caratteri jolly, ovvero il punto interrogativo (?) e l'asterisco (*). Usare il punto interrogativo e l'asterisco per indicare rispettivamente un carattere singolo e una sequenza di caratteri qualsiasi. Se si desidera trovare un punto interrogativo o un asterisco, digitare una tilde (~) prima del carattere.

Osservazioni

  • La funzione SOMMA.SE restituirà risultati non corretti se usata per la corrispondenza con stringhe contenenti più di 255 caratteri o con la stringa #VALORE!.

  • L'argomento int_somma non deve necessariamente avere le stesse dimensioni e forma dell'argomento intervallo. Le celle effettivamente da sommare vengono determinate usando la cella superiore sinistra dell'argomento int_somma come cella iniziale e includendo le celle che corrispondono all'argomento intervallo in termini di dimensioni e forma. Ad esempio:

Se intervallo è

E int_somma è

Le celle effettive sono

A1:A5

B1:B5

B1:B5

A1:A5

B1:B3

B1:B5

A1:B4

C1:D4

C1:D4

A1:B4

C1:C2

C1:D4

Quando tuttavia gli argomenti intervallo e int_somma nella funzione SOMMA.SE non contengono lo stesso numero di celle, il ricalcolo di un foglio di lavoro può richiedere più tempo del previsto.

Esempi

Esempio 1

Copiare i dati di esempio contenuti nella tabella seguente e incollarli nella cella A1 di un nuovo foglio di lavoro Excel. Affinché le formule mostrino i risultati, selezionarle, premere il tasto F2 e quindi Invio. Se necessario, adattare l'ampiezza delle colonne per visualizzare tutti i dati.

Valore proprietà

Commissione

Dati

€ 100.000,00

€ 7.000,00

€ 250.000,00

€ 200.000,00

€ 14.000,00

€ 300.000,00

€ 21.000,00

€ 400.000,00

€ 28.000,00

Formula

Descrizione

Risultato

=SOMMA.SE(A2:A5;">160000";B2:B5)

Somma delle commissioni relative ai valori di proprietà maggiori di 160.000.

€ 63.000,00

=SOMMA.SE(A2:A5;">160000")

Somma dei valori di proprietà maggiori di 160.000.

€ 900.000,00

=SOMMA.SE(A2:A5;300000;B2:B5)

Somma delle commissioni relative ai valori di proprietà uguali a 300.000.

€ 21.000,00

=SOMMA.SE(A2:A5;">" & C2;B2:B5)

Somma delle commissioni relative ai valori di proprietà maggiori del valore in C2.

€ 49.000,00

Esempio 2

Copiare i dati di esempio contenuti nella tabella seguente e incollarli nella cella A1 di un nuovo foglio di lavoro Excel. Affinché le formule mostrino i risultati, selezionarle, premere il tasto F2 e quindi Invio. Se necessario, adattare l'ampiezza delle colonne per visualizzare tutti i dati.

Categoria

Cibo

Vendite

Verdura

Pomodori

€ 2.300,00

Verdura

Sedano

€ 5.500,00

Frutta

Arance

€ 800,00

Burro

€ 400,00

Verdura

Carote

€ 4.200,00

Frutta

Mele

€ 1.200,00

Formula

Descrizione

Risultato

=SOMMA.SE(A2:A7;"Frutta";C2:C7)

Somma delle vendite di tutti gli alimenti della categoria "Frutta".

€ 2.000,00

=SOMMA.SE(A2:A7;"Verdura";C2:C7)

Somma delle vendite di tutti gli alimenti della categoria "Verdura".

€ 12.000,00

=SOMMA.SE(B2:B7;"*e";C2:C7)

Somma delle vendite di tutti gli alimenti il cui nome finisce per "e" (Zucchine, Arance e Mele).

€ 4.300,00

=SOMMA.SE(A2:A7;"";C2:C7)

Somma delle vendite di tutti gli alimenti non assegnati a una categoria specifica.

€ 400,00

Inizio pagina

Si dispone di una domanda di funzione specifica?

Post una domanda nel forum della community di Excel

Migliorare le prestazioni di Excel

Si hanno suggerimenti su come migliorare la prossima versione di Excel? In questo caso, guardare gli argomenti in Excel User Voice.

Nota : Dichiarazione di non responsabilità per la traduzione automatica: Il presente articolo è stato tradotto tramite un software di traduzione automatica e non da una persona. Microsoft offre le traduzioni automatiche per consentire a coloro che non conoscono la lingua inglese di leggere gli articoli sui prodotti, sui servizi e sulle tecnologie Microsoft. Dal momento che l'articolo è stato tradotto automaticamente, potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli.

Vedere anche

La funzione somma.Se somma solo i valori che soddisfano un singolo criterio

La somma q somma i valori più dopo l'esecuzione di un'operazione matematica quadrata di ciascuno

Funzione CONTA.Se il conta solo i valori che soddisfano un singolo criterio

Conta la funzione conta solo i valori che soddisfano più criteri

IFS funzionare (Office 365, Excel 2016 e versioni successive)

Panoramica delle formule in Excel

Come evitare errori nelle formule

Errori di utilizzo per trovare gli errori nelle formule

Matematiche e trigonometriche funzioni

Funzioni di Excel (in ordine alfabetico)

Funzioni di Excel (in base alla categoria)

Queste informazioni sono risultate utili?

Ottimo! Altri commenti?

Cosa possiamo migliorare?

Grazie per i tuoi commenti e suggerimenti

×