Funzione SE

Importante :  Il presente articolo è stato tradotto automaticamente, vedere la dichiarazione di non responsabilità. Per visualizzare la versione inglese dell'articolo, fare clic qui.

La funzione se è una delle funzioni più popolari in Excel e consente di eseguire confronti logici tra un valore e quello previsto. Nella forma più semplice indica che la funzione se:

  • SE(qualcosa è Vero, fai qualcosa, altrimenti fai qualcos'altro)

Un'istruzione IF può avere due risultati. Primo risulta se il confronto è vero, la seconda se il confronto è FALSO.

Se si desidera passare all'utilizzo di più istruzioni IF, vedere: funzioni se avanzate - utilizzo di formule annidate ed evitare problemi.

Usare la funzione SE, una delle funzioni logiche, per restituire un valore se una condizione è vera e un altro valore se è falsa.

Sintassi

SE(test;se_vero;[se_falso])

Ad esempio:

  • =SE(A2>B2;"Fuori budget";"OK")

  • =SE(A2=B2;B4-A4;"")

Nome argomento

Descrizione

test    (obbligatorio)

Condizione da testare.

se_vero    (obbligatorio)

Valore restituito se il risultato di test è VERO.

se_falso    (facoltativo)

Valore restituito se il risultato di test è FALSO.

Esempi di funzioni SE semplici

La cella D2 contiene la formula =SE(C2="Sì";1;2)
  • =SE(C2="Sì";1;2)

Nell'esempio qui sopra la formula nella cella D2 dice: SE(C2 = Sì, allora restituisci 1, altrimenti restituisci 2)

La cella D2 contiene la formula =SE(C2=1;"SÌ";"NO")
  • =SE(C2=1;"Sì";"No")

In questo esempio la formula nella cella D2 dice: SE(C2 = 1, allora restituisci Sì, altrimenti No)

Come viene visualizzato, è possibile utilizzare la funzione se per valutare valori e il testo. Può inoltre essere utilizzato per valutare gli errori. Non si è limitata alla verifica solo se una cosa è uguale a un altro e restituire un singolo risultato, è possibile anche utilizzare gli operatori matematici e calcoli aggiuntive in base ai criteri specificati. È inoltre possibile annidare le funzioni se più insieme per eseguire confronti multipli.

Nota : Se si prevede di utilizzare il testo nelle formule, è necessario disporre il testo tra virgolette (ad esempio, "testo"). L'unica eccezione che utilizza vero o FALSO, che Excel rileva automaticamente.

Come iniziare

Il modo migliore per iniziare a scrivere un'istruzione IF è a pensare a cosa si sta tentando di eseguire. Quali confronto si sta tentando di effettuare? In molti casi, la scrittura di un'istruzione IF può essere costituiti semplicemente da ritenere tramite la logica mente: "l'azione da eseguire se viene soddisfatta la condizione e l'azione da eseguire in caso contrario?" Sempre desiderata per assicurarsi che i passaggi da seguire una progressione logica, altrimenti la formula non è possibile eseguire opinioni che dovrebbe. Questa operazione è particolarmente importante quando si crea complesse istruzioni IF (annidate).

Altri esempi di SE

La formula nella cella D2 è =SE(C2>B2;"Fuori budget";"Nel budget")
  • =SE(C2>B2;"Fuori budget";"Nel budget")

Nell'esempio precedente la funzione SE nella cella D2 dice SE(C2 è maggiore di B2, allora restituisci "Fuori budget", altrimenti "Nel budget")

La formula nella cella E2 è =SE(C2>B2;C2-B2;"")
  • =SE(C2>B2;C2-B2;0)

Nella figura riportata sopra, invece di restituire un risultato di testo, che verranno restituito calcoli matematici. In modo che la formula in E2 se (effettivo è maggiore di budget, quindi Sottrai importo budget da quello effettiva, in caso contrario restituiscono alcuna operazione).

La formula nella cella F7 è SE(E7="Sì";F5*0,0825;0)
  • =SE(E7="Sì";F5*0,0825;0)

In questo esempio la formula nella cella F7 dice SE(E7 = "Sì", allora moltiplica l'importo totale nella cella F5 * 8,25%, altrimenti non sono dovute imposte quindi restituisci 0)

Procedure consigliate - Costanti

Nell'ultimo esempio, viene visualizzato "Sì" sia l'aliquota IVA (0.0825) immesso direttamente nella formula. In genere non è buona norma inserire costanti letterali (valori che potrebbero essere necessario modificare di tanto in tanto) direttamente in formule, in quanto potrebbero essere difficile da individuare e cambiare in futuro. È preferibile inserire le proprie celle, in cui si trovano nelle Apri e facilmente trovato e modificato costanti. In questo caso è, perché è presente solo una funzione se e l'aliquota IVA raramente cambierà. In caso contrario, sarà facile da modificare nella formula.

Operatori di calcolo

Se si desidera acquisire familiarità con gli operatori di calcolo diverse è possibile utilizzare nelle formule (< minore, non è uguale al maggiore =><> uguale a e così via), vedere l'articolo: operatori di calcolo e ordine di precedenza.

Usare SE per controllare se una cella è vuota

Può capitare che sia necessario controllare se una cella è vuota, in genere per evitare che una formula visualizzi un risultato senza input.

La formula nella cella E2 è =SE(D2=1;"Sì";SE(D2=2;"No";"Forse"))

In questo caso viene usata la funzione SE con la funzione VAL.VUOTO:

  • =SE(VAL.VUOTO(D2);"Vuota";"Non vuota")

Che informa che IF(D2 is blank, then return "Blank", otherwise return "Not Blank"). Allo stesso modo, è possibile utilizzare una formula per anche la condizione "Non è vuoto". Nell'esempio seguente viene utilizzato "" anziché Val. La "" significa "nulla".

Verificare se una cella è vuota: la formula nella cella E2 è =SE(VAL.VUOTO(D2);"Vuota";"Non vuota")
  • =SE(D3="";"Vuota";"Non vuota")

Questa formula indica se (D3 niente, quindi tornare "Vuoto", in caso contrario "non è vuoto"). Ecco un esempio di un metodo molto comune di utilizzo "" per impedire a una formula di calcolo se una cella dipendente è vuota:

  • =SE(D3="";"";Formula())

    SE(D3 non è niente, allora non restituire niente, altrimenti calcola la formula).

Esempio di funzioni SE annidate

Mentre una funzione SE semplice restituisce solo due risultati (Vero o Falso), quelle annidate possono generare da 3 a 64 risultati.

Usare le virgolette "" per cercare una cella vuota: la formula nella cella E3 è =SE(D3="";"Vuota";"Non vuota")
  • =SE(D2=1;"SÌ";SE(D2=2;"No";"Forse"))

Nella figura precedente la formula nella cella E2 dice: SE(D2 è uguale a 1, allora restituisci "Sì", altrimenti SE(D2 è uguale a 2, allora restituisci "No", altrimenti restituisci "Forse")). Notare che alla fine della formula sono presenti due parentesi di chiusura. Queste sono necessarie per completare entrambe le funzioni SE e se si prova a immettere la formula senza entrambe le parentesi di chiusura, Excel tenterà di correggerla automaticamente.

Attenzione

Mentre Excel è possibile annidare fino a 64 funzioni se diverse, è nessuna consigliabile per farlo. Perché?

  • Più istruzioni IF richiedono una quantità elevata di pensiero generarle correttamente e assicurarsi che la logica possono essere calcolate correttamente a ogni condizione fino alla fine. Se si non annidare le istruzioni IF 100% in modo accurato, quindi una formula può lavorare 75% del tempo, ma restituire risultati imprevisti 25% del tempo. Purtroppo, la probabilità di si intercettazione il 25% è sottile.

  • Più istruzioni SE possono diventare molto difficili da gestire, soprattutto se in seguito si deve provare a capire cosa si stava cercando di ottenere o, peggio ancora, qual era l'obiettivo di qualcun altro.

  • Più istruzioni SE richiedono più parentesi di apertura e di chiusura, che possono essere difficili da gestire a seconda della complessità della formula.

Problemi comuni

Problema

Causa dell'errore

0 (zero) in una cella

Non è stato specificato un argomento per se_vero o se_falso. Per restituire il valore corretto, aggiungere del testo ai due argomenti o aggiungere VERO o FALSO all'argomento.

#NOME? in una cella

Questo errore indica in genere che la formula non è stata digitata correttamente.

Domande su funzioni specifiche?

Pubblicare una domanda nel forum della community di Excel

Suggerimenti per migliorare Excel

Per suggerimenti su come migliorare la prossima versione di Excel, vedere gli argomenti in Excel User Voice.

Vedere anche

Video: Funzioni se avanzate

Funzione IFS (Office 365, Excel 2016 e versioni successive)

Funzioni se avanzate - utilizzo di formule annidate ed evitare problemi

Video di formazione: funzioni se avanzate

La funzione CONTA.Se cercherà valori in base a un singolo criterio

La funzione CONTA cercherà valori in base a più criteri

La funzione somma.Se la somma di valori in base a un singolo criterio

La funzione somma la somma di valori in base a più criteri

E

Funzione OR

CERCA.VERT

Panoramica delle formule in Excel

Come evitare errori nelle formule

Usare il controllo degli errori per trovare gli errori nelle formule

Funzioni logiche

Funzioni di Excel (in ordine alfabetico)

Funzioni di Excel (in base alla categoria)

Nota : Dichiarazione di non responsabilità per la traduzione automatica: Il presente articolo è stato tradotto tramite un software di traduzione automatica e non da una persona. Microsoft offre le traduzioni automatiche per consentire a coloro che non conoscono la lingua inglese di leggere gli articoli sui prodotti, sui servizi e sulle tecnologie Microsoft. Dal momento che l'articolo è stato tradotto automaticamente, potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli.

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×