Funzione SE

Usare la funzione SE, una delle funzioni logiche, per restituire un valore se una condizione è vera e un altro valore se è falsa.

Sintassi

SE(test; [se_vero]; [se_falso])

Ad esempio:

  • =SE(A2>B2;"Fuori budget";"OK")

  • =SE(A4=500;B4-A4;""

Nome argomento

Descrizione

test    (obbligatorio)

Condizione da testare.

se_vero    (obbligatorio)

Valore restituito se il risultato di test è VERO.

se_falso    (facoltativo)

Valore restituito se il risultato di test è FALSO.

Esempi

Copiare i dati di esempio nella tabella seguente e incollarli nella cella A1 di un nuovo foglio di lavoro di Excel. Per vedere la formula in una cella, selezionare la cella e premere F2.

Spese effettive

Spese previste

€ 1.500

€ 900

€ 500

€ 900

€ 500

€ 925

=SE(A2>B2;"Fuori budget";"OK")

Poiché le spese effettive, pari a € 1500 (A2), hanno superato le spese previste, pari a € 900 (B2), viene restituito Fuori budget.

=SE(A2<B2;VERO; SE(A3>B3,"Fuori budget";"OK"))

La prima funzione SE è falsa. Viene pertanto calcolata la seconda istruzione SE e, poiché anche questa è falsa, viene restituito OK.

=SE(A4=500;B4-A4;"")

Poiché A4 è uguale a 500, il valore di Spese effettive, pari a € 500, viene sottratto dal valore di Spese previste, pari a € 925, per indicare l'importo fuori budget, pari a 425. Se A4 non fosse uguale a 500, verrebbe restituito un testo vuoto ("").

=SE(A2<B2;VERO; SE(A3>B3,"Fuori budget";"OK"))

La prima funzione SE è falsa. Viene pertanto calcolata la seconda istruzione SE e, poiché anche questa è falsa, viene restituito OK.

Problemi comuni

Problema

Causa dell'errore

0 (zero) in una cella

Non è stato specificato un argomento per se_vero o se_falso. Per restituire il valore corretto, aggiungere del testo ai due argomenti o aggiungere VERO o FALSO all'argomento.

#NOME? in una cella

Questo errore indica in genere che la formula non è stata digitata correttamente.

Procedure consigliate

Operazione da eseguire

Motivo

Uso di una funzione SE con un'altra funzione SE.

È possibile annidare fino a 64 funzioni SE l'una nell'altra per gli argomenti se_vero e se_falso per creare test più elaborati.

Uso di SE con le matrici

Se un qualsiasi argomento della funzione SE è una matrice, eseguendo l'istruzione SE verrà valutato ogni elemento della matrice. Per altre informazioni, vedere Creare una formula in forma di matrice.

Informazioni correlate

Si applica a:



Queste informazioni sono risultate utili?

No

Che cosa possiamo migliorare?

255 caratteri rimanenti

Per tutelare la privacy, non includere informazioni di contatto nei commenti e suggerimenti. Consulta la nostra informativa sulla privacy.

Grazie per i tuoi commenti e suggerimenti

Risorse di supporto

Cambia lingua