Funzione SE

La funzione SE, una delle più famose di Excel, consente di eseguire confronti logici tra un valore e un risultato previsto. Nel formato più semplice, la funzione SE dice:

  • SE(qualcosa è Vero, fai qualcosa, altrimenti fai qualcos'altro)

Quindi un'istruzione SE può avere due risultati. Il primo risultato si ottiene se il confronto è Vero, il secondo se è Falso.

Per informazioni sull'uso di più istruzioni SE, vedere: Funzioni SE avanzate: usare le formule annidate ed evitare problemi.

Usare la funzione SE, una delle funzioni logiche, per restituire un valore se una condizione è vera e un altro valore se è falsa.

Sintassi

SE(test;se_vero;[se_falso])

Ad esempio:

  • =SE(A2>B2;"Fuori budget";"OK")

  • =SE(A2=B2;B4-A4;"")

Nome argomento

Descrizione

test    (obbligatorio)

Condizione da testare.

se_vero    (obbligatorio)

Valore restituito se il risultato di test è VERO.

se_falso    (facoltativo)

Valore restituito se il risultato di test è FALSO.

Esempi di funzioni SE semplici

La cella D2 contiene la formula =SE(C2="Sì";1;2)
  • =SE(C2="Sì";1;2)

Nell'esempio qui sopra la formula nella cella D2 dice: SE(C2 = Sì, allora restituisci 1, altrimenti restituisci 2)

La cella D2 contiene la formula =SE(C2=1;"SÌ";"NO")
  • =SE(C2=1;"Sì";"No")

In questo esempio la formula nella cella D2 dice: SE(C2 = 1, allora restituisci Sì, altrimenti No)

Come si può vedere, la funzione SE può essere usata per valutare sia testo che valori, ma anche per valutare errori. Oltre a confrontare se un valore è uguale a un altro restituendo un singolo risultato, è anche possibile usare operatori matematici ed eseguire altri calcoli in base ai criteri specificati. È anche possibile annidare più funzioni SE per eseguire più confronti.

Nota : Se si intende usare testo nelle formule, è necessario racchiuderlo tra virgolette, ad esempio "Testo". L'unica eccezione è l'uso di VERO o FALSO, che Excel riconosce automaticamente.

Come iniziare

Il modo migliore per iniziare a scrivere un'istruzione SE consiste nel valutare cosa si vuole ottenere. Quale tipo di confronto si vuole eseguire? Molte volte un'istruzione SE può essere la semplice trasposizione della domanda "che cosa dovrebbe succedere se questa condizione viene soddisfatta e che cosa in caso contrario?". È sempre consigliabile verificare che i passaggi seguano una progressione logica, altrimenti la formula non darà i risultati previsti. Ciò è particolarmente importante quando si creano istruzioni SE complesse, ossia annidate.

Altri esempi di SE

La formula nella cella D2 è =SE(C2>B2;"Fuori budget";"Nel budget")
  • =SE(C2>B2;"Fuori budget";"Nel budget")

Nell'esempio precedente la funzione SE nella cella D2 dice SE(C2 è maggiore di B2, allora restituisci "Fuori budget", altrimenti "Nel budget")

La formula nella cella E2 è =SE(C2>B2;C2-B2;"")
  • =SE(C2>B2;C2-B2;0)

Nella figura qui sopra, invece di restituire un risultato di testo verrà restituito un calcolo matematico. Quindi la formula nella cella E2 dice SE(Spese effettive è maggiore di Spese previste, allora sottrai l'importo di Spese previste dall'importo di Spese effettive, altrimenti non restituire nulla).

La formula nella cella F7 è SE(E7="Sì";F5*0,0825;0)
  • =SE(E7="Sì";F5*0,0825;0)

In questo esempio la formula nella cella F7 dice SE(E7 = "Sì", allora moltiplica l'importo totale nella cella F5 * 8,25%, altrimenti non sono dovute imposte quindi restituisci 0)

Procedure consigliate - Costanti

Nell'ultimo esempio nella formula vengono immessi direttamente sia "Sì" che l'aliquota dell'imposta (0,0825). In generale, non è consigliabile immettere costanti letterali, ossia valori che potrebbero dover cambiare nel corso del tempo, direttamente nelle formule, perché possono essere difficili da trovare e cambiare nel futuro. È preferibile invece inserire le costanti in celle specifiche, dove è possibile trovarle e cambiarle facilmente. In questo caso la formula è accettabile perché c'è una sola funzione SE ed è improbabile che l'aliquota dell'imposta cambi. E anche se dovesse cambiare, sarà facile modificarla nella formula.

Operatori di calcolo

Per altre informazioni sui vari operatori di calcolo che è possibile usare nelle formule, (< minore di, > maggiore di, = uguale a, <> diverso da e così via), vedere l'articolo: Operatori di calcolo e ordine di precedenza.

Usare SE per controllare se una cella è vuota

Può capitare che sia necessario controllare se una cella è vuota, in genere per evitare che una formula visualizzi un risultato senza input.

La formula nella cella E2 è =SE(D2=1;"Sì";SE(D2=2;"No";"Forse"))

In questo caso viene usata la funzione SE con la funzione VAL.VUOTO:

  • =SE(VAL.VUOTO(D2);"Vuota";"Non vuota")

Che dice Se(D2 è vuota, allora restituisci "Vuota", altrimenti "Non vuota"). È possibile usare altrettanto facilmente una formula personalizzata per la condizione "Non vuota". Nell'esempio seguente vengono usate le virgolette "" al posto di VAL.VUOTO. "" significa essenzialmente "niente".

Verificare se una cella è vuota: la formula nella cella E2 è =SE(VAL.VUOTO(D2);"Vuota";"Non vuota")
  • =SE(D3="";"Vuota";"Non vuota")

Questa formula dice SE(D3 non è niente, allora restituisci "Vuota", altrimenti "Non vuota"). Ecco un esempio di un metodo molto comune che prevede l'uso delle virgolette per impedire di calcolare una formula se una cella dipendente è vuota:

  • =SE(D3="";"";Formula())

    SE(D3 non è niente, allora non restituire niente, altrimenti calcola la formula).

Esempio di funzioni SE annidate

Mentre una funzione SE semplice restituisce solo due risultati (Vero o Falso), quelle annidate possono generare da 3 a 64 risultati.

Usare le virgolette "" per cercare una cella vuota: la formula nella cella E3 è =SE(D3="";"Vuota";"Non vuota")
  • =SE(D2=1;"SÌ";SE(D2=2;"No";"Forse"))

Nella figura precedente la formula nella cella E2 dice: SE(D2 è uguale a 1, allora restituisci "Sì", altrimenti SE(D2 è uguale a 2, allora restituisci "No", altrimenti restituisci "Forse")). Notare che alla fine della formula sono presenti due parentesi di chiusura. Queste sono necessarie per completare entrambe le funzioni SE e se si prova a immettere la formula senza entrambe le parentesi di chiusura, Excel tenterà di correggerla automaticamente.

Attenzione

Anche se Excel consente di annidare fino a 64 funzioni SE diverse, non è consigliabile adottare questo approccio. Perché?

  • La creazione di più istruzioni SE valide richiede molta attenzione ed è necessario verificare che la logica possa essere calcolata correttamente attraverso ogni condizione fino alla fine. Se le istruzioni SE vengono annidate in modo completamente corretto, la formula potrebbe funzionare il 75% delle volte, ma restituire risultati imprevisti nel restante 25%. Purtroppo, le probabilità di capire il problema in quel 25% di occorrenze sono scarse.

  • Più istruzioni SE possono diventare molto difficili da gestire, soprattutto se in seguito si deve provare a capire cosa si stava cercando di ottenere o, peggio ancora, qual era l'obiettivo di qualcun altro.

  • Più istruzioni SE richiedono più parentesi di apertura e di chiusura, che possono essere difficili da gestire a seconda della complessità della formula.

Problemi comuni

Problema

Causa dell'errore

0 (zero) in una cella

Non è stato specificato un argomento per se_vero o se_falso. Per restituire il valore corretto, aggiungere del testo ai due argomenti o aggiungere VERO o FALSO all'argomento.

#NOME? in una cella

Questo errore indica in genere che la formula non è stata digitata correttamente.

Servono altre informazioni?

È sempre possibile rivolgersi a un esperto nella Tech Community di Excel, ottenere supporto nella community Microsoft o suggerire una nuova caratteristica o un miglioramento in Excel UserVoice.

Vedere anche

Video: Funzioni SE avanzate

Funzione PIÙ.SE (Office 365, Excel 2016 e versioni successive)

Funzioni SE avanzate: usare le formule annidate ed evitare problemi

Video di formazione: Funzioni SE avanzate

La funzione CONTA.SE cercherà valori in base a un singolo criterio

La funzione CONTA.PIÙ.SE cercherà valori in base a più criteri

La funzione SOMMA.SE sommerà i valori in base a un singolo criterio

La funzione SOMMA.PIÙ.SE sommerà i valori in base a più criteri

Funzione E

Funzione O

Funzione CERCA.VERT

Panoramica delle formule in Excel

Come evitare errori nelle formule

Usare il controllo degli errori per trovare gli errori nelle formule

Funzioni logiche

Funzioni di Excel (in ordine alfabetico)

Funzioni di Excel (in base alla categoria)

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×