Funzione NON

Usare la funzione NON, una delle funzioni logiche, per assicurarsi che un dato valore non coincida con un altro.

Esempio

Esempi di funzione NON per invertire il valore degli argomenti.  ES. =NON(1+1=2)

La funzione NON inverte il valore dell'argomento.

La funzione NON viene usata comunemente per estendere la capacità di altre funzioni che eseguono test logici. La funzione SE, ad esempio, esegue un test logico e quindi restituisce un valore se il test restituisce VERO e un altro valore se il test restituisce FALSO. Usando la funzione NON come argomento test della funzione SE, è possibile verificare molte condizioni diverse anziché una sola.

Sintassi

NON(logico)

Gli argomenti della sintassi della funzione NON sono i seguenti:

  • Logico    Obbligatorio. Valore o espressione che può dare come risultato VERO o FALSO.

Osservazioni

Se logico è FALSO, NON restituirà VERO, se logico è VERO, NON restituirà FALSO.

Esempi

Ecco alcuni esempi generali dell'uso della funzione NON da sola e in combinazione con le funzioni SE, E e O.

Esempi di funzione NON con SE, E e O


Formula

Descrizione

=NON(A2>100)

A2 NON è maggiore di 100

=SE(E(NON(A2>1);NON(A2<100));A2;"Il valore non è compreso nell'intervallo")

50 è maggiore di 1 (VERO), E 50 è minore di 100 (VERO), quindi la funzione NON inverte entrambi gli argomenti in FALSO. E richiede che entrambi gli argomenti abbiano il valore VERO, quindi restituisce il risultato se è FALSO.

=SE(O(NON(A3<0);NON(A3>50));A3;"Il valore non è compreso nell'intervallo")

100 non è minore di 0 (FALSO) e 100 è maggiore di 50 (VERO), quindi la funzione NON inverte gli argomenti in VERO/FALSO. O richiede che un solo argomento abbia il valore VERO, quindi restituisce il risultato se è VERO.

Calcolo Commissione di vendita

Ecco uno scenario abbastanza comune in cui è necessario calcolare se gli agenti di vendita sono idonei a ricevere un bonus usando la funzione NON con SE ed E.

Esempio di calcolo di bonus di vendita con le funzioni SE, E e NON.  La formula nella cella E14 è =SE(E(NON(B14<$B$7);NON(C14<$B$5));B14*$B$8;0)
  • =SE(E(NON(B14<$B$7);NON(C14<$B$5));B14*$B$8;0)- SE le vendite totali NON sono minori dell'obiettivo di vendita E gli account NON sono minori dell'obiettivo dell'account, moltiplicare le vendite totali per la percentuale della commissione, altrimenti restituire 0.

Servono altre informazioni?

È sempre possibile rivolgersi a un esperto nella Tech Community di Excel, ottenere supporto nella community Microsoft o suggerire una nuova caratteristica o un miglioramento in Excel UserVoice.

Vedere anche

Guardare un video che illustra come usare la funzione SE

Informazioni su come usare le formule annidate in una formula

Funzione SE

Funzione E

Funzione O

Panoramica delle formule in Excel

Come evitare errori nelle formule

Usare il controllo degli errori per trovare gli errori nelle formule

Scelte rapide da tastiera in Excel 2016 per Windows

Scelte rapide da tastiera in Excel 2016 per Mac

Funzioni logiche (riferimento)

Funzioni di Excel (in ordine alfabetico)

Funzioni di Excel (in base alla categoria)

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×