Funzione INDICE

La funzione INDICE restituisce un valore o il riferimento a un valore da una tabella o un intervallo.

Il browser in uso non supporta le funzionalità video. Installare Microsoft Silverlight, Adobe Flash Player o Internet Explorer 9.

La funzione INDICE può essere usata in due modi:

  • Se si vuole restituire il valore di una cella o di una matrice di celle specificata, vedere Matrice.

  • Se si vuole restituire un riferimento alle celle specificate, vedere Riferimento.

Matrice

Descrizione

Restituisce il valore di un elemento in una tabella o una matrice, selezionato mediante gli indici dei numeri di riga e colonna.

Usare la forma per matrice se il primo argomento della funzione INDICE è una costante di matrice.

Sintassi

INDICE(matrice; riga; [col])

Nella sintassi della funzione INDICE sono previsti gli argomenti seguenti:

  • Matrice    Obbligatorio. Intervallo di celle o costante di matrice.

    • Se una matrice contiene una sola riga o colonna, l'argomento Riga o Col corrispondente è facoltativo.

    • Se una matrice contiene più righe e colonne e si utilizza solo Riga o solo Col, INDICE restituisce una matrice dell'intera riga o colonna in matrice.

  • Riga    Obbligatorio. Seleziona la riga nella matrice da cui restituire un valore. Se Riga viene omesso, Col è necessario.

  • Col    Facoltativo. Seleziona la colonna nella matrice da cui restituire un valore. Se Col viene omesso, Riga è necessario.

Osservazioni

  • Se gli argomenti Riga e Col vengono utilizzati entrambi, INDICE restituisce il valore nella cella all'intersezione di Riga e Col.

  • Se si imposta Riga o Col su 0 (zero), INDICE restituisce i valori dell'intera riga o colonna rispettivamente. Per usare i valori restituiti come matrice, immettere la funzione INDICE come formula di matrice in un intervallo orizzontale di celle per una riga e in un intervallo verticale di celle per una colonna. Per immettere una formula in forma di matrice, premere CTRL+MAIUSC+INVIO.

    Nota :  In Excel Web App non è possibile creare formule in forma di matrice.

  • È necessario che Riga e Col facciano riferimento a una cella all'interno della matrice, altrimenti INDICE restituirà il valore di errore #RIF!.

Esempi

Esempio 1

In questi esempi la funzione INDICE viene utilizzata per trovare il valore nella cella di intersezione dove si incontrano una riga e una colonna.

Copiare i dati di esempio contenuti nella tabella seguente e incollarli nella cella A1 di un nuovo foglio di lavoro Excel. Affinché le formule mostrino i risultati, selezionarle, premere il tasto F2 e quindi Invio. Se necessario, adattare l'ampiezza delle colonne per visualizzare tutti i dati.

Dati

Dati

Mele

Limoni

Banane

Pere

Formula

Descrizione

Risultato

=INDICE(A2:B3;2;2)

Valore all'intersezione della seconda riga e della seconda colonna nell'intervallo A2:B3.

Pere

=INDICE(A2:B3;2;1)

Valore all'intersezione della seconda riga e della prima colonna nell'intervallo A2:B3.

Banane

Esempio 2

In questo esempio si utilizza la funzione INDICE in una formula in forma di matrice per trovare i valori in due celle specificate in una matrice 2x2.

In questo caso, selezionare due celle verticali qualsiasi, come A1:A2, incollare la formula =INDICE({1;2;3;4};0;2) nella prima cella, quindi premere CTRL+MAIUSC+INVIO. Quando una formula viene immessa come formula di matrice, Excel la incolla automaticamente nella seconda cella.

Formula

Descrizione

Risultato

=INDICE({1;2;3;4};0;2)

Valore trovato nella prima riga, seconda colonna della matrice. La matrice contiene 1 e 2 nella prima riga e 3 e 4 nella seconda riga.

2

Valore trovato nella seconda riga, seconda colonna della matrice (matrice identica a quella dell'esempio precedente).

4

Nota : Si tratta di una formula di matrice e deve essere immessa con CTRL+MAIUSC+INVIO. Excel racchiude automaticamente la formula tra parentesi graffe {}. Se si prova a immettere la formula manualmente, Excel la visualizza come testo. Se non si preme CTRL+MAIUSC+INVIO, la formula restituisce un errore #VALORE!.

Inizio pagina

Riferimento

Descrizione

Restituisce il riferimento della cella all'intersezione di una particolare riga e colonna. Se il riferimento è costituito da selezioni non adiacenti, sarà possibile scegliere la selezione nella quale effettuare la ricerca.

Sintassi

INDICE(rif; riga; [col]; [area])

Nella sintassi della funzione INDICE sono previsti gli argomenti seguenti:

  • Rif    Obbligatorio. Riferimento a uno o più intervalli di celle.

    • Se si immette un intervallo non adiacente per rif, racchiuderlo tra parentesi.

    • Se ogni area in rif contiene solo una riga o una colonna, l'argomento Riga o Col corrispondente sarà facoltativo. Ad esempio, per un riferimento a una singola riga, utilizzare INDICE(rif;;col).

  • Riga    Obbligatorio. Numero della riga in rif dal quale si desidera restituire un riferimento.

  • Col    Facoltativo. Numero della colonna in rif dal quale si desidera restituire un riferimento.

  • Area    Facoltativo. Seleziona un intervallo in rif dal quale restituire l'intersezione di Riga e di Col. La prima area selezionata o immessa viene contrassegnata dal numero 1, la seconda dal numero 2 e così via. Se Area viene omesso, INDICE userà l'area 1.  Le aree elencate qui devono essere tutte nello stesso foglio.  Se si specificano aree che non si trovano nello stesso foglio, verrà generato un errore #VALORE!.  Se occorre usare intervalli che si trovano in fogli diversi, è consigliabile usare il formato di matrice della funzione INDICE e usare un'altra funzione per calcolare l'intervallo che costituisce la matrice.  Ad esempio, si potrebbe usare la funzione SCEGLI per calcolare l'intervallo che verrà usato.

Ad esempio, se Rif descrive le celle (A1:B4;D1:E4;G1:H4), Area 1 sarà l'intervallo A1:B4, Area 2 l'intervallo D1:E4 e Area 3 l'intervallo G1:H4.

Osservazioni

  • Se in Rif e Area viene selezionato un intervallo particolare, con Riga e Col viene selezionata una cella particolare: Riga 1 è la prima riga dell'intervallo, Col 1 è la prima colonna e così via. Il riferimento restituito da INDICE è l'intersezione di Riga e Col.

  • Se Riga o Col viene impostato sul valore 0, INDICE restituirà il riferimento rispettivamente dell'intera colonna o dell'intera riga.

  • Riga, Col e Area devono fare riferimento a una cella all'interno di rif. In caso contrario, INDICE restituirà il valore di errore #RIF!. Se Riga e Col vengono omessi, INDICE restituirà l'area in rif specificata da Area.

  • Il risultato della funzione INDICE è un riferimento e viene interpretato come tale dalle altre formule. A seconda della formula, il valore restituito da INDICE può essere utilizzato come riferimento o come valore. Ad esempio, la formula CELLA("larghezza";INDICE(A1:B2;1;2)) è uguale a CELLA("larghezza";B1). La funzione CELLA utilizza il valore restituito da INDICE come riferimento di cella. D'altro lato, una formula come 2*INDICE(A1:B2;1;2) traduce il valore restituito da INDICE nel numero della cella B1.

Nota :  La funzione CELLA non è disponibile in Excel Web App.

Esempi

Copiare i dati di esempio nella tabella seguente e incollarli nella cella A1 di un nuovo foglio di lavoro di Excel. Per mostrare i risultati delle formule, selezionarle, premere F2 e quindi INVIO. Se necessario, è possibile adattare la larghezza delle colonne in modo da vedere i dati per intero.

Frutta

Prezzo

Numero

Mele

€ 0,69

40

Banane

€ 0,34

38

Limoni

€ 0,55

15

Arance

€ 0,25

25

Pere

€ 0,59

40

Mandorle

€ 2,80

10

Anacardi

€ 3,55

16

Arachidi

€ 1,25

20

Noci

€ 1,75

12

Formula

Descrizione

Risultato

=INDICE(A2:C6; 2; 3)

L'intersezione della seconda riga e della terza colonna nell'intervallo A2:C6, ossia il contenuto della cella C3.

38

=INDICE((A1:C6; A8:C11); 2; 2; 2)

L'intersezione della seconda riga e della seconda colonna nella seconda area di A8:C11, ossia il contenuto della cella B9.

1,25

=SOMMA(INDICE(A1:C11; 0; 3; 1))

La somma della terza colonna nella prima area dell'intervallo A1:C11, ossia la somma di C1:C11.

216

=SOMMA(B2:INDICE(A2:C6; 5; 2))

La somma dell'intervallo che ha inizio in B2 e termina all'intersezione della quinta riga e della seconda colonna dell'intervallo A2:A6, ossia la somma di B2:B6.

2,42

Inizio pagina

Vedere anche

Funzione CERCA.VERT

Funzione CONFRONTA

Funzione INDIRETTO

Linee guida ed esempi di formule di matrice

Funzioni di ricerca e riferimento (riferimento)

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×