Funzione CONTA.SE

In questo articolo vengono illustrati la sintassi delle formule e l'utilizzo della funzioneCONTA.SE in Microsoft Office Excel.

Descrizione

La funzione CONTA.SE conta il numero di celle di un intervallo che soddisfano un singolo criterio specificato. È ad esempio possibile contare tutte le celle che iniziano con una determinata lettera oppure tutte le celle in cui è contenuto un numero maggiore o miniore di un numero specificato. Si supponga ad esempio che un foglio di lavoro contenga un elenco di attività nella colonna A e il nome della persona a cui è assegnata ogni attività nella colonna B. È possibile utilizzare la funzione CONTA.SE per contare quanto volte si ripete il nome di una persona nella colonna B e determinare in questo modo quante attività sono assegnate a tale persona. Ad esempio:

=CONTA.SE(B2:B25;"Adriana")

Nota   Per contare le celle sulla base di più criteri, vedere Funzione CONTA.PIÙ.SE.

Sintassi

CONTA.SE(intervallo; criteri)

Nella sintassi della funzione CONTA.SE sono previsti gli argomento seguenti:

  • intervallo    Obbligatorio. Indica una o più celle da contare contenenti numeri o nomi, matrici o riferimenti che contengono numeri. Le celle vuote e i valori di testo verranno ignorati.

  • criteri    Obbligatorio. Numero, espressione, riferimento di cella o stringa di testo che determina quali celle verranno contate. I criteri ad esempio possono essere espressi come 32, ">32", B4, "mele" o "32".

    Nota   

    • Nei criteri è possibile utilizzare i caratteri jolly, ovvero il punto interrogativo (?) e l'asterisco (*), che rappresentano rispettivamente un carattere singolo e una sequenza di caratteri. Se si desidera trovare effettivamente un punto interrogativo o un asterisco, anteporre una tilde (~) al carattere.

    • I criteri non operano distinzione tra maiuscole e minuscole. Le stringhe "mele" e "MELE" corrisponderanno alle stesse celle.

Esempio 1: formule CONTA.SE comuni

Per facilitare la comprensione dell'esempio, è possibile copiarlo in un foglio di lavoro vuoto.

Come copiare un esempio

  1. Selezionare l'esempio in questo articolo. Se l'esempio deve essere copiato in Excel Online, copiare e incollare una cella alla volta.
    Important: Non selezionare le intestazioni di riga o di colonna.

    Selezione di un esempio dalla Guida

    Selezione di un esempio nella Guida

  2. Premere CTRL+C.

  3. Creare una cartella di lavoro o un foglio di lavoro vuoto.

  4. Nel foglio di lavoro selezionare la cella A1 e premere CTRL+V. Se si usa Excel Online, ripetere l'operazione di Copia e Incolla per ogni cella nell'esempio.
    Important: Per il corretto funzionamento dell'esempio è necessario incollarlo nella cella A1 del foglio di lavoro.

  5. Per passare dalla visualizzazione dei risultati alla visualizzazione delle formule che restituiscono i risultati, premere CTRL+( oppure fare clic sul pulsante Mostra formule nel gruppo Verifica formule della scheda Formule.

Dopo aver copiato l'esempio in un foglio di lavoro vuoto, è possibile adattarlo in base alle proprie esigenze.

1

2

3

4

5

6


7


8


9



10


11




12

A

B

C

Dati

Dati

mele

32

arance

54

pesche

75

mele

86

Formula

Descrizione

Risultato

=CONTA.SE(A2:A5;"mele")

Numero di celle contenenti "mele" nell'intervallo compreso tra A2 e A5.

2

=CONTA.SE(A2:A5;A4)

Numero di celle contenenti "pesche" nell'intervallo compreso tra A2 e A5.

1

=CONTA.SE(A2:A5;A3)+CONTA.SE(A2:A5;A2)

Numero di celle contenenti "arance" e "mele" nell'intervallo compreso tra A2 e A5.

3

=CONTA.SE(B2:B5;">55")

Numero di celle contenenti un valore maggiore di 55 nell'intervallo compreso tra B2 e B5.

2

=CONTA.SE(B2:B5;"<>"&B4)

Numero di celle contenenti un valore diverso da 75 nell'intervallo compreso tra B2 e B5.

3

=CONTA.SE(B2:B5;">=32")-CONTA.SE(B2:B5;">85")

Numero di celle contenenti un valore maggiore o uguale a 32 e minore o uguale a 85 nell'intervallo compreso tra B2 e B5.

3

Esempio 2: formule CONTA.SE che utilizzano caratteri jolly e gestiscono l'assenza di valori

Per facilitare la comprensione dell'esempio, è possibile copiarlo in un foglio di lavoro vuoto.

Come copiare un esempio

  1. Selezionare l'esempio in questo articolo. Se l'esempio deve essere copiato in Excel Online, copiare e incollare una cella alla volta.
    Important: Non selezionare le intestazioni di riga o di colonna.

    Selezione di un esempio dalla Guida

    Selezione di un esempio nella Guida

  2. Premere CTRL+C.

  3. Creare una cartella di lavoro o un foglio di lavoro vuoto.

  4. Nel foglio di lavoro selezionare la cella A1 e premere CTRL+V. Se si usa Excel Online, ripetere l'operazione di Copia e Incolla per ogni cella nell'esempio.
    Important: Per il corretto funzionamento dell'esempio è necessario incollarlo nella cella A1 del foglio di lavoro.

  5. Per passare dalla visualizzazione dei risultati alla visualizzazione delle formule che restituiscono i risultati, premere CTRL+( oppure fare clic sul pulsante Mostra formule nel gruppo Verifica formule della scheda Formule.

Dopo aver copiato l'esempio in un foglio di lavoro vuoto, è possibile adattarlo in base alle proprie esigenze.

1

2

3

4

5

6

7

8




9






10




11



12





13





14

A

B

C

Dati

Dati

mele

arance

NO

pesche

No

mele

Formula

Descrizione

Risultato

=CONTA.SE(A2:A7;"*e")

Numero di celle che terminano con la lettera "e" nell'intervallo compreso tra A2 e A7.

4

=CONTA.SE(A2:A7;"????he")

Numero di celle che terminano con le lettere "he" contenenti esattamente 6 lettere nell'intervallo compreso tra A2 e A7.

1

=CONTA.SE(A2:A7;"*")

Numero di celle contenenti testo nell'intervallo compreso tra A2 e A7.

4

=COUNTA.SE(A2:A7;"<>"&"*")

Numero di celle non contenenti testo nell'intervallo compreso tra A2 e A7.

2

=CONTA.SE(B2:B7;"No") / RIGHE(B2:B7)

Numero medio di voti No, incluse le celle vuote, nell'intervallo compreso tra B2 e B7.

0,333333333

=CONTA.SE(B2:B7;"Sì") / (RIGHE(B2:B7) -CONTA.SE(B2:B7; "<>"&"*"))

Numero medio di voti Sì, escluse le celle vuote, nell'intervallo compreso tra B2 e B7.

0,5

Nota    Per visualizzare un numero come percentuale, selezionare la cella e quindi nel gruppo Numeri della scheda Home fare clic su Stile percentuale Icona del pulsante.

Si applica a: Excel 2007



Queste informazioni sono risultate utili?

No

Che cosa possiamo migliorare?

255 caratteri rimanenti

Per tutelare la privacy, non includere informazioni di contatto nei commenti e suggerimenti. Consulta la nostra informativa sulla privacy.

Grazie per i tuoi commenti e suggerimenti

Risorse di supporto

Cambia lingua