Funzione CONTA.SE

Usare CONTA.SE, una delle funzioni statistiche, per contare il numero di celle che soddisfano un determinato criterio, ad esempio per contare il numero di volte in cui una particolare città compare in un elenco clienti.

Nel formato più semplice, la funzione CONTA.SE dice:

  • =CONTA.SE(Dove si vuole cercare?; Cosa si vuole cercare?)

Ad esempio:

  • =CONTA.SE(A2:A5;"Londra")

  • =CONTA.SE(A2:A5;A4)

Il browser in uso non supporta le funzionalità video. Installare Microsoft Silverlight, Adobe Flash Player o Internet Explorer 9.

CONTA.SE(intervallo; criteri)

Nome argomento

Descrizione

intervallo    (obbligatorio)

Il gruppo di celle da contare. intervallo può contenere numeri, matrici, un intervallo denominato o riferimenti contenenti numeri. Le celle vuote e i valori di testo vengono ignorati.

Informazioni su come selezionare intervalli in un foglio di lavoro.

criteri    (obbligatorio)

Numero, espressione, riferimento di cella o stringa di testo che determina quali celle verranno contate.

Ad esempio, è possibile usare un numero come 32, un confronto come ">32", una cella come B4 o una parola come "mele".

CONTA.SE usa un solo criterio. Se si vogliono usare più criteri, usare CONTA.PIÙ.SE.

Esempi

Per usare questi esempi in Excel, copiare i dati nella tabella seguente e incollarli nella cella A1 di un nuovo foglio di lavoro.

Dati

Dati

mele

32

arance

54

pesche

75

mele

86

Formula

Descrizione

=CONTA.SE(A2:A5;"mele")

Conta il numero di celle contenenti "mele" nell'intervallo compreso tra A2 e A5. Il risultato è 2.

=CONTA.SE(A2:A5;A4)

Conta il numero di celle contenenti "pesche" (il valore in A4) nell'intervallo compreso tra A2 e A5. Il risultato è 1.

=CONTA.SE(A2:A5;A2)+CONTA.SE(A2:A5;A3)

Conta il numero di celle contenenti "mele" (il valore in A2) e "arance" (il valore in A3) nell'intervallo compreso tra A2 e A5. Il risultato è 3. Questa formula usa CONTA.SE due volte per specificare più criteri, uno per ogni espressione. Si può anche usare la funzione CONTA.PIÙ.SE.

=CONTA.SE(B2:B5;">55")

Conta il numero di celle contenenti un valore maggiore di 55 nell'intervallo compreso tra B2 e B5. Il risultato è 2.

=CONTA.SE(B2:B5;"<>"&B4)

Conta il numero di celle contenenti un valore diverso da 75 nell'intervallo compreso tra B2 e B5. La e commerciale (&) unisce l'operatore di confronto "non uguale a" (<>) e il valore in B4 per leggere =CONTA.SE(B2:B5; "<>75"). Il risultato è 3.

=CONTA.SE(B2:B5;">=32")-CONTA.SE(B2:B5;">85")

Conta il numero di celle contenenti un valore maggiore (>) o uguale (=) a 32 e minore (<) o uguale (=) a 85 nell'intervallo compreso tra B2 e B5. Il risultato è 3.

=CONTA.SE(A2:A5; "*")

Conta il numero di celle contenenti testo nell'intervallo compreso tra A2 e A5. L'asterisco (*) viene usato come carattere jolly corrispondente a un carattere qualsiasi. Il risultato è 4.

=CONTA.SE(A2:A5; "?????le")

Conta il numero di celle che hanno esattamente 7 caratteri e terminano con le lettere "le" nell'intervallo compreso tra A2 e A5. Il punto interrogativo (?) viene usato come carattere jolly corrispondente a un singolo carattere. Il risultato è 2.

Problemi comuni

Problema

Descrizione dell'errore

Valore errato restituito per stringhe lunghe.

La funzione CONTA.SE restituisce risultati non corretti se viene usata per la corrispondenza di stringhe lunghe più di 255 caratteri.

Con le stringhe più lunghe di 255 caratteri, usare la funzione CONCATENA o l'operatore di concatenamento &. Ad esempio, =CONTA.SE(A2:A5;"stringa lunga"&"altra stringa lunga").

Nessun valore restituito mentre è previsto un valore.

Assicurarsi di racchiudere l'argomento criteri tra virgolette.

Una formula CONTA.SE restituisce un errore #VALORE! se fa riferimento a un altro foglio di lavoro.

Questo errore si verifica se la formula che contiene la funzione fa riferimento a celle o a un intervallo di una cartella di lavoro chiusa e vengono calcolate le celle. Per il funzionamento di questa caratteristica, l'altra cartella di lavoro deve essere aperta.

Procedure consigliate

Operazione da eseguire

Motivo

Tenere presente che CONTA.SE non fa distinzione tra maiuscole e minuscole nelle stringhe di testo.

I criteri non fanno distinzione tra maiuscole e minuscole. In altre parole, le stringhe "mele" e "MELE" corrisponderanno alle stesse celle.

Usare caratteri jolly.

Nei criteri è possibile usare i caratteri jolly, ossia il punto interrogativo (?) e l'asterisco (*), che rappresentano rispettivamente un carattere singolo e una sequenza di caratteri. Se si vuole trovare effettivamente un punto interrogativo o un asterisco, anteporre una tilde (~) al carattere.

Ad esempio, =CONTA.SE(A2:A5,"mel?") cercherà tutte le istanze di "mel", con l'ultima lettera variabile.

Verificare che i dati non contengano caratteri errati.

Quando si contano valori di testo, assicurarsi che i dati non contengano spazi iniziali, spazi finali, un uso non coerente delle virgolette semplici e inglesi o caratteri non stampabili. In questi casi, CONTA.SE potrebbe restituire un valore imprevisto.

Provare a usare la funzione LIBERA o la funzione ANNULLA.SPAZI.

Per praticità, usare gli intervalli denominati

CONTA.SE supporta gli intervalli denominati in una formula, ad esempio =CONTA.SE(frutta;">=32")-CONTA.SE(frutta;">85"). L'intervallo denominato può trovarsi nel foglio di lavoro corrente, in un altro della stessa cartella di lavoro oppure in una cartella di lavoro diversa. Per fare riferimento da un'altra cartella di lavoro, la seconda deve essere aperta.

Nota : La funzione CONTA.SE non conta le celle in base allo sfondo della cella o al colore del carattere. Tuttavia, Excel supporta le funzioni definite dall'utente che usano le operazioni di Microsoft Visual Basic, Applications Edition (VBA) sulle celle in base al colore dello sfondo o del carattere. Ecco un esempio di come contare il numero di celle con un colore di cella specifico usando VBA.

Servono altre informazioni?

È sempre possibile rivolgersi a un esperto nella Tech Community di Excel, ottenere supporto nella community Microsoft o suggerire una nuova caratteristica o un miglioramento in Excel UserVoice.

Vedere anche

Per contare le celle non vuote, usare la funzione CONTA.VALORI

Per contare le celle usando più criteri, usare la funzione CONTA.PIÙ.SE

Guardare un video che illustra come usare la funzione CONTA.PIÙ.SE

La funzione SOMMA.SE somma solo i valori che soddisfano un singolo criterio

La funzione SOMMA.PIÙ.SE somma solo i valori che soddisfano più criteri

Funzione PIÙ.SE (Office 365, Excel 2016 e versioni successive)

Usare la funzione ANNULLA.SPAZI per rimuovere gli spazi iniziali e finali dalle celle

Usare la funzione LIBERA per rimuovere i caratteri non stampabili dalle celle

Panoramica delle formule in Excel

Come evitare errori nelle formule

Rilevare gli errori nelle formule

Funzioni statistiche

Funzioni di Excel (in ordine alfabetico)

Funzioni di Excel (per categoria)

Usare SOMMA.PIÙ.SE, CONTA.PIÙ.SE e le funzioni correlate per un'analisi rapida dei dati (anteprima gratuita)

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×