Funzionalità di Correzione automatica in Excel

Usare questa finestra di dialogo per attivare o disattivare le funzionalità di correzione automatica o formattazione automatica in Excel.

Nella finestra di dialogo Correzione automatica sono disponibili quattro schede. Per passare rapidamente alle informazioni desiderate, fare clic sul nome in basso che corrisponde alla scheda su cui si cerca assistenza:

Correzione automatica  |  Formattazione automatica durante la digitazione | Azioni  | Correzione automatica simboli matematici

Correzione automatica

È possibile usare la funzionalità Correzione automatica per correggere errori di digitazione e di ortografia, l'uso non corretto delle maiuscole e per inserire automaticamente simboli e altre parti di testo. Per impostazione predefinita, Correzione automatica usa un elenco di errori e simboli frequenti, ma è possibile modificare le voci di questo elenco.

Per impostazione predefinita, Excel è impostato per correggere automaticamente alcuni errori comuni di digitazione. Usare le opzioni in questa finestra di dialogo per disattivare o modificare un valore su cui non si è soddisfatti.

Se non si è soddisfatti del pulsante Opzioni correzione automatica Icona del pulsante visualizzato durante la digitazione, è possibile usare questa finestra di dialogo per disattivarlo: Deselezionare la casella di controllo accanto a Mostra pulsante Opzioni correzione automatica.

È possibile eseguire le operazioni seguenti in questa scheda della finestra di dialogo. Fare clic su uno dei titoli in basso per espanderlo e visualizzare le istruzioni:

È possibile abilitare o disabilitare varie opzioni per la correzione automatica delle maiuscole nella scheda Correzione automatica.

Selezionare o deselezionare una o più delle caselle di controllo seguenti:

  • Correggi la doppia maiuscola ad inizio parola

  • Inserisci la maiuscola ad inizio frase

  • Iniziali dei giorni maiuscole

  • Correggi l'utilizzo accidentale del tasto BLOC MAIUSC

È possibile definire eccezioni per alcune regole relative alle maiuscole. Le eccezioni impostate vengono applicate a tutte le applicazioni di Officeche supportano la funzionalità Correzione automatica; qualsiasi modifica apportata a questo elenco in un'applicazione avrà quindi effetto anche sulle altre.

Nella scheda Correzione automatica fare clic su Eccezioni e quindi eseguire una delle operazioni seguenti:

  • Se si è selezionata la casella di controllo Correggi la doppia maiuscola ad inizio parola e si vuole impedire la correzione automatica di parole specifiche contenenti combinazioni di lettere maiuscole e minuscole, fare clic sulla scheda Doppia maiuscola.

    Per aggiungere una parola all'elenco delle eccezioni, digitarla nella casella e fare clic su Aggiungi. Per eliminare una parola, selezionarla e fare clic su Elimina.

  • Se si è selezionata la casella di controllo Inserisci la maiuscola ad inizio frase e si vuole impedire che la lettera iniziale di una parola che segue un'abbreviazione specifica venga convertita in maiuscolo, fare clic sulla scheda Prima lettera.

    Per aggiungere una parola all'elenco delle eccezioni, digitarla nella casella e fare clic su Aggiungi. Per eliminare una parola, selezionarla e fare clic su Elimina.

Nota: In alcune applicazioni di Office è anche possibile selezionare o deselezionare la casella di controllo Aggiungi automaticamente parole all'elenco. Questa opzione ha effetto durante la modifica di un file o di un elemento. Se viene eseguita una correzione automatica indesiderata, è possibile annullarla premendo CTRL+Z. Se la casella di controllo Aggiungi automaticamente parole all'elenco è selezionata, le correzioni indesiderate annullate dall'utente vengono aggiunte all'elenco delle eccezioni.

Correzione automatica usa due elenchi paralleli di parole. La prima parola corrisponde a quanto digitato e la seconda parola o espressione a ciò che viene inserito automaticamente al posto della prima.

Elenco correzione automatica

L'elenco Correzione automatica si applica a tutte le applicazioni di Office che supportano questa funzionalità; qualsiasi aggiunta o eliminazione di una parola dall'elenco in un'applicazione di Office avrà quindi effetto anche sulle altre applicazioni di Office.

È possibile aggiungere più voci che fanno riferimento allo stesso testo "Con". Ad esempio, "èstato", "é stato" e "estato" possono essere sostituiti tutti con "è stato". Basta aggiungere una voce distinta per ognuna di queste modifiche.

Importante: Se la correzione automatica sembra non funzionare, nella scheda Correzione automatica, verificare che la casella di controllo Sostituisci il testo durante la digitazione sia selezionata.

Aggiungere, cambiare o eliminare una voce di testo dell'elenco Correzione automatica

Per aggiungere una voce procedere come segue:

  1. Nella scheda Correzione automatica, nella casella Sostituisci, immettere una parola o un'espressione che si digita spesso in modo errato, ad esempio accellerare.

  2. Nella casella Con digitare la forma corretta della parola, in questo caso accelerare.

  3. Fare clic su Aggiungi.

Per cambiare il testo sostitutivo di una voce, selezionarlo nell'elenco e digitare una nuova voce nella casella Con.

Per eliminare una voce, selezionarla nell'elenco e fare clic su Elimina.

Nota: L'elenco Eccezioni indica al correttore ortografico di non sostituire automaticamente gli elementi considerati errori di ortografia. Se una parola viene sostituita automaticamente ed è stato verificato che non si trova nell'elenco Correzione automatica, aggiungere la parola all'elenco Eccezioni per assicurarsi che il correttore ortografico non la sostituisca automaticamente.

Per evitare tutte le modifiche e le sostituzioni automatiche di Correzione automatica, eseguire le operazioni seguenti nella finestra di dialogo:

  • Deselezionare tutte le caselle di controllo nella parte superiore della scheda per disattivare tutte le correzioni automatiche delle maiuscole.

  • Deselezionare la casella Sostituisci il testo durante la digitazione per disattivare tutte le sostituzioni automatiche di testo.

Suggerimento: Se Office ha corretto qualcosa automaticamente e si vuole annullare la modifica, fare clic su Annulla o premere CTRL+Z sulla tastiera.

Per inserire rapidamente un simbolo senza accedere ai menu, assegnare una pressione di tasto o un testo al simbolo. Questa soluzione è particolarmente utile se si prevede di inserire spesso il simbolo e si vuole evitare di usare ogni volta il comando Simbolo sulla barra multifunzione.

Occorre inserire il simbolo la prima volta, copiarlo e quindi aggiungere la regola di Correzione automatica. Una volta completato il passaggio 8, descritto di seguito, è possibile eliminare il simbolo che è stato inserito per creare la regola, se si vuole, quindi non occorre preoccuparsi del punto in cui inserirlo.

  1. Nella scheda Inserisci fare clic su Simbolo > Altri simboli.

  2. Scorrere l'elenco verso il basso e fare doppio clic sul simbolo che si vuole usare per inserirlo nel file. Chiudere la finestra di dialogo Simbolo.

    Suggerimento: Il set di caratteri Wingdings include la maggior parte dei simboli più usati. Per velocizzare la ricerca, impostare il tipo di carattere su Wingdings nella finestra di dialogo Simbolo.

  3. Selezionare il simbolo inserito nella cartella di lavoro e fare clic su Copia nella scheda Home della barra multifunzione oppure premere Ctrl+C.

  4. Fare clic su File > Opzioni > Strumenti di correzione > Opzioni correzione automatica.

  5. Fare clic nella casella Con e premere CTRL+V per incollare il simbolo copiato nel campo.

  6. Nella casella Sostituisci digitare una parola o una frase da associare al simbolo, ad esempio digitare spunta1.

    Nella casella Sostituisci della scheda Correzione automatica digitare una parola o una frase da associare al simbolo del segno di spunta.
  7. Fare clic su Aggiungi > OK.

  8. Quando si vuole usare il simbolo del segno di spunta appena definito, digitare la parola usata nel passaggio 7 per aggiungere il simbolo.

Suggerimento: Se il carattere inserito non è quello desiderato, provare a evidenziare il carattere inserito e verificare che il tipo di carattere sia Wingdings.

Formattaz. autom. durante la digitazione

Per impostazione predefinita, Excel esegue alcune azioni di formattazione automatica durante la digitazione, ad esempio l'applicazione di punti elenco o la formattazione di elenchi numerati quando rileva che si sta digitando un elenco. 

Utilizzare questa finestra di dialogo per disattivare le opzioni di formattazione automatica. Deselezionare la casella di controllo di un elemento per cui non si vuole che la formattazione automatica venga eseguita. 

Azioni

In Excel è disponibile un’azione associata al clic con il pulsante destro. Attivare questa azione selezionando Abilita azioni aggiuntive nel menu di scelta rapida nella finestra di dialogo. 

L’azione Data consente di fare clic con il pulsante destro del mouse su una data completa (inclusi giorno, mese e anno) e aprire il calendario di Outlook in tale data. 

Ignorare i pulsanti Proprietà e Altre azioni della scheda Azioni. Non consentono di eseguire azioni utili. 

Correzione automatica simboli matematici

Per creare un'equazione da zero, premere Alt + il segno uguale. Viene visualizzato il segnaposto di un’equazione in cui è possibile digitare caratteri matematici. 

Quando si usa il segnaposto di un'equazione, Office offre un’ampia serie di collegamenti che è possibile utilizzare per l'inserimento di caratteri matematici specifici. Per impostazione predefinita, i collegamenti di Correzione automatica dei simboli matematici sono attivati.

È possibile eseguire le operazioni seguenti. Fare clic su uno dei titoli in basso per espanderlo e visualizzare le istruzioni:

 Deselezionare la casella di controllo Sostituisci il testo durante la digitazione

  1. Selezionare l'elemento da modificare. 

    Le informazioni vengono aggiunte alle caselle Sostituisci e Con.

  2. Modificare il collegamento nella casella Sostituisci o il simbolo nella casella Con.

  3. Fare clic sul pulsante Sostituisci.

  1. Selezionare l’elemento che si vuole rimuovere dall’elenco.

  2. Fare clic sul pulsante Elimina.

Prima di iniziare, è necessario avere copiato il simbolo desiderato negli Appunti in modo da poterlo incollare nella finestra di dialogo. Per farlo, chiudere la finestra di dialogo, inserire manualmente il simbolo in una diapositiva (Inserisci > Simbolo) e quindi selezionare e copiare il simbolo (Ctrl+C).

  1. Nella casella Sostituisci, immettere il collegamento che si desidera utilizzare.

    (Il collegamento deve essere diverso da una parola normale e corretta, a meno che non si vuole che quella parola venga sempre sostituita con il simbolo definito nel passaggio 2).

  2. Nella casella Con, incollare il simbolo che si desidera venga assegnato al collegamento Correzione automatica simboli matematici specificato nel passaggio 1.

  3. Fare clic su Aggiungi.

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×