Firma digitale del progetto macro

Questo articolo descrive la procedura per aggiungere una firma digitale a un progetto macro usando un certificato. Se non si dispone già di un certificato digitale, è necessario ottenerne uno. Per testare progetti macro nel computer in uso, è possibile creare un certificato autofirmato con lo strumento Selfcert.exe.

Contenuto dell'articolo

Richiesta di un certificato digitale per la firma

Progetti macro e Microsoft Office

Creazione di un certificato autofirmato

Windows 7, Windows Vista o Windows XP

Visualizzazione del certificato con Internet Explorer

Firma digitale di un progetto macro in Excel, PowerPoint, Publisher, Visio o Word

Richiesta di un certificato digitale per la firma

È possibile ottenere un certificato digitale da un'Autorità di certificazione (CA) commerciale oppure dall'amministratore di protezione o dal responsabile IT interno.

Per ulteriori informazioni sulle autorità di certificazione che offrono servizi per i prodotti Microsoft, vedere l'elenco dei membri del programma Microsoft Root Certificate.

Torna all'inizio

Progetti macro e Microsoft Office

Poiché un certificato digitale creato da un utente non viene rilasciato da un'autorità di certificazione formale attendibile, i progetti macro firmati usando un certificato di questo tipo vengono considerati progetti autofirmati. Microsoft Office considera attendibile un certificato autofirmato solo se tale certificato è stato aggiunto alla cartella Autorità di certificazione radice disponibile nell'elenco locale dell'archivio Certificati - Utente corrente nel computer in uso..

Per informazioni sulla creazione di un certificato autofirmato, vedere la sezione seguente.

Creazione di un certificato autofirmato

Windows 7, Windows Vista o Windows XP

  1. Fare clic su Start, scegliere Tutti i programmi, Microsoft Office, Strumenti di Office e quindi Certificato digitale per progetti VBA.
    Verrà visualizzata la finestra di dialogo Crea certificato digitale.

  2. Nella casella Nome certificato digitare un nome descrittivo per il certificato.

  3. Fare clic su OK.

  4. Quando viene visualizzato il messaggio SelfCert eseguito, fare clic su OK.

Finestra di dialogo Crea certificato digitale

Visualizzazione del certificato con Internet Explorer

Per visualizzare il certificato nell'archivio Certificati personali, eseguire le operazioni seguenti:

  1. Aprire Internet Explorer.

  2. Scegliere Opzioni Internet dal menu Strumenti e quindi fare clic sulla scheda Contenuto.

  3. Fare clic su Certificati e quindi sulla scheda Personali.

Torna all'inizio

Firma digitale di un progetto macro in Excel, PowerPoint, Publisher, Visio o Word

  1. Aprire il file contenente il progetto macro che si desidera firmare.

  2. Nel gruppo Codice della scheda Sviluppo fare clic su Visual Basic.

Nota   Se la scheda Sviluppo non è disponibile, fare clic sulla scheda File. Fare clic su Opzioni. Fare clic su Personalizza barra multifunzione. Nell'elenco Personalizza barra multifunzione selezionare Sviluppo e quindi fare clic su OK.

  1. In Visual Basic scegliere Firma digitale dal menu Strumenti.

  2. Verrà visualizzata la finestra di dialogo Firma digitale.

  3. Selezionare un certificato e fare clic su OK.

    Nota   Se non è stato selezionato alcun certificato digitale o si desidera utilizzarne un altro, fare clic su Scegli. Selezionare il certificato e fare clic su OK.

    Note   

    • È consigliabile firmare le macro solo dopo aver sottoposto a test la soluzione e quando questa è pronta per la distribuzione. Quando si modifica il codice di una macro firmata, infatti, la firma digitale viene rimossa. Se tuttavia si dispone del certificato digitale valido utilizzato in precedenza per firmare il progetto nel computer in uso, il progetto macro verrà nuovamente firmato al momento del relativo salvataggio.

    • Per impedire agli utenti della soluzione di modificare accidentalmente il progetto macro e di invalidare la firma, bloccare il progetto macro prima di firmarlo. La firma digitale implica solo che il progetto non è stato manomesso dopo che è stato firmato, ma non prova che il progetto macro sia stato scritto dal firmatario. Il blocco del progetto macro non impedisce pertanto a un altro utente di sostituire la firma digitale con un'altra firma. Gli amministratori aziendali possono firmare nuovamente i modello e i componente aggiuntivo in modo da controllare i codici eseguiti dagli utenti.

    • Se si crea un componente aggiuntivo che consente di aggiungere codice a un progetto macro, il codice deve essere in grado di stabilire se il progetto contiene una firma digitale e avvisare gli utenti delle conseguenze derivanti dalla modifica di un progetto firmato prima che procedano.

    • Quando si firmano digitalmente le macro, è importante ottenere un indicatore di data e ora in modo che altri utenti possano verificare la firma se il certificato viene utilizzato dopo la scadenza o se è stato revocato dopo l'apposizione della firma. Se si firmano macro senza indicatore di data e ora, la firma rimarrà valida per il periodo di validità del certificato.

Torna all'inizio

Si applica a: Visio 2013, Office Shared 2013, Excel 2013, Excel 2010, PowerPoint 2010, Visio 2016 Preview, Visio 2010, Word 2013, Word 2010, Visio Standard 2010, PowerPoint 2013



Queste informazioni sono risultate utili?

No

Che cosa possiamo migliorare?

255 caratteri rimanenti

Per tutelare la privacy, non includere informazioni di contatto nei commenti e suggerimenti. Consulta la nostra informativa sulla privacy.

Grazie per i tuoi commenti e suggerimenti

Risorse di supporto

Cambia lingua