Filtrare i dati in una tabella pivot

Per focalizzare l'attenzione su una porzione ridotta di una grande quantità di dati in una tabella pivot per analizzarli in modo approfondito, è possibile filtrare i dati. Questa operazione può essere eseguita in diversi modi. Prima di tutto, inserire uno o più filtri dei dati per filtrare i dati in modo rapido ed efficace. I filtri dei dati contengono pulsanti sui quali è possibile fare clic per filtrare i dati e rimangono visibili insieme ai dati, consentendo così di sapere sempre quali campi sono visualizzati o nascosti nella tabella pivot filtrata.

Opzioni del filtro dei dati con il pulsante di selezione multipla evidenziato

Suggerimento : Ora Excel 2016 consente di selezionare più filtri dei dati facendo clic sul pulsante sull'etichetta, come mostrato nella figura qui sopra.

  1. Fare clic in un punto qualsiasi della tabella pivot per visualizzare Strumenti tabella pivot sulla barra multifunzione.

    Barra multifunzione Strumenti tabella pivot con le schede Analizza e Progettazione

  2. Se si usa Excel 2016 o 2013, fare clic su Analizza > Inserisci filtro dati.

    pulsante inserisci filtro dati nella scheda analizza

    Se si usa Excel 2010 o 2007, fare clic su Opzioni > Inserisci filtro dati > Inserisci filtro dati.

    immagine della barra multifunzione di excel
  3. Nella finestra di dialogo Inserisci filtri dati selezionare le caselle relative ai campi per cui si desidera creare filtri dei dati.

  4. Fare clic su OK.

    Verrà visualizzato un filtro dei dati per ogni campo selezionato nella finestra di dialogo Inserisci filtri dati.

  5. In ogni filtro dei dati fare clic sugli elementi da visualizzare nella tabella.

    Per scegliere più elementi, tenere premuto CTRL e quindi selezionare gli elementi da mostrare.

Suggerimento :  Per modificare l'aspetto del filtro dei dati, fare clic su di esso per visualizzare Strumenti filtro dati sulla barra multifunzione, quindi applicare uno stile o modificare le impostazioni nella scheda Opzioni.

Altri modi per filtrare i dati di una tabella pivot

Per visualizzare i dati da analizzare, usare le seguenti funzionalità di filtro al posto o in aggiunta ai filtri dei dati.

Filtrare i dati manualmente

Usare un filtro rapporto per filtrare gli elementi

Visualizzare solo particolari testi, valori o date

Visualizzare i primi o gli ultimi 10 elementi

Filtrare in base alla selezione per visualizzare o nascondere solo gli elementi selezionati

Attivare o disattivare le opzioni di filtro

Filtrare i dati manualmente

  1. Nella tabella pivot fare clic sulla freccia Freccia del menu a discesa Filtro in Etichette di riga o Etichette di colonna.

    Filtro per etichetta di riga

  2. Nell'elenco di etichette di riga o colonna deselezionare la casella (Seleziona tutto) in alto nell'elenco e selezionare le caselle relative agli elementi da visualizzare nella tabella pivot.

    Casella Seleziona tutto nella raccolta di filtri

    Per visualizzare più elementi nell'elenco, trascinare il punto di controllo nell'angolo in basso a destra della raccolta filtri per ingrandirla.

  3. Fare clic su OK.

    La freccia di selezione del filtro si trasforma nell'icona Icona filtro applicato a indicare che è applicato un filtro. Fare clic su di essa per modificare o eliminare il filtro facendo clic su Cancella filtro da <Nome campo>.

    Per rimuovere tutti i filtri contemporaneamente, eseguire la procedura seguente:

    • In Excel 2016 o 2013: fare clic in un punto qualsiasi della tabella pivot e quindi su Analizza > Cancella > Cancella filtri.

    • In Excel 2010 o 2007: fare clic in un punto qualsiasi della tabella pivot e quindi su Opzioni > Cancella > Cancella filtri.

    Pulsante Cancella nella scheda Analizza

Usare un filtro rapporto per filtrare gli elementi

Nota : Un filtro rapporto è etichettato come Filtri nel riquadro Campi tabella pivot in Excel 2016 e Excel 2013. Vedere gli screenshot seguenti:

Area Filtri nel riquadro Campi tabella pivot
Riquadro Campi tabella pivot in Excel 2016
Filtro rapporto nel riquadro Elenco campi tabella pivot
Riquadro Campi tabella pivot in Excel 2010

Mediante un filtro rapporto è possibile visualizzare rapidamente un set di valori diverso nella tabella pivot. Gli elementi selezionati nel filtro vengono visualizzati nella tabella pivot, mentre gli elementi non selezionati rimangono nascosti. Si può anche impostare la visualizzazione delle pagine filtro (il set di valori corrispondenti agli elementi del filtro rapporto selezionati) in fogli di lavoro separati.

Aggiungere un filtro rapporto

  1. Fare clic in un punto qualsiasi della tabella pivot.

    Verrà visualizzato il riquadro Elenco campi tabella pivot.

  2. Nel riquadro Elenco campi tabella pivot fare clic sul campo di un'area e selezionare Sposta in filtro rapporto.

    Sposta in filtro rapporto

È possibile ripetere questo passaggio per creare più filtri rapporto. I filtri rapporto sono visualizzati sopra la tabella pivot, per essere facilmente accessibili.

  1. Per cambiare l'ordine dei campi, nell'area Filtro rapporto trascinare i campi nella posizione desiderata. L'ordine dei filtri rapporto si rifletterà nella tabella pivot.

Visualizzare i filtri rapporto in righe o colonne

  1. Fare clic sulla tabella pivot o sulla tabella pivot associata a un grafico pivot.

  2. Fare clic con il pulsante destro del mouse in un punto qualsiasi della tabella pivot e scegliere Opzioni tabella pivot.

  3. Nella scheda Layout e formato specificare queste opzioni:

  4. Nell'elenco a discesa Modalità di visualizzazione dei campi nell'area filtro del rapporto della sezione Layout eseguire una delle operazioni seguenti:

    • Per visualizzare i filtri rapporto in colonne da sinistra a destra, selezionare Da sopra a sotto.

    • Per visualizzare i filtri rapporto in righe dall'alto al basso, selezionare Da sotto a sopra.

  5. Nella casella Campi filtro rapporto per colonna o Campi filtro rapporto per riga digitare o selezionare il numero di campi da visualizzare prima di passare a un'altra colonna o riga in base all'impostazione di Modalità di visualizzazione dei campi nell'area filtro del rapporto.

Selezionare elementi nel filtro rapporto

  1. Nella tabella pivot fare clic sulla freccia in giù accanto al filtro rapporto.

    Fare clic sulla freccia in giù accanto a (Tutti)
  2. Per selezionare una casella di controllo per tutti gli elementi in modo da poterli selezionare o deselezionare in base alle necessità, selezionare la casella di controllo Seleziona più elementi.

    Seleziona più elementi
  3. Ora è possibile selezionare le caselle di controllo accanto agli elementi da visualizzare nel rapporto. Per selezionare tutti gli elementi, fare clic sulla casella di controllo accanto a (Tutti).

  4. Fare clic su OK. Questo pulsante è abilitato solo se è selezionata almeno una casella di controllo.

    Il filtro rapporto ora mostra gli elementi filtrati.

    Elementi filtrati in base a un valore di filtro in un filtro rapporto

Nota : se si usa un'origine dati OLAP come Microsoft SQL Server Analysis Services (versione 2005 o successiva), è possibile selezionare un membro calcolato solo se è un singolo elemento, non è possibile selezionare più elementi se uno o più sono membri calcolati.

Visualizzare le pagine del filtro rapporto in fogli di lavoro separati

  1. Fare clic in un punto qualsiasi della tabella pivot (o della tabella pivot associata a un grafico pivot) a cui sono applicati uno o più filtri rapporto.

  2. Se si usa Excel 2016 o 2013, nel gruppo Tabella pivot della scheda Analizza fare clic sulla freccia accanto a Opzioni e quindi su Mostra pagine filtro rapporto.

    Opzione Mostra pagine filtro rapporto

    Se si usa Excel 2010 o 2007, nel gruppo Tabella pivot della scheda Opzioni fare clic sulla freccia accanto a Opzioni e quindi su Mostra pagine filtro rapporto.

    Gruppo Tabella pivot nella scheda Opzioni in Strumenti tabella pivot

  3. Nella finestra di dialogo Mostra pagine filtro rapporto selezionare un campo di filtro rapporto e fare clic su OK.

Visualizzare solo particolari testi, valori o date

  1. Nella tabella pivot fare clic con il pulsante destro del mouse sull'etichetta di qualsiasi campo di testo, valore o data e scegliere Filtri per etichette, Filtri per valori o Filtri per date.

  2. Fare clic sul comando dell'operatore di confronto desiderato.

    Per filtrare, ad esempio, in base al testo che inizia con un carattere specifico, selezionare Inizia con oppure per filtrare in base al testo che contiene caratteri specifici in un punto qualsiasi nel testo, selezionare Contiene.

    Nota : Filtri per etichette non è disponibile quando i campi delle etichette di riga o di colonna non contengono etichette di testo.

  3. Eseguire una delle operazioni seguenti:

    • Nella finestra di dialogo Filtro per etichette <Nome filtro> immettere il testo in base al quale filtrare.

      Per filtrare, ad esempio, in base al testo che inizia con la lettera "J", immettere J o per filtrare in base al testo che contiene "mente" in un punto qualsiasi del testo, immettere mente.

      Se la tabella pivot è basata su un'origine dati non OLAP, è possibile usare i seguenti caratteri jolly per trovare dati contenenti caratteri specifici.

Utilizzare

Per trovare

? (punto interrogativo)

Qualsiasi carattere singolo
Ad esempio, ross? trova "rossa", "rosse", "rosso" e "rossi"

* (asterisco)

Qualsiasi numero di caratteri
Ad esempio, r*o trova "reo", "roberto" e "rosso"

~ (tilde) seguita da ?, * o ~

Un punto interrogativo, un asterisco o una tilde
Ad esempio, fy06~? trova "fy06?"

  • Nella finestra di dialogo Filtro per valori <Nome filtro> immettere i valori in base ai quali filtrare.

  • Nella finestra di dialogo Filtro per date <Nome filtro> immettere le date in base alle quali filtrare.

    Se la tabella pivot si basa su un'origine dati OLAP, i filtri per date richiedono il tipo di dati ora nella gerarchia di campi del cubo OLAP. Se una data viene immessa come testo in un campo di testo, il filtro per date non sarà disponibile.

Suggerimento : Per rimuovere un filtro per etichette, per valori o per date, fare clic sulla freccia Icona filtro applicato nell'etichetta di riga o di colonna, fare clic su Filtro per etichette, Filtro per date o Filtro per valori e quindi fare clic su Cancella filtro.

Visualizzare i primi o gli ultimi 10 elementi

È anche possibile applicare filtri per visualizzare i primi o gli ultimi 10 valori o dati che soddisfano specifiche condizioni.

  1. Nella tabella pivot fare clic sulla freccia Freccia del menu a discesa Filtro in Etichette di riga o Etichette di colonna, fare clic su Filtri per valori e quindi fare clic su Primi 10.

  2. Nella finestra di dialogo Filtro primi 10 <Nome campo> eseguire le operazioni seguenti:

    1. Fare clic su Primi o Ultimi nella prima casella.

    2. Nella seconda casella digitare un numero.

    3. Nella terza casella fare clic sull'opzione in base alla quale filtrare.

      • Per filtrare in base al numero di elementi, selezionare Elementi.

      • Per filtrare in base alla percentuale, selezionare Percentuale.

      • Per filtrare in base alla somma, selezionare Somma.

    4. Nella quarta casella selezionare il campo desiderato.

Filtrare in base alla selezione per visualizzare o nascondere solo gli elementi selezionati

  1. Nella tabella pivot selezionare uno o più elementi nel campo che si vuole filtrare in base alla selezione.

    È possibile selezionare elementi non contigui tenendo premuto CTRL mentre si seleziona ogni elemento.

  2. Fare clic con il pulsante destro del mouse su un elemento nella selezione e scegliere Filtra.

  3. Eseguire una delle operazioni seguenti:

    • Per visualizzare gli elementi selezionati, fare clic su Mantieni solo elementi selezionati.

    • Per nascondere gli elementi selezionati, fare clic su Nascondi elementi selezionati.

      Suggerimento :  è possibile visualizzare di nuovo gli elementi nascosti rimuovendo il filtro. Fare clic con il pulsante destro del mouse su un altro elemento nello stesso campo, scegliere Filtra e quindi fare clic su Cancella filtro.

Attivare o disattivare le opzioni di filtro

Se si desidera applicare più filtri per campo o se si preferisce non visualizzare i pulsanti Filtro nella tabella pivot, di seguito è spiegato come attivare o disattivare queste e altre opzioni di filtro:

  1. Fare clic in un punto qualsiasi della tabella pivot per visualizzare Strumenti tabella pivot sulla barra multifunzione.

    Barra multifunzione Strumenti tabella pivot con le schede Analizza e Progettazione

  2. Nel gruppo Tabella pivot della scheda Opzioni fare clic su Opzioni.

    Pulsante Opzioni nella scheda Analizza

  3. Nella finestra di dialogo Opzioni tabella pivot fare clic sulla scheda Totali e filtri.

  4. In Filtri eseguire una delle operazioni seguenti:

    • Per usare o non usare più filtri per campo, selezionare o deselezionare la casella Consenti più filtri per campo.

    • Per includere o escludere gli elementi filtrati nei totali, selezionare o deselezionare la casella Includi elementi filtrati nei totali e quindi selezionare o deselezionare la casella Contrassegna totali con *. Se è selezionata, viene visualizzato un asterisco (*) nei totali all'esterno dei campi per cui è disattivata la visualizzazione dei totali. Questa opzione è disponibile solo nelle tabelle pivot connesse a un'origine dati OLAP che supporta il linguaggio delle espressioni MDX e ha effetto su tutti i campi nella tabella pivot.

    • Per includere o escludere gli elementi filtrati nei totali per i set denominati, selezionare o deselezionare la casella Includi elementi filtrati in totali set. Questa opzione è disponibile solo nelle tabelle pivot connesse a un'origine dati OLAP.

    • Per includere o escludere gli elementi filtrati nei subtotali, selezionare o deselezionare la casella Subtotale elementi pagina filtrati.

  5. Per visualizzare o nascondere le didascalie dei campi e gli elenchi a discesa dei filtri, fare clic sulla scheda Visualizza e selezionare o deselezionare la casella di controllo Visualizza didascalie campi ed elenchi a discesa filtri.

È possibile visualizzare e interagire con le tabelle pivot in Excel Online, ad esempio filtrando manualmente i dati e usando i filtri dati creati nell'applicazione desktop Excel. Non è possibile creare nuovi filtri dati in Excel Online.

Per filtrare i dati di una tabella pivot, eseguire una delle operazioni seguenti:

  • Per applicare un filtro manuale, fare clic sulla freccia in Etichette di riga o Etichette di colonna, quindi selezionare le opzioni di filtro desiderate.

Opzioni di filtro per i dati di una tabella pivot

  • Se la tabella pivot include filtri dati, fare clic sugli elementi da visualizzare in ogni filtro dati.

filtro dati con gli elementi selezionati

Se si dispone dell'applicazione desktop Excel, è possibile fare clic sul pulsante Apri in Excel per aprire la cartella di lavoro e applicare altri filtri o creare nuovi filtri dati per i dati della tabella pivot. Ecco come:

Fare clic su Apri in Excel e filtrare i dati nella tabella pivot.

Pulsante Apri in Excel

Per essere sempre informati sugli aggiornamenti apportati alle caratteristiche di Excel Online, visitare il blog di Microsoft Excel.

È possibile provare o acquistare la famiglia completa di applicazioni e servizi Office su Office.com.

Vedere anche

Video: Filtrare elementi in una tabella pivot

Creare una tabella pivot per analizzare i dati di un foglio di lavoro

Creare una tabella pivot per analizzare dati esterni

Creare una tabella pivot per analizzare i dati di più tabelle

Ordinare i dati in una tabella pivot

Raggruppare o separare dati in una tabella pivot

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×