Esercitazione: Analisi dei dati della tabella pivot tramite un modello di dati in Excel 2013

In meno di un'ora, è possibile compilare un rapporto di tabella pivot in Excel in cui vengono combinati i dati di più tabelle. Nella prima parte di questa esercitazione vengono illustrate l'importazione e l'esplorazione dei dati. Nella seconda metà verrà usato il componente aggiuntivo PowerPivot per ridefinire il modello di dati alla base del rapporto, imparando ad aggiungere calcoli, gerarchie e ottimizzazioni per i report Power View.

Iniziare l'esercitazione con l'importazione dei dati.

  1. Scaricare i dati di esempio (ContosoV2) per questa esercitazione. Per i dettagli, vedere Recuperare i dati di esempio per DAX e il modello di dati (Esercitazioni). Estrarre e salvare i file di dati in un percorso facilmente accessibile, ad esempio la cartella Download o Documenti.

  2. Aprire una cartella di lavoro vuota in Excel.

  3. Fare clic su Dati > Recupera dati esterni > Da Access.

  4. Passare alla cartella contenente i file di dati di esempio e selezionare ContosoSales.

  5. Fare clic su Apri. Poiché si esegue la connessione a un file di database contenente più tabelle, viene visualizzata la finestra di dialogo Seleziona tabella per scegliere le tabelle da importare.

    Finestra di dialogo Seleziona tabella

  6. In Seleziona tabella scegliere Abilita la selezione di più tabelle.

  7. Selezionare tutte le tabelle e fare clic su OK.

  8. In Importa dati fare clic su In un rapporto di tabella pivot, quindi su OK.

    Note : 

    • È appena stato creato un modello di dati. Il modello è un livello di integrazione dei dati creato automaticamente quando si importano o si utilizzano più tabelle contemporaneamente nello stesso report di tabella pivot.

    • Il modello è per lo più trasparente in Excel, ma può essere visualizzato e modificato direttamente con il componente aggiuntivo PowerPivot . In Excel la presenza di un modello di dati è evidente quando si osserva una raccolta di tabelle nell'elenco dei campi della tabella pivot. Per creare un modello si può procedere in vari modi. Per altre informazioni, vedere Creare un modello di dati in Excel .

Esplorare i dati utilizzando una tabella pivot

Esplorare i dati è un'operazione semplice quando si trascinano i campi nelle aree Values, Columns e Rows nell'elenco di campi della tabella pivot.

  1. Nell'elenco di campi scorrere verso il basso finché non si individua la tabella FactSales.

  2. Fare clic su SalesAmount. Poiché questi dati sono numerici, tramite Excel è possibile posizionare automaticamente SalesAmount nell'area Values.

  3. In DimDate trascinare CalendarYear in Columns.

  4. In DimProductSubcategory trascinare ProductSubcategoryName in Rows.

  5. In DimProduct trascinare BrandName in Rows, posizionandolo sotto la sottocategoria.

La tabella pivot dovrebbe essere simile alla schermata seguente.

Tabella pivot con dati di esempio

Con alcuni semplici passaggi è ora disponibile una tabella pivot di base in cui sono inclusi campi di quattro tabelle diverse. Ciò che ha reso questa attività così semplice sono state le relazioni pre-esistenti tra le tabelle. Poiché esistevano relazioni tra le tabelle nell'origine tutte le tabelle sono state importante con una sola operazione, Excel è stato in grado di ricreare tali relazioni nel modello.

Ma cosa accade se i dati provengono da varie origini o vengono importati in un momento successivo? In genere si possono incorporare i nuovi dati creando relazioni in base alle colonne corrispondenti. Nel passaggio successivo si importeranno tabelle aggiuntive e si apprenderanno i requisiti e la procedura per creare nuove relazioni.

Aggiungere altre tabelle

Per comprendere come impostare le relazioni tra tabelle, è necessario disporre di tabelle aggiuntive non connesse su cui lavorare. In questo passaggio, si acquisiranno i dati rimanenti usati in questa esercitazione importando un file di database aggiuntivo e incollando i dati da altre due cartelle di lavoro.

Aggiungere categorie di prodotti

  1. Nella cartella di lavoro aprire un nuovo foglio, che sarà utilizzato per archiviare ulteriori dati.

  2. Fare clic su Dati > Recupera dati esterni > Da Access.

  3. Passare alla cartella contenente i file di dati di esempio e selezionare ProductCategories. Fare clic su Apri.

  4. In Importa dati selezionare Tabella, quindi fare clic su OK.

Aggiungere dati geography

  1. Inserire un altro foglio.

  2. Nel file di esempio aprire Geography.xlsx, posizionare il cursore in A1, quindi premere CTRL+MAIUSC+FINE per selezionare tutti i dati.

  3. Copiare i dati negli Appunti.

  4. Incollare i dati nel foglio vuoto appena aggiunto.

  5. Fare clic su Formatta come tabella, scegliendo uno stile. Formattando i dati come tabella è possibile assegnare loro un nome. Questa operazione risulterà molto utile quando si definiranno relazioni in un passaggio successivo.

  6. In Formatta come tabella verificare che l'opzione Tabella con intestazioni sia selezionata. Fare clic su OK.

  7. Assegnare il nome Geography alla tabella. In Strumenti tabella > Progetta digitare Geography nel nome della tabella.

  8. Chiudere Geography.xlsx per cancellarla dall'area di lavoro.

Aggiungere dati relativi ai negozi

  • Ripetere i passaggi precedenti per il file Stores.xlsx, incollando il relativo contenuto in un foglio vuoto. Assegnare il nome Stores alla tabella.

Ora dovrebbero essere disponibili quattro fogli. In Foglio1 è contenuta la tabella pivot, in Foglio2 ProductCategories, in Foglio3 Geography e in Foglio4 Stores. Una volta assegnato un nome a ogni tabella, il passaggio successivo, cioè la creazione di relazioni, sarà molto più semplice.

Usare i campi dalle tabelle appena importate

È possibile iniziare subito a usare i campi dalle tabelle importate. Se Excel non è in grado di determinare come incorporare un campo nel report di tabella pivot, verrà chiesto di creare una relazione di tabella che associa la nuova tabella con una che faccia già parte del modello.

  1. Nella parte superiore dei campi della tabella pivot fare clic su Tutti per vedere l'elenco completo di tabelle disponibili.

  2. Scorrere fino alla fine dell'elenco dove si troveranno le nuove tabelle appena aggiunte.

  3. Espandere Stores.

  4. Trascinare StoreName nell'area Filters.

  5. Si noti che Excel chiede di creare una relazione. Questa notifica si verifica perché sono stati usati i campi di una tabella non correlata al modello.

  6. Fare clic su Crea per aprire la finestra di dialogo Crea relazione.

  7. In Tabella scegliere FactSales. Nella tabella FactSales disponibile nei dati di esempio in uso sono contenute le informazioni dettagliate sulle vendite e sui costi relative alle attività di Contoso, nonché le chiavi di altre tabelle, inclusi i codici dei negozi anche presenti nel file Stores.xlsx importato nel passaggio precedente.

  8. In Colonna (esterna) scegliere StoreKey.

  9. In Tabella correlata scegliere Stores.

  10. In Colonna correlata (principale) scegliere StoreKey.

  11. Fare clic su OK.

Per quanto riguarda il funzionamento dettagliato, tramite Excel viene compilato un modello di dati che può essere utilizzato in qualsiasi numero di tabelle pivot, grafici pivot o report Power View dell'intera cartella di lavoro. Le relazioni tra tabelle che determinano i percorsi di esplorazione e calcolo usati in un rapporto di tabella pivot sono fondamentali per questo modello. Nell'attività successiva si creeranno manualmente relazioni per connettere i dati appena importati.

Aggiungere relazioni

Si possono creare sistematicamente relazioni tra tabelle per tutte le nuove tavelle importate. Se si condivide la cartella di lavoro con i colleghi, sarà utile avere relazioni predefinite se i colleghi non conoscono i dati altrettanto bene.

Quando si creano relazioni manualmente, le operazioni verranno effettuate in due tabelle alla volta. Per ogni tabella, si sceglieranno le colonne tramite cui viene indicato a Excel come individuare le righe correlate in un'altra tabella.

Il browser in uso non supporta le funzionalità video. Installare Microsoft Silverlight, Adobe Flash Player o Internet Explorer 9.

Collegare ProductSubcategory a ProductCategory

  1. In Excel fare clic su Dati > Relazioni > Nuovo.

  2. In Tabella scegliere DimProductSubcategory.

  3. In Colonna (esterna) scegliere ProductCategoryKey.

  4. In Tabella correlata scegliere Table_ProductCategory.accdb.

  5. In Colonna correlata (principale) scegliere ProductCategoryKey.

  6. Fare clic su OK.

  7. Chiudere la finestra di dialogo Gestisci relazioni.

Aggiungere categorie alla tabella pivot.

Sebbene il modello di dati sia stato aggiornato per includere ulteriori tabelle e relazioni, questa condizione non è ancora nota alla tabella pivot. In questa attività si aggiungerà ProductCategory all'elenco di campi della tabella pivot.

  1. Nei campi della tabella pivot fare clic su Tutti per visualizzare le tabelle presenti nel modello di dati.

  2. Scorrere fino alla fine dell'elenco.

  3. Nell'area Rows rimuovere BrandName.

  4. Espandere Table_DimProductCategories.accdb.

  5. Trascinare ProductCategoryName nell'area Rows, posizionandolo su ProductSubcategory.

  6. Nei campi della tabella pivot fare clic su Attiva per verificare che le tabelle appena utilizzate siano ora usate attivamente nella tabella pivot.

Fase di verifica: Rivedere le informazioni acquisite

È ora disponibile una tabella pivot che include i dati sono ricavati da più tabelle, molte delle quali sono state importate come passaggio successivo. Per combinare questi dati, è stato necessario creare relazioni tra tabelle utilizzate da Excel per collegare le righe. Si è appreso che la presenza di colonne tramite cui vengono forniti dati corrispondenti è essenziale per la ricerca di righe correlate. In tutte le tabelle dei file di dati di esempio è inclusa una colonna che può essere utilizzata a questo scopo.

Sebbene la tabella pivot funzioni, diversi aspetti possono essere migliorati. Nell'elenco di campi della tabella pivot sembrano essere presenti tabelle (DimEntity) e colonne (ETLLoadID) aggiuntive non correlate alle attività di Contoso. Inoltre, i dati Geography non sono ancora stati integrati.

Passaggio successivo: Visualizzare ed estendere il modello con PowerPivot

Nella serie successiva di attività verrà usato il componente aggiuntivo Microsoft Office PowerPivot in Microsoft Excel 2013 per estendere il modello. Si scoprirà che la creazione di relazioni tramite la vista diagramma disponibile nel componente aggiuntivo è più semplice. Il componente aggiuntivo verrà inoltre usato per creare calcoli e gerarchie, nascondere elementi che non è consigliabile visualizzare nell'elenco campi e ottimizzare i dati per la creazione di report aggiuntivi.

Nota :  Il componente aggiuntivo PowerPivot in Microsoft Excel 2013 è disponibile in Office Professional Plus. Per altre informazioni, vedere Componente aggiuntivoPower Pivot in Microsoft Excel 2013.

Aggiungere PowerPivot alla barra multifunzione di Excel abilitando il componente aggiuntivo PowerPivot.

  1. Passare a File > Opzioni > Componenti aggiuntivi.

  2. Nella casella Gestisci fare clic su Componenti aggiuntivi COM> Vai.

  1. Selezionare la casella Microsoft Office PowerPivot in Microsoft Excel 2013, quindi scegliere OK.

Nella barra multifunzione è ora disponibile una scheda PowerPivot.

Aggiungere una relazione tramite la vista diagramma in PowerPivot

  1. In Excel fare clic sul Foglio3 per fare in modo che sia quello attivo. Nel Foglio3 è contenuta la tabella Geography importata in precedenza.

  2. Sulla barra multifunzione fare clic su PowerPivot > Aggiungi a modello di dati. Tramite questo passaggio la tabella Geography viene aggiunta al modello e viene aperto il componente aggiuntivo PowerPivot che sarà usato per eseguire i rimanenti passaggi di questa attività.

  3. Nella finestra di PowerPivot vengono visualizzate tutte le tabelle nel modello, inclusa Geography. Fare clic su una coppia di tabelle. Nel componente aggiuntivo è possibile visualizzare tutti i dati contenuti nel modello.

  4. Nella sezione Visualizza della finestra di PowerPivot fare clic su Vista diagramma.

  5. Utilizzare la barra di scorrimento per ridimensionare il diagramma in modo da poter visualizzare tutti i relativi oggetti. Si noti che le due tabelle non sono correlate al resto del diagramma: DimEntity e Geography.

  6. Fare clic con il pulsante destro del mouse su DimEntity e scegliere Elimina. Questa tabella è un artefatto del database originale e non è necessaria nel modello.

  7. Ingrandire Geography in modo da poter visualizzare tutti i relativi campi. È possibile utilizzare il dispositivo di scorrimento per rendere più grande il diagramma della tabella.

  8. Si noti che per Geography è disponibile GeographyKey. In questa colonna sono contenuti valori tramite cui ogni riga della tabella Geography viene identificata in modo univoco. A questo punto è possibile scoprire se questa chiave viene utilizzata anche in altre tabelle del modello. In questo caso, è possibile creare una relazione tramite cui collegare Geography al resto del modello.

  9. Fare clic su Trova.

  10. In Trova metadati digitare GeographyKey.

  11. Fare clic più volte su Trova successivo. Si noterà che GeographyKey viene mostrato nelle tabelle Geography e Stores.

  12. Riposizionare la tabella Geography accanto a Stores.

  13. Trascinare la colonna GeographyKey nella colonna GeographyKey di Geography. PowerPivot disegna una linea tra le due colonne per indicare la relazione.

In questa attività è stata appresa una nuova tecnica per l'aggiunta di tabelle e la creazione di relazioni. A questo punto si ha a disposizione un modello completamente integrato con tutte le tabelle connesse e disponibili per la tabella pivot del Foglio1.

Suggerimento :  In Vista diagramma diversi diagrammi della tabella sono completamente estesi con conseguente visualizzazione di colonne come ETLLoadID, LoadDate e UpdateDate. Questi campi particolari sono artefatti del data warehouse originale Contoso, aggiunti per supportare le operazioni di estrazione e caricamento dei dati. Non sono necessari nel modello. Per eliminarli, evidenziare e fare clic con il pulsante destro del mouse sul campo e selezionare Elimina .

Creare una colonna calcolata

In PowerPivot è possibile usare il linguaggio DAX (Data Analysis Expressions) per aggiungere calcoli. In questa attività viene calcolato il profitto totale e viene aggiunta una colonna calcolata che fa riferimento ai valori di dati di altre tabelle. Successivamente, verrà illustrato come usare le colonne a cui viene fatto riferimento per semplificare il modello.

  1. Nella finestra di PowerPivot tornare alla vista dati.

  2. Rinominare la tabella Table_ProductCategories accdb con un nome più discorsivo. Si farà riferimento a questa tabella nei passaggi successivi e un nome più breve renderà più semplice la lettura dei calcoli. Fare clic con il pulsante destro del mouse sul nome della colonna, scegliere Rinomina, digitareProductCategories, quindi premere INVIO.

  3. Selezionare la tabella FactSales.

  4. Fare clic su Progetta > Colonne > Aggiungi.

  5. Nella barra della formula sopra la tabella digitare la formula seguente. La funzionalità Completamento automatico consente di digitare i nomi completi di colonne e tabelle ed elencare le funzioni disponibili. È inoltre possibile fare clic sulla colonna per aggiungere automaticamente il nome della colonna alla formula.

    = [SalesAmount] - [TotalCost] - [ReturnAmount]

  6. Dopo aver completato la compilazione della formula, premere INVIO per accettarla.

    I valori vengono popolati per tutte le righe nella colonna calcolata. Scorrendo la tabella, si vedrà che le righe possono avere valori diversi per questa colonna, in base ai dati presenti in ogni riga.

  7. Rinominare la colonna facendo clic con il pulsante destro del mouse su CalculatedColumn1 e scegliendo Rinomina colonna. Digitare TotalProfit, quindi premere INVIO.

  8. Ora selezionare la tabella DimProduct .

  9. Fare clic su Progetta > Colonne > Aggiungi.

  10. Nella barra della formula sopra la tabella digitare la formula seguente.

    = RELATED(ProductCategories[ProductCategoryName])

    Tramite la funzione RELATED viene restituito un valore da una tabella correlata. In questo caso, nella tabella ProductCategories sono inclusi i nomi delle categorie di prodotti che sarà utile avere nella tabella DimProduct quando si compila una gerarchia che comprende informazioni sulla categoria. Per ulteriori informazioni su questa funzione, vedere Funzione RELATED (DAX).

  11. Dopo aver completato la compilazione della formula, premere INVIO per accettarla.

    I valori vengono popolati per tutte le righe nella colonna calcolata. Scorrendo la tabella verso il basso, si vedrà che ogni riga dispone ora di un nome Product Category.

  12. Rinominare la colonna facendo clic con il pulsante destro del mouse su CalculatedColumn1 e scegliendo Rinomina colonna. Digitare ProductCategory, quindi premere INVIO.

  13. Fare clic su Progetta > Colonne > Aggiungi.

  14. Nella barra della formula sopra la tabella digitare la formula seguente, quindi premere INVIO per accettare la formula.

    = RELATED(DimProductSubcategory[ProductSubcategoryName])

  15. Rinominare la colonna facendo clic con il pulsante destro del mouse su CalculatedColumn1 e scegliendo Rinomina colonna. Digitare ProductSubcategory, quindi premere INVIO.

Creare una gerarchia

Nella maggior parte dei modelli sono inclusi dati implicitamente gerarchici, ad esempio i dati del calendario, i dati geografici e le categorie di prodotti. La creazione di gerarchie è utile poiché è possibile trascinare un elemento (la gerarchia) in un report anziché dover unire e ordinare più volte gli stessi campi.

  1. In PowerPivot passare a Vista diagramma. Espandere la tabella DimDate in modo da poter visualizzare più facilmente tutti i relativi campi.

  2. Tenere premuto CTRL e fare clic sulle colonne CalendarYear, CalendarQuarter e CalendarMonth (sarà necessario scorrere verso il basso la tabella).

  3. Con le tre colonne selezionate, fare clic con il pulsante destro del mouse su una di esse e fare clic su Crea gerarchia. Nella parte inferiore della tabella viene creato un nodo di gerarchia padre, Hierarchy 1, e le colonne selezionate vengono copiate nella gerarchia come nodi figlio.

  4. Digitare Dates come nome per la nuova gerarchia.

  5. Aggiungere la colonna FullDateLabel alla gerarchia. Fare clic con il pulsante destro del mouse su FullDateLabel e scegliere Aggiungi a gerarchia. Scegliere Date. FullDateLabel contiene una data completa, con anno, mese e giorno. Verificare che FullDateLabel sia indicata per ultima nella gerarchia. A questo punto si dispone di una gerarchia multilivello che include anno, trimestre, mese e singoli giorni di calendario.

  6. Nella vista diagramma passare alla tabella DimProduct, quindi fare clic sul pulsante Crea gerarchia nell'intestazione della tabella. In fondo alla tabella verrà visualizzato il nodo padre di una gerarchia vuota.

  7. Digitare Product Categories come nome per la nuova gerarchia.

  8. Per creare nodi figlio della gerarchia, trascinare ProductCategory e ProductSubcategory nella gerarchia.

  9. Fare clic con il pulsante destro del mouse su ProductName e selezionare Aggiungi a gerarchia. Scegliere Product Categories.

Ora che si conoscono due modi diversi per creare una gerarchia, utilizzarli nella tabella pivot.

  1. Tornare a Excel.

  2. Nel Foglio1, ovvero quello contenente la tabella pivot, rimuovere i campi nell'area Rows.

  3. Sostituirli con la nuova gerarchia Product Categories in DimProduct.

  4. Analogamente, sostituire CalendarYear nell'area Columns con la gerarchia Dates in DimDate.

A questo punto, durante l'esplorazione dei dati, è facile visualizzare i vantaggi derivanti dall'utilizzo delle gerarchie. È possibile espandere e chiudere indipendentemente le diverse aree della tabella pivot, pertanto si dispone di un maggiore controllo sulla modalità di utilizzo dello spazio disponibile. Inoltre, aggiungendo una singola gerarchia a Rows e Columns, si ottiene un drill-down dettagliato e immediato, senza dover distribuire con spaziatura più campi per ottenere un risultato simile.

Nascondere colonne

Dopo aver creato una gerarchia Product Categories e averla posizionata in DimProduct, non è più necessario disporre di DimProductCategory o DimProductSubcategory nell'elenco di campi della tabella pivot. In questa attività verrà illustrato come nascondere tabelle e colonne estranee che stanno occupando spazio nell'elenco di campi della tabella pivot. Nascondendo tabelle e colonne, è possibile migliorare l'esperienza di creazione di report senza influire sul modello tramite cui vengono forniti relazioni e calcoli di dati.

Il browser in uso non supporta le funzionalità video. Installare Microsoft Silverlight, Adobe Flash Player o Internet Explorer 9.

È possibile nascondere singole colonne, un intervallo di colonne o un'intera tabella. I nomi delle tabelle e delle colonne vengono visualizzati in grigio per indicare ai client di creazione di report in cui viene utilizzato il modello che si tratta di elementi nascosti. Le colonne nascoste sono visualizzate in grigio nel modello per indicare il relativo stato, ma restano visibili in Visualizzazione dati in modo che sia possibile continuare a utilizzarle.

  1. In PowerPivot assicurarsi che l'opzione Vista dati sia selezionata.

  2. Nelle schede nella parte inferiore fare clic con il pulsante destro del mouse su DimProductSubcategory e selezionare Nascondi a strumenti client.

  3. Ripetere l'operazione per ProductCategories.

  4. Aprire DimProduct.

  5. Fare clic con il pulsante destro del mouse sulle colonne seguenti e selezionare Nascondi a strumenti client:

    • ProductKey

    • ProductLabel

    • ProductSubcategory

  6. Colonne adiacenti di selezione multipla. Iniziare con ClassID e continuare fino a ProductSubcategory. Fare clic con il pulsante destro del mouse per nasconderle.

  7. Ripetere l'operazione per altre tabelle, rimuovendo gli ID, le chiavi o altri dettagli che non si desidera utilizzare nel report.

Tornare al Foglio1 di Excel con l'elenco di campi della tabella pivot per vedere la differenza. Il numero di tabelle è inferiore e in DimProduct sono inclusi solo gli elementi che più probabilmente verranno utilizzati durante l'analisi delle vendite.

Creazione di un report Power View

I rapporti di tabella pivot non sono l'unico tipo di report che trae vantaggio da un modello di dati. Utilizzando lo stesso modello appena compilato, è possibile aggiungere un foglio di Power View per provare alcuni dei layout forniti.

  1. In Excel fare clic su Inserisci > Power View.

    Nota :  Se si usa Power View per la prima volta su questo computer, verrà chiesto di abilitare il componente aggiuntivo e installare prima Silverlight.

  2. Nei campi di Power View fare clic sulla freccia accanto alla tabella FactSales, quindi fare clic su SalesAmount.

  3. Espandere la tabella Geography e fare clic su RegionCountryName.

  4. Sulla barra multifunzione fare clic su Mappa.

  5. Viene visualizzato un report Mappa. Trascinare un angolo per ridimensionarlo. Tramite i cerchi blu di varie dimensioni sulla mappa vengono indicate le prestazioni delle vendite per i diversi paesi o aree.

Ottimizzare i report Power View

Piccole modifiche apportate al modello produrranno risposte più intuitive al momento della progettazione di un report Power View. In questa attività si aggiungeranno URL di siti web per più produttori quindi si categorizzeranno i dati come URL Web in modo che l'indirizzo URL sia visualizzato come collegamento.

Come primo passaggio aggiungere gli URL alla cartella di lavoro.

  1. In Excel aprire un nuovo foglio e copiare questi valori:

ManufacturerURL

ManufacturerID

http://www.contoso.com

Contoso, LTD

http://www.adventure-works.com

Adventure Works

http://www.fabrikam.com

Fabrikam, Inc.

  1. formattare le celle come una tavella e denominare la tabella URL.

  2. Creare una relazione tra URL e la tabella contenente i nomi dei produttori, DimProduct:

    1. Fare clic su Dati > Relazioni. Verrà visualizzata la finestra di dialogo Crea relazione.

    2. Fare clic su Nuova.

    3. In Tabella selezionare DimProduct.

    4. In Colonna selezionare Manufacturer.

    5. In Tabella correlata selezionare URL.

    6. In Colonna correlata (principale) selezionare ManufacturerID.

Per confrontare i risultati prima e dopo, avviare un nuovo report Power View e aggiungere FactSales | SalesAmount, dimProduct | Manufacturer e URL | ManufacturerURL a un report. Gli URL saranno visualizzati come testo statico.

Per visualizzare un URL come collegamento ipertestuale attivo è necessaria la categorizzazione. Per categorizzare una colonna, usare PowerPivot.

  1. In PowerPivot aprire URL.

  2. Selezionare ManufacturerURL.

  3. Fare clic su Avanzate > Proprietà report > Categoria di dati: Senza categoria.

  4. Fare clic sulla freccia GIÙ.

  5. Selezionare URL Web.

  6. In Excel fare clic su Inserisci > Power View.

  7. Nei campi di Power View selezionare FactSales | SalesAmount, dimProduct | Manufacturer e URL | ManufacturerURL. Questa volta gli URL appariranno come collegamenti ipertestuali affettivi.

Tra le altre ottimizzazioni di Power View sono incluse la definizione di un set di campi predefinito per ogni tabella e l'impostazione di proprietà tramite cui viene determinato se le righe di dati ripetuti vengono aggregate o elencate in modo indipendente. Per ulteriori informazioni, vedere Configurare il set di campi predefiniti per i report Power View e Configurare le proprietà Comportamento tabella per i report Power View.

Creare campi calcolati

Nella seconda attività, Esplorare i dati utilizzando una tabella pivot, si è fatto clic sul campo SalesAmount nell'elenco di campi della tabella pivot. Poiché SalesAmount è una colonna numerica, è stata inserita automaticamente nell'area Values della tabella pivot. Il campo Sum of SalesAmount era quindi pronto per calcolare gli importi di vendita, indipendentemente dai filtri applicati. In questo caso, nessun filtro inizialmente, ma poi CalendarYear, ProductSubcategoryName e BrandName.

In effetti si è creato un campo calcolato implicito, facilitando l'analisi degli importi delle vendite dalla tabella FactSales rispetto ad altri campi, come categoria di prodotti, area e date. I campi calcolati impliciti vengono creati da Excel quando si trascina un campo dall'area Values o quando si fa clic su un campo numerico, come è stato fatto con SalesAmount. I campi calcolati impliciti sono formule che usano funzioni di aggregazione standard, come SOMMA, CONTA.NUMERI e MEDIA, che vengono create automaticamente.

Esistono anche altri tipi di campi calcolati. È possibile creare campi calcolati espliciti in PowerPivot. A differenza di un campo calcolato implicito, che può essere usato solo nella tabella pivot in cui è stato creato, i campi calcolati espliciti possono essere usati in qualsiasi tabella pivot nella cartella di lavoro o da qualsiasi report che usa il modello di dati come origine dati. Con i campi calcolati espliciti creati in PowerPivot è possibile usare Somma automatica per creare automaticamente campi calcolati tramite aggregazioni standard. In alternativa se ne possono creare di personalizzati usando una formula creata con Data Analysis Expressions (DAX).

Come si può immaginare, la creazione di campi calcolati può facilitare l'analisi dei dati in svariati e potenti modi, quindi si vedrà subito come fare.

La creazione di campi calcolati in PowerPivot è un'operazione semplice se si usa la funzione Somma automatica.

  1. Nella tabella FactSales fare clic sulla colonna Profit.

  2. Fare clic su Calcoli > Somma automatica. Come si noterà, un nuovo campo calcolato denominato Sum of Profit è stato creato automaticamente nella cella dell'area di calcolo direttamente sotto la colonna Profit.

  3. In Excel, nell'elenco di campi del Foglio1, nella tabella FactSales fare clic su Sum of Profit.

Ecco fatto. È tutto ciò che occorre fare per creare un campo calcolato tramite un'aggregazione standard in PowerPivot. come si può vedere, in un paio di minuti si è creato un campo calcolato SUM of Profit, che è stato aggiunto alla tabella pivot in modo da facilitare l'analisi dei profitti, a seconda dei filtri applicati. In questo caso si vedrà Sum of Profit filtrato in base alla categoria di prodotti e alle gerarchie di date.

Ma se fosse necessario eseguire analisi più dettagliate, come il numero delle vendite per un particolare canale, prodotto o categoria, si dovrà creare un altro campo calcolato per il conteggio del numero delle righe, uno per ogni vendita nella tabella FactSales, a seconda dei filtri applicati.

  1. Nella tabella FactSales fare clic sulla colonna SalesKey.

  2. In Calcoli fare clic sulla freccia in giù di Somma automatica > Conteggio.

  3. Rinominare il nuovo campo calcolato facendo clic con il pulsante destro del mouse su Count of SalesKey nell'area di calcolo, quindi scegliendo Rinomina. Digitare Count, quindi premere INVIO.

  4. In Excel, nell'elenco di campi del Foglio1, nella tabella FactSales fare clic su Count.

Si noterà che è stata aggiunta una nuova colonna, Count, alla tabella pivot con il numero delle vendite in base ai filtri applicati. Come per il campo calcolato Sum of Profit, si vedrà Count filtrato in base alla categoria di prodotti e alle gerarchie di date.

Si creerà un'altro campo calcolato che calcola la percentuale delle vendite totali per un particolare contesto o filtro. Tuttavia, a differenza dei precedenti campi calcolati creati tramite Somma automatica, questa volta si immetterà la formula manualmente.

  1. Nell'area di calcolo della tabella FactSales fare clic su una cella vuota. Suggerimento: la cella superiore è una posizione ottimale per iniziare a inserire campi calcolati, in quando è più facile trovarli. Nell'area di calcolo è possibile spostare qualsiasi campo calcolato.

  2. Nella barra della formula digitare e usare IntelliSense per creare la formula seguente: Percentage of All Products:=[Count]/CALCULATE([Count], ALL(DimProduct))

  3. Premere INVIO per accettare la formula.

  4. In Excel, nell'elenco di campi del Foglio1, nella tabella FactSales fare clic su Percentage of All Products.

  5. Nella tabella pivot selezionare più colonne Percentage of All Products.

  6. Nella scheda Home fare clic suNumero > Percentuale. Usare due cifre decimali per formattare ogni nuova colonna.

questo nuovo campo calcolato calcola la percentuale delle vendite totali per un determinato contesto di filtro. In questo caso il contesto di filtro sono ancora la categoria di prodotti e le gerarchie di date. È possibile vedere ad esempio che i computer, come percentuale delle vendite di prodotti totali, sono aumentati nel corso degli anni.

La creazione di formule per le colonne e i campi calcolati sarà più facile se si ha familiarità con la creazione di formule di Excel. Che si abbia o meno familiarità con le formule di Excel, un'ottima risorsa per apprendere i concetti di base delle formule DAX sono le lezioni disponibili nella Guida introduttiva: Informazioni sulle nozioni fondamentali di DAX in 30 minuti.

Salvare i dati

salvare la cartella di lavoro per poterla usare con altre esercitazioni o per analizzarla più a fondo.

Passaggi successivi

Benché sia possibile importare facilmente dati da Excel, l'importazione risulta spesso più rapida ed efficiente se si usa il componente aggiuntivo PowerPivot. È possibile filtrare i dati che si stanno importando escludendo le colonne non necessarie. È possibile scegliere se usare un generatore o un comando di query per recuperare i dati. Successivamente, sarà possibile valutare approcci alternativi consultando gli argomenti Recuperare dati da un feed di dati in Power Pivot e Importare dati da Analysis Services o Power Pivot.

I report Power View vengono progettati per l'interazione con modelli di dati simili a quello appena compilato. Per ulteriori informazioni sulle visualizzazioni avanzate di dati garantite da Power View in Excel, vedere Avviare Power View in Excel 2013 e Power View: visualizzare, esplorare e presentare i dati.

Provare a migliorare il modello di dati per creare report Power View migliori, seguendo l'Esercitazione: Ottimizzare il modello di dati per report Power View

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×