Esempi di formule comuni in Elenchi SharePoint

Esempi di formule comuni in Elenchi SharePoint

Importante :  Il presente articolo è stato tradotto automaticamente, vedere la dichiarazione di non responsabilità. Per visualizzare la versione inglese dell'articolo, fare clic qui.

Utilizzo di formule nelle colonne calcolate di una raccolta di elenco o SharePointSharePoint consente di aggiungere colonne esistenti, ad esempio il calcolo dell'IVA su un prezzo. Questi possono essere combinati per convalidare i dati a livello di programmazione.

Quando si immettono formule, se non diversamente specificato, non sono presenti spazi tra le parole chiave e operatori. Di seguito non è un elenco completo. Per visualizzare tutte le formule in SharePoint, vedere l' elenco in ordine alfabetico alla fine di questo articolo.

Nota : Campi calcolati possono funzionano solo nella propria riga, in modo che è possibile fare riferimento a un valore in un'altra riga o colonne contenute in un altro elenco o raccolta. Campi di ricerca non sono supportati in una formula e l'ID della riga appena inserita non può essere utilizzato come l'ID non esiste durante l'elaborazione della formula.

È possibile usare le formule seguenti per testare la condizione di un'istruzione e restituire un valore Sì o No, testare un valore alternativo come OK o NO oppure restituire uno spazio o un trattino per rappresentare un valore Null.

Verificare se un numero è maggiore o minore di un altro numero

Per eseguire questo confronto, usare la funzione SE.

Column1

Column2

Formula

Descrizione (possibile risultato)

15000

9000

=[Column1]>[Column2]

Column1 è maggiore di Column2? Sì

15000

9000

=SE([Column1]<=[Column2], "OK", "NO")

Column1 è minore o uguale di Column2? NO

Restituire un valore logico dopo il confronto del contenuto delle colonne

Per un risultato contenente un valore logico (Sì o No), usare le funzioni E, O e NON.

Column1

Column2

Column3

Formula

Descrizione (possibile risultato)

15

9

8

=E([Column1]>[Column2], [Column1]<[Column3])

15 è maggiore di 9 e minore di 8? No

15

9

8

=O([Column1]>[Column2], [Column1]<[Column3])

15 è maggiore di 9 o minore di 8? Sì

15

9

8

=NON([Column1]+[Column2]=24)

15 più 9 è diverso da 24? (No)

Per ottenere un risultato con altri calcoli o un qualsiasi altro valore diverso da Sì o No, usare le funzioni SE, E e O.

Column1

Column2

Column3

Formula

Descrizione (possibile risultato)

15

9

8

=SE([Column1]=15, "OK", "NO")

Se il valore di Column1 è uguale a 15, restituisce "OK". OK

15

9

8

=SE(E([Column1]>[Column2], [Column1]<[Column3]), "OK", "NO")

Se 15 è maggiore di 9 e minore di 8, restituisce "OK". NO

15

9

8

=SE(O([Column1]>[Column2], [Column1]<[Column3]), "OK", "NO")

Se 15 è maggiore di 9 o minore di 8, restituisce "OK". OK

Visualizzare gli zeri come spazi vuoti o trattini

Per visualizzare uno zero, eseguire un calcolo semplice. Per visualizzare uno spazio vuoto o un trattino, usare la funzione SE.

Column1

Column2

Formula

Descrizione (possibile risultato)

10

10

=[Column1]-[Column2]

Il secondo numero viene sottratto dal primo (0)

15

9

=SE([Column1]-[Column2],"-",[Column1]-[Column2])

Restituisce un trattino quando il valore è zero (-)

Nascondere i valori di errore nelle colonne

Per visualizzare un trattino oppure #N/D o ND al posto di un valore di errore, usare la funzione VAL.ERRORE.

Column1

Column2

Formula

Descrizione (possibile risultato)

10

0

=[Column1]/[Column2]

Restituisce un errore (#DIV/0)

10

0

=SE(VAL.ERRORE([Column1]/[Column2]),"ND",[Column1]/[Column2])

Restituisce ND se il valore è un errore

10

0

=SE(VAL.ERRORE([Column1]/[Column2]),"-",[Column1]/[Column2])

Restituisce un trattino se il valore è un errore

Controlla campi vuoti

È possibile utilizzare la formula Val per trovare campi vuoti.

Column1

Formula

Descrizione (possibile risultato)

"Gelatina beans"

= ISBLANK([Column1]

Restituisce Sì o No se vuoto o meno

"Acciaio"

= IF(ISBLANK([Column1]), "No", "OK")

Inserire le proprie scelte - prima di tutto è se vuoto, secondo se non

Per altre funzioni, vedere funzioni VAL.

È possibile usare le formule seguenti per eseguire calcoli che dipendono da data e ora, ad esempio l'aggiunta di un numero di giorni, mesi o anni a una data, il calcolo della differenza tra due date e la conversione dell'ora in valore decimale.

Aggiungere date

Per aggiungere un numero di giorni a una data, usare l'operatore di addizione (+).

Nota : Quando si modificano le date, il tipo restituito della colonna calcolata deve essere impostato su Data e ora.

Column1

Column2

Formula

Descrizione (risultato)

9/6/2007

3

=[Column1]+[Column2]

Aggiunge 3 giorni al 9/6/2007 (12/6/2007)

10/12/2008

54

=[Column1]+[Column2]

Aggiunge 54 giorni al 10/12/2008 (2/2/2009)

Per aggiungere un numero di mesi a una data, usare le funzioni DATA, ANNO, MESE e GIORNO.

Column1

Column2

Formula

Descrizione (risultato)

9/6/2007

3

=DATA(ANNO([Column1]),MESE([Column1])+[Column2],GIORNO([Column1]))

Aggiunge 3 mesi al 9/6/2007 (9/9/2007)

10/12/2008

25

=DATA(ANNO([Column1]),MESE([Column1])+[Column2],GIORNO([Column1]))

Aggiunge 25 mesi al 10/12/2008 (10/1/2011)

Per aggiungere un numero di anni a una data, usare le funzioni DATA, ANNO, MESE e GIORNO.

Column1

Column2

Formula

Descrizione (risultato)

9/6/2007

3

=DATA(ANNO([Column1])+[Column2],MESE([Column1]),GIORNO([Column1]))

Aggiunge 3 anni al 9/6/2007 (9/6/2010)

10/12/2008

25

=DATA(ANNO([Column1])+[Column2],MESE([Column1]),GIORNO([Column1]))

Aggiunge 25 anni al 10/12/2008 (10/12/2033)

Per aggiungere una combinazione di giorni, mesi e anni a una data, usare le funzioni DATA, ANNO, MESE e GIORNO.

Column1

Formula

Descrizione (risultato)

9/6/2007

=DATA(ANNO([Column1])+3,MESE([Column1])+1,GIORNO([Column1])+5)

Aggiunge 3 anni, 1 mese e 5 giorni al 9/6/2007 (14/7/2010)

10/12/2008

=DATA(ANNO([Column1])+1,MESE([Column1])+7,GIORNO([Column1])+5)

Aggiunge 1 anno, 7 mesi e 5 giorni al 10/12/2008 (15/7/2010)

Calcolare la differenza tra due date

Per eseguire questo calcolo, usare la funzione DATA.DIFF.

Column1

Column2

Formula

Descrizione (risultato)

01-gen-1995

15-giu-1999

=DATA.DIFF([Column1], [Column2],"d")

Restituisce il numero di giorni compresi tra due date (1626)

01-gen-1995

15-giu-1999

=DATA.DIFF([Column1], [Column2],"ym")

Restituisce il numero di mesi tra le date, ignorando la parte relativa all'anno (5)

01-gen-1995

15-giu-1999

=DATA.DIFF([Column1], [Column2],"yd")

Restituisce il numero di giorni tra le date, ignorando la parte relativa all'anno (165)

Calcolare la differenza tra due ore

Per presentare il risultato nel formato standard (ore:minuti:secondi), usare l'operatore di sottrazione (-) e la funzione TESTO. Per eseguire questo metodo, il numero di ore non deve superare 24 e il numero di minuti e secondi non deve superare 60.

Column1

Column2

Formula

Descrizione (risultato)

09/06/2007 10:35

09/06/2007 15:30

=TESTO([Column2]-[Column1],"h")

Ore trascorse tra due orari (4)

09/06/2007 10:35

09/06/2007 15:30

=TESTO([Column2]-[Column1],"h:mm")

Ore e minuti trascorsi tra due orari (4:55)

09/06/2007 10:35

09/06/2007 15:30

=TESTO([Column2]-[Column1],"h:mm:ss")

Ore, minuti e secondi trascorsi tra due orari (4:55:00)

Per presentare il risultato in un totale basato su un'unità di tempo, usare la funzione INT oppure ORA, MINUTO o SECONDO.

Column1

Column2

Formula

Descrizione (risultato)

09/06/2007 10:35

10/06/2007 15:30

=INT(([Column2]-[Column1])*24)

Totale delle ore trascorse tra due orari (28)

09/06/2007 10:35

10/06/2007 15:30

=INT(([Column2]-[Column1])*1440)

Totale dei minuti trascorsi tra due orari (1735)

09/06/2007 10:35

10/06/2007 15:30

=INT(([Column2]-[Column1])*86400)

Totale dei secondi trascorsi tra due orari (104100)

09/06/2007 10:35

10/06/2007 15:30

=ORA([Column2]-[Column1])

Ore trascorse tra due orari, quando la differenza non supera 24 (4)

09/06/2007 10:35

10/06/2007 15:30

=MINUTO([Column2]-[Column1])

Minuti trascorsi tra due orari, quando la differenza non supera 60 (55)

09/06/2007 10:35

10/06/2007 15:30

=SECONDO([Column2]-[Column1])

Secondi trascorsi tra due orari, quando la differenza non supera 60 (0)

Convertire gli orari

Per convertire gli orari dal formato ora standard a un numero decimale, usare la funzione INT.

Column1

Formula

Descrizione (risultato)

10:35

=([Column1]-INT([Column1]))*24

Numero di ore trascorse dalle 12:00 (10,583333)

12:15

=([Column1]-INT([Column1]))*24

Numero di ore trascorse dalle 12:00 (12,25)

Per convertire gli orari da un numero decimale al formato ora standard (ore:minuti:secondi), usare l'operatore di divisione e la funzione TESTO.

Column1

Formula

Descrizione (risultato)

23:58

=TESTO(Column1/24, "hh:mm:ss")

Ore, minuti e secondi trascorsi dalle 12:00 (00: 59:55)

2:06

=TESTO(Column1/24, "h:mm")

Ore e minuti trascorsi dalle 12: 00 (0:05)

Inserire le date giuliane

Una data giuliana indica un formato di data che rappresenta una combinazione dell'anno corrente e del numero di giorni dall'inizio dell'anno. Ad esempio, il 1 gennaio 2007 è rappresentato come 2007001 e il 31 dicembre 2007 come 2007365. Questo formato non è basato sul calendario giuliano.

Per convertire una data in una data giuliana, usare le funzioni TESTO e DATA.VALORE.

Column1

Formula

Descrizione (risultato)

23/6/2007

=TESTO([Column1],"yy")&TESTO(([Column1]-DATA.VALORE("1/1/"& TESTO([Column1],"yy"))+1),"000")

Data in formato giuliano, con due cifre per l'anno (07174)

23/6/2007

=TESTO([Column1],"yyyy")&TESTO(([Column1]-DATA.VALORE("1/1/"&TESTO([Column1],"yy"))+1),"000")

Data in formato giuliano, con quattro cifre per l'anno (2007174)

Per convertire una data in una data giuliana usata in astronomia, usare la costante 2415018.50. Questa formula funziona solo per date successive al 1/3/1901 e solo se si usa il sistema data 1900.

Column1

Formula

Descrizione (risultato)

23/6/2007

=[Column1]+2415018.50

Data in formato giuliano, usato in astronomia (2454274.50)

Mostrare le date come giorni della settimana

Per convertire le date in testo per il giorno della settimana, usare le funzioni TESTO e GIORNO.SETTIMANA.

Column1

Formula

Descrizione (possibile risultato)

19-Feb-2007

=TESTO(GIORNO.SETTIMANA([Column1]), "dddd")

Calcola il giorno della settimana per la data e restituisce il nome completo del giorno (lunedì)

3-gen-2008

=TESTO(GIORNO.SETTIMANA([Column1]), "ddd")

Calcola il giorno della settimana per la data e restituisce il nome abbreviato del giorno (gio)

È possibile usare le formule seguenti per eseguire diversi calcoli matematici, ad esempio sommare, sottrarre, moltiplicare e dividere numeri, calcolare la media o la mediana dei numeri, arrotondare un numero e contare i valori.

Sommare numeri

Per sommare i numeri in due o più colonne di una riga, usare l'operatore di addizione (+) o la funzione SOMMA.

Column1

Column2

Column3

Formula

Descrizione (risultato)

6

5

4

=[Column1]+[Column2]+[Column3]

Somma i valori contenuti nelle prime tre colonne (15)

6

5

4

=SOMMA([Column1],[Column2],[Column3])

Somma i valori contenuti nelle prime tre colonne (15)

6

5

4

=SOMMA(SE([Column1]>[Column2], [Column1]-[Column2], 10), [Column3])

Se Column1 è maggiore di Column2, somma la differenza con Column3. In caso contrario, somma 10 e Column3 (5)

Sottrarre numeri

Per sottrarre i numeri in due o più colonne di una riga, usare l'operatore di sottrazione (-) o la funzione SOMMA con numeri negativi.

Column1

Column2

Column3

Formula

Descrizione (risultato)

15000

9000

-8000

=[Column1]-[Column2]

Sottrae 9000 da 15000 (6000)

15000

9000

-8000

=SOMMA([Column1], [Column2], [Column3])

Somma i numeri nelle prime tre colonne, inclusi i valori negativi (16000)

Calcolare la differenza tra due numeri e visualizzarla come percentuale

Utilizzo di sottrazione (-) e operatori di divisione (/) e la funzione Ass .

Column1

Column2

Formula

Descrizione (risultato)

2342

2500

=([Column2]-[Column1])/ASS([Column1])

Variazione percentuale (6,75% o 0,06746)

Moltiplicare numeri

Per moltiplicare i numeri in due o più colonne di una riga, usare l'operatore di moltiplicazione (*) o la funzione PRODOTTO.

Column1

Column2

Formula

Descrizione (risultato)

5

2

=[Column1]*[Column2]

Moltiplica i numeri contenuti nelle prime due colonne (10)

5

2

=PRODOTTO([Column1], [Column2])

Moltiplica i numeri contenuti nelle prime due colonne (10)

5

2

=PRODOTTO([Column1],[Column2],2)

Moltiplica i numeri contenuti nelle prime due colonne e il numero 2 (20)

Dividere numeri

Per dividere i numeri in due o più colonne di una riga, usare l'operatore di divisione (/).

Column1

Column2

Formula

Descrizione (risultato)

15000

12

=[Column1]/[Column2]

Divide 15000 per 12 (1250)

15000

12

=([Column1]+10000)/[Column2]

Somma 15000 e 10000, quindi divide il totale per 12 (2083)

Calcolare la media di un gruppo di numeri

Per calcolare la media dei numeri in due o più colonne di una riga, usare la funzione MEDIA.

Column1

Column2

Column3

Formula

Descrizione (risultato)

6

5

4

=MEDIA([Column1], [Column2],[Column3])

Media dei numeri nelle prime tre colonne (5)

6

5

4

=MEDIA(SE([Column1]>[Column2], [Column1]-[Column2], 10), [Column3])

Se Column1 è maggiore di Column2, calcola la media della differenza e Column3. In caso contrario, calcola la media del valore 10 e di Column3 (2,5)

Calcolare la mediana di un gruppo di numeri

La mediana è il valore centrale di un intervallo di numeri ordinati. Usare la funzione MEDIANA per calcolare la mediana di un gruppo di numeri.

A

B

C

D

E

F

Formula

Descrizione (risultato)

10

7

9

27

0

4

=MEDIANA(A, B, C, D, E, F)

Mediana dei numeri nelle prima 6 colonne (8)

Calcolare il numero più grande o più piccolo in un intervallo

Per calcolare il numero più grande o più piccolo in due o più colonne di una riga, usare le funzioni MIN e MAX.

Column1

Column2

Column3

Formula

Descrizione (risultato)

10

7

9

=MIN([Column1], [Column2], [Column3])

Numero più piccolo (7)

10

7

9

=MAX([Column1], [Column2], [Column3])

Numero più grande (10)

Contare i valori

Per contare i valori numerici, usare la funzione CONTA.NUMERI.

Column1

Column2

Column3

Formula

Descrizione (risultato)

Apple

12/12/2007

=CONTA.NUMERI([Column1], [Column2], [Column3])

Conta il numero di colonne contenenti valori numerici. Esclude i valori di data e ora, di testo e Null (0)

12 €

#DIV/0!

1,01

=CONTA.NUMERI([Column1], [Column2], [Column3])

Conta il numero di colonne contenenti valori numerici, ma esclude i valori di errore e logici (2)

Aumentare o diminuire un numero in base a una percentuale

Per eseguire questo calcolo, usare l'operatore di percentuale (%).

Column1

Column2

Formula

Descrizione (risultato)

23

3%

=[Column1]*(1+5%)

Aumenta il numero di Column1 del 5% (24,15)

23

3%

=[Column1]*(1+[Column2])

Aumenta il numero in Column1 del valore percentuale in Column2: 3% (23,69)

23

3%

=[Column1]*(1-[Column2])

Riduce il numero in Column1 del valore percentuale in Column2: 3% (22,31)

Elevare un numero a una potenza

Per eseguire questo calcolo, usare l'operatore di elevamento a potenza (^) o la funzione POTENZA.

Column1

Column2

Formula

Descrizione (risultato)

5

2

=[Column1]^[Column2]

Calcola cinque al quadrato (25)

5

3

=POTENZA([Column1], [Column2])

Calcola cinque al cubo (125)

Arrotondare un numero

Per arrotondare per eccesso un numero, usare la funzione ARROTONDA.PER.ECC, DISPARI o PARI.

Column1

Formula

Descrizione (risultato)

20,3

=ARROTONDA.PER.ECC([Column1],0)

Arrotonda 20,3 al numero intero successivo (21)

-5,9

=ARROTONDA.PER.ECC([Column1],0)

Arrotonda per eccesso -5,9 al numero intero successivo (-5)

12,5493

=ARROTONDA.PER.ECC([Column1],2)

Arrotonda per eccesso 12,5493 al centesimo successivo con due posizioni decimali (12,55)

20,3

=PARI([Column1])

Arrotonda per eccesso 20,3 al numero pari successivo (22)

20,3

=DISPARI([Column1])

Arrotonda per eccesso 20,3 al numero dispari successivo (21)

Per arrotondare un numero per difetto, usare la funzione ARROTONDA.PER.DIF.

Column1

Formula

Descrizione (risultato)

20,3

=ARROTONDA.PER.DIF([Column1],0)

Arrotonda per difetto 20,3 al numero intero precedente (20)

-5,9

=ARROTONDA.PER.DIF([Column1],0)

Arrotonda per difetto -5,9 al numero intero precedente (-6)

12,5493

=ARROTONDA.PER.DIF([Column1],2)

Arrotonda per difetto 12,5493 al centesimo precedente con due posizioni decimali (12,54)

Per arrotondare un numero alla frazione o al numero più vicino, usare la funzione ARROTONDA.

Column1

Formula

Descrizione (risultato)

20,3

=ARROTONDA([Column1],0)

Arrotonda per difetto 20,3 perché la parte frazionaria è minore di 0,5 (20)

5,9

=ARROTONDA([Column1],0)

Arrotonda per eccesso 5,9 perché la parte frazionaria è maggiore di 0,5 (6)

-5,9

=ARROTONDA([Column1],0)

Arrotonda per difetto -5,9 perché la parte frazionaria è minore di -0,5 (-6)

1,25

=ARROTONDA([Column1], 1)

Arrotonda il numero al decimo più vicino (una posizione decimale). Il numero viene arrotondato per eccesso perché la parte da arrotondare è uguale o maggiore di 0,05 (risultato: 1,3)

30,452

=ARROTONDA([Column1], 2)

Arrotonda il numero al centesimo più vicino (due posizioni decimali). Il numero viene arrotondato per difetto perché la parte da arrotondare, ovvero 0,002, è minore di 0,005 (risultato: 30,45)

Per arrotondare un numero alla cifra significativa maggiore di 0, usare le funzioni ARROTONDA, ARROTONDA.PER.ECC, ARROTONDA.PER.DIF, INT e LUNGHEZZA.

Column1

Formula

Descrizione (risultato)

5492820

=ARROTONDA([Column1],3-LUNGHEZZA(INT([Column1])))

Arrotonda il numero a 3 cifre significative (5490000)

22230

=ARROTONDA.PER.DIF([Column1],3-LUNGHEZZA(INT([Column1])))

Arrotonda per difetto il numero inferiore a 3 cifre significative (22200)

5492820

=ARROTONDA.PER.ECC([Column1], 5-LUNGHEZZA(INT([Column1])))

Arrotonda per difetto il numero superiore fino a 5 cifre significative (5492900)

È possibile usare le formule seguenti per modificare il testo, ad esempio per combinare o concatenare i valori di più colonne, confrontare il contenuto delle colonne, rimuovere gli spazi o i caratteri e ripetere i caratteri.

Modificare la combinazione di lettere maiuscole o minuscole del testo

Per modificare la combinazione di lettere maiuscole e minuscole del testo, usare la funzione MAIUSC, MINUSC o MAIUSC.INIZ.

Column1

Formula

Descrizione (risultato)

fiamma Greco

=MAIUSC([Column1])

Converte il testo in caratteri maiuscoli (FIAMMA GRECO)

fiamma Greco

=MINUSC([Column1])

Converte il testo in caratteri minuscoli (fiamma greco)

fiamma Greco

=MAIUSC.INIZ([Column1])

Converte il testo inserendo tutte le iniziali maiuscole (Fiamma Greco)

Combinare nomi e cognomi

Per combinare nomi e cognomi, usare l'operatore e commerciale (&) o la funzione CONCATENA.

Column1

Column2

Formula

Descrizione (risultato)

Davide

Milano

=[Column1]&[Column2]

Combina le due stringhe (DavideMilano)

Davide

Milano

=[Column1]&" "&[Column2]

Combina le due stringhe separate da uno spazio (Davide Milano)

Davide

Milano

=[Column2]&", "&[Column1]

Combina le due stringhe separate da una virgola e uno spazio (Milano, Davide)

Davide

Milano

=CONCATENA([Column2], ",", [Column1])

Combina le due stringhe separate da una virgola (Milano, Davide)

Combinare testo e numeri di colonne diverse

Per combinare testo e numeri, usare la funzione CONCATENA, l'operatore e commerciale (&) o la funzione TESTO e l'operatore e commerciale.

Column1

Column2

Formula

Descrizione (risultato)

Longo

28

=[Column1]&" ha venduto "&[Column2]&" unità."

Combina questo contenuto in una frase (Longo ha venduto 28 unità).

Pinto

40%

=[Column1]&" ha venduto il "&TESTO([Column2],"0%")&" delle vendite totali."

Combina questo contenuto in una frase (Pinto ha venduto il 40% delle vendite totali).

Nota : La funzione TESTO aggiunge il valore formattato di Column2 invece del valore sottostante, ovvero 4.

Longo

28

=CONCATENA([Column1]," ha venduto ",[Column2]," unità.")

Combina questo contenuto in una frase (Longo ha venduto 28 unità).

Combinare il testo con una data o un'ora

Per combinare il testo con una data o un'ora, usare la funzione TESTO e l'operatore e commerciale (&).

Column1

Column2

Formula

Descrizione (risultato)

Data di fatturazione

5-giu-2007

="Data rendiconto: "&TESTO([Column2], "d-mmm-yyyy")

Combina il testo con una data (Data rendiconto: 5-giu-2007)

Data di fatturazione

5-giu-2007

=[Column1]&" "&TESTO([Column2], "mmm-dd-yyyy")

Combina testo e data di colonne diverse in un'unica colonna (Data fatturazione 05-giu-2007)

Confrontare il contenuto delle colonne

Per confrontare una colonna con un'altra colonna o con un elenco di valori, usare le funzioni IDENTICO e O.

Column1

Column2

Formula

Descrizione (possibile risultato)

BD122

BD123

=IDENTICO([Column1],[Column2])

Confronta il contenuto delle prime due colonne (No)

BD122

BD123

=IDENTICO([Column1], "BD122")

Confronta il contenuto di Column1 e la stringa "BD122" (Sì)

Controllare se un valore della colonna o una parte di esso corrisponde a un testo specifico

Per verificare se un valore della colonna o una parte di esso corrisponde a un testo specifico, usare le funzioni SE, TROVA, CERCA e VAL.NUMERO.

Column1

Formula

Descrizione (possibile risultato)

Greco

=SE([Column1]="Greco", "OK", "NO")

Controlla se Column1 contiene Greco (OK)

Greco

=SE(VAL.NUMERO(TROVA("v",[Column1])), "OK", "NO")

Verifica se Column1 contiene la lettera v (OK)

BD123

=VAL.NUMERO(TROVA("BD",[Column1]))

Verifica se Column1 contiene BD (Sì)

Contare le colonne non vuote

Per contare le colonne non vuote, usare la funzione CONTA.VALORI.

Column1

Column2

Column3

Formula

Descrizione (risultato)

Vendite

19

=CONTA.VALORI([Column1], [Column2])

Conta il numero di colonne non vuote (2)

Vendite

19

=CONTA.VALORI([Column1], [Column2], [Column3])

Conta il numero di colonne non vuote (2)

Rimuovere caratteri dal testo

Per rimuovere caratteri dal testo, usare le funzioni LUNGHEZZA, SINISTRA e DESTRA.

Column1

Formula

Descrizione (risultato)

Vitamina A

=SINISTRA([Column1],LUNGHEZZA([Column1])-2)

Restituisce 7 caratteri (9-2), a partire da sinistra (Vitamina)

Vitamina B1

=DESTRA([Column1], LUNGHEZZA([Column1])-8)

Restituisce 2 caratteri (10-8), a partire da destra (B1)

Rimuovere gli spazi all'inizio e alla fine di una colonna

Per rimuovere gli spazi da una colonna, usare la funzione ANNULLA.SPAZI.

Column1

Formula

Descrizione (risultato)

 Ciao!

=ANNULLA.SPAZI([Column1])

Rimuovere gli spazi iniziali e finali (Ciao!)

Ripetere un carattere in una colonna

Per ripetere un carattere in una colonna, usare la funzione RIPETI.

Formula

Descrizione (risultato)

=RIPETI(".",3)

Ripete un punto per 3 volte (…)

=RIPETI("-";10)

Ripete un trattino per 10 volte (----------)

Funzioni in ordine alfabetico

Di seguito è un elenco di collegamenti alle funzioni disponibili per gli utenti SharePoint. Includa trigonomic statistiche e funzioni finanziarie, nonché condizionale, le formule di data, matematiche e testo.

Funzione ABS

ARCCOS

ARCCOSH

ARCCOSH

E

ARCSEN

ARCSENH

ARCTAN

ARCTAN.2

MEDIA

MEDIA.VALORI

DISTRIB.BETA

INV.BETA

DISTRIB.BINOM

ARROTONDA.ECCESSO

CODICE.CARATT

DISTRIB.CHI

SCEGLI

CODICE

CONCATENA

CONFIDENZA

COS

CONTA.NUMERI

CONTA.VALORI

CRIT.BINOM

DATA

DATA.DIFF

DATA.VALORE

GIORNO

GIORNO360

AMMORT

GRADI

VALUTA

PARI

IDENTICO

DISTRIB.EXP

FATTORIALE

DISTRIB.F

TROVA

INV.F

FISHER

FISSO

DISTRIB.GAMMA

INV.GAMMA

LN.GAMMA

MEDIA.GEOMETRICA

MEDIA.ARMONICA

ORA

DISTRIB.IPERGEOM

SE

INT

INTERESSI

VAL

SINISTRA

LUNGHEZZA

LN

LOG

LOG10

INV.LOGNORM

DISTRIB.LOGNORM

MINUSC

MAX

ME

MEDIANA

MID

MIN

MIN.VALORI

MINUTO

RESTO

MESE

DISTRIB.BINOM.NEG

DISTRIB.NORM

DISTRIB.NORM.ST

INV.NORM.ST

NON

NUM.RATE

VAN

VAN

DISPARI

O

RATA

POTENZA

P.RATA

PRODOTTO

MAIUSC.INIZ

VA

RADIANTI

SOSTITUISCI

RIPETI

DESTRA

ARROTONDA

ARROTONDA.PER.DIF

ARROTONDA.PER.ECC

RICERCA

SECONDO

SEGNO

SEN

SENH

RADQ

NORMALIZZA

DEV.ST.VALORI

DEV.ST.POP

DEV.ST.POP.VALORI

SOMMA

SOMMA.Q

AMMORT.ANNUO

TANH

DISTRIB.T

TESTO

ORARIO

INV.T

OGGI

ANNULLA.SPAZI

VERO

VERO

MAIUSC

USDOLLAR

VALORE

VAR

VAR.VALORI

VAR.POP

VAR.POP.VALORI

GIORNO.SETTIMANA

WEIBULL

ANNO

Altre risorse

Se non è visibile cosa si sta tentando di eseguire qui, vedere se è possibile eseguire in Excel o esaminare i filtri di Web Part. Ecco alcune altre origini. Alcuni di questi possono coprire le versioni precedenti, in modo che possono essere presenti differenze nell'interfaccia utente visualizzata. Le voci del menu Azioni sito di SharePoint 2010, ad esempio, sono ora nel menu Impostazioni pulsante impostazioni di office 365 rappresentato da un'icona a forma di ingranaggio visualizzata accanto al nome dell'utente .

Sono disponibili molte altre risorse sul web che è possibile eseguire ricerche, ad esempio come campi calcolati codifica a colori.

Nota : Dichiarazione di non responsabilità per la traduzione automatica: Il presente articolo è stato tradotto tramite un software di traduzione automatica e non da una persona. Microsoft offre le traduzioni automatiche per consentire a coloro che non conoscono la lingua inglese di leggere gli articoli sui prodotti, sui servizi e sulle tecnologie Microsoft. Dal momento che l'articolo è stato tradotto automaticamente, potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli.

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×