Esempi di formule comuni

Importante :  Il presente articolo è stato tradotto automaticamente, vedere la dichiarazione di non responsabilità. Per visualizzare la versione inglese dell'articolo, fare clic qui.

È possibile utilizzare gli esempi seguenti nelle colonne calcolate di un elenco o una raccolta. Gli esempi che non includono riferimenti a colonne possono essere utilizzati per specificare il valore predefinito di una colonna.

In questo articolo

Formule condizionali

Formule di data e ora

Formule matematiche

Formule di testo

Formule condizionali

È possibile utilizzare le formule riportate di seguito per verificare la condizione di un'istruzione e restituire un valore Sì o No, per verificare un valore alternativo quale OK o Non OK oppure per restituire un valore vuoto o un trattino che rappresenta un valore nullo.

Verificare se un numero è maggiore o minore di un altro numero

Utilizzare la funzione SE per eseguire questo confronto.

Colonna1

Colonna2

Formula

Descrizione (risultato possibile)

15000

9000

=[Colonna1]>[Colonna2]

La Colonna1 è maggiore della Colonna2? (Sì)

15000

9000

=SE([Colonna1]<=[Colonna2]; "OK"; "Non OK")

La Colonna1 è minore o uguale alla Colonna2? (Non OK)

Restituire un valore logico dopo il confronto del contenuto delle colonne

Per ottenere come risultato un valore logico (Sì o No), utilizzare le funzioni E, O e NON.

Colonna1

Colonna2

Colonna3

Formula

Descrizione (risultato possibile)

15

9

8

=E([Colonna1]>[Colonna2]; [Colonna1]<[Colonna3])

15 è maggiore di 9 e minore di 8? (No)

15

9

8

=O([Colonna1]>[Colonna2]; [Colonna1]<[Colonna3])

15 è maggiore di 9 o minore di 8? (Sì)

15

9

8

=NON([Colonna1]+[Colonna2]=24)

15 più 9 non è uguale a 24? (No)

Per ottenere un risultato corrispondente a un altro calcolo o a qualsiasi altro valore diverso da Sì o No, utilizzare le funzioni SE, E e O.

Colonna1

Colonna2

Colonna3

Formula

Descrizione (risultato possibile)

15

9

8

=SE([Colonna1]=15; "OK"; "Non OK")

Se il valore nella Colonna1 è uguale a 15, restituisce "OK". (OK)

15

9

8

=SE(E([Colonna1]>[Colonna2]; [Colonna1]<[Colonna3]); "OK"; "Non OK")

Se 15 è maggiore di 9 e minore di 8, restituisce "OK". (Non OK)

15

9

8

=SE(O([Colonna1]>[Colonna2]; [Colonna1]<[Colonna3]); "OK"; "Non OK")

Se 15 è maggiore di 9 o minore di 8, restituisce "OK". (OK)

Visualizzare gli zeri come spazi vuoti o trattini

Per visualizzare un valore zero, eseguire un calcolo semplice. Per visualizzare un valore vuoto o un trattino, utilizzare la funzione SE.

C olumn1

Colonna2

Formula

Descrizione (risultato possibile)

10

10

=[Colonna1]-[Colonna2]

Il secondo numero viene sottratto dal primo (0)

15

9

=SE([Colonna1]-[Colonna2];"-";[Colonna1]-[Colonna2])

Restituisce un trattino quando il valore è zero (-)

Nascondere i valori di errore nelle colonne

Per visualizzare un trattino, #N/D, o ND al posto di un valore di errore, utilizzare la funzione VAL.ERRORE.

Colonna1

Colonna2

Formula

Descrizione (risultato possibile)

10

0

=[Colonna1]/[Colonna2]

Restituisce un errore (#DIV/0)

10

0

=SE(VAL.ERRORE([Colonna1]/[Colonna2]);"N/D";[Colonna1]/[Colonna2])

Restituisce N/D quando il valore è un errore

10

0

=SE(VAL.ERRORE([Colonna1]/[Colonna2]);"-";[Colonna1]/[Colonna2])

Restituisce un trattino quando il valore è un errore

Torna all'inizio

Formule di data e ora

È possibile utilizzare le formule riportate di seguito per eseguire calcoli che si basano su data e ora, ad esempio per l'aggiunta di un numero di giorni, mesi o anni a una data, il calcolo della differenza tra due date e la conversione dell'ora in un valore decimale.

Aggiungere date

Per aggiungere un numero di giorni a una data, utilizzare l'operatore di addizione (+).

Nota : Quando si modificano date, il tipo restituito della colonna calcolata deve essere impostato su Data e ora.

Colonna1

Colonna2

Formula

Descrizione (risultato)

09/06/07

3

=[Colonna1]+[Colonna2]

Aggiunge 3 giorni a 09/06/07 (12/06/07)

10/12/08

54

=[Colonna1]+[Colonna2]

Aggiunge 54 giorni a 10/12/2008 (02/02/2009)

Per aggiungere un numero di mesi a una data, utilizzare le funzioni DATA, ANNO, MESE e GIORNO.

Colonna1

Colonna2

Formula

Descrizione (risultato)

09/06/07

3

=DATA(ANNO([Colonna1]);MESE([Colonna1])+[Colonna2];GIORNO([Colonna1]))

Aggiunge 3 mesi a 09/06/07 (09/09/07)

10/12/08

25

=DATA(ANNO([Colonna1]);MESE([Colonna1])+[Colonna2];GIORNO([Colonna1]))

Aggiunge 25 mesi a 10/12/2008 (10/01/2011)

Per aggiungere un numero di anni a una data, utilizzare le funzioni DATA, ANNO, MESE e GIORNO.

Colonna1

Colonna2

Formula

Descrizione (risultato)

09/06/07

3

=DATA(ANNO([Colonna1])+[Colonna2];MESE([Colonna1]);GIORNO([Colonna1]))

Aggiunge 3 anni a 09/06/07 (09/06/10)

10/12/08

25

=DATA(ANNO([Colonna1])+[Colonna2];MESE([Colonna1]);GIORNO([Colonna1]))

Aggiunge 25 anni a 10/12/2008 (10/12/2033)

Per aggiungere una combinazione di giorni, mesi e anni a una data, utilizzare le funzioni DATA, ANNO, MESE e GIORNO.

Colonna1

Formula

Descrizione (risultato)

09/06/07

=DATA(ANNO([Colonna1])+1;MESE([Colonna1])+7;GIORNO([Colonna1])+5)

Aggiunge 3 anni, 1 mese e 5 giorni a 09/06/2007 (14/07/10)

10/12/08

=DATA(ANNO([Colonna1])+1;MESE([Colonna1])+7;GIORNO([Colonna1])+5)

Aggiunge 1 anno, 7 mesi e 5 giorni a 10/12/08 (15/07/2010)

Calcolare la differenza tra due date

Utilizzare la funzione DATA.DIFF per eseguire questo calcolo.

Colonna1

Colonna2

Formula

Descrizione (risultato)

01-gen-1995

15-giu-1999

=DATA.DIFF([Colonna1]; [Colonna2];"g")

Restituisce il numero di giorni compresi tra le due date (1626)

01-gen-1995

15-giu-1999

=DATA.DIFF([Colonna1]; [Colonna2];"am")

Restituisce il numero di mesi compresi tra le due date, ignorando le cifre relative all'anno (5)

01-gen-1995

15-giu-1999

=DATA.DIFF([Colonna1]; [Colonna2];"ag")

Restituisce il numero di giorni compresi tra le date, ignorando le cifre relative all'anno (165)

Calcolare la differenza tra due ore

Per presentare il risultato nel formato ora standard (ore.minuti.secondi), utilizzare l'operatore di sottrazione (-) e la funzione TESTO. Perché il metodo funzioni correttamente, è necessario che non venga utilizzato un valore superiore a 24 per le ore e un valore superiore a 60 per i minuti e i secondi.

Colonna1

Colonna2

Formula

Descrizione (risultato)

09/06/07 10.35

09/06/07 15.30

=TESTO([Colonna2]-[Colonna1];"h")

Restituisce il numero di ore comprese tra due orari (4)

09/06/07 10.35

09/06/07 15.30

=TESTO([Colonna2]-[Colonna1];"h.mm")

Restituisce il numero di ore e minuti compresi tra due orari (4.55)

09/06/07 10.35

09/06/07 15.30

=TESTO([Colonna2]-[Colonna1];"h.mm.ss")

Restituisce il numero di ore, minuti e secondi compresi tra due orari (4.55.00)

Per presentare il risultato in un totale che si basa su una sola unità di tempo, utilizzare la funzione INT oppure la funzione ORA, MINUTO o SECONDO.

Colonna1

Colonna2

Formula

Descrizione (risultato)

09/06/07 10.35

10/06/2007 15.30

=INT(([Colonna2]-[Colonna1])*24)

Restituisce il totale di ore comprese tra due orari (28)

09/06/07 10.35

10/06/2007 15.30

=INT(([Colonna2]-[Colonna1])*1440)

Restituisce il totale di minuti compresi tra due orari (1735)

09/06/07 10.35

10/06/2007 15.30

=INT(([Colonna2]-[Colonna1])*86400)

Restituisce il totale di secondi compresi tra due orari (104100)

09/06/07 10.35

10/06/2007 15.30

=ORA([Colonna2]-[Colonna1])

Restituisce il numero di ore comprese tra due orari, quando la differenza non supera 24 (4)

09/06/07 10.35

10/06/2007 15.30

=MINUTO([Colonna2]-[Colonna1])

Restituisce il numero di minuti compresi tra due orari, quando la differenza non supera 60 (55)

09/06/07 10.35

10/06/2007 15.30

=SECONDO([Colonna2]-[Colonna1])

Restituisce il numero di secondi compresi tra due orari, quando la differenza non supera 60 (0)

Convertire gli orari

Per convertire orari dal formato ora standard in un numero decimale, utilizzare la funzione INT.

Colonna1

Formula

Descrizione (risultato)

10.35

=([Colonna1]-INT([Colonna1]))*24

Restituisce il numero di ore a partire dalle 24.00 (10,583333)

12.15

=([Colonna1]-INT([Colonna1]))*24

Restituisce il numero di ore a partire dalle 24.00 (12,25)

Per convertire le ore da un numero decimale al formato ora standard (ore.minuti.secondi), utilizzare l'operatore di divisione e la funzione TESTO.

Colonna1

Formula

Descrizione (risultato)

23,58

=TESTO(Colonna1/24; "hh.mm.ss")

Restituisce ore, minuti e secondi a partire dalle 24.00 (00.59.55)

2,06

=TESTO(Colonna1/24; "h.mm")

Restituisce ore e minuti a partire dalle 24.00 (0.05)

Inserire le date giuliane

Una data giuliana fa riferimento a un formato di data costituito da una combinazione dell'anno corrente e del numero di giorni trascorsi dall'inizio dell'anno. Il 1 gennaio 2007 viene ad esempio rappresentato come 2007001 mentre il 31 dicembre 2007 viene rappresentato come 2007365. Questo formato non si basa sul calendario giuliano.

Per convertire una data in formato giuliano, utilizzare le funzioni TESTO e DATA.VALORE.

Colonna1

Formula

Descrizione (risultato)

23/06/07

=TESTO([Colonna1];"aa")&TESTO(([Colonna1]-DATA.VALORE("1/1/"& TESTO([Colonna1];"aa"))+1);"000")

Restituisce una data in formato giuliano con un anno a due cifre (07174)

23/06/07

=TESTO([Colonna1];"aaaa")&TESTO(([Colonna1]-DATA.VALORE("1/1/"&TESTO([Colonna1];"aa"))+1);"000")

Restituisce una data in formato giuliano con un anno a quattro cifre (2007174)

Per convertire una data nel formato giuliano utilizzato in astronomia, utilizzare la costante 2415018,50. Questa formula funziona solo per le date successive al 01/03/1901 e se si utilizza il sistema data 1900.

Colonna1

Formula

Descrizione (risultato)

23/06/07

=[Colonna1]+2415018,50

Restituisce una data nel formato giuliano utilizzato in astronomia (2454274,50)

Mostrare le date come giorni della settimana

Per convertire le date nel testo corrispondente al giorno della settimana, utilizzare le funzioni TESTO e GIORNO.SETTIMANA.

Colonna1

Formula

Descrizione (risultato possibile)

19-feb-2007

=TESTO(GIORNO.SETTIMANA([Colonna1]); "gggg")

Calcola il giorno della settimana corrispondente alla data e restituisce il nome completo del giorno (lunedì)

3-gen-2008

=TESTO(GIORNO.SETTIMANA([Colonna1]); "ggg")

Calcola il giorno della settimana corrispondente alla data e restituisce il nome abbreviato del giorno (gio)

Torna all'inizio

Formule matematiche

È possibile utilizzare le formule seguenti per eseguire diversi calcoli matematici quali l'addizione, la sottrazione, la moltiplicazione e la divisione di numeri, il calcolo della media o della mediana di numeri, l'arrotondamento di un numero e il conteggio di valori.

Sommare numeri

Per sommare i numeri di due o più colonne di una riga, utilizzare l'operatore di addizione (+) oppure la funzione SOMMA.

Colonna1

Colonna2

Colonna3

Formula

Descrizione (risultato)

6

5

4

=[Colonna1]+[Colonna2]+[Colonna3]

Somma i valori delle prime tre colonne (15)

6

5

4

=SOMMA([Colonna1]; [Colonna2]; [Colonna3])

Somma i valori delle prime tre colonne (15)

6

5

4

=SOMMA(SE([Colonna1]>[Colonna2]; [Colonna1]-[Colonna2]; 10); [Colonna3])

Se la Colonna1 è maggiore della Colonna2, somma la differenza e la Colonna3. In caso contrario, somma il valore 10 e la Colonna3 (5)

Sottrarre numeri

Per sottrarre i numeri di due o più colonne di una riga, utilizzare l'operatore di sottrazione (-) o la funzione SOMMA con numeri negativi.

Colonna1

Colonna2

Colonna3

Formula

Descrizione (risultato)

15000

9000

-8000

=[Colonna1]-[Colonna2]

Sottrae 9000 da 15000 (6000)

15000

9000

-8000

=SOMMA([Colonna1]; [Colonna2]; [Colonna3])

Somma i numeri delle prime tre colonne, inclusi i valori negativi (16000)

Calcolare la differenza tra due numeri e visualizzarla come percentuale

Utilizzare gli operatori di sottrazione (-) e divisione (/) e la funzione ASS.

Colonna1

Colonna2

Formula

Descrizione (risultato)

2342

2500

=([Colonna2]-[Colonna1])/ASS([Colonna1])

Restituisce la differenza percentuale (6,75% o 0,06746)

Moltiplicare numeri

Per moltiplicare i numeri di due o più colonne di una riga, utilizzare l'operatore di moltiplicazione (*) o la funzione PRODOTTO.

Colonna1

Colonna2

Formula

Descrizione (risultato)

5

2

=[Colonna1]*[Colonna2]

Moltiplica i numeri delle prime due colonne (10)

5

2

=PRODOTTO([Colonna1]; [Colonna2])

Moltiplica i numeri delle prime due colonne (10)

5

2

=PRODOTTO([Colonna1];[Colonna2];2)

Moltiplica i numeri delle prime due colonne e il numero 2 (20)

Dividere numeri

Per dividere i numeri di due o più colonne di una riga, utilizzare l'operatore di divisione (/).

Colonna1

Colonna2

Formula

Descrizione (risultato)

15000

12

=[Colonna1]/[Colonna2]

Divide 15000 per 12 (1250)

15000

12

=([Colonna1]+10000)/[Colonna2]

Somma 15000 e 10000 e quindi divide il totale per 12 (2083)

Calcolare la media di un gruppo di numeri

Per calcolare la media dei numeri di due o più colonne di una riga, utilizzare la funzione MEDIA.

Colonna1

Colonna2

Colonna3

Formula

Descrizione (risultato)

6

5

4

=MEDIA([Colonna1]; [Colonna2];[Colonna3])

Restituisce la media dei numeri delle prime tre colonne (5)

6

5

4

=MEDIA(SE([Colonna1]>[Colonna2]; [Colonna1]-[Colonna2]; 10); [Colonna3])

Se il valore della Colonna1 è maggiore del valore della Colonna2, calcola la media tra la differenza e il valore della Colonna3. In caso contrario, calcola la media tra 10 e il valore della Colonna3 (2,5)

Calcolare la mediana di un gruppo di numeri

La mediana è rappresentata dal valore centrale in un intervallo ordinato di numeri. Utilizzare la funzione MEDIANA per calcolare la mediana in un gruppo di numeri.

A

B

C

D

E

F

Formula

Descrizione (risultato)

10

7

9

27

0

4

=MEDIANA(A; B; C; D; E; F)

Restituisce la mediana dei numeri delle prime sei colonne (8)

Calcolare il numero più grande o più piccolo in un intervallo

Per calcolare il valore minimo o il valore massimo in due o più colonne di una riga, utilizzare le funzioni MIN e MAX.

Colonna1

Colonna2

Colonna3

Formula

Descrizione (risultato)

10

7

9

=MIN([Colonna1]; [Colonna2]; [Colonna3])

Restituisce il valore minimo (7)

10

7

9

=MAX([Colonna1]; [Colonna2]; [Colonna3])

Restituisce il valore massimo (10)

Contare i valori

Per contare valori numerici, utilizzare la funzione CONTA.NUMERI.

Colonna1

Colonna2

Colonna3

Formula

Descrizione (risultato)

Mela

12/12/07

=CONTA.NUMERI([Colonna1]; [Colonna2]; [Colonna3])

Conta il numero di colonne che contengono valori numerici, esclusi valori di data, ora, di testo e nulli (0)

$12

#DIV/0!

1,01

=CONTA.NUMERI([Colonna1]; [Colonna2]; [Colonna3])

Conta il numero di colonne che contengono valori numerici, esclusi valori logici e di errore (2)

Aumentare o diminuire un numero in base a una percentuale

Utilizzare l'operatore percentuale (%) per eseguire questa operazione.

Colonna1

Colonna2

Formula

Descrizione (risultato)

23

3%

=[Colonna1]*(1+5%)

Aumenta il numero nella Colonna1 del 5% (24,15)

23

3%

=[Colonna1]*(1+[Colonna2])

Aumenta il numero nella Colonna1 in base al valore percentuale della Colonna2: 3% (23,69)

23

3%

=[Colonna1]*(1-[Colonna2])

Diminuisce il numero nella Colonna1 in base al valore percentuale della Colonna2: 3% (22,31)

Elevare un numero a una potenza

Utilizzare l'operatore esponenziale (^) o la funzione POTENZA per eseguire questo calcolo.

Colonna1

Colonna2

Formula

Descrizione (risultato)

5

2

=[Colonna1]^[Colonna2]

Calcola cinque al quadrato (25)

5

3

=POTENZA([Colonna1]; [Colonna2])

Calcola cinque al cubo (125)

Arrotondare un numero

Per arrotondare un numero per eccesso, utilizzare le funzioni ARROTONDA.PER.ECC, DISPARI o PARI.

Colonna1

Formula

Descrizione (risultato)

20,3

=ARROTONDA.PER.ECC([Colonna1],0)

Arrotonda 20,3 per eccesso al numero intero successivo (21)

-5,9

=ARROTONDA.PER.ECC([Colonna1],0)

Arrotonda -5,9 per eccesso al numero intero successivo (-5)

12,5493

=ARROTONDA.PER.ECC([Colonna1];2)

Arrotonda 12,5493 per eccesso al centesimo successivo, con due cifre decimali (12,55)

20,3

=PARI([Colonna1])

Arrotonda 20,3 per eccesso al numero pari successivo (22)

20,3

=DISPARI([Colonna1])

Arrotonda 20,3 per eccesso al numero dispari successivo (21)

Per arrotondare un numero per difetto, utilizzare la funzione ARROTONDA.PER.DIF.

Colonna1

Formula

Descrizione (risultato)

20,3

=ARROTONDA.PER.DIF([Colonna1];0)

Arrotonda 20,3 per difetto al numero intero precedente (20)

-5,9

=ARROTONDA.PER.DIF([Colonna1];0)

Arrotonda -5,9 per difetto al numero intero precedente (-6)

12,5493

=ARROTONDA.PER.DIF([Colonna1];2)

Arrotonda 12,5493 per difetto al centesimo precedente, con due cifre decimali (12,54)

Per arrotondare un numero alla frazione o al numero più vicino, utilizzare la funzione ARROTONDA.

Colonna1

Formula

Descrizione (risultato)

20,3

=ARROTONDA([Colonna1];0)

Arrotonda 20,3 per difetto, poiché la parte frazionaria è minore di 0,5 (20)

5,9

=ARROTONDA([Colonna1];0)

Arrotonda 5,9 per eccesso, poiché la parte frazionaria è maggiore di 0,5 (6)

-5,9

=ARROTONDA([Colonna1];0)

Arrotonda -5,9 per difetto, poiché la parte frazionaria è minore di -0.5 (-6)

1,25

=ARROTONDA([Colonna1]; 1)

Arrotonda il numero al decimale più vicino utilizzando una sola cifra. Poiché la parte da arrotondare è 0,05 o superiore, il numero verrà arrotondato per eccesso (risultato: 1,3)

30,452

=ARROTONDA([Colonna1]; 2)

Arrotonda il numero al centesimo più vicino (due cifre decimali). Poiché la parte da arrotondare (0,002) è inferiore a 0,005, il numero verrà arrotondato per difetto (risultato: 30,45)

Per arrotondare un numero alla cifra significativa superiore a 0, utilizzare le funzioni ARROTONDA, ARROTONDA.PER.ECC, ARROTONDA.PER.DIF, INT e LUNGHEZZA.

Colonna1

Formula

Descrizione (risultato)

5492820

=ARROTONDA([Colonna1];3-LUNGHEZZA(INT([Colonna1])))

Arrotonda il numero a 3 cifre significative (5490000)

22230

=ARROTONDA.PER.DIF([Colonna1];3-LUNGHEZZA(INT([Colonna1])))

Arrotonda il numero per difetto a 3 cifre significative (22200)

5492820

=ARROTONDA.PER.ECC([Colonna1]; 5-LUNGHEZZA(INT([Colonna1])))

Arrotonda il numero per eccesso a 5 cifre significative (5492900)

Torna all'inizio

Formule di testo

È possibile utilizzare le formule seguenti per modificare testo, ad esempio combinando o concatenando i valori di più colonne, confrontando il contenuto delle colonne, rimuovendo caratteri o spazi e ripetendo caratteri.

Modificare le lettere maiuscole e minuscole del testo

Per modificare le lettere maiuscole e minuscole del testo, utilizzare la funzione MAIUSC, MINUSC o MAIUSC.INIZ.

Colonna1

Formula

Descrizione (risultato)

adriana Giorgi

=MAIUSC([Colonna1])

Modifica le lettere del testo in lettere maiuscole (ADRIANA GIORGI)

adriana Giorgi

=MINUSC([Colonna1])

Modifica le lettere del testo in lettere minuscole (adriana giorgi)

adriana Giorgi

=MAIUSC.INIZ([Colonna1])

Modifica le lettere iniziali del testo in maiuscole (Adriana Giorgi)

Combinare nomi e cognomi

Per combinare nomi e cognomi, utilizzare l'operatore e commerciale (&) o la funzione CONCATENA.

Colonna1

Colonna2

Formula

Descrizione (risultato)

Agostino

Martino

=[Colonna1]&[Colonna2]

Combina le due stringhe (AgostinoMartino)

Agostino

Martino

=[Colonna1]&" "&[Colonna2]

Combina le due stringhe separandole con uno spazio (Agostino Martino)

Agostino

Martino

=[Colonna2]&"; "&[Colonna1]

Combina le due stringhe separandole con una virgola e uno spazio (Martino, Agostino)

Agostino

Martino

=CONCATENA([Colonna2]; ";"; [Colonna1])

Combina le due stringhe separandole con una virgola (Martino,Agostino)

Combinare testo e numeri di colonne diverse

Per combinare testo e numeri, utilizzare la funzione CONCATENA, l'operatore e commerciale (&) oppure la funzione TESTO e l'operatore commerciale.

Colonna1

Colonna2

Formula

Descrizione (risultato)

Neri

28

=[Colonna1]&" ha venduto "&[Colonna2]&" unità."

Combina il contenuto riportato in una frase (Neri ha venduto 28 unità.).

Scotti

40%

=[Colonna1]&" ha venduto "&TESTO([Colonna2];"0%")&" delle vendite totali."

Combina questo contenuto in una frase (Scotti ha venduto 40% delle vendite totali.).

Nota : La funzione TESTO aggiunge il valore formattato della Colonna2 invece del valore sottostante, ovvero 0,4.

Neri

28

=CONCATENA([Colonna1];" ha venduto ";[Colonna2];" unità.")

Combina il contenuto riportato in una frase (Neri ha venduto 28 unità.).

Combinare il testo con una data o un'ora

Per combinare testo con una data o un orario, utilizzare la funzione TESTO e l'operatore e commerciale (&).

Colonna1

Colonna2

Formula

Descrizione (risultato)

Data fattura

5-giu-2007

="Data rendiconto: "&TESTO([Colonna2]; "g-mmm-aaaa")

Combina testo con una data (Data rendiconto: 5-giu-2007)

Data fatturazione

5-giu-2007

=[Colonna1]&" "&TESTO([Colonna2]; "mmm-gg-aaaa")

Combina testo e data di colonne diverse in un'unica colonna (Data fatturazione giu-05-2007)

Confrontare il contenuto delle colonne

Per confrontare una colonna con un'altra colonna o con un elenco di valori, utilizzare le funzioni IDENTICO e O.

Colonna1

Colonna2

Formula

Descrizione (risultato possibile)

BD122

BD123

=IDENTICO([Colonna1];[Colonna2])

Confronta il contenuto delle prime due colonne (No)

BD122

BD123

=IDENTICO([Colonna1]; "BD122")

Confronta il contenuto della Colonna1 con la stringa "BD122" (Sì)

Controllare se un valore della colonna o una parte di esso corrisponde a un testo specifico

Per verificare se un valore di colonna o una parte di tale valore corrisponde a un testo specifico, utilizzare le funzioni SE, TROVA, RICERCA e VAL.NUMERO.

Colonna1

Formula

Descrizione (risultato possibile)

Giorgi

=SE([Colonna1]="Giorgi"; "OK"; "Non OK")

Verifica se la Colonna1 contiene il testo Giorgi (OK)

Giorgi

=SE(VAL.NUMERO(TROVA("g";[Colonna1])); "OK"; "Non OK")

Verifica se la Colonna1 contiene la lettera g (OK)

BD123

=VAL.NUMERO(TROVA("BD";[Colonna1]))

Verifica se la Colonna1 contiene BD (Sì)

Contare le colonne non vuote

Per contare colonne non vuote, utilizzare la funzione CONTA.VALORI.

Colonna1

Colonna2

Colonna3

Formula

Descrizione (risultato)

Vendite

19

=CONTA.VALORI([Colonna1]; [Colonna2])

Conta il numero di colonne non vuote (2)

Vendite

19

=CONTA.VALORI([Colonna1]; [Colonna2]; [Colonna3])

Conta il numero di colonne non vuote (2)

Rimuovere i caratteri dal testo

Per rimuovere caratteri dal testo, utilizzare le funzioni LUNGHEZZA, SINISTRA e DESTRA.

Colonna1

Formula

Descrizione (risultato)

Vitamina A

=SINISTRA([Colonna1];LUNGHEZZA([Colonna1])-2)

Restituisce 7 (9-2) caratteri a partire da sinistra (Vitamin)

Vitamina B1

=DESTRA([Colonna1]; LUNGHEZZA([Colonna1])-8)

Restituisce 2 (10-8) caratteri a partire da destra (B1)

Rimuovere gli spazi all'inizio e alla fine di una colonna

Per rimuovere spazi da una colonna, utilizzare la funzione ANNULLA.SPAZI.

Colonna1

Formula

Descrizione (risultato)

Ciao a tutti!

=ANNULLA.SPAZI([Colonna1])

Rimuove gli spazi all'inizio e alla fine (Ciao a tutti!)

Ripetere un carattere in una colonna

Per ripetere un carattere in una colonna, utilizzare la funzione RIPETI.

Formula

Descrizione (risultato)

=RIPETI(".";3)

Ripete un punto per 3 volte (...)

=RIPETI("-";10)

Ripete un trattino per 10 volte (----------)

Torna all'inizio

Nota : Dichiarazione di non responsabilità per la traduzione automatica: Il presente articolo è stato tradotto tramite un software di traduzione automatica e non da una persona. Microsoft offre le traduzioni automatiche per consentire a coloro che non conoscono la lingua inglese di leggere gli articoli sui prodotti, sui servizi e sulle tecnologie Microsoft. Dal momento che l'articolo è stato tradotto automaticamente, potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli.

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×