Eseguire il pivot dei dati in un rapporto di tabella pivot o di grafico pivot

In Microsoft Excel 2010 è possibile eseguire il pivot dei dati in un rapporto di tabella pivot o di grafico pivot modificando il layout dei campi dei dati. Mediante Elenco campi tabella pivot è possibile aggiungere, ridisporre o rimuovere i campi per visualizzare i dati esattamente come desiderato in una tabella pivot o in un grafico pivot.

Per impostazione predefinita, quando si apporta una modifica in Elenco campi tabella pivot, il layout del rapporto viene aggiornato automaticamente. Per migliorare le prestazioni quando si accede a una grande quantità di dati esterni, è possibile passare temporaneamente all'aggiornamento manuale.

Contenuto dell'articolo

Utilizzo di Elenco campi tabella pivot

Aggiungere campi a una tabella pivot o a un grafico pivot

Ridisporre i campi nella tabella pivot o nel grafico pivot

Rimuovere campi dalla tabella pivot o dal grafico pivot

Passare dall'aggiornamento automatico a quello manuale del layout del rapporto e viceversa

Utilizzo di Elenco campi tabella pivot

Quando si crea una tabella pivot, in Excel viene visualizzato l'Elenco campi tabella pivot che consente di aggiungere campi alla tabella pivot, ridisporli e riposizionarli in base alle esigenze oppure rimuoverli dalla tabella pivot. Per impostazione predefinita, in Elenco campi tabella pivot vengono visualizzate due sezioni:

  • Una sezione di campi nella parte superiore, in cui è possibile aggiungere e rimuovere campi nella tabella pivot

  • Una sezione di layout nella parte inferiore per ridisporre e riposizionare i campi

    Finestra di dialogo Nuovo elemento grafico dati che contiene due campi dati e una forma con un elemento grafico dati che contiene questi campi come callout

La finestra Elenco campi tabella pivot può essere ancorata a uno dei due lati della finestra di Excel, e quindi ridimensionata orizzontalmente, oppure disancorata, nel qual caso può essere ridimensionata sia verticalmente che orizzontalmente.

Se l'Elenco campi tabella pivot non è visibile, fare clic in un punto qualsiasi della tabella pivot.

Se si chiude l'Elenco campi tabella pivot, è possibile visualizzarlo nuovamente. Fare clic con il pulsante destro del mouse sulla tabella pivot e quindi scegliere Mostra elenco campi. In alternativa, è possibile fare clic su Elenco campi sulla barra multifunzione (Strumenti tabella pivot, scheda Opzioni, gruppo Visualizza, nel caso di una tabella pivot, oppure Strumenti grafico pivot, scheda Analizza, gruppo Mostra/Nascondi nel caso di un grafico pivot).

Se in Elenco campi tabella pivot non sono visualizzati i campi desiderati, aggiornare il rapporto di tabella pivot o di grafico pivot per visualizzare gli eventuali nuovi campi, campo calcolato, misure, misure calcolate o dimensioni aggiunte dall'ultima operazione (Strumenti tabella pivot, scheda Opzioni, gruppo Dati).

Funzionamento di Elenco campi tabella pivot

Per ottenere i risultati desiderati durante la creazione del layout dei campi di un rapporto di tabella pivot o di grafico pivot, è importante comprendere il funzionamento della finestra Elenco campi tabella pivot e i diversi modi in cui è possibile disporre diversi tipi di campi.

Modifica riquadro di Domande e risposte

1. Un'origine dati esterna contiene dati strutturati organizzati in uno o più campi, definiti anche colonne, visualizzati in Elenco campi.

2. Spostare un campo nell'area Filtro rapporto dell'Elenco campi. Il campo verrà automaticamente spostato nell'area Filtro rapporto anche nel rapporto di tabella pivot.

3. Spostare un campo nell'area Etichette di colonna in Elenco campi, in modo da spostare simultaneamente il campo nell'area Etichette di colonna nel rapporto di tabella pivot.

4. Spostare un campo nell'area Etichette di riga, in modo da spostare simultaneamente il campo nell'area Etichette di riga nel rapporto di tabella pivot.

5. Spostare un campo nell'area Valori in Elenco campi, in modo da spostare simultaneamente il campo nell'area Valori del rapporto di tabella pivot.

Linee guida per lo spostamento di campi in Elenco campi tabella pivot

Per creare un layout di campo, utilizzare le linee guida riportate di seguito per spostare i campi Valore, Nome e Dimensione dalla sezione campo alle quattro aree del rapporto nella sezione layout.

  • Campi Valore    Se si seleziona solo una casella di controllo per un campo numerico, per impostazione predefinita tale campo viene spostato nell'area Valori.

  • Campi Riga e Colonna    Un campo può essere aggiunto una sola volta nell'area Filtro rapporto, Etichette di riga o Etichette di colonna, indipendentemente dal fatto che i dati siano di tipo numerico o non numerico. Se si tenta di aggiungere più volte lo stesso campo, ad esempio alle aree Etichette di riga e Etichette di colonna nella sezione layout,  il campo viene rimosso automaticamente dall'area originale e posizionato nella nuova area.

  • Misure    In un'origine dati OLAP spesso sono presenti molti campi (o misure) organizzati in una gerarchia di dimensioni, gerarchie e livelli diversi. Fare clic sui pulsanti di espansione casella Più e compressione casella Meno fino a individuare i campi desiderati.

    È possibile spostare solo gerarchie, attributi e set denominati nelle aree Etichette di riga, Etichette di colonna e Filtro rapporto.

    È possibile spostare solo misure, misure calcolate e indicatori di prestazioni chiave (KPI) nell'area Valori.

Modifica della visualizzazione di Elenco campi tabella pivot

Elenco campi tabella pivot presenta cinque visualizzazioni diverse, progettate e ottimizzate per diversi tipi di attività della tabella pivot.

  1. Per cambiare visualizzazione, fare clic sul pulsante delle visualizzazioni dell'elenco campi nella parte superiore della finestra Elenco campi tabella pivot.

    PivotTable Field List View button

  2. Nell'elenco selezionare una delle visualizzazioni seguenti:

Sezione campi e sezione aree in pila

Questa è la visualizzazione predefinita ed è progettata per un numero limitato di campi.

Sezione campi e sezione aree affiancate

Questa visualizzazione è progettata per l'aggiunta e la rimozione di campi quando in ogni area sono presenti più di quattro campi.

Solo sezione campi

Questa visualizzazione è progettata solo per l'aggiunta e la rimozione di molti campi.

Solo sezione aree (2x2)

Questa visualizzazione è progettata solo per la ridisposizione di molti campi.

Solo sezione aree (1x4)

Questa visualizzazione è progettata solo per la sola ridisposizione di molti campi.

Suggerimento    Per regolare la larghezza e l'altezza di ogni sezione nelle visualizzazioni Sezione campi e sezione aree in pila e Sezione campi e sezione aree affiancate, spostare il puntatore del mouse sul divisore di sezione e mantenerlo in tale posizione fino a quando non assume la forma di una doppia freccia verticale Doppia freccia verticale o orizzontale Doppia freccia orizzontale, trascinare la doppia freccia verso l'alto o verso il basso, oppure verso destra o verso sinistra, fino alla posizione desiderata e quindi fare clic sulla doppia freccia o premere INVIO.

Torna all'inizio

Aggiungere campi a una tabella pivot o a un grafico pivot

Dopo avere creato un rapporto di tabella pivot o di grafico pivot, è possibile aggiungere i campi che contengono i valori che si desidera visualizzare nel rapporto. In genere si seleziona un campo per ogni area nella sezione layout. Tuttavia, per visualizzare valori diversi per un determinato campo, è possibile anche aggiungere più copie di un campo nell'area Valori.

Se il rapporto di tabella pivot è collegato a un'origine dati esterna contenente molti dati, è possibile filtrare uno o più campi prima di aggiungere i campi al rapporto, riducendo in questo modo il tempo necessario per l'aggiornamento del rapporto.

Aggiungere i campi che si desidera visualizzare

In Elenco campi tabella pivot è possibile aggiungere i campi alla tabella pivot o al grafico pivot eseguendo una o più delle seguenti operazioni:

  • Per posizionare un campo in una specifica area della sezione layout, nella casella Selezionare i campi da aggiungere al rapporto selezionare la casella di controllo relativa al campo da aggiungere. I campi possono essere ridisposti successivamente, se necessario.

    Nota    Per impostazione predefinita, i campi non numerici vengono aggiunti all'area Etichette di riga, i campi numerici vengono aggiunti all'area Valori e le gerarchie di data e ora OLAP vengono aggiunte all'area Etichette di colonna.

  • Per posizionare un campo in una specifica area della sezione layout, nella casella Selezionare i campi da aggiungere al rapporto fare clic con il pulsante destro del mouse sul nome del campo e quindi scegliere Aggiungi a filtro rapporto, Aggiungi a etichette di colonna, Aggiungi a etichette di riga o Aggiungi a valori.

  • Per trascinare un campo in un'area della sezione layout, nella casella Selezionare i campi da aggiungere al rapporto fare clic su un campo e tenere premuto il pulsante del mouse, quindi trascinare il campo dalla sezione campo alla sezione layout desiderata.

Aggiungere più copie di un campo nell'area Valori

In un rapporto di tabella pivot basato su dati in un foglio di lavoro di Excel o su dati esterni di un'origine dati non OLAP, è possibile aggiungere più volte uno stesso campo all'area Valori, sia nel caso di dati di tipo numerico che nel caso di dati di tipo non numerico. Ad esempio, può essere utile confrontare calcoli affiancati, quali margini di profitto lordi e netti, vendite minime e massime o numero di clienti e percentuale di clienti totali.

  1. In Elenco campi tabella pivot, nella casella Selezionare i campi da aggiungere al rapporto fare clic su un campo e tenere premuto il pulsante del mouse, quindi trascinarle il campo nell'area Valori della sezione layout.

  2. Ripetere il passaggio 1 per creare tutte le copie di tale campo che si desidera visualizzare nell'area Valori.

  3. Nella tabella pivot apportare le modifiche desiderate alla funzione di riepilogo o al calcolo personalizzato in ogni copia del campo.

    Suggerimento    Nella tabella pivot è anche possibile rinominare i campi copiati in base alle proprie esigenze.

Note    

  • Quando si aggiungono due o più campi all'area Valori, a prescindere dal fatto che si tratti di copie dello stesso campo o di campi diversi, viene aggiunta automaticamente un'etichetta di colonna Valori nell'area Valori. Questo campo può essere utilizzato per spostare i campi verso l'alto o verso il basso nell'area Valori. È anche possibile spostare l'etichetta di colonna Valori nell'area Etichette di colonna o Etichette di riga, ma nonnell'area Filtro rapporto.

  • Un campo può essere aggiunto una sola volta nell'area Filtro rapporto, Etichette di riga o Etichette di colonna, indipendentemente dal fatto che i dati siano di tipo numerico o non numerico. Se si tenta di aggiungere più volte lo stesso campo, ad esempio alle aree Etichette di riga ed Etichette di colonna nella sezione layout,  il campo verrà automaticamente rimosso dall'area originale e posizionato nella nuova area.

  • Un altro modo per aggiungere lo stesso campo all'area Valori consiste nell'utilizzo di una formula (detta anche colonna calcolata) in vui viene utilizzato lo stesso campo.

Filtrare i dati prima di aggiungere campi

  • In Elenco campi tabella pivot, nella casella Selezionare i campi da aggiungere al rapporto lasciare per alcuni istanti il puntatore del mouse sopra il nome di un campo e quindi fare clic sulla freccia a discesa del filtro accanto al nome del campo.

    Nel menu Filtro scegliere le opzioni desiderate per il filtro.

Torna all'inizio

Ridisporre i campi nella tabella pivot o nel grafico pivot

In Elenco campi tabella pivot è possibile ridisporre o riposizionare i campi esistenti utilizzando una delle quattro aree nella parte inferiore della sezione layout:

Rapporto di tabella pivot

Descrizione

Grafico pivot

Descrizione

Valori

Utilizzare questa opzione per visualizzare dati numerici di riepilogo.

Valori

Utilizzare questa opzione per visualizzare dati numerici di riepilogo.

Etichette di riga

Utilizzare questa opzione per visualizzare i campi come riga sul lato del rapporto. Una riga in una posizione inferiore viene annidata all'interno di un'altra riga immediatamente superiore.

Campi asse (categorie)

Utilizzare questa opzione per visualizzare i campi come un asse nel grafico.

Etichette di colonna

Utilizzare quest'opzione per visualizzare i campi come colonne nella parte superiore del rapporto. Una colonna in una posizione inferiore viene annidata all'interno di un'altra colonna immediatamente superiore.

Campi legenda (serie)

Utilizzare quest'opzione per visualizzare i campi nella legenda del grafico.

Filtro rapporto

Utilizzare questa opzione per filtrare l'intero rapporto in base all'elemento selezionato nel filtro per il rapporto.

Filtro rapporto

Utilizzare questa opzione per filtrare l'intero rapporto in base all'elemento selezionato nel filtro per il rapporto.

  • Per ridisporre i campi in un rapporto di tabella pivot, fare clic sul nome del campo in una delle aree e quindi selezionare uno dei comandi seguenti:

Sposta su

Sposta su di una posizione il campo nell'area.

Sposta giù

Sposta giù di una posizione il campo nell'area.

Sposta all'inizio

Sposta il campo all'inizio dell'area.

Sposta alla fine

Sposta il campo alla fine dell'area.

Sposta nel filtro per il rapporto

Sposta il campo nell'area Filtro rapporto.

Sposta nelle etichette di riga

Sposta il campo nell'area Etichette di riga.

Sposta nelle etichette di colonna

Sposta il campo nell'area Etichette di colonna.

Sposta nei valori

Sposta il campo nell'area Valori.

Impostazioni campo valore, Impostazioni campo

Visualizza la finestra di dialogo Impostazioni campo o Impostazioni campo valore. Per ulteriori informazioni su ogni impostazione, fare clic sul pulsante ? Icona del pulsante nella parte superiore della finestra di dialogo.

Suggerimento    È inoltre possibile fare clic e tenere premuto il pulsante del mouse su un nome di campo e quindi trascinare il campo tra le sezioni campo e layout e tra le diverse aree.

Torna all'inizio

Rimuovere campi dalla tabella pivot o dal grafico pivot

Per rimuovere un campo, in Elenco campi tabella pivot eseguire una delle operazioni seguenti:

  • Nella casella Selezionare i campi da aggiungere al rapporto deselezionare la casella di controllo relativa al campo da rimuovere.

    Nota    Se si deseleziona una casella di controllo, tutte le istanze del campo verranno rimosse dal rapporto.

  • In un'area layout fare clic sul campo che si desidera rimuovere e quindi fare clic su Rimuovi campo.

  • In un'area layout fare clic e tenere premuto il pulsante del mouse sul campo che si desidera rimuovere e quindi trascinare il campo all'esterno di Elenco campi tabella pivot.

Torna all'inizio

Passare dall'aggiornamento automatico a quello manuale del layout del rapporto e viceversa

Per impostazione predefinita, quando si apporta una modifica in Elenco campi tabella pivot, il layout del rapporto viene aggiornato automaticamente. Per migliorare le prestazioni quando si accede a una grande quantità di dati esterni, è possibile passare all'aggiornamento manuale. In questa modalità le operazioni di aggiunta, spostamento e rimozione di campi alla sezione campo alla sezione layout sono consentite, ma per utilizzare l rapporto e visualizzare i risultati, è necessario passare nuovamente all'aggiornamento automatico.

  1. Per abilitare l'aggiornamento manuale del rapporto di tabella pivot, selezionare la casella di controllo Rinvia aggiornamento layout nella parte inferiore di Elenco campi tabella pivot.

    Attenzione    Dopo avere impostato l'aggiornamento manuale del layout del rapporto, la chiusura di Elenco campi tabella pivot, il passaggio alla visualizzazione Solo campi o l'uscita da Excel determinano l'eliminazione di tutte le modifiche del layout apportate al rapporto di tabella pivot senza conferma.

  2. In Elenco campi tabella pivot apportare le modifiche al layout di campo e quindi fare clic su Aggiorna per aggiornare manualmente il layout nel rapporto di tabella pivot.

  3. Per ripristinare l'aggiornamento automatico dopo avere modificato il layout del rapporto in Elenco campi, deselezionare la casella di controllo Rinvia aggiornamento layout.

Nota    Ogni volta che si apre la cartella di lavoro, il rapporto di tabella pivot è impostato sull'aggiornamento automatico.

Torna all'inizio

Si applica a: Excel 2010



Queste informazioni sono risultate utili?

No

Che cosa possiamo migliorare?

255 caratteri rimanenti

Per tutelare la privacy, non includere informazioni di contatto nei commenti e suggerimenti. Consulta la nostra informativa sulla privacy.

Grazie per i tuoi commenti e suggerimenti

Risorse di supporto

Cambia lingua