E (funzione E)

Importante :  Il presente articolo è stato tradotto automaticamente, vedere la dichiarazione di non responsabilità. Per visualizzare la versione inglese dell'articolo, fare clic qui.

Utilizzare la funzione e , una delle funzioni logiche, per determinare se tutte le condizioni in un test hanno valore vero.

Esempio

Esempi della funzione E

La funzione e restituisce VERO se tutti gli argomenti restituiscono vero e restituisce FALSO se uno o più argomenti restituiscono FALSO.

La funzione E viene usata comunemente per estendere la capacità di altre funzioni che eseguono test logici. Questa funzione ad esempio esegue un test logico e quindi restituisce un valore se il test restituisce VERO e un altro valore se il test restituisce FALSO. Usando la funzione E come argomento test della funzione SE, è possibile verificare molte condizioni diverse anziché una sola.

Sintassi

E (logico1; [logico2];...)

Nella sintassi della funzione e sono i seguenti argomenti:

Argomento

Descrizione

Logico1

Obbligatorio. Prima condizione da verificare che può restituire VERO o FALSO.

Logico2;...

Facoltativo. Altre condizioni che si desidera verificare che possono restituire VERO o FALSO, fino a un massimo di 255 condizioni.

Osservazioni

  • Gli argomenti devono restituire valori logici, ad esempio VERO o FALSO, oppure devono essere matrici o riferimenti contenenti valori logici.

  • Se una matrice o un riferimento contiene testo o celle vuote, tali valori verranno ignorati.

  • Se l'intervallo specificato non contiene valori logici, la funzione e restituirà #VALUE! errore.

Esempi

Di seguito sono riportati alcuni esempi generali di utilizzo e per sé e in combinazione con la funzione se .

Esempi d'uso delle funzioni SE con AND

Formula

Descrizione

=E(A2>1,A2<100)

Visualizza TRUE se A2 è maggiore di 1 e minore di 100, in caso contrario viene visualizzato FALSE.

=SE(E(A2<A3,A2<100); A2; "Il valore non è compreso nell'intervallo.")

Visualizza il valore nella cella A2, se è minore di A3 e minore di 100, in caso contrario viene visualizzato il messaggio "il valore è compreso nell'intervallo".

=SE(E(A3>1,A3<100), A3, "Il valore non è compreso nell'intervallo")

Visualizza il valore nella cella A3 se è maggiore di 1 e minore di 100, che viene visualizzato il messaggio. È possibile sostituire tutti i messaggi di propria scelta.

Calcolo del bonus

Ecco uno scenario abbastanza comune nel punto in cui sarà necessario calcolare se venditori idonei per l'utilizzo di ANDe se un premio di produzione.

Esempio di calcolo di Bonus di vendita con le funzioni SE ed E.  La formula nella cella E14 è =SE (E(B14>=$B$7,C14>=$B$5),B14*$B$8,0)
  • = Se (e (B14 > = $B$ 7 C14 > = $B$ 5), B14 * $B$ 8,0) - se Total Sales sono maggiori o uguali (> =) per l'obiettivo di vendita, gli account e sono maggiore o uguale a (> =) obiettivo Account e quindi moltiplica totale vendite per % Bonus, in caso contrario restituisce 0.

Domande su funzioni specifiche?

Post una domanda nel forum della community di Excel

Suggerimenti per migliorare Excel

Si dispone di suggerimenti su come migliorare la prossima versione di Excel? In caso affermativo, controllare gli argomenti in Voce di utente di Excel

Nota : Dichiarazione di non responsabilità per la traduzione automatica: Il presente articolo è stato tradotto tramite un software di traduzione automatica e non da una persona. Microsoft offre le traduzioni automatiche per consentire a coloro che non conoscono la lingua inglese di leggere gli articoli sui prodotti, sui servizi e sulle tecnologie Microsoft. Dal momento che l'articolo è stato tradotto automaticamente, potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli.

Vedere anche

Guardare un video che illustra come usare la funzione SE

Informazioni su come usare le formule annidate

Funzione SE

Funzione O

Funzione NON

Panoramica delle formule in Excel

Come evitare errori nelle formule

Usare il controllo degli errori per trovare gli errori nelle formule

Scelte rapide da tastiera in Excel 2016 per Windows

Scelte rapide da tastiera in Excel 2016 per Mac

Funzioni logiche (riferimento)

Funzioni di Excel (in ordine alfabetico)

Funzioni di Excel (in base alla categoria)

Condividi Facebook Facebook Twitter Twitter Posta elettronica Posta elettronica

Queste informazioni sono risultate utili?

Ottimo! Altri commenti?

Cosa possiamo migliorare?

Grazie per i tuoi commenti e suggerimenti

×