Distribuire un'applicazione di Access

Access offre una piattaforma ricca di funzionalità per lo sviluppo di applicazioni di database. Un'applicazione di database è un programma per computer che offre sia un modo per archiviare e gestire dati che un'interfaccia utente che segue la logica delle attività aziendali (logica dell'applicazione). Questo articolo illustra la pianificazione della distribuzione di base, la creazione di pacchetti e la firma, la distribuzione delle applicazioni di database e l'ambiente Access Runtime.

Per saperne di più

Pianificare la distribuzione

Distribuire un'applicazione di Access

Comprendere e scaricare il runtime di Access

Creare un pacchetto di installazione

Pianificare la distribuzione

Prima di iniziare, è necessario porsi le domande seguenti relative alla modalità di distribuzione dell'applicazione.

I dati e la logica devono essere separati?

È possibile creare un'applicazione Access che combina la gestione dei dati e la logica dell'applicazione in un unico file. Si tratta della struttura predefinita dell'applicazione in Access. La combinazione di gestione dei dati e logica dell'applicazione in un unico file offre il metodo di distribuzione più semplice, ma questo metodo funziona meglio solo se poche persone usano l'applicazione contemporaneamente e questo comporta un certo rischio. Un utente potrebbe, ad esempio, causare involontariamente la perdita di dati eliminando o danneggiando il file dell'applicazione. Nella maggior parte dei casi è consigliabile separare la gestione dei dati e la logica dell'applicazione. Questo consente di migliorare le prestazioni e l'affidabilità.

Un modo per separare i dati e la logica consiste nell'usare il comando Database di Access, disponibile nel gruppo Sposta dati della scheda Strumenti database. Questo comando divide l'applicazione di database in due file di Access: uno per Logic (un front-end) e uno per i dati (un back-end). Ad esempio, un database denominato soluzione con estensione accdb è suddiviso in due file denominati MySolution_fe. accdb e MySolution_be. accdb. Si inserisce il database back-end in una posizione condivisa, ad esempio una cartella di rete. Si distribuisce il file front-end, una copia per ogni utente, nei propri computer. È anche possibile distribuire file front-end diversi a utenti diversi. Per altre informazioni, vedere suddividere un database di Access.

Un altro modo per separare gestione dei dati e logica dell'applicazione consiste nell'usare un programma di server di database, come Microsoft SQL Server, per la gestione dei dati e l'accesso alla logica dell'applicazione. Per altre informazioni, vedere eseguire la migrazione di un database di Access a SQL Server.

Altri motivi per separare i dati e la logica sono i seguenti:

  • Integrità e sicurezza dei dati     Se si combinano dati e logica in un file, i dati vengono esposti agli stessi rischi della logica dell'applicazione. Un'applicazione Access che usa logica e file di dati distinti può contribuire a proteggere l'integrità e la sicurezza dei dati sfruttando le caratteristiche di sicurezza NTFS nelle cartelle di rete.

    Access gli utenti devono avere le autorizzazioni di lettura, scrittura, creazione ed eliminazione per la cartella in cui si trova il file front-end. È tuttavia possibile assegnare autorizzazioni diverse al file front-end stesso. Ad esempio, potresti voler assegnare le autorizzazioni di sola lettura ad alcuni utenti e le autorizzazioni di lettura/scrittura ad altri utenti.

    L'applicazione può richiedere ulteriori opzioni di sicurezza, ad esempio la possibilità di controllare quali utenti hanno accesso a dati specifici. In questo caso, è possibile usare SQL Server o SharePoint per archiviare e gestire i dati dell'applicazione e usare Access per specificare la logica dell'applicazione.

  • Scalabilità    Un file di Access può avere una dimensione massima di 2 gigabyte (GB). Anche se 2 GB corrisponde a una notevole quantità di dati di testo, potrebbe risultare insufficiente per alcune applicazioni, in particolare per le applicazioni che archiviano allegati nei record di database. Se dati e logica sono separati, l'applicazione può gestire una maggiore quantità di dati. Se si prevede che gli utenti archivino un volume elevato di dati, è possibile usare più file di dati di Access.

    È opportuno anche rivedere le specifiche del programma Access per altre informazioni sulla scalabilità. Per ulteriori informazioni sulle specifiche di Access, vedere l'articolo specifiche di Access.

  • Capacità della rete    Se più utenti devono usare contemporaneamente l'applicazione in una rete, è più probabile che si verifichino danneggiamenti dei dati se i dati e la logica sono combinati in un unico file. Se, inoltre, si combinano dati e logica in un unico file di Access, non è possibile ottimizzare il traffico di rete generato da Access. Se più utenti usano contemporaneamente l'applicazione in una rete, è consigliabile separare i dati e la logica, usando due o più file di Access oppure usando un prodotto server di database per i dati e Access per la logica dell'applicazione.

Come sarà l'ambiente di rete?

La scelta della soluzione di database di Access corretta per l'ambiente di rete è un passaggio fondamentale per renderlo efficace. Usare le linee guida seguenti per facilitare la scelta ottimale per le proprie esigenze.

Rete domestica

Se si hanno solo pochi utenti con cui condividere il database di Access, è possibile usare un singolo database che ogni persona si apre e USA in una rete domestica. Per altre informazioni, vedere condivisione di file tramite una rete in Windows 10.

Rete LAN (Local Area Network)

Una LAN è una rete interna che in genere offre prestazioni ottimali, ma è limitata a una piccola area geografica, ad esempio una singola sala, un edificio o un gruppo di edifici. Quando si hanno più utenti che condividono il database in una rete LAN, è preferibile suddividere il database, archiviare il database back-end in una cartella di rete e distribuire una copia del database front-end per ogni utente.

Rete WAN (Wide Area Network)

Esistono molte configurazioni possibili per una WAN, che copre una vasta area geografica. Si possono avere più uffici in una città connessa a una rete pubblica, una linea affittata o persino i satelliti. Spesso, una rete privata virtuale (VPN) viene usata per l'accesso remoto sicuro da casa o in viaggio. Un modo semplice per capire una WAN è che ogni volta che ci si trova all'esterno di una LAN ma si è connessi, si usa una WAN.

Avviso    Evitare di usare un database di divisione di Access in una rete WAN perché le prestazioni possono essere lente e i database potrebbero danneggiarsi.

Esistono tre modi supportati per usare Access in una rete WAN:

  • Un database di Access con tabelle collegate agli elenchi di SharePoint.

  • Connessione a un database di Access front-end a un database SQL Server di backend o Azure SQL.

  • Servizi Desktop remoto (RDS) (precedentemente conosciuto come Terminal Server), che crea un ambiente desktop Windows virtuale nel computer client di un utente. RDS offre diversi vantaggi:

    • Non è necessaria alcuna installazione di Access o un database di Access perché gli utenti eseguono il client desktop remoto disponibile in molti dispositivi.

    • Il trasferimento dei dati viene ridotto a icona tra il client e il server perché RD è un thin client che trasmette in modo efficiente solo l'interfaccia utente.

    • Gli utenti possono ancora copiare e incollare dati e stampare report localmente dal computer client.

    • RemoteApp può eseguire solo un singolo programma, ad esempio un'applicazione chiavi in mano per i venditori o i lavoratori Frontline.

    Per altre informazioni, vedere Introduzione ai Servizi Desktop remoto.

Access sarà disponibile per tutti gli utenti?

Se Access verrà installato nei computer di tutti gli utenti, questi possono aprire e usare l'applicazione come con un qualsiasi file di database di Access.

Se alcuni o tutti gli utenti non avranno Access installati nei propri computer, è anche possibile distribuire il software di runtime Access agli utenti quando si distribuisce l'applicazione. Per altre informazioni, vedere comprendere e scaricare il runtime di Access.

Inizio pagina

Distribuire un'applicazione Access

Per distribuire un'applicazione Access, è necessario eseguire le attività seguenti.

Preparare il database come soluzione applicativa

Per bloccare la soluzione, controllare lo spostamento e l'avvio e impostare altre opzioni importanti, eseguire le operazioni seguenti:

Attività

Altre informazioni

Decidere in che modo gli utenti possono esplorare l'interfaccia utente: usare una maschera predefinita, creare un pannello comandi, usare una maschera di spostamento oppure usare i collegamenti ipertestuali e i pulsanti di comando.

Impostare la maschera predefinita visualizzata all'apertura di un database di Access

Creare una maschera di spostamento

Personalizzare il riquadro di spostamento

Visualizzare o nascondere le schede degli oggetti

Modelli di Access in primo piano

I pannelli comandi non sono più disponibili

Decidere se si vuole personalizzare la barra multifunzione di Office e i menu di comando

Creare una barra multifunzione personalizzata in Access

Creare menu e menu di scelta rapida personalizzati utilizzando macro

Usare le barre degli strumenti e le impostazioni di avvio personalizzate delle versioni precedenti di Access

Applicare un tema e uno sfondo di Office coerenti

Aggiungere uno sfondo di Office

Cambiare il tema di Office

Controllo dell'avvio del database

Aggiungere un titolo o un'icona personalizzati a un database

Ignorare le opzioni di avvio quando si apre un database

Creare una macro che viene eseguita all'apertura di un database

Opzioni della riga di comando per i prodotti Microsoft Office

Impostare le proprietà e le opzioni importanti

Impostare le proprietà di avvio e le opzioni nel codice

Visualizzare o cambiare le proprietà di un file di Office

Modificare le impostazioni internazionali

Modificare le impostazioni internazionali di Windows per modificare l'aspetto di alcuni tipi di dati

Suggerimento    Per essere accurati, passare alla finestra di dialogo Opzioni di Access (file > Opzioni) e quindi fare clic su guida per ogni scheda. Potrebbero essere disponibili altre opzioni che si desidera controllare per la soluzione dell'applicazione.

Prima della distribuzione

Prima di distribuire il database front-end, prendere in considerazione le procedure consigliate seguenti:

Scegliere il formato di file da usare

Quando si distribuisce un'applicazione, è possibile usare quattro formati di file Access:

  • accdb    Si tratta del formato di file predefinito per Access. Quando si distribuisce un'applicazione in questo formato, gli utenti hanno a disposizione la maggior parte delle opzioni per personalizzare ed esplorare l'applicazione nel modo che preferiscono. Per evitare che gli utenti modifichino la struttura dell'applicazione, è opportuno usare il formato di file con estensione accde. Un utente non può inoltre determinare facilmente se un file con estensione accdb è stato modificato dopo la creazione del pacchetto. Per renderlo evidente, usare il formato di file con estensione accdc.

  • accdc    Questo formato è noto anche come file di distribuzione di Access. Un file di distribuzione di Access include un file dell'applicazione e una firma digitale associata a tale file. Questo formato di file assicura agli utenti che nessuno ha modificato il file dell'applicazione dopo la creazione del pacchetto. È possibile applicare questo formato a un file di formato predefinito Access (con estensione accdb) o a un file binario compilato di Access (con estensione accde). Per altre informazioni, vedere visualizzare l'attendibilità aggiungendo una firma digitale.

    In un file di distribuzione di Access è possibile inserire un solo file di applicazione. Se l'applicazione contiene file di dati e di logica separati, è possibile creare un pacchetto per ognuno di essi.

  • accde    Questo formato è noto anche come file binario compilato. In Access un file binario compilato è un file dell'applicazione di database che è stato salvato con tutto il codice VBA compilato. Il codice sorgente VBA non rimane in un file binario compilato di Access. Un file con estensione ACCDE impedisce la progettazione e le modifiche al codice, riduce le dimensioni del database e consente di migliorare le prestazioni. Per altre informazioni, vedere nascondere il codice VBA dagli utenti.

    È possibile usare Access per aprire un file binario compilato di Access. Se il runtime non riconosce l'estensione di file ACCDE, aprire il file binario creando un collegamento che punti al runtime e includere il percorso del file binario compilato in cui si vuole aprire il collegamento.

    Importante   Gli utenti non possono aprire un file binario compilato usando una versione precedente di Access rispetto alla versione in cui è stata compilata se la versione precedente non supporta una caratteristica aggiunta nella versione successiva. Per risolvere il problema, compilare il file binario nella versione di Access installata dagli utenti.

  • accdr    Questo formato consente di distribuire un'applicazione che viene aperta nella modalità di runtime. La distribuzione di un'applicazione di runtime permette di controllare la modalità di utilizzo dell'applicazione, anche se non è uno strumento valido per proteggerla. Per altre informazioni sulla modalità di runtime, vedere la sezione Informazioni su Access Runtime.

Installare e aggiornare un database front-end di Access

Quando si adotta una struttura di database divisa, è necessario distribuire il database front-end a ogni utente. Per fare in modo che le cose vadano bene, prendere in considerazione le procedure consigliate seguenti:

  • Assicurarsi che ogni utente disponga della versione corretta di Access e che il database front-end venga aperto nella versione corretta. Access include anche le versioni bit di 32 e 64 bit. L'uso di "bit" non corretto può influire sulle chiamate API di Windows, sui riferimenti alle librerie DLL e sui controlli ActiveX. Per altre informazioni, vedere scegliere tra la versione di Office 64 bit o 32 bit.

  • Creare un pacchetto di installazione per altri file che potrebbero essere necessari, inclusi i driver di database, i file batch per l'installazione e la configurazione e i file correlati alle applicazioni. Per altre informazioni, vedere creare un pacchetto di installazione.

  • Fornisci un collegamento desktop di Windows in modo che l'utente possa eseguire rapidamente la soluzione di Access. Includere nel collegamento il percorso della cartella, un nome di collegamento significativo, una descrizione e un'icona. Per altre informazioni, vedere creare un collegamento sul desktop per un'applicazione o un file di Office.

    Suggerimento    Indica agli utenti come aggiungere app al menu Start.

  • Determinare un modo efficace per ridistribuire e sostituire il database front-end quando è necessario aggiornare gli aggiornamenti e gestire le versioni dei file per tenere traccia delle modifiche. Ad esempio, è possibile aggiungere codice VBA per verificare la ricerca di nuove versioni e l'aggiornamento automatico anche prima che gli utenti avviino l'applicazione.

  • Quando si crea una connessione ODBC usando un file DSN che contiene la stringa di connessione, deve essere installato anche il file DSN in ogni computer client. Un altro approccio consiste nel creare una connessione "senza DSN" nel codice VBA per eliminare la necessità di un file DSN. Per altre informazioni, vedere uso di connessioni senza DSN.

Inizio pagina

Comprendere e scaricare il Access Runtime

Per distribuire Access applicazioni che possono essere eseguite senza un'installazione di Access nel computer di un utente, è possibile distribuirle insieme al Access Runtime, disponibile gratuitamente dall'area download Microsoft. Quando si apre un database di Access con Access Runtime, il database viene aperto in modalità di runtime.

La modalità di runtime è una modalità operativa di Access in cui alcune funzionalità di Access non sono disponibili per impostazione predefinita. È però possibile rendere disponibili alcune di queste funzionalità nella modalità di runtime.

Quali funzionalità non sono disponibili nella modalità di runtime?

Le funzionalità seguenti di Access non sono disponibili nella modalità di runtime:

  • Tasti speciali    Tasti come CTRL + INTERR, CTRL + G e MAIUSC per ignorare le opzioni di avvio nel database.

  • Riquadro di spostamento    Il riquadro di spostamento non è disponibile nella modalità di runtime. In questo modo si impedisce agli utenti di accedere a oggetti arbitrari nell'applicazione di database. Solo gli oggetti esposti agli utenti, ad esempio fornendo una maschera di spostamento, possono essere aperti durante l'uso della modalità runtime. Non è possibile rendere disponibile il riquadro di spostamento nella modalità di runtime.

  • Barra multifunzione    Per impostazione predefinita, la barra multifunzione non è disponibile nella modalità di runtime. In questo modo si impedisce agli utenti di creare o modificare oggetti di database e di eseguire altre azioni potenzialmente nocive, ad esempio la connessione a nuove origini dati o l'esportazione di dati in modi non previsti. Non è possibile esporre le schede predefinite della barra multifunzione nella modalità di runtime. È tuttavia possibile creare una barra multifunzione personalizzata e quindi associarla a una maschera o a un report. Per altre informazioni, vedere creare una barra multifunzione personalizzata in Access.

  • Visualizzazione Struttura e visualizzazione Layout    La visualizzazione Struttura e la visualizzazione Layout non sono disponibili per gli oggetti di database nella modalità di runtime. In questo modo si impedisce agli utenti di modificare la struttura di oggetti nell'applicazione di database. Non è possibile abilitare la visualizzazione Struttura o la visualizzazione Layout nella modalità di runtime.

  • Guida    Per impostazione predefinita, la Guida integrata non è disponibile nella modalità di runtime. Dal momento che si controllano le funzionalità disponibili nell'applicazione nella modalità di runtime, alcuni argomenti della Guida integrata standard di Access potrebbero essere irrilevanti per gli utenti dell'applicazione e potrebbero essere fonte di confusione o frustrazione. Puoi creare un file della Guida personalizzato per completare l'applicazione in modalità di Runtime.

Come si simula la modalità runtime?

È possibile eseguire nella modalità di runtime qualsiasi database di Access in un computer in cui è installata la versione completa di Access. Per eseguire un database di Access nella modalità di runtime, eseguire una delle operazioni seguenti:

  • Modificare l'estensione del file di database da accdb ad accdr.

  • Creare un collegamento al database con l'opzione della riga di comando /Runtime .

    1. Dal desktop di Windows fare clic con il pulsante destro del mouse e scegliere nuova > di scelta rapida.

    2. Immettere il percorso di MSAccess. exe, la posizione del database e il qualificatore del comando /Runtime . Ad esempio:

      "C:\Program Files\Microsoft Office\MSACCESS.EXE" "C:\MyDB.accdb" /runtime

    Per altre informazioni, vedere creare un collegamento sul desktop per un'applicazione o un file di Office.

La modalità di runtime rende più sicuro il database?

Anche se la modalità di runtime limita la disponibilità delle funzionalità di spostamento e progettazione, è consigliabile non usare la modalità di runtime come strumento principale per proteggere un'applicazione di database. In un computer in cui è installata la versione completa di Access un utente può aprire un'applicazione di database di runtime come una normale applicazione di database (ovvero con tutte le funzionalità disponibili) e quindi modificare la struttura o eseguire altre azioni indesiderate.

Anche se si distribuisce l'applicazione di database solo in computer in cui non è installata la versione completa di Access, un utente può comunque trasferire l'applicazione in un computer in cui è installata la versione completa di Access e quindi aprire l'applicazione di database di runtime come una normale applicazione di database.

Inizio pagina

Scaricare Access Runtime

Per scaricare Access Runtime dall'Area download Microsoft, fare clic sul collegamento appropriato per la versione usata:

Non è necessario effettuare alcun acquisto per scaricare, usare o ridistribuire Access Runtime. Non è inoltre previsto alcun limite al numero di utenti a cui distribuire Runtime.

Inizio pagina

Creare un pacchetto di installazione

A seconda della versione di Access, è possibile eseguire diversi approcci.

Usare un pacchetto di installazione generale (Access 2013 o versioni successive)

per le versioni di Access 2013 o successive, è possibile usare Windows Installer o cercare un programma di terze parti che crei pacchetti di installazione.

Creare un pacchetto e firmare un database di Access (Access 2007 e 2010)

In Access 2007 o 2010 è più semplice e veloce firmare e distribuire un database. Dopo avere creato un file con estensione accdb o accde, è possibile creare un pacchetto del file, applicare una firma digitale al pacchetto e quindi distribuire il pacchetto firmato ad altri utenti. Grazie alla funzionalità Crea pacchetto e apponi firma il database viene inserito in un file di distribuzione di Access (con estensione accdc), il pacchetto viene firmato e quindi inserito in un percorso nel computer dell'utente specificato dall'utente stesso. Gli utenti hanno quindi la possibilità di estrarre il database dal pacchetto e di lavorare direttamente nel database e non nel file del pacchetto. Per altre informazioni, Vedi Panoramica della soluzione guidata pacchetti.

Nota: La funzionalità descritta in questa sezione consente di creare il pacchetto di un file Access e di applicare una firma digitale al pacchetto per indicare agli utenti che il file è attendibile.

Quando si passa alla creazione e alla firma di un pacchetto, tenere presente quanto segue:

  • La creazione di un pacchetto del database e la firma del pacchetto sono operazioni che contribuiscono all'attendibilità. Quando si riceve il pacchetto, la firma garantisce che il database non è stato alterato. Se si considera attendibile l'autore, è possibile abilitare il contenuto.

  • La funzionalità Crea pacchetto e apponi firma si applica solo ai database salvati nel formato di file accdb.

  • È possibile aggiungere un solo file di database a un pacchetto.

  • Quando si crea il pacchetto e si firma un database, viene firmato il codice di tutti gli oggetti presenti nel file di database, non solo delle macro o dei moduli di codice. Il processo di creazione del pacchetto e di firma include anche la compressione del file di pacchetto per ridurre i tempi di download.

  • Una volta estratto il database dal pacchetto, non vi sarà più alcuna connessione tra il pacchetto firmato e il database estratto.

  • Se si usa un certificato autofirmato per firmare un pacchetto di database, quindi si fa clic su Considera attendibile tutto quello che proviene da questo editore all'apertura del pacchetto tutti i pacchetti a cui si appone la firma utilizzando i certificati autofirmati saranno sempre considerati attendibili.

  • Se si estrae il database in un percorso attendibile, il contenuto sarà automaticamente abilitato ogni volta che si apre il database. Se si sceglie un percorso non attendibile, è possibile che una parte del contenuto sia disabilitata per impostazione predefinita.

Le sezioni seguenti descrivono come creare un file di pacchetto firmato e usare il database in un file di pacchetto firmato. Per completare questa procedura, deve essere disponibile almeno un certificato di sicurezza. Se nel computer non è installato un certificato, è possibile crearne uno usando lo strumento SelfCert o ottenere un certificato commerciale. Per informazioni sui certificati di sicurezza, vedere mostrare attendibilità aggiungendo una firma digitale.

Creare un pacchetto firmato

  1. Aprire il database di cui si vuole creare il pacchetto firmato.

  2. Fare clic sulla scheda File e quindi su Salva con nome.

  3. In Tipi di file di database fare clic su Crea pacchetto e apponi firma e quindi fare clic su Salva con nome.

  4. Nella finestra di dialogo Seleziona certificato selezionare un certificato digitale e quindi fare clic su OK.

    Viene visualizzata la finestra di dialogo Crea pacchetto firmato di Microsoft Office Access.

  5. Nell'elenco Salva in selezionare una posizione per il pacchetto di database firmato.

  6. Immettere un nome per il pacchetto firmato nella casella Nome file e quindi fare clic su Crea.

    Il file con estensione accdc verrà creato da Access e inserito nel percorso scelto.

Estrarre e usare un pacchetto firmato

  1. Fare clic su File > Apri.

  2. Nella finestra di dialogo Apri selezionare Pacchetti firmati di Microsoft Office Access (*.accdc) come tipo di file.

  3. Nell'elenco Cerca in individuare la cartella contenente il file con estensione accdc, selezionare il file e quindi scegliere Apri.

  4. Eseguire una delle operazioni seguenti:

    • Se si sceglie di considerare attendibile il certificato digitale applicato al pacchetto di distribuzione, verrà visualizzata la finestra di dialogo Estrai database in. Procedere con il passaggio 5.

    • Se non si è scelto di considerare attendibile il certificato digitale, verrà visualizzato un messaggio di avviso.

      Messaggio di avviso

      Se si considera attendibile il database, fare clic su Apri. Se si considera attendibile qualsiasi certificato del provider, fare clic su Considera attendibile tutto quello che proviene da questo autore. Viene visualizzata la finestra di dialogo Estrai database in.

  5. Nell'elenco Salva in è possibile selezionare una posizione per il database estratto, quindi nella casella Nome file immettere un nome diverso per il database estratto.

Se non si è sicuri se considerare attendibile o meno un certificato, vedere l'articolo Verifica dell'attendibilità di una firma digitale in cui vengono fornite informazioni generali sulla verifica delle date e degli altri elementi di un certificato per garantirne la validità.

Inizio pagina

Nota:  Questa pagina è stata tradotta automaticamente e potrebbe contenere errori di grammatica o imprecisioni. L'intento è quello di rendere fruibile il contenuto. Queste informazioni sono risultate utili' Questo è l'articolo in inglese per riferimento.

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×