Creare una tabella pivot per analizzare i dati di un foglio di lavoro

Creare una tabella pivot per analizzare i dati di un foglio di lavoro

La possibilità di analizzare rapidamente i dati può aiutare a prendere decisioni aziendali migliori. A volte, tuttavia, è difficile capire da dove iniziare, in particolare quando i dati sono molti. Le tabelle pivot sono un'ottima soluzione per riepilogare, analizzare, esplorare e presentare i dati e possono essere create con pochi clic. Le tabelle pivot sono molto flessibili e possono essere modificate rapidamente in base alle esigenze di visualizzazione dei risultati. È anche possibile creare grafici pivot basati sulle tabelle pivot, che verranno aggiornati automaticamente quando si aggiornano le tabelle pivot.

Ecco ad esempio un semplice elenco di spese domestiche e una tabella pivot basata sull'elenco:

Dati spese domestiche

Tabella pivot corrispondente

Dati di esempio relativi alle spese domestiche per la creazione di una tabella pivot con mesi, categorie e importi



Tabella pivot di esempio con le categorie nella sezione Righe e i mesi nella sezione Colonne

Ecco quindi un grafico pivot:

Esempio di grafico pivot di Excel

Nota : Gli screenshot di questo articolo si riferiscono a Excel 2016. Se si usa una versione diversa, la visualizzazione potrebbe risultare leggermente diversa ma, se non diversamente specificato, le funzionalità sono le stesse.

Prima di iniziare

  • I dati devono essere organizzati in formato tabulare e non devono esserci righe o colonne vuote. Idealmente, è possibile usare una tabella di Excel come nell'esempio precedente.

  • Le tabelle costituiscono un'origine dati eccellente per le tabelle pivot, perché le righe aggiunte a una tabella vengono automaticamente incluse nella tabella pivot quando si aggiornano i dati e le nuove colonne vengono incluse nell'elenco Campi tabella pivot. In caso contrario, sarebbe necessario aggiornare manualmente l'intervallo dell'origine dati o usare una formula di intervallo denominato dinamica.

  • I tipi di dati nelle colonne devono corrispondere. Ad esempio, non si devono combinare date e testo nella stessa colonna.

  • Le tabelle pivot usano uno snapshot dei dati, detto cache, quindi i dati effettivi non vengono modificati in alcun modo.

Creare una tabella pivot

Se non si ha molta esperienza nella creazione di tabelle pivot o non si sa esattamente come iniziare, è preferibile usare una tabella pivot consigliata. Quando si usa questa caratteristica, Excel determina un layout significativo stabilendo una corrispondenza tra i dati e le aree più appropriate nella tabella pivot. La tabella così ottenuta costituisce un punto di partenza per sperimentare le varie possibilità. Dopo aver creato una tabella pivot consigliata, è possibile esaminare le diverse opzioni di orientamento e ridisporre i campi per ottenere risultati specifici. La caratteristica Tabelle pivot consigliate è stata aggiunta in Excel 2013. Se si usa una versione precedente, seguire invece le istruzioni seguenti per la creazione manuale di una tabella pivot.

Tabelle pivot consigliate

Creare manualmente una tabella pivot

  1. Fare clic su una cella nei dati di origine o nell'intervallo della tabella.

  2. Passare a Inserisci > Tabelle > Tabelle pivot consigliate.

    Passare a Inserisci > Tabelle pivot consigliate per fare in modo che Excel crei una tabella pivot

  3. Excel analizza i dati e fornisce diverse opzioni, come in questo esempio che usa i dati delle spese domestiche.

    Finestra di dialogo Tabelle pivot consigliate di Excel
  4. Selezionare la tabella pivot preferita e premere OK. Excel creerà una tabella pivot in un nuovo foglio e visualizzerà l'elenco Campi tabella pivot.

  1. Fare clic su una cella nei dati di origine o nell'intervallo della tabella.

  2. Passare a Inserisci > Tabelle > Tabelle pivot.

    Passare a Inserisci > Tabella pivot per inserire una tabella pivot vuota

    Se si usa Excel per Mac 2011 e versioni precedenti, il pulsante Tabella pivot si trova nel gruppo Analisi della scheda Dati.

    scheda dati, gruppo analisi

  3. Excel visualizzerà la finestra di dialogo Crea tabella pivot con il nome di tabella o l'intervallo selezionato. In questo caso viene usata una tabella denominata "tbl_HouseholdExpenses".

    Finestra di dialogo Crea tabella pivot di Excel
  4. Nella sezione Specificare dove collocare il rapporto di tabella pivot selezionare Nuovo foglio di lavoro o Foglio di lavoro esistente. Per Foglio di lavoro esistente, sarà necessario selezionare sia il foglio di lavoro sia la cella in cui inserire la tabella pivot.

  5. Per includere più tabelle o origini dati in una tabella pivot, fare clic sulla casella di controllo Aggiungi dati al modello di dati.

  6. Fare clic su OK. Excel creerà una tabella pivot vuota e visualizzerà l'elenco Campi tabella pivot.

Uso dell'elenco Campi tabella pivot

Nell'area Nome campo nella parte superiore selezionare la casella di controllo per tutti i campi da aggiungere a una tabella pivot. Per impostazione predefinita, i campi non numerici vengono aggiunti all'area Riga, i campi di data e ora vengono aggiunti all'area Colonna e i campi numerici vengono aggiunti all'area Valori. È anche possibile trascinare manualmente gli elementi disponibili e rilasciarli in uno qualsiasi dei campi della tabella pivot oppure, se non si vuole più avere un elemento in una tabella pivot, è sufficiente trascinarlo fuori dall'elenco dei campi o deselezionarlo. La possibilità di ridisporre gli elementi campo è una delle caratteristiche delle tabelle pivot grazie a cui è possibile cambiare l'aspetto in modo estremamente rapido.

Elenco Campi tabella pivot

Campi corrispondenti in una tabella pivot

Esempio di finestra di dialogo con l'elenco Campi tabella pivot di Excel



Esempio di tabella pivot e della modalità di correlazione tra i campi nell'elenco campi.

Valori di una tabella pivot

  • Riepiloga valori per

    Per impostazione predefinita, i campi di tabella pivot presenti nell'area Valori verranno visualizzati come SOMMA. Se Excel interpreta i dati come testo, verranno visualizzati come CONTEGGIO. Per questo motivo, è importante assicurarsi di non combinare tipi di dati diversi per i campi dei valori. È possibile modificare il calcolo predefinito facendo innanzitutto clic sulla freccia a destra del nome del campo e quindi scegliendo Impostazioni campo valore.

    Finestra di dialogo Impostazioni campo valore di Excel

    Modificare quindi il calcolo nella sezione Riepiloga valori per. Si noti che quando si modifica il metodo di calcolo, Excel lo aggiunge automaticamente nella sezione Nome personalizzato, ad esempio "Somma di NomeCampo". È comunque possibile modificare questo nome. Se si fa clic sul pulsante Formato numeri, è possibile modificare il formato dei numeri per l'intero campo.

    Finestra di dialogo Impostazioni campo valore di Excel con le opzioni Riepiloga valori per

    Suggerimento : Poiché modificando il calcolo nella sezione Riepiloga valori per si modifica il nome del campo della tabella pivot, è preferibile non rinominare i campi della tabella pivot fino a quando non è stata completata la configurazione della tabella pivot. Un possibile metodo consiste nell'usare Trova e sostituisci (CTRL+H) > Trova > "Somma di", quindi Sostituisci con > lasciare vuoto per sostituire tutti gli elementi contemporaneamente invece di dover digitare di nuovo.

  • Mostra valori come

    Invece di usare un calcolo per riepilogare i dati, è anche possibile visualizzarli come percentuale di un campo. Nell'esempio seguente l'importo delle spese domestiche è stato modificato per essere visualizzato come % del totale complessivo invece che come somma dei valori.

    Esempio di tabella pivot con i valori visualizzati come percentuale del totale complessivo

    Dopo aver aperto la finestra di dialogo Impostazioni campo valore, è possibile effettuare le selezioni desiderate nella scheda Mostra valori come.

    Finestra di dialogo Impostazioni campo valore > Mostra valori come, per una tabella pivot
  • Visualizzare un valore sia come calcolo che come percentuale.

    Trascinare semplicemente l'elemento nella sezione Valori due volte e quindi impostare le opzioni Riepiloga valori per e Mostra valori come per ogni elemento.

Aggiornamento di tabelle pivot

Se si aggiungono nuovi dati all'origine dati della tabella pivot, tutte le tabelle pivot basate su tale origine dovranno essere aggiornate. Per aggiornare una sola tabella pivot, è possibile fare clic con il pulsante destro del mouse in un punto qualsiasi dell'intervallo di tabella pivot e quindi scegliere Aggiorna. Se ci sono più tabelle pivot, selezionare prima di tutto una cella in una tabella pivot e quindi sulla barra multifunzione passare a Strumenti tabella pivot > Analizza > Dati > Clic sulla freccia sotto il pulsante Aggiorna e selezionare Aggiorna tutto.

Aggiornare tutte le tabelle pivot dalla barra multifunzione > Strumenti tabella pivot > Analizza > Dati, fare clic sulla freccia sotto il pulsante Aggiorna e selezionare Aggiorna tutto.

Eliminazione di una tabella pivot

Se dopo aver creato una tabella pivot si decide che non è più necessaria, è sufficiente selezionare l'intero intervallo della tabella pivot e fare clic su Elimina. L'operazione non avrà alcun effetto su altri dati né su altri grafici o tabelle pivot. Se la tabella pivot si trova in un altro foglio che non contiene altri dati da conservare, è possibile rimuovere rapidamente la tabella pivot eliminando tale foglio.

Domande specifiche sulle tabelle pivot?

Pubblicare una domanda nel forum della community di Excel

Suggerimenti per migliorare Excel

Per suggerimenti su come migliorare la prossima versione di Excel, vedere gli argomenti in Excel User Voice

Vedere anche

Creare un grafico pivot

Creare una tabella pivot con il modello di dati per analizzare i dati in più tabelle

Usare l'Elenco campi per disporre i campi in una tabella pivot

Modificare i dati di origine di una tabella pivot

Calcolare i valori in una tabella pivot

Eliminare una tabella pivot

Condividi Facebook Facebook Twitter Twitter Posta elettronica Posta elettronica

Queste informazioni sono risultate utili?

Ottimo! Altri commenti?

Cosa possiamo migliorare?

Grazie per i tuoi commenti e suggerimenti

×