Creare una soluzione di tracciabilità delle risorse usando InfoPath ed Excel

Importante :  Il presente articolo è stato tradotto automaticamente, vedere la dichiarazione di non responsabilità. Per visualizzare la versione inglese dell'articolo, fare clic qui.

Microsoft Office InfoPath consente di creare modelli di modulo per l'immissione e la raccolta di dati. Microsoft Office Excel 2007 consente agli utenti di calcolare e analizzare i dati e disegnare grafici in base a essi. Usando sia di questi programmi sia XML, è possibile creare facilmente una semplice ma efficace soluzione aziendale senza codice per inventariare i beni in una società.

Panoramica della soluzione di inventario beni mobili

In questo articolo

Introduzione alla creazione di una soluzione di Inventario beni mobili

Passaggio 1: Personalizzare il modello di modulo Inventario beni mobili

Passaggio 2: Mappare il file di schema e personalizzare il layout di tabella in Excel

Passaggio 3: Creare un report di riepilogo della tabella pivot e del grafico pivot

Passaggio 4: Raccogliere informazioni sui beni da parte degli utenti

Passaggio 5: Importare i moduli in Excel

Considerazioni finali: Valutare l'uso di un elenco SharePoint o un database di Access

Introduzione alla creazione di una soluzione di Inventario beni mobili

È possibile scambiare dati XML tra InfoPath ed Excel. Nonostante il comando Esporta di Infopath sia un modo semplice e immediato per inviare dati del modulo a Excel, esiste un altro approccio che offre maggiore flessibilità. Eseguendo in modo esplicito il mapping del file di schema InfoPath XML (XSD) in Excel e quindi importando i file di modulo di InfoPath (XML) in Excel, è possibile personalizzare il layout dei dati e sfruttare al meglio le caratteristiche di Excel che consentono di gestire e analizzare i dati in modo più efficiente.

In questo articolo verrà usato il modello di modulo Inventario beni mobili di InfoPath per illustrare come è possibile far interagire InfoPath, XML ed Excel. Si supponga che ogni anno, l'organizzazione esegua l'inventario beni nell'ufficio di ogni dipendente. Viene quindi eseguito un report di Excel per aiutare a decidere come allocare il budget delle attrezzature per l'anno successivo. Il diagramma seguente rappresenta una panoramica di come è possibile raccogliere, tenere traccia e creare un report dei dati sui beni nel proprio reparto.

a

1. Viene creato il modello di modulo Inventario beni mobili.

2. Il file di schema viene mappato a una tabella di Excel e il layout di tabella viene personalizzato.

3. Viene creato un report di riepilogo vuoto della tabella pivot e del grafico pivot.

4. Il modulo Inventario beni mobili viene usato per raccogliere dati da parte degli utenti.

5. Tutti i dati del modulo vengono esportati in una tabella di Excel e vengono aggiornati i report di grafico pivot e di tabella pivot.

Questa soluzione prevede i prodotti e i ruoli utente seguenti:

Icona Supporto completo = Obbligatorio Icona Nessun supporto = Non obbligatorio

Requisiti software

Ruoli

Office InfoPath 2007

Office Outlook 2007

Office Excel 2007

Solution Designer

Icona Supporto completo

Icona Supporto completo

Icona Supporto completo

Decisore

Icona Supporto completo

Icona Supporto completo

Icona Supporto completo

Dipendenti

Icona Supporto completo

Icona Supporto completo

Icona Nessun supporto

Inizio pagina

Passaggio 1: Personalizzare il modello di modulo Inventario beni mobili

Il modello di modulo Inventario beni mobili, incluso in InfoPath, consente di raccogliere informazioni su ogni bene presente nell'ufficio di un dipendente, sul reparto a cui appartiene il dipendente, sulle categorie dei beni e informazioni dettagliate su ogni bene. In questa soluzione, un progettista di moduli invia il modello di modulo all'account di posta elettronica del decisore usando Office Outlook 2007.

Modello per inventario beni

Attività 1: Aprire e personalizzare il modello di modulo Inventario beni mobili

Perché non è possibile pubblicare un modello di modulo in un elenco dei destinatari di posta elettronica se contiene un controllo casella di testo RTF contenente immagini collegate, è necessario apportare piccole modifiche al modello di modulo Inventario beni mobili di esempio.

  1. Scegliere Progetta modello modulo dal menu File.

  2. Nella finestra di dialogo Progetta modello di modulo, in Apri modello di modulo, fare clic su Personalizza modulo di esempio.

  3. Nella finestra di dialogo Riquadro attività iniziale fare clic su Esempio - Inventario beni mobili e quindi in Attività modulo, fare clic su Progetta modulo.

  4. Fare clic con il pulsante destro del mouse sul controllo assetNotes, scegliere le proprietà Casella di testo RTF, fare clic sulla scheda Visualizza e quindi in Formattazione disponibile selezionare la casella di controllo Immagini collegate.

Attività 2: Definire le Opzioni invio

L'attività successiva consiste nel definire le Opzioni invio in modo che i dipendenti possano inviare un file di modulo denominato in modo univoco (con estensione xml) all'account di posta elettronica del decisore come file allegato.

  1. Scegliere Opzioni invio dal menu Strumenti.

  2. Nella finestra di dialogo Opzioni invio selezionare la casella di controllo Consenti agli utenti di inviare il modulo.

  3. Fare clic su Invia dati modulo a una destinazione sola e quindi selezionare Posta elettronica nell'elenco.

  4. Fare clic su Aggiungi.

    Verrà visualizzata la Connessione guidata dati.

  5. Nella casella A digitare l'alias del decisore che riceverà tutti i moduli inviati.

  6. Per specificare una riga dell'oggetto univoca, nella casella Oggetto:

    • Fare clic su Inserisci formula icona del pulsante .

    • Digitare la formula seguente:

concat(my:employee/my:employeeName, my:employee/my:employeeDepartment)

  • Fare clic su Verifica formula, quindi fare clic su OK due volte.

  • Nella casella Introduzione digitare un messaggio appropriato oppure aggiungere istruzioni importanti per questa soluzione.

  • Fare clic su Avanti.

  • Nella pagina successiva della procedura guidata, fare clic su Invia i dati del modulo come allegato, quindi selezionare la casella di controllo Allega il modello di modulo per garantire che gli utenti possano aprire il modulo.

    Questo garantisce che i dipendenti abbiano accesso al file del modello di modulo (con estensione xsn) nel caso in cui non possano accedervi dal relativo percorso di rete.

  • Per specificare un nome file univoco per ogni file modulo (con estensione xml) nella casella Nome allegato:

    1. Fare clic su Inserisci formula icona del pulsante .

    2. Digitare la stessa formula presente nella riga Oggetto:

concat(my:employee/my:employeeName, my:employee/my:employeeDepartment)

  1. Fare clic su Verifica formula, quindi fare clic su OK due volte.

  • Fare clic su Avanti.

  • Nella casella Immettere un nome per la connessione dati della pagina successiva della procedura guidata digitare un nome descrittivo per questa connessione di invio dati.

  • Verificare la correttezza delle informazioni nella sezione Riepilogo e quindi fare clic su Fine.

  • Salvare il modulo in una cartella di rete pubblica accessibile al decisore e a tutti i dipendenti.

Inizio pagina

Passaggio 2: Mappare il file di schema e personalizzare il layout di tabella in Excel

La configurazione della connessione tra InfoPath ed Excel richiede tre attività: estrazione del file di dati del modulo l'estrazione del file di schema per il modello di modulo Inventario beni comuni, il mapping di questo file di schema in Excel e la personalizzazione del layout predefinito della tabella di Excel che conterrà tutti i file dati del modulo XML importati.

Attività 1: Estrarre il file di schema da InfoPath

  1. In InfoPath, aprire il file del modello di modulo Inventario beni comuni.

  2. Scegliere Progetta modulo dal menu Strumenti.

  3. Scegliere Salva come file di origine dal menu File.

  4. Nella finestra di dialogo Sfoglia per cartella selezionare una cartella in cui archiviare il file di schema oppure crearne una nuova.

Annotare il percorso della cartella di salvataggio dei file di origine e il nome del file di schema, in questo caso myschema.xsd, che contiene la definizione dello schema dei dati XML del modulo.

Attività 2: Mappare il file di schema InfoPath in Excel

  1. Creare un nuovo file di Excel e quindi salvarlo in una posizione accessibile al decisore.

  2. In Excel, se la scheda Sviluppo non è visibile, eseguire le operazioni seguenti:

    1. Fare clic sul pulsante Microsoft Office Icona del pulsante Office e quindi su Opzioni di Excel.

    2. Nella categoria Impostazioni generali in Opzioni principali per l'utilizzo di Excel selezionare la casella di controllo Mostra scheda Sviluppo sulla barra multifunzione, quindi scegliere OK.

      Nota : La barra multifunzione è un componente dell'interfaccia utente Microsoft Office Fluent.

  3. Nel gruppo XML della scheda Sviluppo fare clic su Origine.

    gruppo xml sulla barra multifunzione

    Verrà visualizzato il riquadro attività Origine XML.

  4. Fare clic su Mapping XML e quindi, nella finestra di dialogo Mapping XML, fare clic su Aggiungi.

  5. In un computer che esegue Windows Vista   

    1. Nel barra degli indirizzi, fare clic sull'unità o sulla cartella contenente il file myschema.xsd creato nel passaggio 2 della sezione Attività 1: Estrarre il file di schema da InfoPath

      In un computer che esegue Microsoft Windows XP   

    2. Nell'elenco Cerca in, fare clic sull'unità o sulla cartella contenente il file myschema.xsd creato nel passaggio 2 della sezione Attività 1: Estrarre il file di schema da InfoPath

  6. Selezionare il file, quindi scegliere Apri.

  7. Quando viene visualizzata la finestra di dialogo Più nodi radice, fare clic sul nodo radice assetTracking definito nel file myschema.xsd, quindi fare clic su OK.

    Il mapping XML verrà visualizzato nel riquadro attività Origine XML.

  8. Trascinare l'elemento nodo ns1:asset, cioè un elemento XML ripetuto, sulla posizione del foglio di lavoro in cui si vuole visualizzare la tabella di Excel.

    mapping del file di schema inopath in excel

Attività 3: Personalizzare il layout della tabella di Excel

Per impostazione predefinita, Excel usa i nomi degli elementi XML come intestazioni di colonna per la tabella. Tuttavia, è possibile modificare le intestazioni di colonna modificando le celle di intestazione di colonna.

  1. Per modificare le intestazioni di colonna predefinite, mantenere selezionata la tabella di Excel, trovare il prefisso di stringa ns1:asset e rimuoverlo. Ad esempio, si potrebbe modificare ns1:assetID in ID.

    Personalizzazione delle intestazioni di tabella in Excel

  2. Per regolare la larghezza delle colonne, fare clic sul pulsante Seleziona tutto e quindi fare doppio clic sul bordo di qualsiasi intestazione di colonna.

Inizio pagina

Passaggio 3: Creare un report di riepilogo della tabella pivot e del grafico pivot

I decisori usano una tabella pivot e un grafico pivot per analizzare, esplorare e visualizzare i dati di riepilogo. L'impostazione anticipata dei report di tabella pivot e grafico pivot da usare in questo scenario consente al decisore di eseguire semplicemente il report con i dati completati in un secondo momento.

  1. Selezionare una cella nella tabella di Excel.

  2. Nel gruppo Tabelle della scheda Inserisci fare clic su Tabella pivot, quindi su Tabella pivot.

    immagine della barra multifunzione di excel

    Verrà visualizzata la finestra di dialogo Crea tabella pivot.

  3. Per inserire il rapporto di tabella pivot in un nuovo foglio di lavoro a partire dalla cella A1, fare clic su Nuovo foglio di lavoro, quindi fare clic su OK.

    Un rapporto di tabella pivot vuoto verrà aggiunto automaticamente nella posizione specificata e verrà visualizzato l'Elenco campi della tabella pivot per consentire l'aggiunta di campi, la creazione di un layout e la personalizzazione del report.

  4. Per creare un report tabulare incrociato dei dati, trascinare il campo ID nell'area Valori, il campo Reparto nell'area Etichette di colonna, il campo Categoria nell'area Etichette di riga e il campo AssegnatoA nell'area Filtro rapporto.

  5. Fare clic sul rapporto di tabella pivot.

  6. Nel gruppo Grafici della scheda Inserisci fare clic sul tipo di grafico A barre.

    immagine della barra multifunzione di excel

  7. In Barre 2D selezionare Barre raggruppate.

  8. Regolare le dimensioni e posizione del report di grafico pivot secondo le proprie preferenze.

Rapporti di tabella pivot e grafico pivot vuoti

Inizio pagina

Passaggio 4: Raccogliere informazioni su beni da parte degli utenti

A questo punto, il modello di modulo è pronto per essere compilato da tutti i dipendenti ed è quindi necessario pubblicarlo e inviarlo a ciascun dipendente. Quando ogni dipendente invia il modulo compilato, questo verrà allegato come file di dati XML (con estensione xml) a un messaggio di posta elettronica inviato all'account di posta elettronica del decisore. Il decisore potrà quindi spostare tutti i messaggi in una cartella di InfoPath dedicata in Outlook. In questo scenario, si consiglia di assegnare un periodo di tempo specifico a tutti gli utenti per completare i moduli, in modo che il decisore possa eseguire il report con tutti i moduli completati quando viene raggiunta la scadenza di raccolta dei dati.

l'immissione di dati nei moduli di registro delle risorse

  1. In InfoPath, aprire il modello di modulo (XSN) salvato al Passaggio 1: Progettare il modello di modulo Inventario beni comuni di esempio

  2. Scegliere Progetta modulo dal menu Strumenti.

  3. Scegliere Pubblica dal menu File.

  4. Nella Pubblicazione guidata fare clic su In un elenco di destinatari di posta elettronica e quindi fare clic su Avanti.

  5. Nella pagina successiva della procedura guidata digitare un nome per il modello di modulo nella casella Nome modello di modulo e quindi fare clic su Avanti. Il nome del modello di modulo verrà visualizzato nell'oggetto del messaggio inviato ai destinatari di posta elettronica.

  6. Facoltativamente, nella pagina successiva della procedura guidata, è possibile creare colonne che verranno visualizzate nelle cartelle di Outlook per organizzare i messaggi di posta elettronica.

  7. Fare clic su Avanti.

  8. Fare clic su Pubblica.

  9. Al termine della pubblicazione del modello di modulo verrà aperto un messaggio di posta elettronica con il modulo.

  10. Compilare il messaggio, digitare i nomi dei dipendenti oppure usare una lista di distribuzione, quindi inviare il messaggio.

In Outlook, il decisore può organizzare tutti i moduli XML inviati in uno di due modi:

  • Se viene visualizzata la finestra di messaggio Cartelle moduli di InfoPath la prima volta che si apre il messaggio, fare clic su Crea cartella moduli.

  • Creare una regola di Outlook per spostare tutti i moduli di InfoPath correlati in una cartella di InfoPath.

    Per ulteriori informazioni, vedere gestione dei messaggi mediante le regole.

Inizio pagina

Passaggio 5: Importare i moduli in Excel

Poiché sono già stati creati i passaggi 2 e 3 della cartella di lavoro di Excel, il decisore dovrà solo esportare e analizzare i dati del modulo. Il decisore deve semplicemente esportare i file con estensione xml (XML) da Outlook, importare tutti i file di modulo (XML) nella cartella di lavoro di Excel e quindi aggiornare i dati.

Attività 1: Esportare i moduli da Outlook in una cartella di Windows

  1. In Outlook, selezionare la cartella che contiene tutti i moduli ricevuti dai dipendenti e quindi premere CTRL + A per selezionare tutti i messaggi di posta elettronica del modulo.

  2. Fare clic con il pulsante destro del mouse sulla selezione, scegliere Azioni InfoPath, quindi fare clic su Esporta moduli.

  3. Nella finestra di dialogo Esporta moduli selezionare una cartella e premere OK.

Attività 2: Importare i moduli in Excel

  1. Nella cartella di lavoro di Excel creata al Passaggio 2: Mappare il file di schema e personalizzare il layout di tabella in Excel, selezionare una delle celle mappate nella tabella di Excel.

  2. Nel gruppo XML della scheda Sviluppo fare clic su Importa.

    gruppo xml sulla barra multifunzione

    Verrà visualizzata la finestra di dialogo Importa XML.

  3. In un computer che esegue Windows Vista   

  4. Eseguire una delle seguenti operazioni:

    • Se i file sono contigui, premere MAIUSC e fare clic sul primo e sull'ultimo file nell'elenco.

    • Se i file non sono contigui, premere CTRL e fare clic su tutti i file che si desidera importare nell'elenco.

  5. Fare clic su Importa.

    Tabella di Excel dei dati importati

Per impostazione predefinita, Excel sovrascrive eventuali dati esistenti nelle celle mappate, ovvero il risultato finale desiderato per questa soluzione aziendale. Tuttavia, un decisore potrebbe, ad esempio, importare i dati più volte per valutare l'avanzamento prima della scadenza programmata.

Nota : In Excel, è anche possibile aggiungere i dati usando l'opzione Aggiungi i nuovi dati alle tabelle XML esistenti (nel gruppo XML della scheda Sviluppo fare clic su Proprietà mapping), che può essere appropriata per altre soluzioni.

Per ulteriori informazioni, vedere gli argomenti della Guida di Excel, dati XML di importazione e Accodamento o sovrascrivere i dati XML mappati.

Attività 3: Aggiornare i report di tabella e di grafico pivot

  • Fare clic sul report di tabella pivot.

  • Nel gruppo Dati della scheda Opzioni fare clic sulla freccia accanto ad Aggiorna tutti, quindi scegliere Aggiorna.

    Gruppo Dimensioni sulla barra multifunzione di Excel

rapporto di tabella pivot e grafico pivot

La cartella di lavoro di Excel ora contiene tutti i dati e report di riepilogo necessari per allocare il budget delle attrezzature per l'anno successivo. Naturalmente, è possibile eseguire ulteriori analisi nella cartella di lavoro di Excel, se necessario, ad esempio ordinamento, filtro o formattazione condizionale dei dati.

Inizio pagina

Considerazioni finali: Valutare l'uso di un elenco di SharePoint o un database di Access

In alternativa, valutare l'uso di un elenco SharePoint o un database di Access, anziché XML, per trasferire i dati tra InfoPath ed Excel.

Usare un elenco SharePoint

Da InfoPath, è possibile usare facilmente un elenco SharePoint come origine dati di sola lettura. È possibile eseguire una delle operazioni seguenti:

  • Dall'elenco SharePoint, esportare i dati in Excel, in cui viene automaticamente creata una connessione dati in Excel.

  • Da Excel, creare in modo esplicito una connessione dati all'elenco SharePoint.

Dopo aver creato una connessione dati, è possibile aggiornare i dati in Excel per recuperare i dati più aggiornati.

È possibile usare un elenco SharePoint per aggiungere e aggiornare i dati, usare un modulo di InfoPath per visualizzare un elemento nell'elenco (ad esempio, un elemento lungo o complesso meglio visualizzato in verticale) e quindi usare Excel per analizzare ulteriormente i dati.

Combinazione di InfoPath, elenco di SharePoint ed Excel

1. Visualizzare un singolo elemento da revisionare semplicemente in InfoPath.

2. Aggiungere e aggiornare i dati in un elenco SharePoint.

3. Aggiornare un report con Excel.

Per altre informazioni, vedere Aggiungere una connessione dati a una raccolta documenti o a un elenco SharePoint e Importare dati da un elenco SharePoint.

Usare un database di Access

Da InfoPath, è possibile creare una connessione di lettura/scrittura a un database di Access. Da Excel, è possibile creare in modo esplicito una connessione dati al database di Access che può essere aggiornata per recuperare i dati più aggiornati. È anche possibile definire l'aggiornamento automatico della connessione all'apertura della cartella di lavoro oppure l'aggiornamento periodico, ad esempio ogni 5 minuti.

È possibile usare un database di Access come intermediario tra InfoPath ed Excel. Quando si invia un modulo di InfoPath ad Access, si aggiorna il database di Access. Quando si aggiorna la connessione dati in Excel, si recuperano i dati aggiornati provenienti da Access. In effetti, si effettua l'invio di dati indirettamente da InfoPath a una cartella di lavoro di Excel.

combinazione di infopath, accedere e di excel

1. Visualizzare e inviare un modulo a un database di Access.

2. Archiviare dati in un database di Access

3. Aggiornare un report con Excel.

Per altre informazioni, vedere Progettare un modello di modulo basato su un database di Microsoft Access.

Suggerimento : Non tutti sanno che è possibile creare un modulo di InfoPath direttamente da Access 2007. Se gli utenti hanno installato nel computer Outlook 2007 e InfoPath 2007, è possibile raccogliere dati da diversi utenti direttamente da Access 2007 usando la procedura guidata Raccolta dati tramite messaggi di posta elettronica. Per altre informazioni, vedere l'argomento della Guida di Access 2007, Raccogliere dati tramite messaggi di posta elettronica.

Inizio pagina

Nota : Dichiarazione di non responsabilità per la traduzione automatica: Il presente articolo è stato tradotto tramite un software di traduzione automatica e non da una persona. Microsoft offre le traduzioni automatiche per consentire a coloro che non conoscono la lingua inglese di leggere gli articoli sui prodotti, sui servizi e sulle tecnologie Microsoft. Dal momento che l'articolo è stato tradotto automaticamente, potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli.

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×