Creare una query di selezione semplice

Per selezionare dati specifici provenienti da una o più origini, è possibile usare una query di selezione. La query di selezione consente di recuperare solo i dati necessari, oltre che di combinare i dati di diverse origini. Per una query di selezione, è possibile usare tabelle e altre query di selezione. Questo argomento fornisce una panoramica delle query di selezione, nonché la procedura per crearle usando la Creazione guidata Query o visualizzazione Struttura.

Se si vuole usare il database di esempio Northwind per altre informazioni sul funzionamento delle query, vedere l'articolo Introduzione alle query.

In questo articolo

Panoramica

Usare la Creazione guidata Query per creare una query di selezione

Creare una query in visualizzazione Struttura

Creare una query di selezione in un'app Web di Access

Panoramica

Quando si vogliono consultare dati, non è detto che siano necessari tutti i dati di un'unica tabella. Se ad esempio si sceglie di usare i dati di una tabella Contatti, in genere si vuole esaminare un record specifico o anche solo il numero di telefono. A volte si vogliono combinare i dati di più tabelle, ad esempio le informazioni sui clienti e quelle sugli ordini. Per selezionare i dati da usare, si usa una query di selezione.

Una query di selezione è un oggetto di database che visualizza informazioni in visualizzazione Foglio dati. La query non archivia i dati, ma visualizza quelli archiviati nelle tabelle. Una query può mostrare dati di una o più tabelle, di altre query o di una combinazione di entrambe.

Vantaggi dell'uso di una query

Una query consente di:

  • Visualizzare solo i dati dei campi a cui si è interessati. Quando si apre una tabella, vengono visualizzati tutti i campi. Una query offre un metodo pratico per salvare una selezione di campi.

    Nota : Una query si limita a puntare ai dati, ma non li archivia. Quando si salva una query, non si salva una copia dei dati.

  • Combinare i dati di più origini dati. Una tabella in genere visualizza solo i dati archiviati al suo interno. Una query consente di selezionare e scegliere i campi di varie origini, quindi di specificare come combinare le informazioni.

  • Usare espressioni come campi. Si potrebbe ad esempio usare la funzione Date come campo oppure la funzione Format con un campo per controllare il modo in cui viene formattata la data del campo nei risultati della query.

  • Visualizzare record che soddisfano i criteri specificati. Quando si apre una tabella, vengono visualizzati tutti i record. Una query offre un metodo pratico per salvare una selezione di record.

Procedura di base per creare una query di selezione

Si può creare una query di selezione usando la Creazione guidata Query oppure in visualizzazione Struttura. Alcuni elementi di progettazione non sono disponibili quando si usa la procedura guidata, ma è possibile aggiungerli in seguito con la visualizzazione Struttura. Anche se i due metodi sono piuttosto diversi tra loro, la procedura di base è essenzialmente la stessa:

  1. Scegliere le tabelle o le query da usare come origini dei dati.

  2. Specificare i campi delle origini dati da includere.

  3. Facoltativamente, specificare i criteri per limitare i record restituiti dalla query.

Dopo aver creato una query di selezione, eseguirla per vedere i risultati. Per eseguire una query di selezione, aprirla in visualizzazione Foglio dati. Se si salva una query, è possibile riutilizzarla ogni volta che è necessario, ad esempio come origine dati per una maschera, un report o un'altra query.

Usare la Creazione guidata Query per creare una query di selezione

Per creare una query di selezione, è possibile usare la Creazione guidata Query. Quando si usa la procedura guidata, si ha meno controllo sui dettagli della progettazione, ma la query viene in genere creata più velocemente. Inoltre, la procedura guidata può rilevare alcuni semplici errori di progettazione e chiedere di eseguire un'azione diversa.

Prima di iniziare

Se si usano i campi di origini dati non correlate tra loro, la Creazione guidata Query chiede di specificare se si vogliono creare relazioni. La procedura guidata apre automaticamente la finestra Relazioni, ma è necessario riavviarla se è necessario modificarne alcune. Pertanto, prima di eseguire la procedura guidata, è consigliabile creare le eventuali relazioni necessarie per la query.

Per altre informazioni sulla creazione di relazioni tra tabelle, vedere l'articolo Guida alle relazioni tra tabelle.

Usare la Creazione guidata Query

  1. Nel gruppo Query della scheda Crea fare clic su Creazione guidata Query. Se si usa Access 2007, fare clic su Crea > Altro > Creazione guidata Query.

    Il gruppo Query della barra multifunzione di Access visualizza due opzioni: Creazione guidata Query e Struttura query
  2. Nella finestra di dialogo Nuova query fare clic su Creazione guidata Query semplice, quindi fare clic su OK.

  3. Quindi, aggiungere i campi. È possibile aggiungere fino a 255 campi di un totale di 32 tabelle o query.

    Per ogni campo, eseguire questi due passaggi:

    1. In Tabelle/query fare clic sulla tabella o sulla query che contiene il campo.

    2. In Campi disponibili fare doppio clic sul campo per aggiungerlo all'elenco Campi selezionati. Se si vogliono aggiungere tutti i campi alla query, fare clic sul pulsante con le doppie frecce a destra (>>).

    3. Dopo aver aggiunto tutti i campi, fare clic su Avanti.

      Nella finestra di dialogo Creazione guidata Query semplice selezionare i campi da usare.
  4. Se non sono stati aggiunti campi contenenti dati numerici, procedere con il passaggio 9. Se invece sono stati aggiunti campi numerici, la procedura guidata chiede di specificare se si vuole che la query restituisca dettagli o dati di riepilogo.

    Eseguire una delle operazioni seguenti:

    1. Se si vogliono visualizzare singoli record, selezionare Dettagli e quindi Avanti. Procedere con il passaggio 9.

    2. Se si vogliono visualizzare dati numerici di riepilogo, come le medie, selezionare Riepilogo e quindi Opzioni di riepilogo.

      Nella finestra di dialogo Creazione guidata Query semplice selezionare Dettagli o Riepilogo
  5. Nella finestra di dialogo Opzioni di riepilogo specificare i campi di cui ottenere un riepilogo e il modo in cui riepilogare i dati. Sono elencati solo campi numerici.

    Per ogni campo numerico, scegliere una delle funzioni seguenti:

    1. Sum    La query restituisce la somma di tutti i valori del campo.

    2. Avg    La query restituisce la media dei valori del campo.

    3. Min    La query restituisce il valore minimo del campo.

    4. Max    La query restituisce il valore massimo del campo.

    Nella finestra di dialogo Opzioni di riepilogo selezionare come calcolare i valori di riepilogo
  6. Se vuoi che i risultati della query includano un conteggio dei record in un'origine dati, selezionare la casella di controllo Conta record in nome origine dati.

  7. Fare clic su OK per chiudere la finestra di dialogo Opzioni di riepilogo.

  8. Se alla query non è stato aggiunto un campo di data/ora, procedere con il passaggio 9. Se è stato aggiunto un campo di data/ora, la Creazione guidata query chiede di specificare come raggruppare i valori di data. Si supponga ad esempio di aver aggiunto alla query un campo numerico ("Price") e un campo di data/ora ("Transaction_Time") e di aver quindi specificato nella finestra di dialogo Opzioni di riepilogo di voler visualizzare il valore medio del campo "Price". Poiché è stato incluso un campo di data/ora, è possibile calcolare i valori di riepilogo per ogni valore di data/ora univoco, per ogni giorno, mese, trimestre o anno.

    Nella finestra di dialogo Creazione guidata Query semplice selezionare come raggruppare le date nella query

    Selezionare il periodo di tempo da usare per raggruppare i valori di data e ora e quindi fare clic su Avanti.

    Nota : In visualizzazione Struttura è possibile usare un'espressione per raggruppare in base a qualsiasi periodo di tempo, ma la procedura guidata offre solo queste opzioni.

  9. Nell'ultima pagina della procedura guidata assegnare un titolo alla query, specificare se la si vuole aprire o modificare e quindi fare clic su Fine.

    Se si sceglie di aprire la query, i dati selezionati vengono aperti in visualizzazione Foglio dati. Se si sceglie i modificarla, la query viene aperta in visualizzazione Struttura.

Inizio pagina

Creare una query in visualizzazione Struttura

È possibile usare la visualizzazione Struttura per creare manualmente una query di selezione. Con la visualizzazione Struttura, si ha un maggior controllo sui dettagli della query, ma è più facile commettere errori di progettazione e può essere richiesto più tempo rispetto all'uso della procedura guidata.

Creare una query

Passaggio 1: Aggiungere le origini dati

Passaggio 2: Creare un join tra le origini dati correlate

Passaggio 3: Aggiungere i campi di output

Passaggio 4: Specificare i criteri

Passaggio 5: Riepilogare i dati

Passaggio 6: Visualizzare i risultati

Passaggio 1: Aggiungere le origini dati

In visualizzazione Struttura, poiché per aggiungere le origini dati si usa la finestra di dialogo Mostra tabella, le origini dati e i campi vengono aggiunti in passaggi distinti. È tuttavia sempre possibile aggiungere altre origini dati in seguito, se necessario.

  1. Nel gruppo Altro della scheda Crea fare clic su Struttura query. Se si usa Access 2007, fare clic su Crea > Altro > Struttura query.

    Il gruppo Query della barra multifunzione di Access visualizza due opzioni: Creazione guidata Query e Struttura query
  2. Nella scheda Tabelle, Query o Entrambe della finestra di dialogo Mostra tabella fare doppio clic su ogni origine dati da usare oppure selezionarla e quindi fare clic su Aggiungi.

    Finestra di dialogo Mostra tabella in Access, in cui sono visualizzati i nomi di tabella
  3. Chiudere la finestra di dialogo Mostra tabella.

Join automatici

Se tra le origini dati che si aggiungono sono state definite relazioni, vengono automaticamente aggiunte alla query come join. I join specificano come devono essere combinati i dati di origini correlate. Access crea inoltre automaticamente un join tra due tabelle se i campi hanno tipi di dati compatibili e un campo è una chiave primaria.

Si può scegliere di modificare i join creati da Access. Access determina il tipo di join da creare in base alla relazione che rappresenta. Se Access crea un join ma non sono state definite relazioni, viene creato un inner join.

Se Access crea automaticamente i join corretti quando si aggiungono le origini dati, è possibile procedere con il Passaggio 3: Aggiungere i campi di output.

Usare più volte la stessa origine dati

In alcuni casi, si vogliono unire due copie della stessa tabella o query, in un cosiddetto self-join, che combina i record della stessa tabella quando i campi uniti contengono valori corrispondenti. Si supponga ad esempio di avere una tabella Employees in cui il campo ReportsTo per il record di ogni dipendente visualizza l'ID del manager invece del nome. Si potrebbe usare un self-join per visualizzare invece il nome del manager nel record di ogni dipendente.

Quando si aggiunge un'origine dati una seconda volta, Access aggiunge _1 al nome della seconda istanza. Se ad esempio si aggiunge due volte la tabella Employees, la seconda istanza si chiamerà Employees_1.

Passaggio 2: Creare un join tra le origini dati correlate

Se le origini dati che si aggiungono a una query hanno già relazioni, Access crea automaticamente un inner join per ogni relazione. Se viene applicata l'integrità referenziale, Access visualizza inoltre il numero "1" sulla linea di join per indicare la tabella che si trova sul lato "uno" di una relazione uno-a-molti e il simbolo di infinito () per indicare la tabella che si trova sul lato "molti".

Se si aggiungono query alla query e non sono state create relazioni, Access non crea automaticamente join tra tali query né tra query e tabelle non correlate. Se Access non crea join quando si aggiungono origini dati, è in genere necessario aggiungerli manualmente. Le origini dati non unite tramite join ad altre origini dati possono generare problemi con i risultati delle query.

Si può anche scegliere di cambiare il tipo di join da inner join a outer join, in modo che la query includa più record.

Aggiungere un join

  • Per aggiungere un join, trascinare un campo da un'origine dati a un campo corrispondente in un'altra origine dati.

    Access visualizza una linea tra i due campi per indicare che è stato creato un join.

    Linea di join in visualizzazione Struttura query
    Linea di join (cerchiata in rosso).

Cambiare un join

  1. Fare doppio clic sul join da cambiare.

    Verrà visualizzata la finestra di dialogo Proprietà join.

    Finestra di dialogo Proprietà join
    Finestra di dialogo Proprietà join I nomi delle tabelle nella finestra di dialogo cambiano in base alle tabelle effettive coinvolte.
  2. Nella finestra di dialogo Proprietà join esaminare le tre opzioni.

  3. Fare clic sull'opzione da usare e quindi su OK.

Quando i join sono pronti, aggiungere i campi di output, ossia quelli che includono i dati da inserire nei risultati della query.

Passaggio 3: Aggiungere i campi di output

È possibile aggiungere facilmente un campo da una delle origini dati aggiunte nel passaggio 1.

  • Per aggiungere un campo, trascinarlo dall'origine dati nel riquadro superiore della finestra di progettazione query alla riga Campo della griglia di struttura, nel riquadro inferiore della finestra di progettazione query.

    Quando si aggiunge un campo in questo modo, Access compila automaticamente la riga Tabella della griglia di struttura in base all'origine dati del campo.

    Suggerimento : Se si vogliono aggiungere rapidamente tutti i campi fino alla riga Campo della griglia di struttura query, fare doppio clic sul nome della tabella o della query nel riquadro superiore per evidenziare tutti i campi in tale origine e quindi trascinarli nella griglia di struttura contemporaneamente.

Usare un'espressione come campo di output

Per eseguire calcoli o usare una funzione per produrre l'output della query, includere un'espressione come campo di output. L'espressione può usare dati da una qualsiasi delle origini dati della query, oltre a funzioni come Format o InStr, e può anche contenere costanti e operatori aritmetici.

  1. In una colonna vuota della griglia di struttura query fare clic con il pulsante destro del mouse sulla riga Campo, quindi scegliere Zoom dal menu di scelta rapida.

  2. Nella casella Zoom digitare o incollare l'espressione. Anteporre all'espressione il nome da usare per l'output, seguito da due punti. Ad esempio, per specificare l'espressione da etichettare come "Ultimo aggiornamento", iniziare l'espressione con Ultimo aggiornamento:.

    Nota : Con le espressioni è possibile eseguire un'ampia varietà di operazioni. Una spiegazione dettagliata delle espressioni esula dall'ambito di questo articolo. Per altre informazioni sulla creazione di un'espressione, vedere l'articolo Generare un'espressione.

Passaggio 4: Specificare i criteri

Questo passaggio è facoltativo.

Usare i criteri per limitare i record restituiti dalla query, a seconda che i valori dei campi soddisfino o meno i criteri specificati.

Specificare i criteri per un campo di output

  1. Nella griglia di struttura query, nella riga Criteri del campo che contiene i valori da limitare, digitare un'espressione che i valori del campo devono soddisfare per essere inclusi nei risultati. Se ad esempio si vuole limitare una query in modo che vengano inclusi solo i record in cui il valore del campo Città è Las Vegas, digitare Las Vegas nella riga Criteri sotto tale campo.

    Per vedere altri esempi di criteri di query per vari tipi di dati, vedere l'articolo Esempi di criteri di query.

  2. Specificare criteri alternativi nella riga Or, sotto la riga Criteri.

    Se si specificano criteri alternativi, un valore di campo può soddisfare qualsiasi criterio elencato per essere incluso nei risultati della query.

Criteri per più campi

È possibile usare i criteri con più campi. In questo caso, affinché venga incluso il record, è necessario che vengano soddisfatti tutti i criteri nella riga Criteri o Or.

Specificare i criteri usando un campo da non includere nell'output

È possibile aggiungere un campo nella struttura della query e non includere i relativi dati nell'output. Questa operazione si esegue se si vogliono usare i valori del campo per limitare i risultati della query ma non si vogliono vedere tali valori.

  1. Aggiungere il campo alla griglia di struttura.

  2. Deselezionare la casella di controllo nella riga Mostra del campo.

  3. Specificare i criteri come si farebbe per un campo di output.

Passaggio 5: Riepilogare i dati

Questo passaggio è facoltativo.

Si può scegliere di riepilogare i dati, in particolare se si tratta di dati numerici, ad esempio per vedere il prezzo medio o il totale delle vendite.

Per riepilogare i dati in una query, usare la riga Totale. Per impostazione predefinita, la riga Totale non è visibile in visualizzazione Struttura.

  1. Con la query aperta in visualizzazione Struttura, nel gruppo Mostra/Nascondi della scheda Progettazione fare clic su Totali.

    Access visualizza la riga Totale nella griglia di struttura query.

  2. Per ogni campo da riepilogare, scegliere la funzione da usare nella riga Totale. Le funzioni disponibili dipendono dal tipo di dati del campo.

    Per altre informazioni sulla funzionalità della riga Totale nelle query, vedere l'articolo Sommare o conteggiare valori in un foglio dati con una riga totali.

Passaggio 6: Visualizzare i risultati

Per visualizzare i risultati della query, fare clic su Esegui nella scheda Progettazione. Access apre i risultati della query in visualizzazione Foglio dati.

Per apportare altre modifiche alla query, fare clic su Home > Visualizza > Visualizzazione Struttura per tornare alla visualizzazione Struttura.

Cambiare i campi, le espressioni o i criteri e rieseguire la query finché non restituisce i dati desiderati.

Inizio pagina

Creare una query di selezione in un'app Web di Access

La procedura per creare una query di selezione in un'app Web di Access è simile a quella descritta in precedenza per i database desktop, con la differenza che è necessario eseguire qualche passaggio aggiuntivo per rendere i risultati disponibili nel browser.

Importante   : contrariamente al passato, Microsoft non consiglia di creare e usare le app Web Access in SharePoint. In alternativa, usare Microsoft PowerApps per creare soluzioni aziendali senza codice per il Web e i dispositivi mobili.

  1. Aprire l'app Web in Access.

  2. Fare clic su Home > Avanzate > Query.

  3. Nella scheda Tabelle, Query o Entrambe della finestra di dialogo Mostra tabella fare doppio clic su ogni origine dati da usare oppure selezionarla e quindi fare clic su Aggiungi. Al termine, fare clic su Chiudi.

  4. Trascinare i campi dall'origine dati nel riquadro superiore della finestra di progettazione query alla riga Campo della griglia di struttura, nel riquadro inferiore della finestra di progettazione query.

    Struttura query con tabella query evidenziata

  5. Aggiungere i criteri da applicare ai campi.

  6. Fare clic con il pulsante destro del mouse sulla scheda della query e scegliere Salva, quindi assegnare un nome alla query.

  7. Per visualizzare i risultati della query, fare clic con il pulsante destro del mouse sulla scheda della query e scegliere Visualizzazione Foglio dati.

Per rendere i risultati della query disponibili nella visualizzazione del browser, è necessario aggiungere una visualizzazione basata sulla query in Selezione tabella. Per aggiungere una nuova visualizzazione a una didascalia di tabella in Selezione tabella, completare i passaggi seguenti:

  1. Fare clic sul nome della didascalia della tabella in Selezione tabella nel riquadro sinistro, quindi fare clic sul pulsante Aggiungi nuova visualizzazione (il segno più).

    Aggiungere la Visualizzazione elenco dal client Access

  2. Nella finestra di dialogo Aggiungi nuova visualizzazione immettere un nome per la visualizzazione nella casella Nome visualizzazione, selezionare un'opzione per Tipo di visualizzazione e quindi selezionare il nome della query nella casella Origine record.

    Aggiunta di una visualizzazione Foglio dati della query alla tabella sorgente.

    Suggerimento :  Se si utilizzano tabelle multiple in una query, è possibile aggiungere la visualizzazione a ciascuna delle tabelle, o a tutte le tabelle.

  3. Fare clic su Home > Avvia app per aprire la visualizzazione nel browser.

  4. Fare clic sul nome della tabella e quindi sul nome della visualizzazione per aggiungere, modificare o eliminare i dati in questa visualizzazione se la query supporta gli aggiornamenti.

Inizio pagina

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×