Creare una casella di riepilogo a cascata

Le caselle di riepilogo a cascata consentono di compilare più velocemente i moduli e di assicurarsi che gli utenti immettano correttamente i dati. Questo articolo descrive come creare caselle di riepilogo a cascata e inserirvi dati. In Microsoft Office InfoPath è possibile popolare un elenco con dati che usano i valori del modulo, i valori di un documento XML (Extensible Markup Language) esterno o i valori di un database di Microsoft Office Access.

In questo articolo

Cos'è una casella di riepilogo a cascata?

Passaggio 1: Inserire una casella di riepilogo a cascata

Passaggio 2: Fornire i dati

Cos'è una casella di riepilogo a cascata?

Una casella di riepilogo a cascata è una casella di riepilogo le cui opzioni cambiano in base al valore che un utente seleziona in un'altra casella di riepilogo. Se ad esempio un utente fa clic su Condimenti nella casella Categorie della figura seguente, nella casella Prodotti verrà visualizzato un elenco di condimenti.

Esempio di casella di riepilogo a cascata

Le sezioni seguenti illustrano come progettare un modello di modulo con due caselle di controllo, in cui la seconda viene filtrata in base al valore che un utente seleziona nella prima. Quando il valore della prima casella di riepilogo cambia, alla seconda viene automaticamente applicato il filtro, cambiandone i valori.

Considerazioni sulla compatibilità

I filtri possono essere usati solo nei modelli di modulo progettati per essere compilati in InfoPath. Non sono invece disponibili nei modelli di modulo compatibili con browser.

Inizio pagina

Passaggio 1: Inserire una casella di riepilogo a cascata

Per creare una casella di riepilogo a cascata, è necessario inserire due caselle di riepilogo nel modello di modulo.

Nota : Assicurarsi che le due caselle di riepilogo inserite non si trovino in una sezione ripetuta o in una tabella ripetuta.

  1. Se il riquadro attività Controlli non è visibile, fare clic su Altri controlli nel menu Inserisci oppure premere ALT+I, C.

  2. In Inserisci controlli nel riquadro attività Controlli fare clic su Casella di riepilogo a discesa. Quando un utente compila un modulo basato sul modello di modulo, la selezione in questa casella di riepilogo a discesa determinerà le opzioni disponibili nell'altra.

  3. Fare clic su Casella di riepilogo. Il modello di modulo dovrebbe ora contenere una casella di riepilogo a discesa e una standard.

    Casella di riepilogo a discesa e casella di riepilogo in un modulo

  4. Fare doppio clic sulla casella di riepilogo a discesa inserita nel modello di modulo nel passaggio 2.

  5. Nella finestra di dialogo Casella di riepilogo a discesa - Proprietà fare clic sulla scheda Dati.

  6. Nella casella Nome campo digitare listBox1 e quindi fare clic su OK.

  7. Fare doppio clic sulla casella di riepilogo inserita nel modello di modulo nel passaggio 3.

  8. Nella finestra di dialogo Casella di riepilogo - Proprietà fare clic sulla scheda Dati.

  9. Nella casella Nome campo digitare listBox2Cascade e quindi fare clic su OK.

Inizio pagina

Passaggio 2: Fornire i dati

Dopo aver inserito le caselle di riepilogo nel modello di modulo, è necessario fornire i dati che verranno visualizzati. È quindi necessario applicare un filtro in modo che le opzioni della seconda casella di riepilogo siano basate sulla selezione dell'utente nella prima.

Questa sezione illustra come connettere le caselle di riepilogo ai dati usando tre metodi comuni, ossia aggiungendo i dati dal modulo stesso, connettendo il modulo a un documento XML esistente che contiene i dati o connettendo il modulo a un database che contiene i dati. Per completare la creazione della casella di riepilogo a cascata, fare clic sul metodo da usare nell'elenco seguente.

Aggiungere i dati dal modulo

Connettere il modulo a un documento XML esterno

Connettere il modulo a un database

Aggiungere i dati dal modulo

In questa sezione verrà illustrato come popolare le caselle di riepilogo con i dati del modulo. A questo scopo, è necessario prima configurare i campi nel modello di modulo in modo che sia possibile immettere i nomi delle categorie e una serie di prodotti per ognuna.

Configurare i campi nel modello di modulo

  1. Se il riquadro attività Origine dati non è visibile, scegliere Origine dati dal menu Visualizza.

  2. Nel riquadro attività Origine dati fare clic con il pulsante destro del mouse sul gruppo campiPersonali e quindi scegliere Aggiungi.

  3. Nella casella Nome della finestra di dialogo Aggiungi campo o gruppo digitare CategoriesAndProducts.

  4. Nell'elenco Tipo fare clic su Gruppo.

  5. Selezionare la casella di controllo Ripetuto e quindi fare clic su OK.

  6. Nel riquadro attività Origine dati fare clic con il pulsante destro del mouse sul gruppo CategoriesAndProducts.

  7. Nella casella Nome della finestra di dialogo Aggiungi campo o gruppo digitare Categoria e quindi fare clic su OK. Questo campo conterrà i nomi delle categorie della prima casella di riepilogo.

  8. Fare clic con il pulsante destro del mouse sul gruppo CategoriesAndProducts e quindi scegliere Aggiungi.

  9. Nella casella Nome della finestra di dialogo Aggiungi campo o gruppo digitare Prodotto.

  10. Selezionare la casella di controllo Ripetuto e quindi fare clic su OK. Questo campo conterrà i nomi delle categorie della seconda casella di riepilogo.

Poiché questa casella di riepilogo viene popolata con i dati del modulo, è necessario aggiungere i dati al modulo. A questo scopo, è necessario creare valori predefiniti per i campi Prodotto e Categoria.

Suggerimento

È anche possibile creare caselle di riepilogo che visualizzano i valori digitati dagli utenti stessi nel modulo. A questo scopo, associare la casella di riepilogo ai campi associati ai controlli del modulo. Quando un utente immette valori nei controlli, le opzioni della casella di riepilogo cambiano.

Creare valori predefiniti

  1. Scegliere Valori predefiniti dal menu Strumenti.

  2. Nel gruppo CategoriesAndProducts della finestra di dialogo Modifica valori predefiniti selezionare il campo Categoria (non deselezionare la casella di controllo) e quindi nella casella Valore predefinito digitare Seafood.

  3. Selezionare il campo Prodotto (non deselezionare la casella di controllo) e quindi nella casella Valore predefinito digitare Crab meat.

  4. Fare clic con il pulsante destro del mouse sul campo Prodotto e quindi scegliere Aggiungi un altro Prodotto sopra. In questo modo è possibile aggiungere un secondo prodotto per Seafood come valore predefinito.

  5. Fare clic con il pulsante destro del mouse sulla seconda istanza del campo Prodotto (non deselezionare la casella di controllo) e quindi nella casella Valore predefinito digitare Salmon.

  6. Fare clic con il pulsante destro del mouse sul gruppo CategoriesAndProducts e quindi scegliere Aggiungi un altro CategoriesAndProducts sotto. In questo modo è possibile aggiungere una seconda categoria come valore predefinito.

  7. Eseguire la procedura precedente per specificare i valori predefiniti per la seconda istanza dei campi Categoria e Prodotto impostandoli rispettivamente su Dairy, Cheddar e Chocolate milk.

  8. Fare clic su OK.

Dopo aver immesso i valori predefiniti per i campi Prodotto e Categoria, è possibile connettere la prima casella di riepilogo ai dati appena immessi.

Connettere la prima casella di riepilogo ai dati

  1. Nel modello di modulo fare doppio clic sulla casella di riepilogo a discesa inserita in precedenza.

  2. Fare clic sulla scheda Dati.

  3. Nella finestra di dialogo Casella di riepilogo a discesa - Proprietà, in Voci casella di riepilogo, fare clic su Cerca valori nell'origine dati del modulo.

  4. Fare clic su Seleziona XPath Pulsante Origine dati accanto alla casella Voci.

  5. Nel gruppo CategoriesAndProducts della finestra di dialogo Seleziona campo o gruppo fare clic sul campo Categoria e quindi due volte su OK.

Ora è necessario connettere la seconda casella di riepilogo ai dati. Quando si crea questa connessione dati, applicare un filtro alla seconda casella di riepilogo. Questo filtro popolerà la seconda casella di riepilogo con i prodotti appropriati in base alla categoria selezionata nella prima. Il filtro confronta il valore selezionato nella prima casella di riepilogo (campo listBox1) con l'elenco di categorie salvato nel modulo (campo Categoria).

Connettere la seconda casella di riepilogo ai dati

  1. Nel modello di modulo fare doppio clic sulla casella di riepilogo standard inserita in precedenza.

  2. Fare clic sulla scheda Dati.

  3. Nella finestra di dialogo Casella di riepilogo - Proprietà, in Voci casella di riepilogo, fare clic su Cerca valori nell'origine dati del modulo.

  4. Fare clic su Seleziona XPath Pulsante Origine dati accanto alla casella Voci.

  5. Nel gruppo CategoriesAndProducts della finestra di dialogo Seleziona campo o gruppo fare clic sul campo Prodotto e quindi su Filtra dati.

  6. Nella finestra di dialogo Filtra dati fare clic su Aggiungi.

  7. Nella finestra di dialogo Specifica condizioni filtro fare clic su Seleziona campo o gruppo nella prima casella.

  8. Nella finestra di dialogo Seleziona campo o gruppo fare clic su listBox1 e quindi su OK.

  9. Nella finestra di dialogo Specifica condizioni filtro fare clic su Seleziona campo o gruppo nella terza casella.

  10. Nella finestra di dialogo Seleziona campo o gruppo fare clic sul campo Categoria e quindi su OK per chiudere tutte le finestre di dialogo aperte.

Una volta connessa la seconda casella di riepilogo ai dati e applicato il filtro, è possibile testare le caselle di riepilogo per verificare che funzionino correttamente.

Testare le caselle di riepilogo

  1. Per verificare le modifiche, fare clic su Anteprima nella barra degli strumenti Standard oppure premere CTRL+MAIUSC+B.

  2. Nella casella di riepilogo a discesa fare clic su Seafood. La casella di riepilogo standard dovrebbe visualizzare una riga vuota, Crab meat e Salmon.

    Nota : La riga vuota consente all'utente di deselezionare le opzioni della casella di riepilogo.

Se le caselle di riepilogo non funzionano correttamente, rivedere il filtro della seconda casella di riepilogo per assicurarsi che confronti il campo listBox1 con il campo Categoria.

Inizio sezione

Connettere il modulo a un documento XML esterno

In questa sezione verrà illustrato come creare una connessione dati a un documento XML che contiene i valori di prodotti e categorie. Il documento XML sarà l'origine dati secondaria. Per creare questa connessione dati, è necessario creare il documento XML, associarvi le caselle di riepilogo del modello di modulo e quindi applicare un filtro alla seconda casella di riepilogo in modo che l'elenco di prodotti cambi correttamente.

Prima di associare il modulo a un'origine dati secondaria, è necessario creare il documento XML.

Creare il documento XML

  1. Avviare il Blocco appunti o un altro editor di testo.

  2. Copiare e incollare i dati XML seguenti nell'editor di testo:

    <?xml version="1.0" encoding="UTF-8"?>
    <ListBoxData>
    <CategoriesAndProducts>
    <Categories>Seafood</Categories>
    <Products>
    <Product>Crab meat</Product>
    </Products>
    <Products>
    <Product>Salmon</Product>
    </Products>
    </CategoriesAndProducts>
    <CategoriesAndProducts>
    <Categories>Dairy</Categories>
    <Products>
    <Product>Chocolate milk</Product>
    </Products>
    <Products>
    <Product>Cheddar</Product>
    </Products>
    </CategoriesAndProducts>
    </ListBoxData>
  3. Salvare il file nel computer con il nome listBoxData.xml.

Dopo aver creato un documento XML, è possibile connetterlo al modello di modulo. Verrà creata un'origine dati secondaria.

Connettere il documento XML al modello di modulo

  1. Scegliere Connessioni dati dal menu Strumenti.

  2. Nella finestra di dialogo Connessioni dati fare clic su Aggiungi.

  3. Nella Connessione guidata dati fare clic su Ricezione dati e quindi su Avanti.

  4. Nella pagina successiva della procedura guidata fare clic su Documento XML e quindi su Avanti.

  5. Nella pagina successiva della procedura guidata fare clic su Sfoglia, selezionare il file listBoxData.xml salvato nel computer e quindi fare clic su Apri.

  6. Nella pagina successiva della procedura guidata fare clic su Includi i dati come file di risorse nel modello di modulo o nella parte modello e quindi su Avanti.

  7. Nella pagina successiva della procedura guidata digitare listBoxDataXMLFile nella casella Immettere un nome per la connessione dati.

  8. Selezionare la casella di controllo Recupera automaticamente i dati all'apertura del modulo. In questo modo si garantisce che i dati della casella di riepilogo saranno disponibili ogni volta che viene aperto il modulo, invece di chiedere all'utente di eseguire una query per cercarli.

  9. Scegliere il pulsante Fine.

  10. Nella finestra di dialogo Connessioni dati scegliere Chiudi.

Ora è possibile connettere la prima casella di riepilogo del modello di modulo ai dati del documento XML.

Connettere la prima casella di riepilogo ai dati

  1. Nel modello di modulo fare doppio clic sulla casella di riepilogo a discesa inserita in precedenza.

  2. Fare clic sulla scheda Dati.

  3. Nella finestra di dialogo Casella di riepilogo a discesa - Proprietà, in Voci casella di riepilogo, fare clic su Cerca valori in un'origine dati esterna.

  4. Nella casella Origine dati fare clic su listBoxDataXMLFile.

  5. Fare clic su Seleziona XPath Pulsante Origine dati accanto alla casella Voci.

  6. Nel gruppo CategoriesAndProducts della finestra di dialogo Seleziona campo o gruppo fare clic sul campo Categories.

    Nota : Lo sfondo giallo della finestra di dialogo Seleziona campo o gruppo indica che si sta usando un'origine dati secondaria.

  7. Scegliere OK due volte.

A questo punto è necessario connettere la seconda casella di riepilogo al documento XML. Quando si crea questa connessione dati, applicare un filtro alla seconda casella di riepilogo. Questo filtro popolerà la seconda casella di riepilogo con i prodotti appropriati in base alla categoria selezionata nella prima. Il filtro confronta il valore selezionato nella prima casella di riepilogo (campo listBox1) con l'elenco di categorie salvato nel modulo (campo Categoria).

Connettere la seconda casella di riepilogo ai dati

  1. Nel modello di modulo fare doppio clic sulla casella di riepilogo standard inserita in precedenza.

  2. Fare clic sulla scheda Dati.

  3. Nella finestra di dialogo Casella di riepilogo - Proprietà, in Voci casella di riepilogo, fare clic su Cerca valori in un'origine dati esterna.

  4. Nella casella Origine dati fare clic su listBoxDataXMLFile.

  5. Fare clic su Seleziona XPath Pulsante Origine dati accanto alla casella Voci.

  6. Nel gruppo CategoriesAndProducts della finestra di dialogo Seleziona campo o gruppo espandere il gruppo Products e quindi fare clic sul campo Prodotto.

  7. Fare clic su Filtra dati.

  8. Nella finestra di dialogo Filtra dati fare clic su Aggiungi.

  9. Nella finestra di dialogo Specifica condizioni filtro fare clic su Seleziona campo o gruppo nella prima casella.

  10. Nella casella Origine dati della finestra di dialogo Seleziona campo o gruppo fare clic su Principale.

  11. Fare clic su listBox1 e quindi su OK.

  12. Nella finestra di dialogo Specifica condizioni filtro fare clic su Seleziona campo o gruppo nella terza casella.

  13. Nella casella Origine dati della finestra di dialogo Seleziona campo o gruppo fare clic su listBoxDataXMLFile (secondaria) e quindi su Categorie.

  14. Fare clic su OK per chiudere tutte le finestre di dialogo aperte.

Una volta connessa la seconda casella di riepilogo al documento XML e applicato il filtro, è possibile testare le caselle di riepilogo per verificare che funzionino correttamente.

Testare le caselle di riepilogo

  1. Per verificare le modifiche, fare clic su Anteprima nella barra degli strumenti Standard oppure premere CTRL+MAIUSC+B.

  2. Nella casella di riepilogo a discesa fare clic su Seafood. La casella di riepilogo standard dovrebbe visualizzare una riga vuota, Crab meat e Salmon.

    Nota : La riga vuota consente all'utente di deselezionare le opzioni della casella di riepilogo.

Se le caselle di riepilogo non funzionano correttamente, rivedere il filtro della seconda casella di riepilogo per assicurarsi che confronti il campo listBox1 con il campo Categoria.

Inizio sezione

Connettere il modulo a un database

In questa sezione verrà illustrato come creare una connessione dati a due tabelle in un database di Access. A questo scopo, associare le caselle di riepilogo del modello di modulo al database e quindi applicare un filtro alla seconda casella di riepilogo in modo che l'elenco visualizzato al suo interno cambi correttamente in base al valore selezionato nella prima casella di riepilogo. Per questo esempio, si presuppone che il database di Access contenga due tabelle, chiamate Categories e Products, e che queste due tabelle siano correlate tra loro tramite un campo CategoryID, usato in ognuna.

Tabella Categories    

CategoryID

CategoryName

1

Seafood

2

Dairy

Tabella Products    

ProductID

CategoryID

ProductName

1

1

Crab meat

2

1

Salmon

3

2

Chocolate Milk

4

2

Cheddar

Connettere il modello di modulo all'origine dati

Prima di tutto, è necessario creare una connessione dati tra il modello di modulo e le tabelle del database. Poiché i dati del database vengono solo visualizzati, e non modificati direttamente, il database di Access sarà un'origine dati secondaria per il modello di modulo.

  1. Scegliere Connessioni dati dal menu Strumenti.

  2. Nella finestra di dialogo Connessioni dati fare clic su Aggiungi.

  3. Nella Connessione guidata dati fare clic su Ricezione dati e quindi su Avanti.

  4. Nella pagina successiva della procedura guidata fare clic su Database (solo Microsoft SQL Server o Microsoft Office Access), quindi su Avanti.

  5. Nella pagina successiva della procedura guidata fare clic su Seleziona database, quindi individuare e fare doppio clic sul database di Access nel disco rigido.

  6. Nella finestra di dialogo Seleziona tabella fare clic sulla tabella che contiene i dati da visualizzare nel primo elenco, in questo caso la tabella Categories, quindi fare clic su OK. In questo modo la tabella viene specificata come primaria per la connessione dati.

  7. Nella procedura guidata fare clic su Aggiungi tabella.

  8. Nella finestra di dialogo Aggiungi tabella o query fare clic sulla tabella che contiene i dati da visualizzare nel secondo elenco, in questo caso la tabella Products, quindi fare clic su Avanti.

  9. Nella finestra di dialogo Modifica relazione verificare che i campi di connessione siano corretti. In questo esempio le tabelle sono correlate tra loro tramite il campo CategoryID.

    Suggerimento : Se i campi di connessione non sono corretti, selezionarli e quindi fare clic su Rimuovi relazione. Quindi fare clic su Aggiungi relazione, selezionare i campi corretti e fare clic su OK.

  10. Scegliere il pulsante Fine.

    Nota : In questo esempio la tabella di categorie ha una relazione uno-a-molti con la tabelle di prodotti, il che significa che per ogni singola categoria possono esserci molti prodotti. In un database questo tipo di relazione viene in genere stabilito tramite campi chiave. In questo caso, il campo chiave CategoryID consente ad Access di associare la serie corretta di prodotti alla categoria appropriata.

  11. Nella procedura guidata rivedere la struttura dell'origine dati. Dovrebbero essere visualizzate due tabelle connesse tra loro, la tabella primaria e quella secondaria. Per vedere i singoli campi della tabella, selezionare la casella di controllo Mostra colonne tabella. Dopo aver rivisto la struttura dei dati, fare clic su Avanti.

  12. Deselezionare la casella di controllo Memorizza una copia dei dati nel modello di modulo, quindi fare clic su Avanti.

  13. Nella casella Immettere un nome per la connessione dati della pagina successiva della procedura guidata digitare un nome descrittivo per questa connessione dati.

  14. Selezionare la casella di controllo Recupera automaticamente i dati all'apertura del modulo.

  15. Fare clic su Fine e quindi su Chiudi nella finestra di dialogo Connessioni dati.

Connettere la prima casella di riepilogo ai dati

Una volta creata la connessione dati all'origine dati secondaria, è possibile connettere la prima casella di riepilogo del modello di modulo alle tabelle del database.

  1. Nel modello di modulo fare doppio clic sulla casella di riepilogo a discesa inserita in precedenza.

  2. Fare clic sulla scheda Dati.

  3. Nella finestra di dialogo Casella di riepilogo a discesa - Proprietà, in Voci casella di riepilogo, fare clic su Cerca valori in un'origine dati esterna.

  4. Nella casella Origine dati verificare che sia selezionata la connessione dati creata.

  5. Fare clic su Seleziona XPath Pulsante Origine dati accanto alla casella Voci.

  6. Nella finestra di dialogo Seleziona campo o gruppo fare clic sul nome della tabella che contiene i dati da visualizzare nel primo elenco a discesa, in questo esempio la tabella d:Categories, quindi fare clic su OK.

    Nota : Lo sfondo giallo della finestra di dialogo Seleziona campo o gruppo indica che si sta usando un'origine dati secondaria.

  7. Fare clic su Seleziona XPath Pulsante Origine dati accanto alla casella Valore.

  8. Nella finestra di dialogo Seleziona campo o gruppo assicurarsi che sia selezionato il campo di connessione, in questo esempio :CategoryID, quindi fare clic su clic OK. Questo è il valore che verrà salvato quando l'utente effettua una selezione nella casella di riepilogo.

  9. Fare clic su Seleziona XPath Pulsante Origine dati accanto alla casella Nome visualizzato.

  10. Nella finestra di dialogo Seleziona campo o gruppo fare clic sul nome del campo da visualizzare nel primo elenco a discesa, in questo esempio :CategoryName.

  11. Scegliere OK due volte.

Connettere la seconda casella di riepilogo ai dati

A questo punto è necessario connettere la seconda casella di riepilogo al database. Quando si crea questa connessione dati, applicare un filtro alla seconda casella di riepilogo. Questo filtro popolerà la seconda casella di riepilogo con i valori appropriati in base al valore selezionato nella prima.

  1. Nel modello di modulo fare doppio clic sulla casella di riepilogo standard.

  2. Fare clic sulla scheda Dati.

  3. Nella finestra di dialogo Casella di riepilogo - Proprietà, in Voci casella di riepilogo, fare clic su Cerca valori in un'origine dati esterna.

  4. Nella casella Origine dati verificare che sia selezionata la connessione dati creata.

  5. Fare clic su Seleziona XPath Pulsante Origine dati accanto alla casella Voci.

  6. Nella finestra di dialogo Seleziona campo o gruppo espandere il gruppo primario, in questo esempio d:Categories, quindi fare clic sul gruppo secondario che corrisponde alla tabella contenente i dati da visualizzare nella casella di riepilogo a cascata, in questo esempio Products.

  7. Fare clic su Filtra dati.

  8. Nella finestra di dialogo Filtra dati fare clic su Aggiungi.

  9. Nella prima casella della finestra di dialogo Specifica condizioni filtro assicurarsi che sia selezionato il campo di connessione della tabella secondaria, in questo esempio Products.

    Importante : Se i campi di connessione hanno lo stesso nome in entrambe le tabelle, assicurarsi di selezionare quello corretto. I campi di ogni tabella sono disposti insieme nell'elenco. Pertanto, è possibile usare i nomi dei campi circostanti per determinare qual è quello corretto. In questo esempio selezionare il campo CategoryID visualizzato con gli altri campi della tabella Products.

  10. Nella terza casella fare clic su Selezionare campo o gruppo.

  11. Nella casella Origine dati della finestra di dialogo Seleziona campo o gruppo fare clic su Principale, sul campo listBox1 e quindi su OK.

    A questo punto è stato configurato un filtro che confronta il valore selezionato nella casella di riepilogo a discesa (campo listBox1) con l'elenco di valori della casella di riepilogo standard.

  12. Fare tre volte clic su OK per tornare nella finestra di dialogo Casella di riepilogo - Proprietà.

  13. Fare clic su Seleziona XPath Pulsante Origine dati accanto alla casella Valore.

  14. Nella finestra di dialogo Seleziona campo o gruppo selezionare il valore da salvare quando l'utente effettua una selezione nella casella di riepilogo. In questo esempio è necessario salvare il campo ProductID per un uso successivo. Pertanto, selezionare il gruppo :ProductID e quindi fare clic su OK.

  15. Fare clic su Seleziona XPath Pulsante Origine dati accanto alla casella Nome visualizzato.

  16. Nella finestra di dialogo Seleziona campo o gruppo fare clic sul nome del campo da visualizzare nella casella di riepilogo, in questo esempio :ProductName.

  17. Scegliere OK due volte.

Testare le caselle di riepilogo

Una volta connessa la seconda casella di riepilogo al database e applicato il filtro, è possibile testare le caselle di riepilogo per verificare che funzionino correttamente.

  1. Per verificare le modifiche, fare clic su Anteprima nella barra degli strumenti Standard oppure premere CTRL+MAIUSC+B.

  2. Selezionare un valore nella casella di riepilogo a discesa. La casella di riepilogo standard dovrebbe visualizzare i valori appropriati della tabella secondaria, in base al campo di connessione scelto.

Suggerimento : Se le caselle di riepilogo non funzionano correttamente, rivedere il filtro della seconda casella di riepilogo per assicurarsi che confronti il campo listBox1 con il campo CategoryID.

Inizio sezione

Inizio pagina

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×