Creare un riferimento esterno (collegamento) a un intervallo di celle in un'altra cartella di lavoro

È possibile fare riferimento al contenuto delle celle di un'altra cartella di lavoro creando un riferimento esterno, denominato anche collegamento, ovvero un riferimento a una cella o a un intervallo in un foglio di lavoro di un'altra cartella di lavoro di Excel oppure un riferimento a un nome definito in un'altra cartella di lavoro. Si può fare riferimento all'intervallo di celle specifico, a un nome definito per l'intervallo di celle oppure si può definire un nome per il riferimento esterno.

Per saperne di più

Altre informazioni sui riferimenti esterni

Creare un riferimento esterno tra celle di cartelle di lavoro diverse

Creare un riferimento esterno a un nome definito in un'altra cartella di lavoro

Definire un nome contenente un riferimento esterno a celle in un'altra cartella di lavoro

Altre informazioni sui riferimenti esterni

Benché i riferimenti esterni siano analoghi ai riferimenti di cella, vi sono alcune differenze importanti. I riferimenti esterni vengono utilizzati per quantità elevate di dati o formule complesse che interessano diverse cartelle di lavoro. Vengono creati mediante una procedura diversa da quella dei riferimenti di cella e vengono visualizzati in modo diverso in una cella o nella barra della formula.

Utilizzo ottimale dei riferimenti esterni

I riferimenti esterni sono particolarmente utili se risulta poco pratico conservare modelli di foglio di lavoro di grandi dimensioni nella stessa cartella di lavoro.

  • Unire dati di diverse cartelle di lavoro    È possibile collegare cartelle di lavoro di diversi utenti o reparti e successivamente integrare i dati pertinenti in una cartella di lavoro di riepilogo. In questo modo, quando si apporteranno modifiche alle cartelle di lavoro di origine, non sarà necessario modificare manualmente la cartella di lavoro di riepilogo.

  • Creare visualizzazioni di dati diverse    È possibile immettere tutti i dati in una o più cartelle di lavoro di origine e quindi creare una cartella di lavoro di rapporto contenente solo i riferimenti esterni ai dati pertinenti.

  • Semplificare modelli complessi       Suddividendo un modello complicato in una serie di cartelle di lavoro interdipendenti, sarà possibile intervenire sul modello senza aprire tutti i fogli a esso correlati. Le cartelle di lavoro di dimensioni contenute sono più facili da modificare, richiedono poca memoria e minor tempo per aprirle, salvarle e calcolarle.

Procedure per la creazione di riferimenti esterni

Se si utilizza un riferimento di cella per creare un riferimento esterno, è quindi possibile applicare formule alle informazioni. Spostandosi tra i vari tipi di riferimenti di cella, è inoltre possibile controllare le celle collegate se si sposta il riferimento esterno. Se ad esempio si utilizza un riferimento relativo, quando si sposta il riferimento esterno, la cella o le celle a cui è collegato vengono modificate per riflettere la nuova posizione nel foglio di lavoro.

Quando si crea un riferimento esterno da una cartella di lavoro a un'altra, è consigliabile utilizzare un nome per fare riferimento alle celle con cui si desidera stabilire il collegamento. È possibile creare un riferimento esterno utilizzando un nome già definito, oppure definire il nome quando si crea il riferimento esterno. Tramite l'utilizzo di un nome, è più semplice ricordare il contenuto delle celle con le quali si stabilisce il collegamento. I riferimenti esterni che utilizzano nomi definiti rimangono invariati quando vengono spostati, in quanto un nome fa riferimento a una cella o a un intervallo di celle specifico. Se si desidera che un riferimento esterno che utilizza un nome definito venga modificato quando lo si sposta, è possibile modificare il nome utilizzato nel riferimento esterno o le celle a cui il nome fa riferimento.

Aspetto di un riferimento esterno a un'altra cartella di lavoro

Le formule contenenti riferimenti esterni ad altre cartelle di lavoro vengono visualizzate in due modi, a seconda che la cartella di lavoro di origine, ovvero quella da cui provengono i dati necessari alla formula, sia aperta o chiusa.

Quando l'origine è aperta, nel riferimento esterno viene incluso il nome della cartella di lavoro tra parentesi quadre ([ ]), seguito dal nome del foglio di lavoro, da un punto esclamativo (!) e dalle celle da cui dipende la formula. La formula seguente ad esempio aggiunge le celle C10:C25 della cartella di lavoro denominata Bilancio.xlsx.

Riferimento esterno

=SOMMA([Bilancio.xlsx]Annuale!C10:C25)

Quando l'origine è chiusa, nel riferimento esterno viene incluso l'intero percorso.

Riferimento esterno

=SOMMA('C:\Report\[Bilancio.xlsx]Annuale'!C10:C25)

Nota : Se il nome dell'altro foglio di lavoro o dell'altra cartella di lavoro contiene caratteri non alfabetici, sarà necessario racchiudere il nome o il percorso tra virgolette singole.

Le formule che collegano a un determinato nome in un'altra cartella di lavoro utilizzano il nome della cartella di lavoro seguito da un punto esclamativo (!), quindi il nome. La formula seguente ad esempio aggiunge nell'intervallo denominato Vendite le celle della cartella di lavoro denominata Bilancio.xlsx.

Riferimento esterno

=SOMMA(Bilancio.xlsx!Vendite)

Inizio pagina

Creare un riferimento esterno tra celle di cartelle di lavoro diverse

  1. Aprire la cartella di lavoro che includerà il riferimento esterno, ovvero la cartella di lavoro di destinazione, e la cartella di lavoro contenente i dati con cui si desidera stabilire il collegamento, ovvero la cartella di lavoro di origine.

  2. Nella cartella di lavoro di origine fare clic su Salva Icona del pulsante sulla barra di accesso rapido.

  3. Selezionare la cella o le celle in cui si vuole creare il riferimento esterno.

  4. Digitare = (segno di uguale). Per eseguire calcoli o funzioni sul valore del riferimento esterno, digitare l'operatore o la funzione che deve precedere il riferimento esterno.

  5. Passare alla cartella di lavoro di origine e quindi fare clic sul foglio di lavoro che include le celle alle quali creare il collegamento.

  6. Selezionare la cella o le celle con cui si desidera stabilire il collegamento.

  7. Tornare alla cartella di lavoro di destinazione. Si noti che il riferimento viene aggiunto automaticamente alla cartella di lavoro di origine e alle celle selezionate nel passaggio precedente.

  8. È possibile modificare la formula nel foglio di lavoro di destinazione.

  9. Premere CTRL+MAIUSC+INVIO.

Inizio pagina

Creare un riferimento esterno a un nome definito in un'altra cartella di lavoro

  1. Aprire la cartella di lavoro che includerà il riferimento esterno, ovvero la cartella di lavoro di destinazione, e la cartella di lavoro contenente i dati con cui si desidera stabilire il collegamento, ovvero la cartella di lavoro di origine.

  2. Nella cartella di lavoro di origine fare clic su Salva Icona del pulsante sulla barra di accesso rapido.

  3. Selezionare la cella o le celle in cui si vuole creare il riferimento esterno.

  4. Digitare = (segno di uguale). Per eseguire calcoli o funzioni sul valore del riferimento esterno, digitare l'operatore o la funzione che deve precedere il riferimento esterno.

  5. Fare clic su Cambia finestre nel gruppo Finestra della scheda Visualizza, fare clic sulla cartella di lavoro di origine e quindi fare clic sul foglio di lavoro contenente le celle da collegare.

    Icona del pulsante

  6. Premere F3 e selezionare il nome da collegare.

Inizio pagina

Definire un nome contenente un riferimento esterno a celle in un'altra cartella di lavoro

  1. Aprire la cartella di lavoro di destinazione e la cartella di lavoro di origine.

  2. Nel gruppo Nomi definiti della scheda Formule della cartella di lavoro di destinazione fare clic Definisci nome.

    Immagine della barra multifunzione di Excel

  3. Nella casella Nome della finestra di dialogo Nuovo nome digitare un nome per l'intervallo.

  4. Nella casella Riferito a eliminare il contenuto e quindi mantenere il cursore nella casella.

    Se il nome contiene una formula, immettere la formula e quindi posizionare il cursore nel punto in cui si desidera inserire il riferimento esterno. Ad esempio, digitare =SOMMA() e quindi posizionare il cursore tra le parentesi.

  5. Fare clic su Cambia finestre nel gruppo Finestra della scheda Visualizza, fare clic sulla cartella di lavoro di origine e quindi fare clic sul foglio di lavoro contenente le celle da collegare.

    Icona del pulsante

  6. Selezionare la cella o l'intervallo di celle da collegare.

  7. Nella finestra di dialogo Nuovo nome fare clic su OK.

Inizio pagina

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×