Creare un report sul progetto

Con Project è possibile creare e personalizzare report grafici d'impatto sui dati desiderati del progetto senza dover usare altre applicazioni software. Se il progetto viene modificato, non è necessario aggiornare manualmente i report, in quanto questi rispecchiano automaticamente le informazioni più recenti. Vedere un elenco di tutti i report e informazioni su come usarli.

  1. Fare clic sulla scheda Report.

  2. Nella finestra di dialogo Visualizza report fare clic sul tipo di report desiderato e quindi selezionare un report specifico.

Ad esempio, per aprire il report Informazioni generali progetto fare clic su Report > Dashboard > Informazioni generali progetto.

menu dashboard nella scheda report.

Nel report Informazioni generali progetto vengono combinati grafici e tabelle per visualizzare inizio e fine di ogni fase del progetto, le prossime attività cardine e le attività scadute.

Report Informazioni generali progetto

In Project sono disponibili decine di report che è possibile usare immediatamente. Questo non deve però costituire una limitazione alle scelte disponibili. È infatti possibile personalizzare il contenuto e l'aspetto dei report oppure crearne uno completamente nuovo.

Utilizzare il report

Modificare i dati in un report

Esempio

Modificare l'aspetto di un report

Esempio

Creare un report personalizzato

Condividere un report

Rendere disponibile un nuovo report per i progetti futuri

Altri modi per creare un report sulle informazioni del progetto

Modificare i dati in un report

È possibile scegliere i dati visualizzati da Project in qualsiasi parte di un report.

  1. Fare clic sulla tabella o sul grafico che si desidera modificare.

  2. Utilizzare il riquadro Elenco campi nella parte destra della schermata per selezionare i campi da visualizzare e filtrare le informazioni.

Suggerimento:  Quando si fa clic su un grafico, vengono inoltre visualizzati tre pulsanti direttamente a destra del grafico. Utilizzare i pulsanti Elementi grafico pulsante elementi grafico e Filtri grafico pulsante filtri grafico per selezionare rapidamente elementi quali etichette dati e filtrare le informazioni da includere nel grafico.

Esempio

Nel report Informazioni generali progetto è possibile modificare il grafico % completamento in modo da visualizzare le sottoattività critiche anziché le attività di riepilogo di primo livello:

  1. Fare clic in un punto qualsiasi del grafico % completamento.

  2. Nel riquadro Elenco campi passare alla casella Filtro e selezionare Critiche.

  3. Nella casella Livello struttura selezionare Livello 2. Nell'esempio questo corrisponde al primo livello della struttura che include sottoattività anziché attività di riepilogo.

    Il grafico viene modificato in base alle selezioni effettuate.

    report informazioni generali progetto con riquadro dati grafico aperto

Modificare l'aspetto di un report

Con Project è possibile controllare l'aspetto dei report, scegliendo ad esempio tra un asettico bianco e nero e un'esplosione di colori ed effetti.

Suggerimento:  È possibile impostare un report come parte di una Doppia visualizzazione in modo da visualizzare le modifiche apportate al report in tempo reale quando si lavora sui dati del progetto. Per ulteriori informazioni, vedere Dividere una visualizzazione.

Fare clic in un punto qualsiasi del report e quindi su Progettazione Strumenti report per visualizzare le opzioni per la modifica dell'aspetto dell'intero report. In questa scheda è possibile modificare il tipo di carattere, il colore o il tema dell'intero report, nonché aggiungere nuove immagini (incluse foto), forme, grafici o tabelle.

Scheda Progettazione Strumenti report

Quando si fa clic su singoli elementi (grafici, tabelle e così via) di un report, nella parte superiore della schermata vengono visualizzate nuove schede con le opzioni per la formattazione di tale parte.

Gruppo Stili tabella della scheda Progettazione Strumenti tabella

Suggerimento:  Quando si fa clic su un grafico, vengono inoltre visualizzati tre pulsanti direttamente a destra del grafico. Fare clic sul pulsante Stili grafico Pulsante Personalizza l'aspetto del grafico per modificare rapidamente il colore o lo stile di un grafico.

Esempio

Si supponga di voler modificare l'aspetto del grafico %completamento nel report Informazioni generali progetto.

Grafico % completamento nel report Informazioni generali progetto

  1. Fare clic in un punto qualsiasi del grafico % completamento e quindi fare clic su Progettazione Strumenti grafico.

  2. Selezionare un nuovo stile nel gruppo Stili grafico. Questo stile implica la rimozione delle linee e l'aggiunta di ombre alle colonne.

    Gruppo Stili grafico nella scheda Progettazione Strumenti grafico

  3. Per conferire un effetto di profondità al grafico, fare clic su Progettazione Strumenti grafico > Cambia tipo di grafico.

    Pulsante Cambia tipo di grafico

  4. Fare clic su Colonna > Colonne 3D in pila.

    Finestra di dialogo Cambia tipo di grafico

  5. Aggiungere un colore di sfondo. Fare clic su Formato Strumenti grafico > Riempimento forma e selezionare un nuovo colore.

    Menu delle opzioni per i colori di Riempimento forma

  6. Modificare i colori delle barre. Fare clic sulle barre per selezionarle e quindi fare clic su Formato Strumenti grafico > Riempimento forma e infine selezionare un nuovo colore.

  7. Spostare i numeri all'esterno delle barre. Fare clic sui numeri per selezionarli e quindi trascinarli verso l'alto.

Pochi clic possono fare una grande differenza. Con queste operazioni sono state esaminate solo alcune delle numerose opzioni di formattazione disponibili.

Grafico % completamento formattato nel report Informazioni generali progetto

Creare un report personalizzato

  1. Fare clic su Report > Nuovo report.

  2. Scegliere una delle quattro opzioni e quindi fare clic su Seleziona.

  3. Assegnare un nome al report e iniziare ad aggiungervi informazioni.

    menu nuovo report nella scheda report

    Vuoto    Consente di creare un'area di disegno vuota. Utilizzare la scheda Progettazione Strumenti report per aggiungere grafici, tabelle, testo e immagini.

    Grafico    Per impostazione predefinita, in Project viene creato un grafico confrontando i valori di Lavoro effettivo, Lavoro rimanente e Lavoro. Usare il riquadro Elenco campi per selezionare campi diversi da confrontare. Usare quindi i controlli per modificare il colore e il formato del grafico.

    Tabella    Usare il riquadro Elenco campi per scegliere i campi da visualizzare nella tabella. I campi Nome, Inizio, Fine e % completamento vengono visualizzati per impostazione predefinita. La casella Livello struttura consente di selezionare il numero di livelli della struttura del progetto da visualizzare nella tabella. Per cambiare l'aspetto della tabella, usare le schede Progettazione Strumenti tabella e Layout Strumenti tabella.

    Di confronto    Consente di impostare due grafici affiancati. Inizialmente i grafici contengono gli stessi dati. Fare clic su un grafico e selezionare i dati desiderati nel riquadro Elenco campi per iniziare a distinguerli.

Tutti i nuovi grafici creati sono completamente personalizzabili. È possibile aggiungere ed eliminare elementi, nonché modificare i dati in base alle esigenze.

Condividere un report

  1. Fare clic in un punto qualsiasi del report.

  2. Fare clic su Progettazione Strumenti report > Copia report.

    Pulsante Copia report nella scheda Progettazione Strumenti report

  3. Incollare il report in qualsiasi programma in grado di visualizzare grafica.

Suggerimento:  Quando si incolla il report nella sua nuova posizione può essere necessario ridimensionarlo e allinearlo.

È anche possibile stampare il report per condividerlo in formato cartaceo.

Rendere disponibile un nuovo report per i progetti futuri

Usare la libreria per copiare un nuovo report nel modello globale per poterlo usare nei progetti futuri.

Altri modi per creare un report sulle informazioni del progetto

Le relazioni grafiche consentono di visualizzare graficamente le informazioni di Project usando le tabelle pivot avanzate in Excel 2010. Una volta che le informazioni di Project sono state esportate in Excel, è possibile personalizzare ulteriormente le relazioni con le funzionalità avanzate delle tabelle pivot di Excel 2010, come il filtro dei dati, la ricerca all'interno delle tabelle pivot, i grafici sparklines all'interno delle tabelle pivot per visualizzare immediatamente le tendenze e i miglioramenti del writeback di OLAP.

I modelli di relazioni in Project 2010 sono divisi in sei categorie nella finestra di dialogo Relazioni grafiche - Creazione relazione, alla quale è possibile accedere facendo clic su Relazioni grafiche nel gruppo Relazioni della scheda Project. Le sezioni seguenti forniscono la descrizione delle relazioni grafiche in ogni categoria.

È anche possibile creare relazioni personalizzate. Le relazioni personalizzate verranno visualizzate nella categoria per il tipo di dati usati.

Categoria Gestione attività

La tabella seguente descrive le relazioni grafiche nella categoria Gestione attività. Queste relazioni si basano sui dati dell'attività rapportato alla scala cronologica.

Nota: I dati dell'assegnazione rapportata alla scala cronologica sono disponibili nelle relazioni della categoria Uso assegnazioni.

Name

Tipo

Descrizione

Rapporto flusso di cassa

Excel

Usare questa relazione per visualizzare un grafico a barre con gli importi dei costi e dei costi cumulativi illustrati nel tempo.

Relazione Costo realizzato nel tempo

Excel

Usare questa relazione per visualizzare un grafico che traccia il valore AC (costo effettivo del lavoro eseguito), il valore pianificato (costo preventivato del lavoro programmato) e il costo realizzato (costo preventivato del lavoro eseguito) nel tempo.

Categoria Uso risorse

La tabella seguente descrive le relazioni grafiche nella categoria Uso risorse. Queste relazioni si basano sui dati relativi delle risorse rapportate alla scala cronologica.

Nota: I dati dell'assegnazione rapportata alla scala cronologica sono disponibili nelle relazioni della categoria Uso assegnazioni.

Name

Tipo

Descrizione

Rapporto flusso di cassa

Visio

Usare questa relazione per visualizzare un diagramma che mostra i costi pianificati ed effettivi del progetto nel tempo. I costi sono ripartiti per tipo di risorsa (lavoro, materiale e costo). Un indicatore mostra se i costi pianificati superano i costi previsti.

Rapporto disponibilità risorse

Visio

Usare questa relazione per visualizzare un diagramma che mostra il lavoro e la disponibilità residua per le risorse del progetto, suddivise per tipo di risorsa (lavoro, materiale e costo). Un contrassegno rosso viene visualizzato accanto a ogni risorsa sovrassegnata.

Relazione Riepilogo costi risorse

Excel

Usare questa relazione per visualizzare un grafico a torta che illustra la ripartizione del costo delle risorse tra i tre tipi di risorse: costo, materiale e lavoro.

Relazione Disponibilità lavoro risorse

Excel

Usare questa relazione per visualizzare un grafico a barre con la capacità totale, il lavoro e la disponibilità residua delle risorse di lavoro illustrate nel tempo.

Relazione Riepilogo lavoro risorse

Excel

Usare questa relazione per visualizzare un grafico a barre con la capacità totale delle risorse, il lavoro, la disponibilità residua e il lavoro effettivo illustrati in unità di lavoro.

Categoria Uso assegnazioni

La tabella seguente descrive le relazioni grafiche nella categoria Uso assegnazioni. Queste relazioni sono basate sui dati rapportati alla scala cronologica, simili ai dati che si trovano nelle visualizzazioni Gestione attività e Uso risorse.

Name

Tipo

Descrizione

Relazione Costo previsto

Excel

Usare questa relazione per visualizzare un grafico a barre con i costi previsti, i costi pianificati e i costi effettivi del progetto illustrati nelle attività.

Rapporto previsioni

Visio

Usare questa relazione per visualizzare un diagramma del progetto suddiviso per trimestre e quindi per attività. Questa relazione consente di confrontare il lavoro e i costi pianificati con il lavoro e i costi previsti. Vengono usati degli indicatori per mostrare quando il lavoro pianificato supera il lavoro previsto e quando il costo pianificato supera il costo previsto.

Relazione Lavoro previsto

Excel

Usare questa relazione per visualizzare un grafico a barre con il lavoro previsto, il lavoro pianificato e il lavoro effettivo del progetto illustrati nelle attività.

Relazione Costi preventivati

Excel

Usare questa relazione per visualizzare un grafico a barre con i costi preventivati, i costi previsti, i costi pianificati e i costi effettivi illustrati nel tempo.

Relazione Lavoro preventivato

Excel

Usare questa relazione per visualizzare un grafico a barre con il lavoro preventivato, il lavoro previsto, il lavoro pianificato e il lavoro effettivo illustrati nel tempo.

Relazione Costo realizzato nel tempo

Excel

Usare questa relazione per visualizzare un grafico che traccia il valore AC (costo effettivo del lavoro eseguito), il valore pianificato (costo preventivato del lavoro programmato) e il costo realizzato (costo preventivato del lavoro eseguito) nel tempo.

Categorie Riepilogo attività, risorse e assegnazioni

La tabella seguente descrive le relazioni grafiche nelle categorie Riepilogo attività, Riepilogo risorse e Riepilogo assegnazioni. Le relazioni di riepilogo non includono dati rapportati alla scala cronologica.

Categoria

Name

Tipo

Descrizione

Riepilogo attività

Rapporto sullo stato attività critiche

Visio

Usare questa relazione per visualizzare un diagramma che mostra il lavoro e il lavoro rimanente sia per le attività critiche che per quelle non critiche. La barra dei dati indica la percentuale di lavoro completato.

Riepilogo attività

Rapporto sullo stato attività

Visio

Usare questa relazione per visualizzare un diagramma del lavoro e la percentuale di lavoro completato per le attività del progetto, con simboli che indicano quando il lavoro previsto supera il lavoro, quando il lavoro previsto equivale al lavoro e quando il lavoro supera il lavoro previsto. La barra dei dati indica la percentuale di lavoro completato.

Riepilogo risorse

Relazione Lavoro rimanente risorse

Excel

Usare questa relazione per visualizzare un grafico a barre con il lavoro rimanente e il lavoro effettivo per ogni risorsa di lavoro, illustrati in unità di lavoro.

Riepilogo assegnazioni

Rapporto sullo stato risorse

Visio

Usare questa relazione per visualizzare un diagramma dei valori relativi al lavoro e ai costi per ogni risorsa del progetto. La percentuale di lavoro completato è indicata dall'ombreggiatura in ciascuna delle caselle del diagramma. L'ombreggiatura diventa più scura quando la risorsa si avvicina al completamento del lavoro assegnato.

Creare una relazione grafica usando un modello

  1. Nel gruppo Relazioni della scheda Project fare clic su Relazioni grafiche.
    Elemento grafico del gruppo Report

  2. Nella scheda Tutte della finestra di dialogo Relazioni grafiche fare clic sulla relazione che si vuole creare.

    Se la relazione che si vuole creare non è elencata, selezionare la casella di controllo Includi modelli di relazioni da e quindi fare clic su Modifica per passare al percorso che contiene la relazione.

    Suggerimento: se si sa quale categoria contiene la relazione, è possibile fare clic sulla scheda di quella categoria per visualizzare un elenco più breve di relazioni. Se si vuole elencare solo le relazioni aperte in Excel o Visio, selezionare o deselezionare la casella di controllo Microsoft Excel o Microsoft Visio.

  3. Per modificare il livello di dati di utilizzo inclusi nella relazione, selezionare Anni, Trimestri, Mesi, Settimane o Giorni nell'elenco Selezionare il livello di dati di utilizzo da includere nella relazione.

    Nota: per impostazione predefinita, Project imposta il livello di dati di utilizzo sul valore consigliato per le dimensioni del progetto. Per la maggior parte dei progetti, tale valore corrisponde a settimane. Se si sceglie di includere i dati a un livello più dettagliato, le prestazioni delle relazioni potranno risultare ridotte. Per ottenere prestazioni ottimali, se si visualizzano contemporaneamente più relazioni per lo stesso progetto, evitare di modificare il livello dei dati. Se si modifica il livello dei dati, è necessario ricreare il database temporaneo di relazioni archiviato localmente. Se non è necessario includere i dati di utilizzo nelle relazioni, impostare il livello di dati su Anni per ottenere prestazioni ottimali.

  4. Fare clic su Visualizza per generare la relazione e aprirla in Excel o Visio.

Modificare un modello di relazione grafica esistente

  1. Nel gruppo Relazioni della scheda Project fare clic su Relazioni grafiche.
    Elemento grafico del gruppo Report

  2. Nella scheda Tutte della finestra di dialogo Relazioni grafiche fare clic sulla relazione che si vuole modificare.

    Suggerimento: se si sa quale categoria contiene la relazione, è possibile fare clic sulla scheda di quella categoria per visualizzare un elenco più breve di relazioni. Se si vuole elencare solo le relazioni aperte in Excel o Visio, selezionare o deselezionare le caselle di controllo Microsoft Excel o Microsoft Visio.

  3. Fare clic su Modifica modello.

  4. Nella finestra di dialogo Relazioni grafiche - Selezione campi fare clic sui campi che si vuole aggiungere o rimuovere dalla relazione e quindi fare clic su Aggiungi, Rimuovi o Rimuovi tutto per spostare i campi tra le caselle Campi disponibili e Campi selezionati o tra le caselle Campi personalizzati disponibili e Campi personalizzati selezionati.

    I campi nelle caselle Campi selezionati e Campi personalizzati selezionati verranno inclusi nella relazione.

  5. Fare clic su Modifica modello per creare la relazione con l'elenco di campi modificato.

  • Nella finestra di dialogo Relazioni grafiche - Selezione campi alcuni campi sono identificati come dimensioni. È importante selezionare meno di sei dimensioni per la relazione. Se si selezionano più di sei dimensioni, le prestazioni della relazione vengono notevolmente ridotte.

  • Non tutti i campi sono disponibili in tutte le relazioni. Alcuni campi sono disponibili solo nelle relazioni di Visio, ma non nelle relazioni di Excel.

  • Se non si riesce a trovare il campo che si vuole includere nella finestra di dialogo Relazioni grafiche - Selezione campi, è possibile che sia archiviato in un'altra categoria di dati. Ad esempio, molti campi che si potrebbero pensare come campi di Riepilogo attività sono in realtà campi di Riepilogo assegnazioni.

Creare un nuovo modello di relazione grafica

  1. Nel gruppo Relazioni della scheda Project fare clic su Relazioni grafiche.
    Elemento grafico del gruppo Report

  2. Nella finestra di dialogo Relazioni grafiche fare clic su Nuovo modello.

  3. Nella sezione Selezione applicazione fare clic su Excel per creare un modello di Excel oppure fare clic su Visio (unità metriche) per creare un modello di Visio.

  4. Nella sezione Selezione tipo di dati selezionare il tipo di dati che si vuole usare nella relazione.

    Per includere i dati rapportati alla scala cronologica selezionare Gestione attività, Uso risorse o Uso assegnazioni nell'elenco della sezione Selezione tipo di dati.

  5. Fare clic su Selezione campi.

  6. Nella finestra di dialogo Relazioni grafiche - Selezione campi tenere premuto CTRL e fare clic sui campi predefiniti di Project che si vuole aggiungere alla relazione nella casella Campi disponibili.

  7. Fare clic su Aggiungi per spostarli nella casella Campi selezionati.

  8. Tenere premuto CTRL e fare clic sui campi personalizzati che si vuole aggiungere alla relazione nella casella Campi personalizzati disponibili.

  9. Fare clic su Aggiungi per spostarli nella casella Campi personalizzati selezionati.

  • Se è installata la versione inglese di Office Project 2007, sarà possibile creare un modello di Visio che usa unità statunitensi.

  • Per rimuovere un campo dalla relazione, nella finestra di dialogo Relazioni grafiche - Selezione campi fare clic sul campo nella casella Campi selezionati o Campi personalizzati selezionati e quindi fare clic su Rimuovi. Per rimuovere tutti i campi predefiniti o personalizzati dalla relazione, fare clic su Rimuovi tutto nella sezione Seleziona campi o Seleziona campi personalizzati.

  • Non tutti i campi sono disponibili in tutte le relazioni. Alcuni campi sono disponibili solo nelle relazioni di Visio e non nelle relazioni di Excel.

  • Se non si riesce a trovare il campo che si vuole includere nella finestra di dialogo Relazioni grafiche - Selezione campi, è possibile che sia archiviato in un'altra categoria di dati. Ad esempio, molti campi che si potrebbero pensare come campi di Riepilogo attività sono in realtà campi di Riepilogo assegnazioni.

  • Nella finestra di dialogo Relazioni grafiche - Selezione campi alcuni campi sono identificati come dimensioni. È importante selezionare meno di sei dimensioni per la relazione. Se si selezionano più di sei dimensioni, le prestazioni della relazione vengono notevolmente ridotte.

  • Al termine della creazione della relazione grafica, è possibile scegliere se salvarla nel percorso predefinito dei modelli (c:\Program Files\Microsoft Office\Templates) o in un altro percorso nel computer o in rete. I modelli salvati nel percorso predefinito dei modelli vengono visualizzati automaticamente nella finestra di dialogo Relazioni grafiche - Creazione relazione.

  • Se si inizia a usare un Language Pack diverso dopo aver salvato un modello di relazione grafica personalizzato, il modello rimane disponibile ma non viene popolato. I nomi dei campi originali non vengono riconosciuti nella nuova lingua e non vengono inclusi nella relazione.

Esportare i dati della relazione

È possibile selezionare dati specifici da esportare all'interno di una categoria (cubo OLAP) oppure è possibile esportare tutti i dati del progetto come un database di relazioni.

Esportare i dati come cubo OLAP

  1. Nel gruppo Relazioni della scheda Project fare clic su Relazioni grafiche.
    Elemento grafico del gruppo Report

  2. Nella finestra di dialogo Relazioni grafiche fare clic su Salva dati.

  3. Nella sezione Salvataggio cubo relazioni selezionare la categoria che contiene il tipo di dati che si vuole salvare.

  4. Fare clic su Selezione campi per modificare i campi inclusi nell'elenco di dati da esportare.

  5. Nella finestra di dialogo Relazioni grafiche - Selezione campi fare clic sui campi che si vuole aggiungere o rimuovere dall'elenco di dati da esportare e quindi fare clic su Aggiungi, Rimuovi o Rimuovi tutto per spostare i campi tra le caselle Campi disponibili e Campi selezionati o tra le caselle Campi personalizzati disponibili e Campi personalizzati selezionati.

    I campi nelle caselle Campi selezionati e Campi personalizzati selezionati verranno inclusi nei dati esportati.

  6. Fare clic su OK nella finestra di dialogo Relazioni grafiche - Selezione campi e quindi fare clic su Salva cubo.

  7. Selezionare il percorso in cui salvare i dati del cubo e quindi fare clic su Salva.

  • I dati del cubo vengono salvati come file cub.

  • Quando si accede ai dati del cubo con Visio, il file cub non può essere archiviato in una condivisione di rete.

Esportare i dati come un database di relazioni

  1. Nel gruppo Relazioni della scheda Project fare clic su Relazioni grafiche.
    Elemento grafico del gruppo Report

  2. Nella finestra di dialogo Relazioni grafiche fare clic su Salva dati.

  3. Fare clic su Salva database.

  4. Selezionare il percorso in cui salvare il database e quindi fare clic su Salva.

    I dati vengono salvati come file di database di Microsoft Office Access (mdb).

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×