Creare un report semplice

In Access è possibile creare un'ampia gamma di report diversi con vari livelli di complessità. Prima di tutto è importante definire un'origine record per il report. Indipendentemente dal fatto che il report sia un semplice elenco di record oppure un riepilogo di dati sulle vendite raggruppati per zona, è necessario individuare i campi che includono i dati da visualizzare nel report, nonché le tabelle o query in cui sono memorizzati.

Dopo aver scelto l'origine record, per semplificare la creazione del report è consigliabile usare la Creazione guidata Report, una caratteristica di Access che visualizza una serie di domande e genera un report in base alle risposte fornite dall'utente.

Per saperne di più

Scegliere un'origine record

Creare un report con lo strumento Report

Creare un report con la Creazione guidata Report

Creare etichette con la Creazione guidata Etichetta

Creare un report con lo strumento Report vuoto

Informazioni sulle sezioni dei report

Informazioni sui controlli

Ottimizzare il report in visualizzazione Layout

Ottimizzare il report in visualizzazione Struttura

Aggiungere controlli al report

Salvare i dati

Visualizzare, stampare o inviare il report come messaggio di posta elettronica

Visualizzare il report

Stampare il report

Inviare il report come messaggio di posta elettronica

Scegliere un'origine record

Un report è costituito da informazioni estratte da tabelle o query e da informazioni archiviate nella struttura del report, come etichette, intestazioni ed elementi grafici. Le tabelle o query contenenti i dati sottostanti sono note anche come origine record del report. Se i campi da includere sono tutti presenti in un'unica tabella, usare quest'ultima come origine record. Se invece i campi sono contenuti in più tabelle, come origine record occorre usare una o più query. Le query potrebbero essere già presenti nel database o potrebbe essere necessario creare nuove query specifiche in base alle particolari esigenze del report.

Creare un report con lo strumento Report

Lo strumento Report è il modo più rapido per creare un report perché lo genera automaticamente senza richiedere alcuna informazione. Nel report vengono visualizzati tutti i campi della tabella o query sottostante. Il report creato con questo strumento potrebbe non avere un aspetto finale perfetto, ma consente di vedere rapidamente i dati sottostanti. Potrà poi essere salvato e modificato in visualizzazione Layout o Struttura in base alle specifiche esigenze.

  1. Nel riquadro di spostamento fare clic sulla tabella o query su cui basare il report.

  2. Nel gruppo Report della scheda Crea fare clic su Report. Icona del pulsante

    Access crea il report e lo apre in visualizzazione Layout.

  3. Per altre informazioni su come visualizzare e stampare il report, vedere la sezione Visualizzare, stampare o inviare il report come messaggio di posta elettronica.

Dopo aver visualizzato il report, è possibile salvarlo e quindi chiudere sia il report che la tabella o query sottostante usata come origine record. Alla successiva apertura del report, verranno visualizzati i dati più recenti disponibili nell'origine record.

Creare un report con la Creazione guidata Report

Per scegliere in modo più selettivo i campi da visualizzare nel report, si può usare la Creazione guidata report. È anche possibile specificare come raggruppare e ordinare i dati, nonché usare i campi di più tabelle o query, a condizione che le relazioni tra le tabelle e le query siano state specificate in precedenza.

  • Nel gruppo Report della scheda Crea fare clic su Creazione guidata Report.

  • Seguire le istruzioni visualizzate nelle pagine della Creazione guidata Report. Nell'ultima pagina fare clic su Fine.

    Quando si visualizza il report in anteprima è possibile vedere quale sarà l'aspetto del report una volta stampato. Si può anche fare zoom avanti per ingrandire e vedere meglio i dettagli. Per altre informazioni su come visualizzare e stampare il report, vedere la sezione Visualizzare, stampare o inviare il report come messaggio di posta elettronica.

Nota : Se si vogliono includere nel report i campi da più tabelle e query, non fare clic su Avanti o Fine dopo aver selezionato i campi della prima tabella o query nella prima pagina della Creazione guidata Report. Ripetere invece i passaggi per selezionare una tabella o una query e quindi fare clic su ogni campo aggiuntivo da includere nel report. Fare quindi clic su Avanti o su Fine per continuare.

Creare etichette con la Creazione guidata Etichetta

Usare la Creazione guidata Etichetta per creare in modo semplice e rapido etichette di varie dimensioni standard.

  1. Nel riquadro di spostamento fare doppio clic sulla tabella o query che costituirà l'origine record per le etichette per aprirla.

  2. Nel gruppo Report della scheda Crea fare clic su Etichette.

  3. Seguire le istruzioni visualizzate nelle pagine della Creazione guidata Etichetta. Nell'ultima pagina fare clic su Fine.

Access visualizza le etichette in Anteprima di stampa, ovvero come verranno riprodotte in stampa. È possibile usare il dispositivo di scorrimento sulla barra di stato di Access per eseguire lo zoom avanti e ingrandire i dettagli. Per altre informazioni su come visualizzare e stampare il report, vedere la sezione Visualizzare, stampare o inviare il report come messaggio di posta elettronica.

Nota : La visualizzazione Anteprima di stampa è l'unica che consente di vedere più colonne perché le altre visualizzazioni mostrano i dati in una singola colonna.

Creare un report con lo strumento Report vuoto

Se non si vuole usare lo strumento Report o la Creazione guidata Report, è possibile usare lo strumento Report vuoto per creare un report ex novo. Questo strumento consente di creare rapidamente un report, soprattutto se si intende includervi solo pochi campi. Eccome come usare lo strumento Report vuoto:

  • Nel gruppo Report della scheda Crea fare clic su Report vuoto. Icona del pulsante

    Verrà aperto un report vuoto in visualizzazione Layout e sul lato destro della finestra di Access verrà visualizzato il riquadro Elenco campi.

  • Nel riquadro Elenco campi fare clic sul segno più (+) accanto alla tabella o alle tabelle che contengono i campi che si vogliono visualizzare nel report.

  • Trascinare i campi desiderati nel report, uno alla volta, oppure tenere premuto CTRL e selezionare più campi, quindi trascinarli contemporaneamente nel report.

  • Usare gli strumenti disponibili nel gruppo Intestazione/piè di pagina della scheda Progettazione per aggiungere un logo, un titolo, i numeri di pagina oppure la data e l'ora al report. Se si usa Access 2007, questi strumenti si trovano nel gruppo Controlli della scheda Formato.

Informazioni sulle sezioni dei report

La struttura di un report in Access è suddivisa in sezioni, che sono visibili nella visualizzazione Struttura del report. Per creare report utili è necessario capire il funzionamento di ogni sezione. Ad esempio, la sezione in cui si sceglie di inserire un controllo calcolato determina il modo in cui Access calcola i risultati. L'elenco seguente mostra un riepilogo dei tipi di sezione e ne illustra l'uso:

  • Intestazione report    Questa sezione viene stampata una sola volta all'inizio del report. Usare l'intestazione di report per includere informazioni che in genere sono riportate su una copertina, ad esempio il logo, il titolo e la data. Se nell'intestazione di report viene inserito un controllo calcolato che usa la funzione di aggregazione Somma, verrà calcolata la somma per l'intero report. L'intestazione di report viene stampata prima dell'intestazione di pagina.

  • Intestazione pagina    Questa sezione viene stampata nella parte superiore di ogni pagina. Ad esempio, usare un'intestazione di pagina per ripetere il titolo del report su ogni pagina.

  • Intestazione gruppo    Questa sezione viene stampata all'inizio di ogni nuovo gruppo di record. Usare l'intestazione gruppo per stampare il nome del gruppo. In un report raggruppato per prodotto usare, ad esempio, l'intestazione gruppo per stampare il nome del prodotto. Se nell'intestazione di gruppo viene inserito un controllo calcolato che usa la funzione di aggregazione Somma, verrà calcolata la somma relativa al gruppo corrente.

  • Corpo    Questa sezione viene stampata una sola volta per ogni riga nell'origine record. In questa sezione vengono inseriti i controlli che compongono la parte principale del report.

  • Piè di pagina gruppo    Questa sezione viene stampata alla fine di ogni gruppo di record. Usare un piè di pagina gruppo per stampare le informazioni di riepilogo per un gruppo.

  • Piè di pagina pagina    Questa sezione viene stampata alla fine di ogni pagina. Usare un piè di pagina della pagina per stampare i numeri di pagina oppure informazioni specifiche per ogni pagina.

  • Piè di pagina report    Questa sezione viene stampata una sola volta alla fine del report. Usare il piè di pagina report per stampare i totali del report oppure altre informazioni di riepilogo per l'intero report.

    Nota : In visualizzazione Struttura il piè di pagina report è posizionato sotto il piè di pagina. Tuttavia, quando si esegue la stampa o l'anteprima del report, il piè di pagina report viene riportato sopra il piè di pagina, subito dopo l'ultimo piè di pagina gruppo oppure l'ultima riga della sezione Corpo nella pagina finale.

Inizio pagina

Informazioni sui controlli

I controlli sono oggetti che visualizzano dati, eseguono azioni e permettono di visualizzare e usare informazioni che migliorano l'interfaccia utente, ad esempio etichette e immagini. Access supporta tre tipi di controlli: associati, non associati e calcolati.

  • Controllo associato    Un controllo la cui origine dati è rappresentata da un campo di una tabella o di una query è detto controllo associato. I controlli associati consentono di visualizzare i valori dei campi del database. I valori possono essere di testo, di data, numerici, valori Sì/No, immagini o grafici. Una casella di testo è il tipo più comune di controllo associato. Ad esempio, una casella di testo in una maschera che visualizza il cognome di un dipendente potrebbe recuperare questa informazione dal campo Cognome della tabella Dipendenti.

  • Controllo non associato    Un controllo che non ha un'origine dati (un campo o un'espressione) è detto controllo non associato. I controlli non associati consentono di visualizzare informazioni, righe, rettangoli e immagini. Un'etichetta contenente il titolo di un report è un esempio di controllo non associato.

  • Controllo calcolato    Un controllo la cui origine dati è rappresentata da un'espressione, anziché da un campo è un controllo calcolato. Si specifica il valore da usare nel controllo definendo un'espressione come origine dei dati per il controllo. Un'espressione è una combinazione di operatori, ad esempio = e +, nomi di controlli, nomi di campi, valori costanti e funzioni che restituiscono un valore. Ad esempio, l'espressione seguente calcola il prezzo di un articolo con uno sconto del 25% moltiplicando il valore contenuto nel campo Prezzo unitario per un valore costante (0,75).

    =[Prezzo unitario] * 0,75

    Un'espressione può usare i dati inclusi in un campo della tabella o della query sottostante del report oppure i dati inclusi in un altro controllo del report.

Quando si crea un report, può risultare più pratico aggiungere e disporre prima i controlli associati, in particolare se costituiscono la maggior parte dei controlli del report. Aggiungere quindi i controlli non associati e calcolati che completano la struttura usando gli strumenti disponibili nel gruppo Controlli della scheda Struttura.

Per associare un controllo a un campo, identificare il campo dal quale il controllo deve recuperare i dati. È possibile creare un controllo associato al campo selezionato trascinando il campo dal riquadro Elenco campi al report. Il riquadro Elenco campi visualizza i campi della tabella o query sottostante del report. Per visualizzare il riquadro Elenco campi, nel gruppo Controlli della scheda Struttura fare clic su Aggiungi campi esistenti.

In alternativa, è possibile associare un campo a un controllo digitando il nome del campo nel controllo stesso oppure nella casella del valore Origine controllo nella finestra delle proprietà del controllo stesso. La finestra delle proprietà definisce le caratteristiche del controllo, ad esempio il nome, l'origine dei dati e il formato.

L'uso del riquadro Elenco campi rappresenta il modo migliore per creare un controllo associato, per due motivi:

  • A un controllo associato è allegata un'etichetta, che prende il nome del campo (o della didascalia definita per quel campo nella tabella o nella query sottostante), evitando all'utente di dover digitare il testo della didascalia.

  • Un controllo associato eredita molte delle impostazioni del campo della tabella o query sottostante (come nel caso delle proprietà Formato, Posizioni decimali e Maschera di input). Di conseguenza, è possibile assicurarsi che queste proprietà per il campo rimangono invariate ogni volta che si crea un controllo associato a tale campo.

Se è già stato creato un controllo non associato e lo si vuole associare a un campo, impostare la proprietà Origine controllo del controllo sul nome del campo. Per informazioni dettagliate sulla proprietà ControlSource, cercare "ControlSource" nella Guida.

Inizio pagina

Ottimizzare il report in visualizzazione Layout

Dopo aver creato un report, è possibile ottimizzarne con facilità la struttura lavorando in visualizzazione Layout. Usando i dati del report effettivo come guida, è possibile modificare le larghezze di colonna, ridisporre le colonne e aggiungere livelli di raggruppamento e totali. È anche possibile posizionare nuovi campi nel report e impostare le proprietà del report e dei relativi controlli.

Per passare alla visualizzazione Layout, fare clic con il pulsante destro del mouse sul report nel riquadro di spostamento e quindi scegliere Visualizzazione Layout Icona del pulsante .

Il report viene aperto in visualizzazione Layout.

È possibile usare la finestra delle proprietà per modificare le proprietà del report e dei relativi controlli e sezioni. Per visualizzare la finestra delle proprietà, premere F4.

È possibile usare il riquadro Elenco campi per aggiungere campi dalla tabella o query sottostante alla struttura del report. Per visualizzare il riquadro Elenco campi, eseguire una delle operazioni seguenti:

  • Nel gruppo Strumenti della scheda Progettazione fare clic su Aggiungi campi esistenti Icona del pulsante . Se si usa Access 2007, il comando Aggiungi campi esistenti si trova nel gruppo Controlli della scheda Formato.

  • Premere ALT+F8.

È quindi possibile aggiungere i campi trascinandoli dal riquadro Elenco campi al report.

Inizio pagina

Ottimizzare il report in visualizzazione Struttura

Si può ottimizzare la struttura del report anche lavorando in visualizzazione Struttura. È possibile aggiungere nuovi controlli e campi al report aggiungendoli alla griglia di struttura. Tramite la finestra delle proprietà è possibile accedere a un gran numero di proprietà che è possibile impostare per personalizzare il report.

Per passare alla visualizzazione Struttura, fare clic con il pulsante destro del mouse sul nome del report nel riquadro di spostamento e scegliere Visualizzazione Struttura Icona del pulsante .

Il report viene aperto in visualizzazione Struttura.

È possibile usare la finestra delle proprietà per modificare le proprietà del report e dei controlli e sezioni che contiene. Per visualizzare la finestra delle proprietà, premere F4.

È possibile usare il riquadro Elenco campi per aggiungere campi dalla tabella o query sottostante alla struttura del report. Per visualizzare il riquadro Elenco campi, eseguire una delle operazioni seguenti:

  • Nel gruppo Controlli della scheda Formato fare clic su Aggiungi campi esistenti Icona del pulsante . Se si usa Access 2007, il comando Aggiungi campi esistenti si trova nel gruppo Controlli della scheda Formato.

  • Premere ALT+F8.

È quindi possibile aggiungere i campi trascinandoli dal riquadro Elenco campi al report.

Inizio pagina

Aggiungere campi dal riquadro Elenco campi

  • Per aggiungere un singolo campo, trascinarlo dal riquadro Elenco campi nella sezione in cui lo si vuole visualizzare nel report.

  • Per aggiungere contemporaneamente diversi campi, tenere premuto CTRL e fare clic sui campi desiderati. Quindi, trascinare i campi selezionati nel report.

Quando si rilasciano i campi in una sezione di report, Access crea un controllo casella di testo associato per ogni campo e inserisce automaticamente un controllo etichetta accanto a ogni campo.

Inizio pagina

Aggiungere controlli al report

Alcuni controlli vengono creati automaticamente, ad esempio il controllo casella di testo associato che viene creato quando si aggiunge un campo dal riquadro Elenco campi al report. In visualizzazione Struttura è possibile creare molti altri controlli usando gli strumenti disponibili nel gruppo Controlli della scheda Struttura.

Determinare il nome di uno strumento

  • Posizionare il puntatore del mouse sullo strumento.

    Viene visualizzato il nome dello strumento.

Creare un controllo con gli strumenti disponibili nel gruppo Controlli

  1. Fare clic sullo strumento corrispondente al tipo di controllo che si vuole aggiungere. Ad esempio, per creare una casella di controllo, fare clic sullo strumento Casella di controllo Icona del pulsante .

  2. Fare clic nella griglia di struttura del report nel punto in cui si vuole posizionare l'angolo superiore sinistro del controllo. Fare clic una volta per creare un controllo con dimensioni predefinite oppure fare clic sullo strumento e quindi trascinare il mouse nella griglia di struttura del report per creare un controllo con le dimensioni desiderate.

  3. Se al primo tentativo non si riesce a posizionare il controllo perfettamente, è possibile spostarlo usando la procedura seguente:

    1. Fare clic sul controllo per selezionarlo.

    2. Posizionare il puntatore del mouse sul bordo del controllo finché non assume la forma di una freccia a quattro punte Puntatore Sposta .

    3. Trascinare il controllo nella posizione desiderata.

In questo modo viene creato un controllo "non associato". Se il controllo è del tipo che consente la visualizzazione di dati, ad esempio una casella di testo o una casella di controllo, è necessario immettere un nome di campo o un'espressione nella proprietà ControlSource prima che i dati possano essere visualizzati. Per altre informazioni, vedere la sezione Informazioni sui controlli in questo argomento.

Visualizzare la finestra delle proprietà

Per visualizzare la finestra delle proprietà in visualizzazione Struttura, eseguire una delle operazioni seguenti:

  • Nel gruppo Strumenti della scheda Progettazione fare clic su Finestra delle proprietà. Se si usa Access 2007, il comando Finestra delle proprietà si trova nel gruppo Mostra/Nascondi della scheda Struttura.

  • Premere F4.

Inizio pagina

Salvare i dati

Dopo aver salvato la struttura del report, sarà possibile eseguire il report quando necessario. La struttura del report non cambia, ma ogni volta che il report viene stampato o visualizzato vengono recuperati dati aggiornati. Nel momento in cui le esigenze relative ai report dovessero cambiare, sarà possibile modificare la struttura del report o creare un nuovo report simile basato sull'originale.

Salvare la struttura del report

  • Fare clic su File > Salva o premere CTRL+S. Se si usa Access 2007, fare clic sul pulsante Microsoft Office e quindi su Salva oppure premere CTRL+S.

    In alternativa, fare clic su Salva Icona del pulsante sulla barra di accesso rapido.

  • Se al report non è stato assegnato un titolo, digitare un nome nella casella Nome report e quindi fare clic su OK.

Salvare la struttura del report con un nuovo nome

  • Se si usa Access 2013 o versione successiva, fare clic su File > Salva con nome > Salva oggetto con nome.

    Se si usa Access 2010, fare clic su File > Salva oggetto con nome.

    Se si usa Access 2007, fare clic sul pulsante Microsoft Office e quindi su Salva con nome > Salva oggetto con nome.

  • Nella finestra di dialogo Salva con nome digitare un nome per il nuovo report nella casella Salva report come e quindi fare clic su OK.

Inizio pagina

Visualizzare, stampare o inviare il report come messaggio di posta elettronica

Dopo aver salvato la struttura del report, è possibile riutilizzarla più volte. La struttura del report non cambia, ma ogni volta che il report viene visualizzato o stampato verranno recuperati i dati aggiornati. Nel momento in cui le esigenze relative ai report dovessero cambiare, sarà possibile modificare la struttura del report o creare un nuovo report simile basato sull'originale.

Visualizzare il report

Esistono diversi modi per visualizzare i report. Il metodo da scegliere dipende da come verranno usati il report e i relativi dati:

  • Se si vogliono apportare modifiche temporanee ai dati visualizzati nel report prima di stamparlo oppure copiare i dati del report negli Appunti, usare la visualizzazione Report.

  • Per poter modificare la struttura del report mentre si osservano i dati, usare la visualizzazione Layout.

  • Se si vuole semplicemente controllare come verrà stampato il report, usare Anteprima di stampa.

Nota : Se il report è formattato con più colonne, il layout a colonne sarà visibile solo in Anteprima di stampa. Nelle visualizzazioni Layout e Report il report viene visualizzato con una sola colonna.

Aprire il report in visualizzazione Report

La visualizzazione Report è la visualizzazione predefinita che viene usata quando si fa doppio clic su un report nel riquadro di spostamento. Se il report non è aperto, fare doppio clic su di esso nel riquadro di spostamento per aprirlo in visualizzazione Report.

Se il report è già aperto, fare clic con il pulsante destro del mouse sul nome del report nel riquadro di spostamento e scegliere Visualizzazione report.

Usare i dati in visualizzazione Report

In visualizzazione Report è possibile selezionare il testo e copiarlo negli Appunti. Per selezionare intere righe, fare clic e trascinare il puntatore del mouse lungo il margine accanto alle righe da selezionare. Per copiare le righe selezionate negli Appunti, eseguire una delle operazioni seguenti:

  1. Nel gruppo Appunti della scheda Home fare clic su Copia. Icona del pulsante

  2. Fare clic con il pulsante destro del mouse sulle righe selezionate e scegliere Copia.

  3. Usare le scelte rapide da tastiera - Premere CTRL+C.

Usare i filtri per visualizzare solo determinate righe

È possibile applicare filtri direttamente al report senza uscire dalla visualizzazione Report. Ad esempio, se è presente una colonna "Paese" e si vogliono visualizzare solo le righe in cui il paese è "Canada", seguire questa procedura:

  1. Trovare la parola "Canada" nel report e fare clic con il pulsante destro del mouse su di essa.

  2. Fare clic su Uguale a "Canada".

Access crea e applica il filtro.

Attivare e disattivare un filtro

Per passare dalla visualizzazione filtrata a quella non filtrata, è possibile fare clic su Attiva/disattiva filtro nel gruppo Ordina e filtra della scheda Home. In questo modo il filtro non viene rimosso, ma solo attivato e disattivato.

Rimuovere un filtro

  1. Fare clic sul campo da cui si vuole rimuovere il filtro.

  2. Fare clic su Cancella filtro da <nome campo>. (nome campo è il segnaposto per il campo effettivo).

Dopo la rimozione di un filtro, non è possibile riattivarlo con il comando Attiva/disattiva filtro. Se necessario, il filtro deve essere creato nuovamente.

Nota : Se si applica un filtro a un report e quindi si salva e si chiude il report, il filtro verrà salvato con il report. Alla successiva apertura del report, però, il filtro non viene applicato automaticamente. Per riapplicare il filtro, nel gruppo Ordina e filtra della scheda Home fare clic su Attiva/disattiva filtro.

Visualizzare il report in Anteprima di stampa

Fare clic con il pulsante destro del mouse sul report nel riquadro di spostamento e scegliere Anteprima di stampa dal menu di scelta rapida.

Per visualizzare le pagine di un report in modo sequenziale o passare a una pagina specifica del report, è possibile usare i pulsanti di spostamento.

Pulsanti di spostamento

1. Fare clic per visualizzare la prima pagina.

2. Fare clic per visualizzare la pagina precedente.

3. Fare clic per visualizzare la pagina successiva.

4. Fare clic per visualizzare l'ultima pagina.

5. Digitare un numero di pagina in questa casella e quindi premere INVIO per passare a una pagina specifica.

In Anteprima di stampa è possibile ingrandire la visualizzazione del report per esaminarne i dettagli oppure ridurla per verificare il corretto posizionamento dei dati sulla pagina. Verificare che il cursore sia posizionato sul report e fare clic una volta. Per annullare l'ingrandimento, fare di nuovo clic. Si può anche usare il controllo Zoom sulla barra di stato di Access per fare ulteriormente zoom avanti o indietro.

Per chiudere l'anteprima di stampa, eseguire una delle operazioni seguenti:

  • Nella scheda Anteprima di stampa fare clic su Chiudi anteprima di stampa.

  • Fare clic con il pulsante destro del mouse sul report nel riquadro di spostamento e scegliere Visualizzazione Layout Icona del pulsante o Visualizzazione Struttura Icona del pulsante dal menu di scelta rapida.

Suggerimento : Dopo aver visualizzato il report in anteprima, è possibile esportare i risultati in Microsoft Word, Microsoft Excel o in altre applicazioni di Office. Nel gruppo Esporta della scheda Dati esterni fare clic sul pulsante corrispondente al formato desiderato e quindi seguire le istruzioni.

Inizio pagina

Stampare il report

È possibile stampare un report aperto in qualsiasi visualizzazione e anche un report chiuso. Prima di stampare, verificare le impostazioni di pagina, come i margini o l'orientamento della pagina. Access salva le impostazioni della pagina con il report, quindi è sufficiente configurarle una sola volta. Le impostazioni possono comunque essere modificate in seguito, se necessario.

Modificare le impostazioni della pagina

  1. Aprire il report in Anteprima di stampa. È possibile modificare le impostazioni di pagina in qualsiasi visualizzazione, ma Anteprima di stampa è la scelta migliore perché permette di vedere subito l'effetto delle modifiche.

  2. Nei gruppi Layout di pagina e Dimensioni pagina della scheda Anteprima di stampa fare clic su Verticale Icona del pulsante o Orizzontale Icona del pulsante per impostare l'orientamento della pagina, su Dimensioni Icona del pulsante per impostare il formato della carta, su Margini Icona del pulsante per regolare i margini e così via.

  3. Dopo aver apportato una modifica, usare i pulsanti di spostamento per visualizzare altre pagine e verificare di non avere creato problemi di formattazione nelle pagine successive.

Inviare il report a una stampante

  1. Aprire il report in qualsiasi visualizzazione o selezionarlo nel riquadro di spostamento.

  2. Fare clic su File > Stampa > Stampa. Se si usa Access 2007, fare clic sul pulsante Microsoft Office e quindi su Stampa > Stampa.

    Access visualizza la finestra di dialogo Stampa.

  3. Immettere le opzioni preferite riguardo la stampante, l'intervallo di stampa e il numero di copie.

  4. Fare clic su OK.

Inizio pagina

Inviare il report come messaggio di posta elettronica

È possibile inviare il report ai destinatari come messaggio di posta elettronica invece di stampare una copia cartacea:

  1. Nel riquadro di spostamento fare clic sul report per selezionarlo. Nel gruppo Esporta della scheda Dati esterni fare clic su Posta elettronica. Se si usa Access 2007, nel riquadro di spostamento fare clic sul report per selezionarlo, fare clic sul pulsante Microsoft Office e quindi su Posta elettronica.

  2. Nell'elenco Selezionare un formato di output della finestra di dialogo Invia oggetto come fare clic sul formato di file da usare.

  3. Completare le eventuali finestre di dialogo rimanenti.

  4. Nel programma di posta elettronica digitare i dettagli del messaggio e inviarlo.

Inizio pagina

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×