Creare un report con raggruppamenti o di riepilogo

Importante :  Il presente articolo è stato tradotto automaticamente, vedere la dichiarazione di non responsabilità. Per visualizzare la versione inglese dell'articolo, fare clic qui.

La gestione e la comprensione delle informazioni risultano spesso più semplici quando i dati sono suddivisi in gruppi. Ad esempio, un report in cui le vendite sono raggruppate per zona consente di evidenziare tendenze specifiche che altrimenti risulterebbero difficilmente individuabili e analizzabili. Inoltre, l'inserimento dei totali in fondo ai gruppi inclusi nel report consente di velocizzare l'analisi dei dati e di evitare l'uso di una calcolatrice.

Microsoft Office Access 2007 semplifica l'uso dei report con raggruppamenti. È infatti possibile creare un report con raggruppamenti di base tramite la Creazione guidata Report, aggiungere opzioni di raggruppamento o ordinamento a un report esistente oppure modificare le opzioni di raggruppamento e ordinamento precedentemente definite.

In questo articolo

Informazioni su raggruppamento, sezioni del report e controlli

Creare un nuovo report con raggruppamenti tramite la Creazione guidata Report

Ottimizzare il report

Aggiungere campi o altri controlli a un report esistente

Aggiungere o modificare le opzioni di raggruppamento e ordinamento in un report esistente

Salvare, stampare o inviare il report

Osservazioni

Informazioni su raggruppamento, sezioni del report e controlli

Se non si ha familiarità con i report con raggruppamenti, è utile avere alcune informazioni sul raggruppamento e l'ordinamento, oltre che sulle diverse sezioni del report e i tipi di controlli. Per acquisire subito dimestichezza con questi concetti, è possibile ignorare questa sezione e passare alla sezione Creare un nuovo report con raggruppamenti tramite la Creazione guidata Report.

Informazioni sul raggruppamento e sull'ordinamento

Quando si stampa un report, in genere si preferisce organizzare i record in un ordine specifico. Ad esempio, se si stampa un elenco di fornitori, è consigliabile ordinare i record in ordine alfabetico in base al nome della società.

Per molti tipi di report, ordinare i record non è sufficiente: è anche consigliabile dividerli in gruppi. Un gruppo è una raccolta di record, insieme a eventuali informazioni introduttive e di riepilogo visualizzate con i record, ad esempio un'intestazione. Un gruppo è costituito da un'intestazione gruppo, gruppi annidati (se presenti), record di dettaglio e un piè di pagina gruppo.

Il raggruppamento consente di separare visivamente i gruppi di record e di visualizzare i dati introduttivi e di riepilogo per ogni gruppo. Ad esempio, il report seguente raggruppa le vendite per data di spedizione e calcola l'importo totale delle vendite per ogni giorno.

Report con raggruppamenti con totali

1. La data introduce il gruppo.

2. Il totale riepiloga il gruppo.

È possibile vedere come funziona il raggruppamento confrontando il report che elenca i Prodotti per categoria (illustrato nella figura seguente) con il foglio dati per la relativa query sottostante, Elenco prodotti. Sia il report che la query ordinano i prodotti per categoria, ma il report stampa anche il nome di ogni categoria su una riga separata all'inizio di ciascun gruppo (nell'intestazione gruppo) e il numero di prodotti per ciascuna categoria su una riga separata alla fine di ogni gruppo (nel piè di pagina gruppo).

Report Prodotti per categoria

1. Il nome della categoria viene visualizzato in ogni riga del foglio dati.

2. Il nome della categoria viene visualizzato una sola volta per ogni gruppo del report, nell'intestazione del gruppo.

3. Il totale per la categoria viene visualizzato alla fine di ogni gruppo, nel piè di pagina gruppo.

4. I record vengono visualizzati come un unico gruppo esteso nel foglio dati.

5. I record per ogni categoria vengono visualizzati come una sezione separata nel report, preceduta da un'intestazione gruppo e seguita da un piè di pagina gruppo.

È possibile eseguire il raggruppamento in base a tutti i campi e le espressioni di cui si esegue l'ordinamento (fino a 10). È possibile eseguire il raggruppamento più volte nello stesso campo o nella stessa espressione. Quando si esegue il raggruppamento in base a più campi o espressioni, Office Access 2007 annida i gruppi in base al relativo livello di gruppo. Il primo campo in base al quale si esegue il raggruppamento è il primo e più significativo livello di gruppo, il secondo campo è il livello di gruppo successivo e così via. La figura seguente mostra in che modo Office Access 2007 annida i gruppi.

Gerarchia intestazione e piè di pagina

1. Ogni intestazione gruppo viene abbinata a un piè di pagina gruppo.

In genere si usa un'intestazione gruppo per visualizzare i dati che identificano il gruppo in una sezione separata al suo inizio. In genere si usa un piè di pagina gruppo per riepilogare i dati nel gruppo in una sezione separata alla sua fine.

Inizio pagina

Informazioni sulle sezioni dei report

In Access, la struttura di un report è divisa in sezioni. Per creare report utili è necessario capire il funzionamento di ogni sezione. Ad esempio, la sezione in cui si sceglie di inserire un controllo calcolato determina la modalità di calcolo dei risultati in Access. L'elenco seguente mostra un riepilogo dei tipi di sezione e delle modalità d'uso.

  • Intestazione report    Stampata una sola volta all'inizio del report. Usare l'intestazione report per le informazioni che potrebbero comparire in genere in un frontespizio, ad esempio un logo o un titolo e una data. L'intestazione report viene stampata prima dell'intestazione pagina. Quando si posiziona un controllo calcolato nell'intestazione report, il valore viene calcolato per l'intero report. Ad esempio, se nell'intestazione report viene inserito un controllo che usa la funzione di aggregazione Somma verrà calcolata la somma relativa all'intero report.

  • Intestazione pagina    Stampata nella parte superiore di ogni pagina. Usare un'intestazione di pagina, ad esempio, per ripetere il titolo del report su ogni pagina.

  • Intestazione gruppo    Stampata all'inizio di ogni nuovo gruppo di record. Usare l'intestazione gruppo per stampare il nome del gruppo. In un report raggruppato per prodotto usare, ad esempio, l'intestazione gruppo per stampare il nome del prodotto. Se nell'intestazione di gruppo viene inserito un controllo calcolato che usa la funzione di aggregazione Somma, verrà calcolata la somma relativa al gruppo corrente.

  • Corpo    Stampato una sola volta per ogni riga nell'origine record. Nella sezione Corpo vengono inseriti i controlli che compongono la parte principale del report.

  • Piè di pagina gruppo    Stampato alla fine di ogni gruppo di record. Usare un piè di pagina gruppo per stampare le informazioni di riepilogo per un gruppo.

  • Piè di pagina    Stampato alla fine di ogni pagina. Usare un piè di pagina per stampare il numero di pagina oppure informazioni specifiche per ogni pagina.

  • Piè di pagina report    Stampato una sola volta alla fine del report. Usare il piè di pagina report per stampare i totali oppure altre informazioni di riepilogo per l'intero report.

    Nota : In visualizzazione Struttura il piè di pagina report è posizionato sotto il piè di pagina. Tuttavia, quando si esegue la stampa o l'anteprima del report, il piè di pagina report viene riportato sopra il piè di pagina, subito dopo l'ultimo piè di pagina gruppo oppure l'ultima riga della sezione Corpo nella pagina finale.

Inizio pagina

Informazioni sui controlli

I controlli sono oggetti che visualizzano dati, eseguono azioni e permettono di visualizzare e usare informazioni che migliorano l'interfaccia utente, ad esempio etichette e immagini. Access supporta tre tipi di controlli: associati, non associati e calcolati. L'elenco seguente mostra un riepilogo di questi controlli e delle modalità d'uso.

  • Controllo associato    Un controllo la cui origine dati è rappresentata da un campo di una tabella o di una query. Si usano i controlli associati per visualizzare valori che provengono da campi del database. I valori possono essere di testo, di data, numerici, valori Sì/No, immagini o grafici. Una casella di testo è il tipo più comune di controllo associato. Ad esempio, una casella di testo in una maschera che visualizza il cognome di un dipendente potrebbe recuperare questa informazione dal campo Cognome della tabella Dipendenti.

  • Controllo non associato    Un controllo che non ha un'origine dei dati. Si usano i controlli non associati per visualizzare informazioni, immagini, linee o rettangoli. Ad esempio, un'etichetta che mostra il titolo di un report è un controllo non associato.

  • Controllo calcolato    Un controllo la cui origine dati è rappresentata da un'espressione, anziché da un campo. Si specifica il valore da usare nel controllo definendo un'espressione come origine dei dati per il controllo. Un'espressione è una combinazione di operatori, ad esempio = e +, nomi di controlli, nomi di campi, valori costanti e funzioni che restituiscono un valore. Ad esempio, l'espressione seguente calcola il prezzo di un articolo con uno sconto del 25% moltiplicando il valore contenuto nel campo Prezzo unitario per un valore costante (0,75).

= [Unit Price] * .75

Un'espressione può usare i dati inclusi in un campo della tabella o della query sottostante del report oppure i dati inclusi in un altro controllo del report.

Quando si crea un report, può risultare più pratico aggiungere e disporre prima i controlli associati, in particolare se costituiscono la maggior parte dei controlli del report. Aggiungere quindi i controlli non associati e calcolati che completano la struttura usando gli strumenti disponibili nel gruppo Controlli della scheda Progettazione.

immagine della barra multifunzione di access

Per associare un controllo a un campo, identificare il campo dal quale il controllo deve recuperare i dati. È possibile creare un controllo associato al campo selezionato trascinando il campo dal riquadro Elenco campi al report. Il riquadro Elenco campi visualizza i campi della tabella o query sottostante del report. Per visualizzare il riquadro Elenco campi, eseguire una delle operazioni seguenti:

  • Nel gruppo Strumenti della scheda Progettazione fare clic su Aggiungi campi esistenti. Callout 4

  • Premere ALT+F8.

Quando si fa doppio clic su un campo o lo si trascina dal riquadro Elenco campi sul report, si crea un controllo associato.

In alternativa, è possibile associare un campo a un controllo digitando il nome del campo nel controllo stesso oppure nella casella del valore Origine controllo nella finestra delle proprietà del controllo stesso. La finestra delle proprietà definisce le caratteristiche del controllo, ad esempio il nome, l'origine dei dati e il formato. Per visualizzare la finestra delle proprietà, premere F4.

L'uso del riquadro Elenco campi rappresenta il modo migliore per creare un controllo associato, per due motivi:

  • A un controllo associato è allegata un'etichetta, che prende il nome del campo (o della didascalia definita per quel campo nella tabella o nella query sottostante), evitando all'utente di dover digitare il testo della didascalia.

  • Un controllo associato eredita molte delle impostazioni del campo della tabella o query sottostante (come nel caso delle proprietà Formato, Posizioni decimali e Maschera di input). Di conseguenza, è possibile assicurarsi che queste proprietà per il campo rimangono invariate ogni volta che si crea un controllo associato a tale campo.

Se si ha già un controllo non associato e lo si vuole associare a un campo, impostare la proprietà Origine controllo del controllo sul nome del campo desiderato.

Inizio pagina

Creare un nuovo report con raggruppamenti tramite la Creazione guidata Report

La Creazione guidata Report visualizza una serie di domande e in base alle risposte immesse dall'utente genera un report. Ad esempio, viene visualizzata una domanda che richiede di specificare il campo o i campi da utilizzare per raggruppare il report. Dopo aver creato il report, è possibile utilizzarlo nella sua struttura originale oppure modificarlo in base alle specifiche esigenze di lavoro. Prima di eseguire la Creazione guidata Report, è tuttavia necessario definire un'origine dati.

Scegliere un'origine record

Un report è costituito da informazioni estratte da una tabella o query e da informazioni archiviate nella struttura del report, come etichette, intestazioni ed elementi grafici. La tabella o query contenente i dati sottostanti è nota anche come origine record del report. Prima di avviare la creazione del report, è consigliabile prima di tutto valutare le informazioni da includere. Tra i campi prescelti devono esserci quelli in base ai quali si vuole eseguire il raggruppamento o il riepilogo. Se i campi da includere sono tutti presenti in un'unica tabella, usare quest'ultima come origine record. Se i campi vengono estratti da più di una tabella, è consigliabile usare una query come origine record. La query potrebbe essere già presente nel database, o potrebbe essere necessario creare una query in modo specifico per soddisfare le esigenze del report.

Per altre informazioni sulle query, fare clic sui collegamenti nella sezione Vedere anche in questo articolo.

Avviare la Creazione guidata Report

  1. Nel gruppo Report della scheda Crea fare clic su Creazione guidata Report. Callout 4

    Verrà avviata la Creazione guidata Report.

    Selezione di campi nella Creazione guidata Report

  2. Fare clic nell'elenco a discesa Tabelle/query e scegliere la tabella o la query contenente i campi che si desidera includere nel report.

  3. Fare doppio clic sui campi nell'elenco Campi disponibili per selezionarli.

    I campi selezionati verranno spostati nell'elenco Campi selezionati. In alternativa, è possibile fare clic sui pulsanti situati tra le caselle Campi disponibili e Campi selezionati per aggiungere o rimuovere il campo selezionato o per aggiungere o rimuovere tutti i campi.

  4. Se in un'altra tabella o query sono inclusi campi che si desidera inserire nel report, fare nuovamente clic nell'elenco a discesa Tabelle/query, scegliere l'altra tabella o query e continuare ad aggiungere i campi desiderati.

  5. Dopo aver aggiunto tutti i campi, fare clic su Avanti.

Raggruppare i record nella Creazione guidata Report

Il raggruppamento consente di organizzare e disporre i record in base a gruppi specifici, ad esempio per zona o venditore. I gruppi possono essere annidati in modo da semplificare le relazioni tra gruppi e velocizzare la ricerca delle informazioni. È anche possibile usare il raggruppamento per calcolare informazioni di riepilogo, ad esempio totali e percentuali.

Se in un report vengono incluse più tabelle, la procedura guidata analizza le relazioni tra le tabelle e determina la possibile modalità di visualizzazione.

  1. Quando viene visualizzato il messaggio Aggiungere livelli di gruppo? durante la Creazione guidata Report, fare clic su uno dei nomi di campo nell'elenco e quindi su Avanti.

  2. Per aggiungere livelli di gruppo, fare doppio clic su un qualsiasi nome di campo nell'elenco per aggiungerlo al report.

    Per rimuovere un livello di gruppo, fare doppio clic su di esso nella visualizzazione di pagina a destra della finestra di dialogo. Usare i tasti di direzione per aggiungere e rimuovere i livelli di gruppo e modificare la priorità di un livello di gruppo selezionandolo e facendo clic sui pulsanti per lo spostamento verso l'alto o verso il basso nell'ordine di priorità. I singoli livelli di gruppo vengono aggiunti e annidati all'interno del relativo livello di gruppo padre.

    aggiunta di livelli di raggruppamento nella creazione guidata report

  3. Fare clic su Opzioni raggruppamento per visualizzare la finestra di dialogo Intervalli di raggruppamento.

    Intervalli di raggruppamento nella Creazione guidata Report

  4. Facoltativamente, scegliere un intervallo di raggruppamento per ogni campo nei livelli di gruppo.

    Gli intervalli di raggruppamento consentono di personalizzare la modalità di raggruppamento dei record. Nell'illustrazione precedente i record sono raggruppati in base al campo Data spedizione, ovvero un campo il cui tipo di dati è Data/ora. Durante la procedura guidata vengono visualizzate le selezioni appropriate per il tipo di campo nell'elenco Intervalli di raggruppamento. Pertanto, poiché il tipo di dati del campo Data spedizione è Data/ora, è possibile scegliere di eseguire il raggruppamento in base al valore effettivo (Normale), Anno, Trimestre, Mese, Settimana, Giorno, Ora e Minuto. Se invece il tipo di dati del campo è Testo, è possibile scegliere di eseguire il raggruppamento in base all'intero campo (Normale) oppure in base ai primi cinque caratteri. Per un campo con tipo di dati numerico, è possibile scegliere di eseguire il raggruppamento in base al valore (Normale) oppure in base all'intervallo negli incrementi selezionati.

    Dopo aver selezionato l'intervallo di raggruppamento, fare clic su OK.

  5. Fare clic su Avanti per passare alla pagina successiva della procedura guidata.

Ordinare e riepilogare i record

È possibile ordinare i record in base a un massimo di quattro campi in ordine crescente o decrescente.

  1. Fare clic sul primo elenco a discesa e scegliere un campo in base al quale eseguire l'ordinamento.

    È possibile fare clic sul pulsante a destra dell'elenco per alternare la modalità di ordinamento crescente e decrescente (l'opzione di ordinamento predefinita è Crescente). Facoltativamente, fare clic sul secondo, terzo e quarto elenco a discesa per scegliere i campi di ordinamento aggiuntivi.

    Tipi di ordinamento nella Creazione guidata Report

  2. Fare clic su Opzioni di riepilogo se si desidera riepilogare i campi numerici.

    Si noti che il pulsante Opzioni di riepilogo verrà visualizzato solo se sono presenti più campi numerici nella sezione Corpo del report. Nella Creazione guidata Report verranno visualizzati i campi numerici disponibili.

    Opzioni di riepilogo nella Creazione guidata Report

  3. Selezionare la casella di controllo corrispondente a Somma, Media, Min o Max per includere i relativi calcoli nel piè di pagina di gruppo.

    È inoltre possibile scegliere di visualizzare i dettagli e il riepilogo oppure solo il riepilogo. Nel secondo caso, verranno visualizzati i totali per ogni valore di Data spedizione se, ad esempio, è stata selezionata la casella di controllo corrispondente a Somma. Vengono tuttavia omessi i dettagli relativi all'ordine. È inoltre possibile scegliere di visualizzare la percentuale dei totali complessivi per le somme.

  4. Fare clic su OK.

  5. Seguire le istruzioni visualizzate nelle pagine rimanenti della procedura guidata. Nell'ultima pagina è possibile modificare il titolo del report. Il titolo verrà visualizzato sulla prima pagina del report e sarà utilizzato da Access come nome del documento durante il salvataggio del report. È possibile modificare il titolo e il nome del documento in un secondo momento.

  6. Fare clic su Fine. Il report verrà automaticamente salvato e visualizzato in anteprima di stampa, ovvero il report viene visualizzato come sarà riprodotto in stampa.

È possibile utilizzare i pulsanti di spostamento nella parte inferiore del riquadro di anteprima per visualizzare le pagine del report in ordine sequenziale oppure passare a pagine specifiche del report. Fare clic su uno dei pulsanti di spostamento oppure immettere il numero della pagina che si desidera visualizzare nella casella del numero di pagina e quindi premere INVIO.

Nella visualizzazione Anteprima di stampa è possibile ingrandire i dettagli oppure ridurre la visualizzazione per verificare il corretto posizionamento dei dati sulla pagina. Verificare che il puntatore del mouse sia posizionato sul report e fare clic. Per annullare l'ingrandimento, fare di nuovo clic. È inoltre possibile utilizzare il controllo Zoom sulla barra di stato.

Inizio pagina

Ottimizzare il report

È probabile che la Creazione guidata Report non produca i risultati voluti nel report. Ad esempio, si potrebbe voler aggiungere testo, modificare la larghezza, aggiungere un logo e così via. Access include due visualizzazioni in cui è possibile apportare modifiche al report: la visualizzazione Layout e la visualizzazione Struttura. Le visualizzazioni saranno illustrate brevemente in questa sezione.

Informazioni sulla visualizzazione Layout

La visualizzazione Layout è la più facile da usare per apportare modifiche al report perché contiene la maggior parte degli strumenti necessari per ottimizzarlo. È possibile regolare la larghezza delle colonne, ridisporre le colonne e aggiungere o modificare i livelli di gruppo e totali. È anche possibile posizionare nuovi campi nella struttura del report e impostare le proprietà del report e dei relativi controlli. Il vantaggio della visualizzazione Layout è che è possibile visualizzare i dati mentre si apportano modifiche al formato del report, in modo da visualizzare immediatamente come le modifiche apportate influiscono sulla visualizzazione dei dati.

Per aprire un report in visualizzazione Layout fare clic con il pulsante destro del mouse su di esso nel riquadro di spostamento e quindi scegliere Visualizzazione Layout Callout 4 .

È possibile usare la finestra delle proprietà per modificare le proprietà del report e dei relativi controlli e sezioni. Per visualizzare la finestra delle proprietà, premere F4.

È possibile usare il riquadro Elenco campi per aggiungere campi dalla tabella o dalla query sottostante alla struttura del report. Per visualizzare il riquadro Elenco campi:

  1. Nel gruppo Controlli della scheda Formato fare clic su Aggiungi campi esistenti Callout 4 .

    Suggerimento :  Access 2010 include nuove funzionalità di formattazione condizionale che consentono di migliorare sensibilmente la leggibilità di un report.

Informazioni sulla visualizzazione Struttura

Se non è possibile apportare modifiche specifiche al report in visualizzazione Layout, provare la visualizzazione Struttura. La visualizzazione Struttura mostra la struttura di base del report e fornisce alcuni altri strumenti e funzionalità di progettazione rispetto alla visualizzazione Layout. Ad esempio, è possibile inserire una più ampia varietà di controlli nel report, modificare l'allineamento dei controlli con maggiore precisione e avere la possibilità di impostare altre proprietà rispetto alla visualizzazione Layout.

Per aprire un report in visualizzazione Struttura fare clic con il pulsante destro del mouse su di esso nel riquadro di spostamento e quindi scegliere Visualizzazione Struttura Callout 4 .

Inizio pagina

Aggiungere campi o altri controlli a un report esistente

Ogni campo, etichetta, riga o immagine che viene visualizzato nel report viene creato usando un tipo di controllo. Il controllo usato più spesso in un report è la casella di testo, in genere usata per visualizzare i dati dall'origine record sottostante del report. È possibile creare caselle di testo che sono già associate ai campi nell'origine record aggiungendo i campi dal riquadro Elenco campi oppure è possibile aggiungerli al report mentre si lavora in visualizzazione Struttura (ma è necessario "associarli" ai campi nell'origine record personalmente). Il vantaggio della visualizzazione Struttura è che è possibile aggiungere molti altri tipi di controlli oltre alle caselle di testo associate, ad esempio rettangoli, interruzioni di pagina e grafici. Questa sezione descrive entrambi i metodi di aggiunta dei controlli a un report.

Aggiungere campi a un report esistente

La visualizzazione Layout è quella consigliata per aggiungere campi a un report, ma questa operazione può anche essere eseguita in visualizzazione Struttura. Per aggiungere un campo, assicurarsi prima che sia visualizzato il riquadro Elenco campi. Il riquadro Elenco campi contiene un elenco di tutti i campi disponibili da inserire nel report. Per visualizzare il riquadro Elenco campi, premere ALT+F8.

Aggiungere campi dal riquadro Elenco campi

  • Per aggiungere un singolo campo, trascinarlo dal riquadro Elenco campi nella sezione del report in cui lo si vuole visualizzare.

  • Per aggiungere contemporaneamente diversi campi, fare clic sul primo campo desiderato e, tenendo premuto CTRL, fare clic sui campi da aggiungere. Quindi, trascinare i campi selezionati nel report.

Quando si rilasciano i campi, Access crea un controllo casella di testo associato per ogni campo e inserisce automaticamente un controllo etichetta accanto a ogni campo.

Nota : 

  • Se si aggiunge un campo da una tabella correlata, Access aggiungerà automaticamente il livello di raggruppamento appropriato.

  • Se si aggiunge un campo da un'altra tabella (non correlata), in Access viene visualizzata una finestra di dialogo in cui è possibile specificare come correlare la tabella all'origine dati esistente per il report.

Per visualizzare le relazioni tra tabelle già specificate per il database o per aggiungerne di nuove:

  1. Nel gruppo Mostra/Nascondi della scheda Strumenti database fare clic su Relazioni. Callout 4

Per altre informazioni, vedere l'articolo Creare, modificare o eliminare una relazione.

Aggiungere altri controlli a un report esistente

Quando si aggiunge un campo dal riquadro Elenco campi al report, viene creato automaticamente un controllo casella di testo associato. È possibile aggiungere altri controlli, ad esempio etichette, righe e immagini, passando alla visualizzazione Struttura e usando gli strumenti disponibili nel gruppo Controlli nella scheda Progettazione.

immagine della barra multifunzione di access

Determinare il nome di uno strumento

  • Posizionare il puntatore del mouse sullo strumento.

    Viene visualizzato il nome dello strumento.

Creare un controllo con gli strumenti disponibili nel gruppo Controlli

  • Fare clic sullo strumento corrispondente al tipo di controllo che si vuole aggiungere. Ad esempio, per creare una casella di controllo, fare clic sullo strumento Casella di controllo Callout 4 .

  • Fare clic nella struttura del report nel punto in cui si vuole posizionare l'angolo superiore sinistro del controllo. Fare clic una volta per creare un controllo con dimensioni predefinite oppure fare clic e trascinare nel report per creare un controllo delle dimensioni desiderate.

  • Se al primo tentativo non si riesce a posizionare il controllo perfettamente, è possibile spostarlo usando la procedura seguente:

    • Fare clic sul controllo per selezionarlo.

    • Posizionare il puntatore sul controllo finché non assume la forma di una freccia a quattro punte puntatore sposta , quindi trascinare il controllo nella posizione desiderata.

Questo processo crea un controllo "non associato". Se il controllo è del tipo che consente la visualizzazione di dati, ad esempio una casella di testo o una casella di controllo, sarà necessario immettere un nome di campo o un'espressione nella proprietà Origine controllo prima che i dati possano essere visualizzati.

Visualizzare la finestra delle proprietà

  • Premere F4.

Nota : Una volta completato il nuovo report, assicurarsi di salvare il lavoro.

Inizio pagina

Aggiungere o modificare le opzioni di raggruppamento e ordinamento in un report esistente

Nella sezione seguente sono riportate le informazioni necessarie per aggiungere opzioni di raggruppamento o di ordinamento a un report esistente oppure per modificare le opzioni esistenti.

Aggiungere raggruppamenti, ordinamenti e totali in visualizzazione Layout

Per eseguire semplici operazioni di ordinamento, raggruppamento e calcolo dei totali, fare clic con il pulsante destro del mouse sui campi nella visualizzazione Layout e quindi scegliere l'operazione desiderata dal menu di scelta rapida. Per passare alla visualizzazione Layout, fare clic con il pulsante destro del mouse sul report nel riquadro di spostamento e quindi scegliere Visualizzazione Layout Callout 4 .

Nota : Anche se le istruzioni riportate in questa sezione non fanno specifico riferimento all'utilizzo del riquadro Raggruppamento, ordinamento e totale è buona norma aprire il riquadro e osservare come varia durante la sessione di lavoro. In questo modo si comprenderà meglio il funzionamento di Access, nonché l'utilizzo del riquadro Raggruppamento, ordinamento e totale per apportare modifiche aggiuntive al report. Per visualizzare il riquadro Raggruppamento, ordinamento e totale:

  1. Nel gruppo Raggruppamento e totali della scheda Formato fare clic su Raggruppa e ordina. Callout 4

Ordinare in base a un singolo campo

  • Fare clic con il pulsante destro del mouse su un valore qualsiasi nel campo per il quale si desidera eseguire l'ordinamento.

  • Scegliere l'opzione di ordinamento desiderata dal menu di scelta rapida. Ad esempio, per ordinare un campo di testo in ordine crescente, fare clic su Ordina dalla A alla Z Callout 4 . Per ordinare un campo numerico in ordine decrescente, fare clic su Ordina dal più grande al più piccolo Callout 4 .

Il report verrà ordinato nel modo specificato. Se il riquadro Raggruppamento, ordinamento e totale è aperto, si noti che al campo è stata aggiunta una nuova riga Ordina per.

Ordinare in base a più campi

Nota : Se si esegue l'ordinamento facendo clic su un campo nella visualizzazione Layout, è possibile eseguire l'ordinamento solo di un campo alla volta. Se si ordina un altro campo, l'ordinamento del primo campo viene rimosso. Questa caratteristica di ordinamento è diversa nelle maschere, dove è possibile definire più ordinamenti facendo clic con il pulsante destro del mouse su ogni campo in sequenza e scegliendo l'ordinamento desiderato. Per creare più livelli di ordinamento, vedere la sezione Aggiungere opzioni di raggruppamento, ordinamento e calcolo dei totali tramite il riquadro Raggruppamento, ordinamento e totale.

Eseguire il raggruppamento in base a un campo

  • Fare clic con il pulsante destro del mouse su un valore qualsiasi nel campo in base al quale si desidera eseguire il raggruppamento.

  • Scegliere Raggruppa secondo Callout 4 dal menu di scelta rapida .

Verrà aggiunto il livello di gruppo, a cui verrà associata un'intestazione di gruppo. Se il riquadro Raggruppamento, ordinamento e totale è aperto, si noti che al campo è stata aggiunta una nuova riga Raggruppa secondo.

Aggiungere un totale a un campo

Questa opzione consente di calcolare la somma, la media, il conteggio o altre aggregazioni di un campo. Alla fine del report viene aggiunto un totale complessivo e verranno inseriti i totali di gruppo a tutti i gruppi inclusi nel report.

  • Fare clic con il pulsante destro del mouse su un valore qualsiasi nel campo per il quale si desidera calcolare il totale.

  • Fare clic Totale.

  • Fare clic sull'operazione che si desidera eseguire: Somma, Media, Conta record (per contare tutti i record), Conta valori (per contare solo i record con un valore in questo campo), Max, Min, Deviazione standard oppure Varianza.

Verrà aggiunto un controllo casella di testo calcolata al piè di pagina del report in modo da creare un totale complessivo. Se il report include livelli di gruppo, verranno inoltre aggiunti i piè di pagina di gruppo, se non sono già presenti, e in ogni piè di pagina verrà inserito il totale.

Per aggiungere i totali, è inoltre possibile fare clic sul campo di cui eseguire il totale e nella scheda Formato fare clic su Totali nel gruppo Raggruppamento e totali Callout 4 .

Aggiungere opzioni di raggruppamento, ordinamento e calcolo dei totali tramite il riquadro Raggruppamento, ordinamento e totale

Il riquadro Raggruppamento, ordinamento e totale offre la massima flessibilità quando si desidera aggiungere o modificare le opzioni di raggruppamento, ordinamento o calcolo dei totali in un report. Anche in questo caso è consigliabile utilizzare la visualizzazione Layout perché risulta più semplice controllare l'impatto delle modifiche apportate sulla visualizzazione dei dati.

Visualizzare il riquadro Raggruppamento, ordinamento e totale

  • In visualizzazione Layout:

    Nel gruppo Raggruppamento e totali della scheda Formato fare clic su Raggruppa e ordina. Callout 4

  • In visualizzazione Struttura:

    Nel gruppo Raggruppamento e totali della scheda Struttura fare clic su Raggruppa e ordina. Callout 4

Access visualizza il riquadro Raggruppamento, ordinamento e totale.

riquadro raggruppamento, ordinamento e totale

Per aggiungere un nuovo ordinamento o livello di gruppo, fare clic su Aggiungi gruppo oppure su Aggiungi ordinamento.

Al riquadro Raggruppamento, ordinamento e totale verrà aggiunta una nuova riga e verrà visualizzato l'elenco dei campi disponibili.

Elenco di campi nel riquadro Raggruppamento, ordinamento e totale

È possibile fare clic su uno di questi nomi di campo oppure su espressione in fondo all'elenco di campi per immettere un'espressione. Dopo aver scelto un campo o immesso un'espressione, Access aggiunge il livello di gruppo corrispondente al report. Nella visualizzazione Layout, la visualizzazione viene aggiornata immediatamente in base al raggruppamento o al tipo di ordinamento.

Note : 

  • Se sono stati definiti più livelli di ordinamento o di gruppo, potrebbe essere necessario scorrere il riquadro Raggruppamento, ordinamento e totale prima di essere in grado di visualizzare i pulsanti Aggiungi gruppo e Aggiungi ordinamento.

  • In un report è possibile definire un massimo di 10 livelli di gruppo e ordinamento.

Modificare le opzioni di raggruppamento

Per ogni livello di ordinamento o di gruppo è possibile impostare un determinato numero di opzioni in modo da ottenere i risultati desiderati.

Opzioni raggruppamento

  • Per visualizzare tutte le opzioni disponibili per un livello di gruppo o un livello di ordinamento, fare clic su Altro nel livello che si desidera modificare.

    Opzioni raggruppamento (espanso)

  • Per nascondere le opzioni, fare clic su Meno.

Criterio ordinamento    Per modificare l'ordinamento, fare clic sull'elenco a discesa Criterio ordinamento e quindi scegliere l'opzione desiderata.

Intervallo raggruppam.    Questa opzione determina la modalità di raggruppamento dei record. Ad esempio, è possibile eseguire il raggruppamento in base al primo carattere di un campo di testo in modo tale che tutti gli elementi che iniziano con "A" vengano inseriti in un gruppo e che tutti gli elementi che iniziano con "B" vengano inseriti in un altro gruppo e così via. Nel caso di un campo di tipo Data è possibile eseguire il raggruppamento in base al giorno, alla settimana, al mese o al trimestre oppure immettere un intervallo personalizzato.

Totali    Per aggiungere totali, fare clic su questa opzione. È possibile aggiungere totali in più campi oppure eseguire tipi diversi di totali nello stesso campo.

Finestra popup Totali

  • Fare clic sulla freccia dell'elenco a discesa Totale su e quindi selezionare il campo in cui si desidera inserire il riepilogo.

  • Fare clic sulla freccia dell'elenco a discesa Tipo e quindi selezionare il tipo di calcolo da eseguire.

  • Selezionare Mostra totale complessivo per aggiungere un totale complessivo alla fine del report, ovvero nel piè di pagina del report.

  • Selezionare Mostra totali di gruppo come % del totale complessivo per aggiungere un controllo al piè di pagina di gruppo per il calcolo della percentuale del totale complessivo per ogni gruppo.

  • Selezionare Mostra in intestazione di gruppo o Mostra in piè di pagina di gruppo per visualizzare il totale nella posizione desiderata.

Dopo aver selezionato tutte le opzioni per un campo, è possibile ripetere la procedura ed eseguire il riepilogo in base a un altro campo selezionando il campo desiderato dall'elenco a discesa Totale su. In alternativa, fare clic all'esterno della finestra popup Totali per chiuderla.

Titolo    Consente di modificare il titolo del campo che verrà riepilogato. Viene utilizzato come intestazione di colonna e come etichetta per i campi di riepilogo in intestazioni e piè di pagina.

Per aggiungere o modificare il titolo:

  • Fare clic sul testo blu che segue con titolo.

    Verrà visualizzata la finestra di dialogo Zoom.

  • Digitare il nuovo titolo nella finestra di dialogo e quindi fare clic su OK.

Con/senza sezione intestazione    Utilizzare questa impostazione per aggiungere o rimuovere la sezione intestazione che segue ogni gruppo. Quando si aggiunge una sezione intestazione, il campo di raggruppamento verrà automaticamente spostato sull'intestazione. Quando si rimuove una sezione intestazione contenente controlli diversi dal campo di raggruppamento, verrà richiesto di confermare l'eliminazione dei controlli.

Con/senza sezione piè di pagina    Utilizzare questa impostazione per aggiungere o rimuovere la sezione piè di pagina che segue ogni gruppo. Quando si rimuove una sezione piè di pagina contenente controlli, verrà richiesto di confermare l'eliminazione dei controlli.

Mantiene il gruppo su una sola pagina    Questa impostazione determina la disposizione dei gruppi durante la fase di stampa del report. È possibile mantenere insieme il maggior numero di gruppi in modo da ridurre il numero di pagine da sfogliare per visualizzare l'intero gruppo. Tuttavia, questa impostazione comporta l'utilizzo di una maggiore quantità di carta per stampare il report in quanto sarà presente spazio vuoto nella parte inferiore della maggior parte delle pagine.

  • Non mantenere il gruppo su una sola pagina     Utilizzare questa opzione se risulta irrilevante il fatto che i gruppi vengano separati da interruzioni di pagina. Ad esempio, con un gruppo di 30 elementi è possibile che 10 elementi vengano posizionati alla fine di una pagina e i restanti 20 all'inizio della pagina successiva.

  • Mantieni l'intero gruppo su una sola pagina     Questa opzione consente di ridurre il numero di interruzioni di pagina in un gruppo. Se un gruppo non può essere contenuto nello spazio rimanente di una pagina, tale spazio verrà lasciato vuoto e il gruppo verrà posizionato sulla pagina successiva. Gruppi di grandi dimensioni potrebbero comunque occupare più pagine. Questa opzione consente tuttavia di ridurre il più possibile il numero di interruzioni di pagina all'interno del gruppo.

  • Mantieni l'intestazione e il primo record su una sola pagina     Per gruppi con intestazioni di gruppo, questa opzione consente di evitare che l'intestazione di gruppo venga stampata da sola in fondo a una pagina. Se lo spazio non è sufficiente per stampare almeno una riga di dati dopo l'intestazione, il gruppo verrà stampato sulla pagina successiva.

Modificare la priorità dei livelli di gruppo e dei livelli di ordinamento

Per modificare la priorità dei livelli di gruppo e dei livelli di ordinamento, fare clic sulla riga nel riquadro Raggruppamento, ordinamento e totale e quindi fare clic sulle frecce in su o in giù a destra della riga.

Eliminare i livelli di gruppo e di ordinamento

Per eliminare un livello di gruppo o di ordinamento, fare clic sulla riga da eliminare nel riquadro Raggruppamento, ordinamento e totale e quindi premere CANC oppure fare clic sul pulsante Elimina a destra della riga. Quando si elimina un livello di gruppo, se il campo di raggruppamento era contenuto nell'intestazione o nel piè di pagina di gruppo, tale campo verrà spostato nella sezione Corpo del report. Qualsiasi altro controllo incluso nell'intestazione o piè di pagina di gruppo verrà eliminato.

Inizio pagina

Creare un report di riepilogo senza dettagli dei record

Per visualizzare solo i totali, ovvero solo le informazioni nelle righe dell'intestazione e del piè di pagina, nel gruppo Raggruppamento e totali della scheda Formato (o nella scheda Struttura in visualizzazione Struttura) fare clic su Nascondi dettagli. Verranno nascosti i record al successivo livello di gruppo inferiore e pertanto i dati di riepilogo saranno presentati in un formato più compatto. Anche se i record sono nascosti, i controlli nella sezione nascosta non vengono eliminati. Fare nuovamente clic su Nascondi dettagli per ripristinare la visualizzazione delle righe dei dettagli nel report.

Creare un effetto di raggruppamento senza usare le intestazioni

È possibile ottenere un effetto di raggruppamento nel report senza l'ausilio delle intestazioni. La rimozione delle intestazioni permette di creare un report più compatto perché viene usato meno spazio verticale per le righe di intestazione.

La procedura generale implica la rimozione dell'intestazione per ogni gruppo, spostando ogni campo di raggruppamento nella sezione Corpo del report. Per ripristinare l'effetto di raggruppamento visivo, impostare la proprietà Nascondi duplicati di ogni campo di raggruppamento su .

Esempio

Prendere in considerazione questo tipico report con raggruppamenti che usa le intestazioni di gruppo:

Report con raggruppamenti con intestazioni di gruppo

Come si può notare, ogni nome di società occupa un'intera riga, in modo analogo a ogni ID dell'ordine.

In questo esempio, il report verrà modificato in modo che appaia simile al seguente:

report con raggruppamento senza intestazioni di gruppo

  1. Aprire il report in visualizzazione Layout facendo clic con il pulsante destro del mouse su di esso nel riquadro di spostamento e quindi scegliendo Visualizzazione Layout Callout 4 .

  2. Nel gruppo Raggruppamento e totali della scheda Formato fare clic su Raggruppa e ordina. Callout 4

    Nota :  È consigliabile iniziare con il gruppo di livello inferiore; in caso contrario, la visualizzazione del report può generare confusione mentre si lavora.

  3. Fare clic sul livello di raggruppamento inferiore dell'elenco e quindi fare clic su Altro.

  4. Dall'elenco a discesa della sezione intestazione selezionare senza sezione intestazione.

    Quando si rimuove un'intestazione, Access mantiene la casella di testo per il campo di raggruppamento spostandola alla sezione Corpo. Tuttavia, potrebbero essere eliminati tutti gli altri controlli nell'intestazione gruppo. Verrà visualizzato un avviso se tutti i controlli saranno eliminati in seguito a questa azione. Se si vogliono conservare alcuni controlli nell'intestazione gruppo, assicurarsi di spostarli in un'altra sezione del report prima di eseguire questo passaggio. È necessario passare alla visualizzazione Struttura per spostare i controlli ad altre sezioni.

    La figura seguente illustra il report risultante. Si noti che il primo ID ordine si trova nella stessa riga del primo record di dettaglio, invece che su una riga distinta.

    report con raggruppamento senza intestazione idordine

    Purtroppo, l'ID ordine si ripete in ogni riga di dettaglio e in questo modo risulta difficile vedere esattamente quanti ordini sono presenti. A questo punto, è utile impostare la proprietà Nascondi duplicati del controllo casella di testo. Seguire questa procedura per impostare questa proprietà:

    • Selezionare uno dei valori ripetuti.

    • Se la finestra delle proprietà non è attualmente visualizzata, premere F4 per aprirla.

    • Nella scheda Formato della finestra delle proprietà fare clic su nell'elenco a discesa Nascondi duplicati.

      Gli ID ordine duplicati verranno nascosti. Si noti che è possibile visualizzare il numero di ordini e il numero di prodotti specifici per ogni ordine.

      Report con raggruppamento con IDOrdine duplicati nascosti

  5. In questo esempio, ripetere il passaggio 4 per il livello di gruppo di Nome società. Il report finale è simile a quello illustrato nella figura seguente:

    report con raggruppamento senza intestazioni di gruppo

    Il valore Nome società è ora nella stessa riga del primo record di dettaglio e la proprietà Nascondi duplicati evita che il valore Nome società si ripeta in ogni riga. Per un report lungo che usa diversi livelli di gruppo, questo può causare un risparmi di carta significativo.

Inizio pagina

Salvare, stampare o inviare il report

Dopo aver salvato la struttura del report, è possibile riusarla più volte. La struttura del report non cambia, ma ogni volta che il report viene stampato verranno visualizzati i dati aggiornati. Se è necessario apportare modifiche ai report, è possibile modificare la struttura del report oppure creare una nuovo report simile, basato sull'originale.

Salvare il report

  1. Fare clic sul pulsante Microsoft Office icona del pulsante e quindi su Salva oppure premere CTRL+S Callout 4 .

    In alternativa, è possibile fare clic su Salva Callout 4 nella barra di accesso rapido.

  2. Se al report non è stato assegnato un titolo, digitare un nome nella casella Nome report e quindi scegliere OK.

Salvare la struttura del report con un nuovo nome

  1. Fare clic sul pulsante Microsoft Office icona del pulsante e quindi su Salva con nome icona del pulsante .

  2. Nella finestra di dialogo Salva con nome digitare un nome nella casella Salva report come, fare clic su Report nella casella Come e quindi fare clic su OK.

Stampare il report

È possibile stampare un report dall'anteprima di stampa, dalla visualizzazione Layout, dalla visualizzazione Struttura, dalla visualizzazione report o dal riquadro di spostamento. Prima di stampare, è necessario verificare le impostazioni della pagina, ad esempio i margini e l'orientamento della pagina. Access salva le impostazioni della pagina con il report, quindi è necessario configurarle una sola volta. È possibile salvare le impostazioni in un secondo momento, se le proprie esigenze cambiano.

Modificare le impostazioni della pagina

  1. Aprire il report in qualsiasi visualizzazione.

  2. Nel gruppo Pagina della scheda Layout di pagina fare clic su un'opzione:

    • Dimensioni icona del pulsante consente di selezionare una serie di formati della carta o di immettere un formato della carta personalizzato.

    • Verticale icona del pulsante imposta l'orientamento verticale della pagina.

    • Orizzontale Callout 4 imposta l'orientamento orizzontale della pagina.

    • Margini Icona del pulsante consente di selezionare tra più larghezze dei margini predefinite oppure è possibile fare clic su Avanzate per immettere larghezze dei margini personalizzate usando la finestra di dialogo Imposta pagina.

    • Mostra margini attiva e disattiva la visualizzazione dei margini (solo visualizzazione Layout)

    • Colonne visualizza la finestra di dialogo Imposta pagina. Immettere il numero di colonne desiderate, impostare le dimensioni della colonna desiderate e quindi fare clic su OK.

    • Solo dati annulla la stampa di qualsiasi etichetta inserita nel report. Verranno stampati solo i controlli associati ai dati della tabella o query sottostante. Questa funzionalità può essere utile nei report che occasionalmente si stampano sui moduli prestampati. È possibile annullare la stampa di etichette in queste situazioni e quindi abilitarla quando si stampa il report su un foglio vuoto.

Nota : Per usare impostazioni di pagina più dettagliate, fare clic su Imposta pagina in basso a destra del gruppo Layout di pagina per visualizzare la finestra di dialogo Imposta pagina. È possibile usare la finestra di dialogo Imposta pagina per modificare tutte le impostazioni disponibili nella scheda Layout di pagina e anche per selezionare una stampante specifica per il report.

Inviare il report a una stampante

  1. Aprire il report in qualsiasi visualizzazione o semplicemente selezionare il report nel riquadro di spostamento.

  2. Fare clic sul pulsante Microsoft Office icona del pulsante e quindi su Stampa. Strumenti tabella pivot

  3. Nella finestra di dialogo Stampa immettere le opzioni preferite riguardo la stampante, l'intervallo di stampa e il numero di copie.

  4. Fare clic su OK.

Inizio pagina

Inviare il report come messaggio di posta elettronica

È possibile inviare il report agli utenti come messaggio di posta elettronica invece di stampare una copia cartacea.

  1. Nel riquadro di spostamento, fare clic sul report per selezionarlo, fare clic sul pulsante Microsoft Office icona del pulsante e quindi fare clic su Posta elettronica Callout 4 .

  2. Nella finestra di dialogo Invia oggetto come fare clic sul formato di file da usare.

    Finestra di dialogo Invia oggetto come

  3. Completare le eventuali finestre di dialogo rimanenti.

  4. Quando viene visualizzato il programma di posta elettronica, digitare i dettagli del messaggio e inviare il messaggio.

Inizio pagina

Osservazioni

Può verificarsi un problema in presenza di un report in un file con estensione accdb che esegue l'ordinamento o il raggruppamento in base a un campo di ricerca e lo si vuole importare in un file con estensione mdb e quindi aprirlo con una versione precedente di Access.

Il metodo interno in base al quale i campi di ricerca vengono ordinati e raggruppati nel file con estensione accdb non è compatibile con i file con estensione mdb. Se si crea un report in un file con estensione accdb che usa il raggruppamento o l'ordinamento in base a un campo di ricerca e quindi lo si esporta in un file con estensione mdb (o si usa il comando Salva con nome per salvare il database con estensione mdb) e quindi si prova ad aprire il report con una versione precedente di Access, non sarà possibile caricare il report.

Per aggiornare il report in modo che sia possibile importarlo in un file con estensione mdb e aprirlo in una versione precedente di Access, eseguire le operazioni seguenti:

  1. Nel file con estensione accdb, creare una copia del report.

  2. Aprire la copia del report in visualizzazione Layout.

  3. Se il riquadro Raggruppamento, ordinamento e totale non viene visualizzato:

    1. Nel gruppo Raggruppamento e totali della scheda Formato fare clic su Raggruppa e ordina. Callout 4

  4. Per eliminare tutte le righe del riquadro Raggruppamento, ordinamento e totale fare clic su Elimina a destra di ogni riga.

  5. Fare clic sul pulsante Microsoft Office icona del pulsante e quindi su Salva oppure premere CTRL+S Callout 4 .

  6. Fare clic sul pulsante Microsoft Office icona del pulsante e quindi su Chiudi database. icona del pulsante

  7. Fare clic sul pulsante Microsoft Office icona del pulsante e quindi su Apri. Callout 4

  8. Passare al file con estensione mdb in cui si vuole importare il report e quindi fare clic su Apri.

  9. Importare la copia del report nel file con estensione mdb.

    Procedura

    1. Nella scheda Dati esterni fare clic su Access nel gruppo Importa. Callout 4

    2. Fare clic su Sfoglia.

    3. Passare al file con estensione accdb contenente il report e quindi fare clic su Apri.

    4. Al momento non si sta importando alcuna tabella, per cui non è importante se si sceglie di importare o collegarsi ai dati di origine. Fare clic su OK per continuare.

    5. Nella finestra di dialogo Importa oggetti fare clic sulla scheda Report.

    6. Fare clic sul report che si vuole importare e quindi fare clic su OK.

    7. Se l'operazione di importazione riesce, Access richiede se si vuole salvare la procedura di importazione per un uso futuro. Se si vuole salvare la procedura, selezionare la casella di controllo Salvare i passaggi dell'operazione di importazione, immettere le informazioni richieste e fare clic su Salva importazione. Se non si vuole salvare la procedura, fare clic su Chiudi.

      Access importa il report e lo visualizza nel riquadro di spostamento.

  10. Aprire il report in visualizzazione Layout.

  11. Se il riquadro Elenco campi non viene visualizzato:

    1. Nel gruppo Controlli della scheda Formato fare clic su Aggiungi campi esistenti Callout 4 .

  12. Nel riquadro Campi disponibili nelle tabelle correlate cercare la tabella contenente il campo da visualizzare nel report. Il campo conterrà gli stessi valori attualmente visualizzati nel campo di ricerca nel report.

  13. Trascinare il campo nel report.

    Sono ora disponibili due colonne che visualizzano le stesse informazioni.

  14. Fare clic con il pulsante destro del mouse sul campo di visualizzazione appena aggiunto e quindi sull'opzione di ordinamento preferita.

  15. Eliminare il campo di visualizzazione appena aggiunto e ordinato.

  16. Se il riquadro Raggruppamento, ordinamento e totale non viene visualizzato:

    1. Nel gruppo Raggruppamento e totali della scheda Formato fare clic su Raggruppa e ordina. Callout 4

  17. Fare clic su Aggiungi un gruppo.

  18. Nella finestra popup Campo/Espressione fare clic sul nome del campo di ricerca nel report.

Il report è ora ordinato e raggruppato come se fosse un file con estensione accdb. Salvare e chiudere il report.

Inizio pagina

Nota : Dichiarazione di non responsabilità per la traduzione automatica: Il presente articolo è stato tradotto tramite un software di traduzione automatica e non da una persona. Microsoft offre le traduzioni automatiche per consentire a coloro che non conoscono la lingua inglese di leggere gli articoli sui prodotti, sui servizi e sulle tecnologie Microsoft. Dal momento che l'articolo è stato tradotto automaticamente, potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli.

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×