Creare un grafico pivot

Quando si ha un'enorme quantità di dati in una tabella pivot o in una cartella di lavoro comprendente testo e numeri con intestazioni di colonna, come negli esempi seguenti, ottenere una panoramica dei propri dati può risultare difficile.

dati del foglio di lavoro complessi

I grafici pivot aiutano a organizzare questi dati. I grafici pivot mostrano le serie di dati, le categorie e gli assi allo stesso modo dei grafici standard, ma offrono filtri interattivi direttamente sul grafico, che consentono di analizzare più velocemente i sottoinsiemi dei dati.

Grafico pivot con controlli di filtro

Per i dati dei fogli di lavoro, è possibile creare un grafico pivot senza prima creare una tabella pivot. È inoltre possibile creare il grafico pivot consigliato per i propri dati. Excel creerà automaticamente la tabella pivot corrispondente. Ecco come:

  1. Fare clic in un punto qualsiasi dei dati.

  2. Nel gruppo Grafici della scheda Inserisci scegliere Grafici consigliati.

    Pulsante Grafici consigliati nella scheda Inserisci

  3. Nella scheda Grafici consigliati scegliere uno dei grafici con l'icona grafico pivot Pulsante indicatore Grafico pivot nell'angolo superiore. Nel riquadro dell'anteprima comparirà un'anteprima del grafico pivot.

    Finestra di dialogo Inserisci grafico che mostra i grafici pivot consigliati

  4. Dopo aver trovato il grafico pivot desiderato, fare clic su OK.

Nota : Se non si riesce a trovare un grafico pivot adatto, fare clic su Grafico pivot nella scheda Inserisci, e non su Grafici consigliati.

  1. Nel grafico pivot che compare, fare clic su uno dei controlli interattivi e scegliere il tipo di opzioni di filtro desiderate.

    opzioni di ordinamento e filtro di un grafico pivot

    Suggerimento :  Per rimuovere un grafico pivot, è sufficiente selezionarlo e premere Elimina.

Altri modi di creare un grafico pivot

Se già si dispone di una tabella pivot, è possibile usarla come base per un grafico pivot. Se invece si è connessi a un OLAP (Online Analytical Processing) esterno o a fonti dati di un modello dati, è possibile creare un grafico pivot indipendente, senza dovere creare una tabella pivot.

Creare un grafico pivot per una tabella pivot esistente

Connettersi a dati esterni per creare un grafico pivot

Usare una connessione dati esterni esistente per creare un grafico pivot

Creare un grafico pivot per una tabella pivot esistente

  1. Fare clic in un punto qualsiasi della tabella pivot per visualizzare Strumenti tabella pivot sulla barra multifunzione.

    strumenti tabella pivot

  2. Fare clic su Analizza> Grafico pivot.

    Pulsante Grafico pivot nella scheda Analizza

  3. Nella finestra di dialogo Inserisci grafico fare clic sul tipo e sottotipo di grafico desiderati. È possibile utilizzare qualsiasi tipo di grafico ad eccezione di un grafico XY (a dispersione), un grafico azionario o un grafico a bolle.

    Finestra di dialogo Inserisci grafico per i grafici pivot

Per altre informazioni sui tipi di grafico, vedere Tipi di grafico disponibili.

  1. Fare clic su OK.

  2. Nel grafico pivot che compare, fare clic su uno dei controlli interattivi e scegliere il tipo di opzioni di filtro desiderate.

Inizio pagina

Connessione a dati esterni per la creazione di un grafico pivot

  1. Fare clic su Dati > Da altre origini e scegliere l'origine dati desiderata. Ad esempio, per connettersi a un file cubo OLAP (Online Analytical Processing), scegliere Da Analysis Services.

    Pulsante Da altre origini nella scheda Dati

  2. Seguire i passaggi della Connessione guidata dati e fare clic su Fine.

  3. Nella finestra di dialogo Importa dati, scegliere Grafico pivot e il percorso in cui inserire i dati, quindi fare clic su OK.

    Compariranno un grafico pivot vuoto e l'elenco dei campi, che consentono di aggiungere o riorganizzare i campi nel grafico pivot.

  4. Nell'elenco dei campi scegliere i campi da mostrare nel grafico pivot.

Elenco dei campi con la sezione campo e la sezione aree

  1. Dopo aver creato un grafico pivot, è possibile personalizzarlo allo stesso modo di qualunque altro grafico standard. Quando si seleziona un grafico pivot:

  2. Accanto al grafico compaiono due pulsanti che consentono di aggiungere o modificare gli elementi del grafico, come titoli o etichette dati, e di modificare stile e colori del grafico pivot allo stesso modo di qualunque grafico standard.

    I pulsanti Elementi grafico e Stili grafico accanto a un grafico pivot

  3. Nella barra multifunzione sono presenti gli Strumenti grafico pivot. Nelle schede Analizza, Progettazione e Formato è possibile scegliere le opzioni per il funzionamento e la personalizzazione del grafico pivot.

    strumenti grafico pivot sulla barra multifunzione

Inizio pagina

Usare una connessione dati esterni esistente per creare un grafico pivot

  1. Fare clic su Inserisci > Grafico pivot.

    Pulsante grafico pivot nella scheda Inserisci

  2. Nella finestra di dialogo Crea grafico pivot, fare clic su Origine dati esterna e quindi su Seleziona connessione.

  3. Nella scheda Connessioni della finestra di dialogo Connessioni esistenti fare doppio clic sulla connessione desiderata.

  4. Fare clic su OK.

    Compariranno un grafico pivot vuoto e l'elenco dei campi, che consentono di aggiungere o riorganizzare i campi nel grafico pivot.

  5. Nell'elenco dei campi scegliere i campi da mostrare nel grafico pivot.

Elenco dei campi con la sezione campo e la sezione aree

  1. Dopo aver creato un grafico pivot, è possibile personalizzarlo allo stesso modo di qualunque altro grafico standard. Quando si seleziona un grafico pivot:

  • Accanto al grafico compaiono due pulsanti che consentono di aggiungere o modificare gli elementi del grafico, come titoli o etichette dati, e di modificare stile e colori del grafico pivot allo stesso modo di qualunque grafico standard.

    I pulsanti Elementi grafico e Stili grafico accanto a un grafico pivot

  • Nella barra multifunzione sono presenti gli Strumenti grafico pivot. Nelle schede Analizza, Progettazione e Formato è possibile scegliere le opzioni per il funzionamento e la personalizzazione del grafico pivot.

    strumenti grafico pivot sulla barra multifunzione

Inizio pagina

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×