Creare un filtro personalizzato

Nota: Riteniamo importante fornire il contenuto della Guida più recente non appena possibile, nella lingua dell'utente. Questa pagina è stata tradotta automaticamente e potrebbe contenere errori di grammatica o imprecisioni. L'intento è quello di rendere fruibile il contenuto. Nella parte inferiore della pagina è possibile indicare se le informazioni sono risultate utili. Questo è l'articolo in lingua inglese per riferimento.

Con Project è possibile filtrare la visualizzazione in modo da visualizzare solo le attività critiche, le attività cardine e altre informazioni più importanti per l'utente. Esistono tre modi per filtrare le attività o le risorse del progetto, che forniscono filtri predefiniti per la visualizzazione di specifici aspetti di attività e risorse. Se nessuno di questi filtri soddisfa le proprie esigenze, è possibile creare un nuovo filtro o modificare un filtro esistente.

  • Filtri predefiniti    Questi sono filtri forniti con Project. Vengono usati per filtrare rapidamente le attività o le risorse, ad esempio le attività incomplete o le risorse che sono state sovraassegnate.

  • Filtri personalizzati    Si tratta di filtri che progettate per le proprie esigenze progettuali.

  • I filtri automatici    Quando questi sono attivati, vengono visualizzati come frecce nella parte superiore di ogni colonna in una visualizzazione elenco. Usare questi strumenti per filtrare rapidamente gli elementi in una colonna.

In questo articolo

Filtrare attività o risorse

Usare i filtri automatici

Filtrare attività o risorse

Ci sono momenti in cui si vuole visualizzare solo un particolare tipo di informazioni nel progetto. Ad esempio, potresti voler visualizzare solo le attività cardine del progetto o vedere le attività che non sono state avviate. Se il progetto ha molte attività e include molte risorse, i filtri possono essere molto utili per la visualizzazione di un intervallo specifico di informazioni. I filtri ti consentono di visualizzare solo le informazioni che ti interessano e nascondono il resto.

È possibile filtrare i dati delle attività o delle risorse usando i filtri di progetto predefiniti. Se nessuno dei filtri soddisfa le proprie esigenze, è possibile creare un nuovo filtro o modificare un filtro esistente.

Applicare o rimuovere un filtro

  1. Nel gruppo dati della scheda Visualizza scegliere un filtro nell'elenco dei filtri.

    Per applicare un filtro non presente nell'elenco, scegliere altri filtrie quindi eseguire una delle operazioni seguenti:

    • Per selezionare un filtro attività, scegliere attività, scegliere un nome di filtro nell'elenco filtri e quindi scegliere applica.

    • Per selezionare un filtro per le risorse, scegliere risorsa, scegliere un nome di filtro nell'elenco filtri e quindi scegliere applica.

      Nota: Non è possibile applicare filtri delle attività alle visualizzazioni delle risorse o ai filtri delle risorse alle visualizzazioni delle attività.

  2. Se si applica un filtro interattivo, digitare i valori richiesti e quindi scegliere OK.

  3. Per disattivare un filtro, scegliere nessun filtro nell'elenco dei filtri.

Applicare un colore alle attività filtrate con un'evidenziazione

Quando si filtrano attività o risorse, è possibile applicare un'evidenziazione. Le attività o le risorse evidenziate vengono visualizzate con attività non filtrate, ma con un colore diverso.

  1. Nel gruppo dati della scheda Visualizza selezionare un filtro nell'elenco filtro. e quindi scegliere altri filtri.

  2. Selezionare un filtro nell'elenco dei filtri e quindi scegliere evidenzia.

Suggerimento:  Per applicare un colore diverso alle attività evidenziate, usare uno stile di testo diverso. Scegliere la scheda formato e quindi scegliere stili testo. Nell'elenco elemento da modificare selezionare attività evidenziatee quindi selezionare opzioni di formattazione.

Creare un filtro personalizzato

  1. Nel gruppo dati della scheda Visualizza fare clic sulla freccia accanto a filtroe quindi scegliere altri filtri.

    La barra multifunzione di Project, dalla quale è possibile creare un filtro personalizzato.

  2. Selezionare attività o risorsa (a seconda del tipo di filtro che si vuole creare) e quindi scegliere nuovo.

  3. Digitare un nome per il nuovo filtro. Selezionare Mostra nel menu se si vuole includere questo filtro nell'elenco gruppo dati .

  4. Nella colonna e/o scegliere e mostrare i risultati che soddisfano più di uno dei criteri di filtro. Scegliere o visualizzare le righe che soddisfano una o l'altra.

    A seconda dei risultati che si desidera ottenere dal filtro, scegliere E o O.

  5. Nella colonna nome campo scegliere il campo che si vuole filtrare.

  6. Nella colonna test decidere come corrispondere a quello scelto per la colonna nome campo nella colonna valore /i nel passaggio successivo.

  7. Nella colonna valore/i scegliere il valore desiderato oppure digitarne uno nuovo.

    Se si è scelto uguale o non è uguale nella colonna test , è possibile digitare un carattere jolly nella colonna values , anziché scegliere un'opzione dall'elenco. Ad esempio, se si digita un punto interrogativo (?), i caratteri vengono trovati singolarmente. DiGitando un asterisco (*) si trova il numero di caratteri. Se si usano i caratteri jolly, assicurarsi che la colonna nome campo sia di tipo testo (ad esempio nome) anziché numeri (ad esempio durata).

  8. Per aggiungere un'altra riga al filtro (e scegliere un altro nome di campo in cui filtrare), scegliere Inserisci riga. È possibile raggruppare le righe aggiungendo una riga vuota. Aggiungere una riga and o o nella riga vuota per filtrare un gruppo rispetto a un altro.

  9. Al termine, scegliere Salva.

Suggerimento: Per rimuovere rapidamente tutti i filtri, usare il tasto F3. Tenere presente che i filtri delle attività funzionano solo con le visualizzazioni delle attività e i filtri delle risorse funzionano solo con le visualizzazioni delle risorse.

Modificare un filtro esistente

  1. Nel gruppo dati della scheda Visualizza selezionare l'elenco di filtri e quindi scegliere altri filtri.

  2. Eseguire una delle operazioni seguenti:

    • Per modificare un filtro attività, scegliere attività, scegliere il filtro che si vuole modificare e quindi scegliere modifica.

    • Per modificare un filtro delle risorse, scegliere risorsa, scegliere il filtro che si vuole modificare e quindi scegliere modifica.

  3. Modificare le impostazioni per il filtro usando i controlli nella finestra di dialogo definizione filtro .

Usare i filtri automatici

È possibile applicare un filtro automatico ai campi in qualsiasi visualizzazione foglio. Oltre ai filtri standard, Project fornisce filtri automatici, visibili nella parte superiore di ogni colonna in visualizzazioni foglio.

Applicare e rimuovere filtri automatici

  1. Nel gruppo dati della scheda Visualizza fare clic sulla freccia dell'elenco di filtri e quindi scegliere Visualizza filtro automatico.

  2. Scegliere la freccia del filtro automatico accanto all'intestazione di colonna che contiene le informazioni che si desidera visualizzare e quindi scegliere un valore per filtrare la tabella.
    La freccia del filtro automatico e l'intestazione del campo diventano blu.

  3. Per applicare una condizione aggiuntiva in base a un valore di un'altra colonna, ripetere il passaggio 2 per l'altra colonna.

  4. Per rimuovere il filtro in una riga specifica, scegliere Cancella tutti i filtri nell'elenco filtro automatico per il campo.

  5. Per disattivare i filtri automatici, scegliere di nuovo Visualizza filtro automatico .

    Nota:  Se le informazioni cambiano in una delle righe della visualizzazione, è possibile aggiornare le impostazioni di filtro automatico scegliendo la freccia e riselezionando i valori di filtro.

Creare un filtro automatico personalizzato

  1. Visualizzare i filtri automatici.

  2. Fare clic sulla freccia del filtro automatico, scegliere filtroe quindi Personalizza.

  3. Scegliere l'operatore che si vuole usare nella prima casella e quindi digitare o selezionare il valore che si vuole trovare nella seconda casella.

    Ad esempio, per corrispondere a una data specifica in un campo di data, scegliere l'operatore di uguale nella prima casella e quindi selezionare la data in cui si vuole trovare la seconda casella.

  4. Per applicare due condizioni al filtro automatico, eseguire una delle operazioni seguenti:

    • Per visualizzare le righe nella visualizzazione che soddisfano entrambe le condizioni, scegliere l'operatore e il valore desiderato nella seconda riga di caselle e quindi scegliere e.

    • Per visualizzare le righe nella visualizzazione che soddisfano una o più condizioni, scegliere l'operatore e il valore desiderato nella seconda riga di caselle e quindi scegliere o.

  5. Per salvare le impostazioni del filtro automatico, scegliere Salva.

    Se nella visualizzazione è già applicato un filtro predefinito, le condizioni impostate per il filtro automatico vengono incluse come condizioni aggiuntive per il filtro corrente. Quando si salva un'impostazione di filtro automatico, il filtro viene salvato con altri filtri nel file ed è disponibile solo tramite la finestra di dialogo altri filtri .

Attivare automaticamente i filtri automatici per i nuovi progetti

  1. Nella scheda File scegliere Opzioni.

  2. Scegliere Avanzatee quindi nella sezione generale Selezionare la casella di controllo Imposta filtro automatico per nuovi progetti .

Torna all'inizio

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×