Creare un diagramma di comunicazione UML

Creare un diagramma di comunicazione UML

È possibile creare un diagramma Comunicazione UML che mostri le interazioni tra le linee di vita che usano messaggi in sequenza in una disposizione libera. Prima di tutto, aprire il modello Comunicazione UML e sceglierne una delle quattro opzioni. Viene quindi visualizzato lo stencil Comunicazione UML, insieme alle forme conformi allo standard UML 2.5.

Stencil Comunicazione UML, forme di esempio sulla pagina

Nota : Lo stencil Comunicazione UML è disponibile solo con un abbonamento a Visio Pro per Office 365. Se si ha un abbonamento, verificare di avere installato la versione più recente di Visio.

  1. Avviare Visio. In alternativa, se è già aperto un file, fare clic su File > Nuovo.

  2. Passare a Categorie > Software e database > Comunicazione UML.

  3. Selezionare il modello vuoto o uno dei tre diagrammi di base. Se si vuole rappresentare la collaborazione di linee di vita mostrando le interazioni tra linee di vita, assicurarsi di scegliere il diagramma di base nell'angolo in basso a sinistra.

  4. Fare clic su Crea.

  5. Accanto al diagramma dovrebbe comparire la finestra Forme. Se non viene visualizzata, passare a Visualizza > Riquadri attività e assicurarsi che l'opzione Forme sia selezionata. Se non è ancora visibile, fare clic sul pulsante Espandi la finestra Forme Pulsante Espandi la finestra Forme a sinistra.

  6. Nella scheda Visualizza assicurarsi che la casella di controllo accanto a Punti di connessione sia selezionata. In questo modo vengono visualizzati i punti di connessione quando si inizia a collegare le forme.

  7. A questo punto, trascinare le forme da includere in un diagramma dalla finestra Forme alla pagina. Per rinominare le etichette di testo, fare doppio clic sulle etichette.

Quando si usano

  1. Trascinare la forma Attore nella pagina per rappresentare il ruolo di un utente o di un sistema esterno.

  2. Trascinare la forma Linea di vita nella pagina per ogni elemento denominato che rappresenta un singolo partecipante.

1: Forma Attore con il testo "Qualcuno" - 2: forma Linea di vita con il testo ":Coupon"

Passaggio 1

Trascinare una forma messaggio nella pagina e associare un'estremità a un punto di connessione in un'altra forma. L'associazione è indicata da un quadrato verde attorno al punto di connessione.

Forma Messaggio con un'estremità evidenziata in verde e connessa a una forma Linea di vita

Passaggio 2

Eseguire la stessa operazione per l'altra estremità del messaggio in modo da associarlo a un punto di connessione. L'associazione è indicata da un'evidenziazione verde attorno al punto.

Forma Messaggio con un'estremità evidenziata in verde e connessa a un'altra forma Linea di vita

Passaggio 3

Se si vuole che il messaggio sia asincrono, fare clic con il pulsante destro del mouse e scegliere Asincrono. In questo modo la punta della freccia chiusa diventerà aperta.

Forma Messaggio, menu di scelta rapida, comando Asincrono selezionato

Panoramica

  1. Prima di tutto connettere le linee di vita con lo strumento Connettore.

  2. Usare quindi le forme Messaggio e Messaggio restituito per mostrare le interazioni tra le linee di vita.

1 punta alla linea di connessione grigia, 2 punta alla linea del messaggio con il testo "4: Esegui()"

Passaggio 1

Nella scheda Home fare clic sullo strumento Connettore (1). Passare il mouse su uno dei punti di connessione di una forma di linea di vita finché non viene visualizzata un'evidenziazione verde (2).

1 punta allo strumento Connettore, 2 punta al cursore che passa sul punto di connessione evidenziato in verde sulla forma Linea di vita

Passaggio 2

Fare clic e trascinare dall'evidenziazione verde a un punto di connessione in un'altra forma di linea di vita finché non viene visualizzata un'evidenziazione simile a questa.

Estremità della linea di connessione trascinata su un'altra forma Linea di vita, con un'evidenziatura verde attorno al punto di connessione

Passaggio 3

Fare clic sullo strumento Puntatore dopo aver connesso le forme di linea di vita.

"Al termine fare clic qui" che punta al comando Strumento Selezione

Passaggio 4

Trascinare un'altra forma messaggio in modo che sia parallela all'altra linea.

Cursore che trascina la forma Messaggio in posizione accanto alla linea di connessione

Raddrizzare i connettori

Se un connettore ha una traiettoria troppo complessa, fare clic con il pulsante destro del mouse su di esso e scegliere Connettore dritto.

Cambiare tipo di connettore

È possibile cambiare il tipo di connettore. Ad esempio, si può passare da Associazione ad Associazione diretta. Fare clic con il pulsante destro del mouse sul connettore e scegliere Imposta tipo di connettore.

Creare connessioni dinamiche anziché connessioni a un punto

Se si prevede di spostare spesso le forme, è consigliabile creare una connessione dinamica anziché una connessione a un punto.

Spostare o ruotare il testo sui connettori

In genere è necessario ruotare o spostare il testo sulle linee di connessione. Ecco come fare:

  1. Fare clic su un'area vuota della pagina per deselezionare tutte le opzioni selezionate.

  2. Nel gruppo Strumenti della scheda Home fare clic sullo strumento Blocco di testo Pulsante Blocco di testo .

  3. Fare clic sul connettore contenente il testo da ruotare o spostare.

  4. Trascinare il blocco di testo per spostarlo oppure ruotarlo usando il punto di manipolazione di rotazione Punto di manipolazione di rotazione

  5. Al termine fare clic sul pulsante Strumento Selezione Icona del puntatore

    Quando si torna allo Strumento Selezione Icona del puntatore , il testo rimane nella stessa posizione relativa rispetto alla forma. Se si usa lo Strumento Selezione Icona del puntatore per trascinare il testo, si sposterà anche la forma. Per spostare il testo in modo indipendente dalla forma, tornare allo strumento Blocco di testo Pulsante Blocco di testo .

Vedere anche

Diagrammi UML in Visio

Creare un diagramma di componente UML

Creare un diagramma di distribuzione UML

Creare un diagramma di sequenza UML

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×