Creare un diagramma dei componenti UML

È possibile creare un diagramma dei componenti UML che mostri componenti, porte, interfacce e le relazioni tra di essi. Prima di tutto, aprire il modello UML - Componente e sceglierne una delle quattro opzioni. Viene quindi visualizzato lo stencil UML - Componente, insieme alle forme conformi allo standard UML 2.5.

Stencil Componente UML con forme di esempio sulla pagina

Nota : Lo stencil UML - Componente è disponibile solo con un abbonamento a Visio Pro per Office 365. Se si ha un abbonamento, verificare di avere installato la versione più recente di Visio.

  1. Avviare Visio. In alternativa, se è già aperto un file, fare clic su File > Nuovo.

  2. Passare a Categorie > Software e database > UML - Componente.

  3. Selezionare il modello vuoto o uno dei tre diagrammi di base. Dopo aver scelto il modello desiderato, fare clic su Crea.

  4. Accanto al diagramma dovrebbe comparire la finestra Forme. Se non viene visualizzata, passare a Visualizza > Riquadri attività e assicurarsi che l'opzione Forme sia selezionata. Se non è ancora visibile, fare clic sul pulsante Espandi la finestra Forme Pulsante Espandi la finestra Forme a sinistra.

  5. Nella scheda Visualizza assicurarsi che la casella di controllo accanto a Punti di connessione sia selezionata. In questo modo vengono visualizzati i punti di connessione quando si inizia a collegare le forme.

  6. A questo punto, trascinare le forme da includere in un diagramma dalla finestra Forme alla pagina. Per rinominare le etichette di testo, fare doppio clic sulle etichette.

Quando si usano

Usare le forme componente per ogni unità funzionale nel sistema o nell'applicazione.

Forma componente "Archivio"

Mostrare o nascondere lo stereotipo

Fare clic con il pulsante destro del mouse sulla forma per visualizzare o nascondere l'etichetta dello stereotipo.

Menu di scelta rapida, comando Mostra stereotipo, etichetta di testo <<componente>>

Sottosistemi

È possibile usare la forma componente come forma sottosistema contenente altri componenti. È sufficiente ingrandirla e rilasciare gli altri componenti su di essa. Quando viene visualizzata l'evidenziazione verde, rilasciare. Da quel momento, la forma più grande agirà da contenitore e la forma più piccola si sposterà con essa.

Suggerimento : Se un componente scompare dopo averlo trascinato su un altro componente, portarlo in primo piano premendo CTRL+MAIUSC+F.

Forma sottosistema Archivio con il componente Ordine trascinato su di essa

Quando si usano

  1. Usare la forma Interfaccia fornita quando si vuole specificare la realizzazione di una classe/interfaccia.

  2. Usare la forma Interfaccia richiesta quando si vuole specificare una dipendenza da una classe/interfaccia.

Due interfacce connesse, 1: Forma Interfaccia fornita che termina con un cerchio, 2: Forma Interfaccia richiesta che termina con un giunto

Passaggio 1

Trascinare una forma Interfaccia fornita nella pagina e allineare il quadrato porta a un punto di connessione. La connessione è indicata da un'evidenziazione verde attorno al punto di connessione.

Forma Interfaccia fornita associata alla forma Componente

Passaggio 2

Trascinare una forma Interfaccia richiesta nella pagina e allineare il quadrato porta a un punto di connessione anche in questo caso. La connessione è indicata da un'evidenziazione verde attorno al punto di connessione.

Forma Interfaccia richiesta associata alla forma Componente

Passaggio 3

Per connettere un'interfaccia fornita a un'interfaccia richiesta, selezionare prima di tutto la forma Interfaccia richiesta. Cercare quindi il punto di manipolazione giallo.

Punto di manipolazione giallo sulla forma Interfaccia richiesta

Passaggio 4

Trascinare il punto di manipolazione giallo per la connessione all'interfaccia fornita.

Forma Interfaccia richiesta connessa alla forma Interfaccia fornita

Raddrizzare i connettori

Se un connettore ha una traiettoria troppo complessa, fare clic con il pulsante destro del mouse su di esso e scegliere Connettore dritto.

Mostrare la molteplicità

Se necessario, fare clic con il pulsante destro del mouse sul connettore e scegliere Mostra molteplicità. Al termine vengono visualizzate quattro caselle di testo in cui è possibile aggiungere dettagli. Se non tutte le caselle di testo sono necessarie, eliminare quelle superflue.

Cambiare tipo di connettore

È possibile cambiare il tipo di connettore. Ad esempio, si può passare da Associazione ad Associazione diretta. Fare clic con il pulsante destro del mouse sul connettore e scegliere Imposta tipo di connettore.

Creare connessioni dinamiche anziché connessioni a un punto

Se si prevede di spostare spesso le forme, è consigliabile creare una connessione dinamica anziché una connessione a un punto.

Spostare o ruotare il testo sui connettori

In genere è necessario ruotare o spostare il testo sulle linee di connessione. Ecco come fare:

  1. Fare clic su un'area vuota della pagina per deselezionare tutte le opzioni selezionate.

  2. Nel gruppo Strumenti della scheda Home fare clic sullo strumento Blocco di testo Pulsante Blocco di testo .

  3. Fare clic sul connettore contenente il testo da ruotare o spostare.

  4. Trascinare il blocco di testo per spostarlo oppure ruotarlo usando il punto di manipolazione di rotazione Punto di manipolazione di rotazione

  5. Al termine fare clic sul pulsante Strumento Selezione Icona del puntatore

    Quando si torna allo Strumento Selezione Icona del puntatore , il testo rimane nella stessa posizione relativa rispetto alla forma. Se si usa lo Strumento Selezione Icona del puntatore per trascinare il testo, si sposterà anche la forma. Per spostare il testo in modo indipendente dalla forma, tornare allo strumento Blocco di testo Pulsante Blocco di testo .

Vedere anche

Diagrammi UML in Visio

Creare un diagramma di comunicazione UML

Creare un diagramma di distribuzione UML

Creare un diagramma di sequenza UML

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×