Creare un box plot

Importante :  Il presente articolo è stato tradotto automaticamente, vedere la dichiarazione di non responsabilità. Per visualizzare la versione inglese dell'articolo, fare clic qui.

Se si stanno eseguendo analisi statistiche, è consigliabile creare un box plot standard per mostrare la distribuzione di un set di dati. In un box plot i dati numerici sono divisi in quartili ed è presente una casella tra il primo e il terzo quartile, con una linea aggiuntiva disegnata lungo il secondo quartile per contrassegnare la mediana. In alcuni box plot i valori minimi e massimi all'esterno del primo e del terzo quartile sono rappresentati con linee, spesso chiamate baffi.

Le diverse parti di un box plot

Excel 2013 non include un modello di grafico per il box plot, ma i box plot possono essere creati con la procedura seguente:

  1. Calcolare i valori del quartile dal set di dati di origine.

  2. Calcolare le differenze tra quartili.

  3. Creare un tipo di istogramma in pila dagli intervalli di quartile.

  4. Convertire l'istogramma in pila nello stile box plot.

In questo esempio il set di dati di origine contiene tre colonne. Ogni colonna contiene 30 voci degli intervalli seguenti:

  • Colonna 1 (2013): 100–200

  • Colonna 2 (2014): 120–200

  • Colonna 3 (2015): 100–180

Tabella Dati di origine

In questo articolo

Passaggio 1: Calcolare i valori di quartile

Prima di tutto è necessario calcolare i valori minimi, massimi e mediani, nonché il primo e il terzo quartile, dal set di dati.

  1. Per farlo, creare una seconda tabella e inserire le formule seguenti:

    Valore

    Formula

    Valore minimo

    MIN(intervallo di celle)

    Primo quartile

    INC.QUARTILE(intervallo di celle, 1)

    Valore mediano

    INC.QUARTILE(intervallo di celle, 2)

    Terzo quartile

    INC.QUARTILE(intervallo di celle, 3)

    Valore massimo

    MAX(intervallo di celle)

  2. Viene restituita una tabella che contiene i valori corretti. I quartili seguenti vengono calcolati dal set di dati di esempio:

    Tabella con i valori finali

Inizio pagina

Passaggio 2: Calcolare le differenze tra quartili

Calcolare quindi le differenze tra ogni fase. In pratica, è necessario calcolare i differenziali tra:

  • Primo quartile e valore minimo

  • Mediana e primo quartile

  • Terzo quartile e mediana

  • Valore massimo e terzo quartile

  1. Per iniziare, creare una terza tabella e copiare i valori minimi direttamente dall'ultima tabella.

  2. Calcolare le differenze tra quartili con la formula di sottrazione Excel (cella1-cell2) e popolare la terza tabella con i differenziali.

Per il set di dati di esempio, la terza tabella è simile alla seguente:

Inizio pagina

Passaggio 3: Creare un istogramma in pila

I dati nella terza tabella sono idonei per un box plot, quindi si può iniziare creando un istogramma in pila che verrà poi modificato.

  1. Selezionare tutti i dati nella terza tabella e fare clic su Inserisci > Inserisci istogramma > Colonne in pila.

    Per iniziare, selezionare Colonne in pila.

    Inizialmente, il grafico non somiglia al box plot perché Excel disegna per impostazione predefinita colonne in pila dal set di dati orizzontale invece che verticale.

    Grafico predefinito con colonne in pila
  2. Per invertire gli assi del grafico, fare clic con il pulsante destro del mouse sul grafico, quindi scegliere Seleziona dati.

  3. Selezionare Inverti righe/colonne.

    Suggerimenti : 

    • Per rinominare le colonne, sul lato Etichette asse orizzontale (categoria) fare clic su Modifica, selezionare l'intervallo di celle nella terza tabella con i nomi di categoria desiderati, quindi fare clic su OK. Selezionare l'intervallo di celle da rinominare.

    • Per rinominare le voci della legenda, sul lato Voci legenda (serie) fare clic su Modifica, quindi digitare la voce desiderata.

  4. Fare clic su OK.

Il grafico dovrebbe essere simile a quello mostrato di seguito. In questo esempio è stato modificato anche il titolo del grafico e, a questo punto, la legenda risulta nascosta.

Questo dovrebbe essere l'aspetto attuale del grafico.

Inizio pagina

Passaggio 4: Convertire l'istogramma in pila nello stile box plot

Nascondere la serie di dati inferiore

Per convertire l'istogramma in pila in un box plot, iniziare nascondendo le serie di dati inferiori:

  1. Selezionare la parte inferiore delle colonne.

    Nota : Quando si fa clic su una singola colonna, vengono selezionate tutte le istanze della stessa serie.

  2. Fare clic su Formato > Selezione corrente > Formatta selezione. Il pannello Formato si apre sulla destra.

    L'opzione  Formato selezione è nella scheda Formato.
  3. Nella scheda Riempimento del pannello Formato selezionare Nessun riempimento.

    La serie di dati inferiore è nascosta nel grafico.

    I dati inferiori sono nascosti in questo grafico.

Creare baffi per il box plot

Il passaggio successivo consiste nel sostituire la serie di dati superiore e la seconda dal basso (le aree blu scuro e arancione nell'immagine) con le linee o baffi.

  1. Selezionare la serie di dati superiore.

  2. Nella scheda Riempimento del pannello Formato selezionare Nessun riempimento.

  3. Nella barra multifunzione fare clic su Progettazione > Aggiungi elemento grafico > Barre di errore > Deviazione standard.

    Menu "Aggiungi elemento grafico" e "Barre di errore".
  4. Fare clic su una delle barre di errore disegnate.

  5. Aprire la scheda Opzioni barra di errore nel pannello Formato e impostare quanto segue:

    • Impostare Direzione su Meno.

    • Impostare Stile fine su Nessuna estremità.

    • Per Intervallo di errore, impostare Percentuale su 100.

      Per Intervallo di errore l'opzione Percentuale dovrebbe essere impostata su 100%.
  6. Ripetere i passaggi precedenti per la seconda serie di dati dal basso.

    L'istogramma in pila dovrebbe iniziare a somigliare a un box plot.

    Il grafico finale è di tipo "scatola e baffi".

Colorare le aree centrali

I box plot in genere vengono disegnati con un colore di riempimento, con un bordo esterno sottile. La procedura seguente descrive come completate il layout.

  1. Selezionare l'area superiore del box plot.

  2. Nella scheda Riempimento e linea nel pannello Formato fare clic su Riempimento a tinta unita.

  3. Selezionare un colore di riempimento.

  4. Fare clic su Linea continua nella stessa scheda.

  5. Selezionare un colore di contorno e premere Larghezza.

  6. Impostare gli stessi valori per altre aree del box plot.

    Il risultato finale dovrebbe essere simile a un box plot.

    Il box plot finale dovrebbe avere questo aspetto.

Inizio pagina

Nota : Dichiarazione di non responsabilità per la traduzione automatica: Il presente articolo è stato tradotto tramite un software di traduzione automatica e non da una persona. Microsoft offre le traduzioni automatiche per consentire a coloro che non conoscono la lingua inglese di leggere gli articoli sui prodotti, sui servizi e sulle tecnologie Microsoft. Dal momento che l'articolo è stato tradotto automaticamente, potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli.

Vedere anche

Tipi di grafico disponibili

Grafici e altre visualizzazioni in Power View

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×