Creare o eseguire una macro

In Word è possibile automatizzare le attività usate di frequente creando ed eseguendo macro. Una macro è costituita da una serie di comandi e istruzioni che vengono raggruppati in un unico comando che permette di completare un'attività automaticamente.

Per risparmiare tempo con le attività eseguite di frequente, è possibile accorpare i passaggi in una macro. Dopo aver registrato la macro, è possibile eseguirla facendo clic su un pulsante della barra di accesso rapido o premendo una combinazione di tasti in base all'impostazione scelta.

  1. Fare clic su Visualizza > Macro > Registra macro.

    comando registra macro

  2. Digitare un nome per la macro.

    casella nome macro

  3. Per usare questa macro in tutti i nuovi documenti creati, accertarsi che la casella Memorizza la macro in sia impostata su Tutti i documenti (Normal.dotm).

    Casella per la scelta della posizione di memorizzazione di una macro

  4. Per eseguire la macro quando si fa clic su un pulsante, fare clic su Pulsante.

    fare clic per assegnare la macro a un pulsante

  5. Fare clic sulla nuova macro, a cui viene assegnato un nome simile a Normal.NewMacros.<nome macro>, quindi su Aggiungi.

    La macro e il pulsante Aggiungi

  6. Fare clic Modifica.

    Pulsante Modifica nel riquadro Personalizzazione della barra di accesso rapido

  7. Scegliere un'icona del pulsante, digitare il nome desiderato e fare clic due volte su OK.

    Opzioni del pulsante nel riquadro Modifica pulsante

  8. A questo punto è necessario registrare i passaggi. Scegliere i comandi o premere i tasti per ogni passaggio dell'attività. Word registrerà le scelte e le pressioni dei tasti.

    Nota : Per selezionare testo durante la registrazione della macro, usare la tastiera. Le macro non registrano le selezioni effettuate con il mouse.

  9. Per interrompere la registrazione, fare clic su Visualizza > Macro > Interrompi registrazione.

    comando interrompi registrazione

Il pulsante della macro verrà visualizzato sulla barra di accesso rapido.

Pulsante della macro sulla barra di accesso rapido

Per eseguire la macro, fare clic sul pulsante.

  1. Fare clic su Visualizza > Macro > Registra macro.

    comando registra macro

  2. Digitare un nome per la macro.

    casella nome macro

  3. Per usare questa macro in tutti i nuovi documenti creati, accertarsi che la casella Memorizza la macro in sia impostata su Tutti i documenti (Normal.dotm).

    Casella per la scelta della posizione di memorizzazione di una macro

  4. Per eseguire la macro quando si preme una scelta rapida da tastiera, fare clic su Tastiera.

    fare clic per assegnare la macro a una scelta rapida da tastiera

  5. Digitare una combinazione di tasti nella casella Nuova combinazione.

  6. Verificare che la combinazione non sia già assegnata. In caso contrario, provare con una combinazione diversa.

  7. Per usare questa scelta rapida da tastiera in tutti i nuovi documenti creati, accertarsi che la casella Salva le modifiche in sia impostata su Normal.dotm.

  8. Fare clic su Assegna.

  9. A questo punto è necessario registrare i passaggi. Scegliere i comandi o premere i tasti per ogni passaggio dell'attività. Word registrerà le scelte e le pressioni dei tasti.

    Nota : Per selezionare testo durante la registrazione della macro, usare la tastiera. Le macro non registrano le selezioni effettuate con il mouse.

  10. Per interrompere la registrazione, fare clic su Visualizza > Macro > Interrompi registrazione.

    comando interrompi registrazione

Per eseguire la macro, premere la scelta rapida da tastiera.

Fare clic sul pulsante sulla barra di accesso rapido, premere la scelta rapida da tastiera oppure eseguire la macro dall'elenco Macro.

  1. Fare clic su Visualizza > Macro > Visualizza macro.

    Comando Visualizza macro

  2. Nell'elenco in Nome macro fare clic sulla macro da eseguire.

  3. Fare clic su Esegui.

Per rendere disponibile in tutti i nuovi documenti una macro creata in un documento, aggiungerla al modello Normal.dotm.

  1. Aprire il documento contenente la macro.

  2. Fare clic su Visualizza > Macro > Visualizza macro.

    Comando Visualizza macro

  3. Fare clic su Libreria.

    Pulsante Libreria nella finestra Visualizza macro

  4. Fare clic sulla macro che si vuole aggiungere al modello Normal.dotm e quindi su Copia.

  1. Scegliere File > Opzioni > Personalizzazione barra multifunzione.

  2. In Scegli comandi da fare clic su Macro.

  3. Fare clic sulla macro desiderata.

  4. In Personalizza barra multifunzione fare clic sulla scheda e sul gruppo personalizzato in cui si vuole aggiungere la macro.

Se non è presente un gruppo personalizzato, fare clic su Nuovo gruppo, quindi su Rinomina e digitare un nome per il gruppo personalizzato.

  1. Fare clic su Aggiungi.

  2. Fare clic su Rinomina per scegliere un'immagine per la macro e digitare il nome desiderato.

  3. Fare clic due volte su OK.

  1. Nel gruppo Codice della scheda Sviluppo fare clic su Macro.

  2. Nella casella Nome macro digitare un nome per la macro.

    Nota : Se si assegna a una nuova macro lo stesso nome di una macro predefinita in Word, le azioni della nuova macro sostituiranno la macro predefinita. Per visualizzare un elenco di macro predefinite, fare clic su Comandi di Word nell'elenco Macro in.

  3. Nell'elenco Macro in fare clic sul modello o sul documento in cui memorizzare la macro.

    Per rendere la macro disponibile in tutti i documenti, assicurarsi di fare clic su Normal.dotm.

  4. Fare clic su Crea per aprire Visual Basic Editor.

Dopo avere aperto Visual Basic Editor, è consigliabile leggere altre informazioni sull'uso di Visual Basic, Applications Edition. Per altre informazioni, fare clic su Guida di Microsoft Visual Basic nel menu Guida oppure premere F1.

È possibile registrare una sequenza di azioni oppure scrivere una macro da zero inserendo il codice Visual Basic, Applications Edition in Visual Basic Editor.

Nota : Per usare le macro in Office Word 2007, è necessario visualizzare la scheda Sviluppo.

  1. Fare clic sul pulsante Microsoft Office icona del pulsante e quindi su Opzioni di Word.

  2. Fare clic su Impostazioni generali.

  3. In Opzioni principali per l'utilizzo di Word selezionare la casella di controllo Mostra scheda Sviluppo sulla barra multifunzione.

    Nota : La barra multifunzione è un componente dell'interfaccia utente Microsoft Office Fluent.

  1. Nel gruppo Codice della scheda Sviluppo fare clic su Registra macro.

    Gruppo Codice della scheda Sviluppo
  2. Nella casella Nome macro digitare un nome per la macro.

    Nota : Se si assegna a una nuova macro lo stesso nome di una macro predefinita in Office Word 2007, le azioni della nuova macro sostituiranno la macro predefinita. Per visualizzare un elenco di macro predefinite, fare clic su Macro nel gruppo Codice della scheda Sviluppo. Nell'elenco Macro in fare clic su Comandi di Word.

  3. Nella casella Memorizza macro in fare clic sul modello o sul documento in cui si vuole memorizzare la macro.

    Importante : Per rendere la macro disponibile in tutti i documenti, assicurarsi di fare clic su Normal.dotm.

  4. Nella casella Descrizione digitare una descrizione della macro.

  5. Eseguire una delle operazioni seguenti:

    • Iniziare la registrazione    Per avviare la registrazione della macro senza assegnarla a un pulsante sulla barra di accesso rapido o a una combinazione di tasti, fare clic su OK.

    • Creare un pulsante    Per assegnare la macro a un pulsante sulla barra di accesso rapido, seguire questa procedura:

      1. Fare clic su Pulsante.

      2. In Personalizza barra di accesso rapido selezionare il documento (o tutti i documenti) a cui si vuole aggiungere la macro nella barra di accesso rapido.

        Importante : Per rendere la macro disponibile in tutti i documenti, assicurarsi di fare clic su Normal.dotm.

      3. Nella finestra di dialogo Scegli comandi da fare clic sulla macro che si sta registrando e quindi fare clic su Aggiungi.

      4. Per personalizzare il pulsante, fare clic su Modifica.

      5. In Simbolo fare clic sul simbolo da usare per il pulsante.

      6. Nella casella Nome visualizzato digitare il nome della macro da visualizzare.

      7. Fare due volte clic su OK per iniziare la registrazione della macro.

        Il simbolo scelto viene visualizzato nella barra di accesso rapido. Il nome digitato viene visualizzato quando si posiziona il puntatore sul simbolo.

    • Assegnare una scelta rapida da tastiera    Per assegnare la macro a una scelta rapida da tastiera, seguire questa procedura:

      1. Fare clic su Tastiera.

      2. Nella casella Comandi fare clic sulla macro che si sta registrando.

      3. Nella casella Nuova combinazione digitare la sequenza di tasti desiderata, quindi fare clic su Assegna.

      4. Fare clic su Chiudi per iniziare la registrazione della macro.

  6. Eseguire le azioni da includere nella macro.

    Nota : Durante la registrazione di una macro è possibile usare il mouse per scegliere i comandi e le opzioni, ma non per selezionare il testo. Per selezionare il testo deve essere usata la tastiera. Per altre informazioni sulla selezione del testo con la tastiera, vedere Selezionare testo.

  7. Per interrompere la registrazione delle azioni, fare clic su Interrompi registrazione nel gruppo Codice.

Modificare una scelta rapida da tastiera per una macro

  1. Fare clic sul pulsante Microsoft Office icona del pulsante e quindi su Opzioni di Word.

  2. Fai clic su Personalizza.

  3. Fare clic su Personalizza accanto a Scelte rapide da tastiera.

  4. Nell'elenco Categorie fare clic su Macro.

  5. Nell'elenco Macro selezionare la macro da modificare.

  6. Nella casella Nuova combinazione digitare la combinazione di tasti desiderata.

  7. Controllare la casella Combinazioni correnti per verificare che la combinazione di tasti che si sta assegnando non sia già in uso per un'altra attività.

  8. Nell'elenco Salva le modifiche in fare clic sull'opzione che corrisponde alla posizione in cui si vuole eseguire la macro.

    Importante : Per rendere la macro disponibile in tutti i documenti, assicurarsi di fare clic su Normal.dotm.

  9. Fare clic su Chiudi.

  1. Nel gruppo Codice della scheda Sviluppo fare clic su Macro.

    Gruppo Codice della scheda Sviluppo

  2. Nell'elenco in Nome macro fare clic sulla macro da eseguire.

  3. Fai clic su Esegui.

  1. Nel gruppo Codice della scheda Sviluppo fare clic su Macro.

    Gruppo Codice della scheda Sviluppo

  2. Nella casella Nome macro digitare un nome per la macro.

    Nota : Se si assegna a una nuova macro lo stesso nome di una macro predefinita in Office Word 2007, le azioni della nuova macro sostituiranno la macro predefinita. Per visualizzare un elenco di macro predefinite, fare clic su Comandi di Word nell'elenco Macro in.

  3. Nell'elenco Macro in fare clic sul modello o sul documento in cui memorizzare la macro.

    Per rendere la macro disponibile in tutti i documenti, assicurarsi di fare clic su Normal.dotm.

  4. Fare clic su Crea per aprire Visual Basic Editor.

Dopo avere aperto Visual Basic Editor, è consigliabile leggere altre informazioni sull'uso di Visual Basic, Applications Edition. Per altre informazioni, fare clic su Guida di Microsoft Visual Basic nel menu Guida oppure premere F1.

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×