Creare o eliminare un rapporto di tabella pivot o di grafico pivot

Importante :  Il presente articolo è stato tradotto automaticamente, vedere la dichiarazione di non responsabilità. Per visualizzare la versione inglese dell'articolo, fare clic qui.

Per analizzare in modo approfondito i dati numerici e rispondere a domande impreviste relative ai dati del foglio di lavoro o a un'origine dati esterna, è possibile creare un rapporto di tabella pivot o un rapporto di grafico pivot.

Importante    In Microsoft Excel 2010 la Creazione guidata Tabella pivot e grafico pivot disponibile nelle versioni precedenti di Excel è stata sostituita dai comandi Tabella pivot e Grafico pivot nel gruppo Tabelle della scheda Inserisci. La Creazione guidata Tabella pivot e grafico pivot è ancora disponibile e può essere usata secondo le esigenze aggiungendola alla barra di accesso rapido o premendo ALT+D+P per avviarla.

Per saperne di più

Informazioni sui rapporti di tabella pivot e di grafico pivot

Che cos'è un rapporto di tabella pivot?

Che cos'è un rapporto di grafico pivot?

Creare una tabella pivot dai dati del foglio di lavoro

Creare una tabella pivot da un'origine dati esterna

Creare un rapporto di grafico pivot da un rapporto di tabella pivot esistente

Convertire un rapporto di grafico pivot in un grafico standard

Creare un grafico standard da alcuni o tutti i dati presenti in un rapporto di tabella pivot

Eliminare un rapporto di tabella pivot o di grafico pivot

Eliminare un rapporto di tabella pivot

Eliminare un rapporto di grafico pivot

Informazioni sui rapporti di tabella pivot e di grafico pivot

Un rapporto di tabella pivot è utile per riepilogare, analizzare, esplorare e presentare dati di riepilogo. Un rapporto di grafico pivot consente di rappresentare visivamente i dati di riepilogo di un rapporto di tabella pivot, al fine di semplificare i confronti e identificare con facilità schemi e tendenze. Entrambi i rapporti consentono di prendere decisioni basate su informazioni aggiornate in relazione ai dati critici dell'azienda.

Che cos'è un rapporto di tabella pivot?

Un rapporto di tabella pivot è una soluzione interattiva che consente di riepilogare rapidamente grandi quantità di dati, nonché analizzare in modo approfondito i dati numerici e rispondere a domande impreviste relative a tali dati. Tale rapporto è progettato in modo specifico per eseguire le operazioni seguenti:

  • Esecuzione di query su grandi quantità di dati in diversi modi.

  • Calcolo di subtotali e aggregazioni di dati numerici, riepilogo di dati in base a categorie e sottocategorie e creazione di calcoli e formule personalizzati.

  • Espansione e compressione di livelli di dati per evidenziare i risultati e drill-down ai dettagli a partire dai dati di riepilogo relativi alle aree di interesse.

  • Spostamento di righe in colonne o di colonne in righe, o "calcolo pivot", per visualizzare riepiloghi diversi dei dati di origine.

  • Applicazione di filtri, ordinamento, raggruppamento e formattazione condizionale ai sottoinsiemi di dati più utili e interessanti, in modo da consentire di evidenziare le informazioni desiderate.

  • Presentazione di rapporti online o stampati sintetici, interessanti e con annotazioni.

Un rapporto di tabella pivot spesso viene usato per analizzare totali correlati, soprattutto quando è necessario sommare un lungo elenco di cifre e la disponibilità di dati aggregati o subtotali può semplificare l'analisi dei dati da prospettive diverse e il confronto di cifre di dati simili. Nel seguente esempio di rapporto di tabella pivot è possibile confrontare facilmente le vendite del reparto Golf durante il terzo trimestre nella cella F3 con le vendite relative ad altri sport o ad altri trimestri oppure con le vendite totali di tutti i reparti.

Esempio di dati di origine e relativo rapporto di tabella pivot

1. Dati di origine, in questo caso da un foglio di lavoro

2. Valori di origine per il riepilogo Golf Trim3 nel rapporto di tabella pivot

3. Intero rapporto di tabella pivot

4. Riepilogo dei valori di origine in C2 e C8 dai dati di origine

Esempio di dati di origine e rapporto di tabella pivot risultante

In un rapporto di tabella pivot, ogni colonna o campo nei dati di origine diventa un campo di tabella pivot che riepiloga più righe di informazioni. Nell'esempio precedente la colonna Sport diventa il campo Sport e ogni record (una raccolta di informazioni su un campo) relativo al Golf viene riepilogato in un unico elementoGolf.

I valori da riepilogare sono contenuti in un campo valore, ad esempio Totale vendite. Il riepilogo Golf 3° trimestre del rapporto riportato sopra contiene la somma del valore Vendite di ogni riga nell'origine dati per cui la colonna Sport contiene Golf e la colonna Trimestre contiene 3° trimestre. Per impostazione predefinita, i dati inclusi nell'area Valori riepilogano i dati di origine sottostanti nel rapporto di grafico pivot nel modo seguente: per i valori numerici viene usata la funzione SOMMA per sommare i valori e per i valori di testo viene usata la funzione CONTA.NUMERI per contare il numero di valori.

Per creare un rapporto di tabella pivot, è necessario definirne i dati di origine, specificare una posizione nella cartella di lavoro e stabilire il layout dei campi.

Che cos'è un rapporto di grafico pivot?

Un rapporto di grafico pivot offre una rappresentazione grafica dei dati inclusi in un rapporto di tabella pivot, che in questo caso è denominato rapporto di tabella pivot associato. Un rapporto di grafico pivot è interattivo e ciò significa che è possibile ordinarlo e filtrarlo in modo da visualizzare sottoinsiemi dei dati della tabella pivot. Quando si crea un rapporto di grafico pivot, nell'area grafico vengono visualizzati i filtri del rapporto di grafico pivot che consentono di ordinare e filtrare i dati sottostanti. Le modifiche apportate al layout e ai dati dei campi nel rapporto di tabella pivot associato vengono applicate immediatamente nel rapporto di grafico pivot.

In un rapporto di grafico pivot vengono visualizzati serie di dati, categorie, indicatori di dati e assi esattamente come nei grafici standard. È anche possibile modificare il tipo di grafico e altre opzioni, ad esempio i titoli, la posizione della legenda, le etichette dei dati e la posizione del grafico.

rapporto di grafico pivot

Rapporto di grafico pivot relativo alle vendite nell'ambito di uno sport per trimestre

È possibile creare automaticamente un rapporto di grafico pivot quando si crea un rapporto di tabella pivot oppure crearlo a partire da un rapporto di tabella pivot esistente.

Inizio pagina

Creare una tabella pivot dai dati del foglio di lavoro

Quando si crea un rapporto di tabella pivot dai dati del foglio di lavoro, tali dati diventano i dati di origine del rapporto.

  1. Eseguire una delle operazioni seguenti:

    • Per usare i dati di un foglio di lavoro come origine dati, fare clic su una cella nell'intervallo di celle contenenti i dati.

    • Per usare i dati in una tabella di Excel come origine dati, fare clic su una cella all'interno di tale tabella.

      Nota    Verificare che nell'intervallo siano presenti intestazioni di colonna o che nella tabella siano visualizzate intestazioni e che nell'intervallo o nella tabella non siano presenti righe vuote.

  2. Nel gruppo Tabelle della scheda Inserisci fare clic su Tabella pivot oppure fare clic sulla freccia sotto Tabella pivot e scegliere Tabella pivot.

    immagine della barra multifunzione di excel

    Verrà visualizzata la finestra di dialogo Crea tabella pivot.

    Suggerimento    Per creare contemporaneamente un rapporto di tabella pivot e di grafico pivot, nel gruppo Tabelle della scheda Inserisci fare clic sulla freccia sotto Tabella pivot e scegliere Grafico pivot. Verrà visualizzata la finestra di dialogo Crea tabella pivot con grafico pivot.

  3. In Specificare i dati da analizzare assicurarsi che sia selezionata l'opzione Seleziona tabella o intervallo, quindi verificare che nella casella Tabella/Intervallo: sia indicato l'intervallo di celle che si vuole usare come dati sottostanti.

    L'intervallo per il rapporto di tabella pivot viene determinato automaticamente da Excel, ma è possibile sostituirlo digitando un intervallo diverso o un nome definito per tale intervallo. Per altre informazioni sulla definizione dei nomi, vedere Definire e usare nomi nelle formule.

    Per i dati presenti in un altro foglio di lavoro o un'altra cartella di lavoro, includere il nome della cartella di lavoro e del foglio di lavoro usando la sintassi seguente: [nomecartella di lavoro]nomefoglio!intervallo.

    Suggerimento    È anche possibile fare clic su Comprimi finestra Icona del pulsante per nascondere temporaneamente la finestra di dialogo, selezionare l'intervallo nel foglio di lavoro e quindi fare clic su Espandi finestra Icona del pulsante .

  4. In Specificare dove collocare il rapporto di tabella pivot selezionare una posizione in uno dei modi seguenti:

    • Per inserire il rapporto di tabella pivot in un nuovo foglio di lavoro a partire dalla cella A1, fare clic su Nuovo foglio di lavoro.

    • Per inserire il rapporto di tabella pivot in un foglio di lavoro esistente, selezionare Foglio di lavoro esistente e quindi, nella casella Posizione, specificare la prima cella dell'intervallo in cui posizionare il rapporto.

  5. Fare clic su OK.

    Excel aggiunge un rapporto di tabella pivot vuoto nella posizione specificata e visualizza l'opzione Elenco campi tabella pivot, che consente di aggiungere campi, creare un layout e personalizzare il rapporto.

    Nota    Se si creano contemporaneamente un rapporto di grafico pivot e un rapporto di tabella pivot, il grafico verrà automaticamente visualizzato sopra il rapporto di tabella pivot associato. Il rapporto di grafico pivot e il rapporto di tabella pivot associato devono sempre trovarsi nella stessa cartella di lavoro.

  6. Per aggiungere campi al rapporto, eseguire una o più delle operazioni seguenti:

    • Per inserire un campo nell'area predefinita della sezione del layout, selezionare la casella di controllo accanto al relativo nome nella sezione dei campi.

      Per impostazione predefinita, i campi non numerici vengono aggiunti all'area Etichette di riga, i campi numerici vengono aggiunti all'area Valori e le gerarchie di data e ora OLAP (Online Analytical Processing) vengono aggiunte all'area Etichette di colonna.

    • Per inserire un campo in un'area specifica della sezione del layout, fare clic con il pulsante destro del mouse sul nome del campo nella sezione dei campi e quindi scegliere Aggiungi a filtro rapporto, Aggiungi a etichette di colonna, Aggiungi a etichette di riga o Aggiungi a valori.

    • Per trascinare un campo nell'area desiderata, fare clic e tenere premuto il pulsante del mouse sul nome del campo nella sezione dei campi, quindi trascinarlo in un'area della sezione del layout.

      Suggerimenti

  7. È possibile usare Elenco campi tabella pivot per ridisporre i campi in qualsiasi momento. A questo scopo, fare clic con il pulsante destro del mouse sui campi nella sezione del layout e quindi scegliere l'area desiderata oppure trascinare i campi tra le aree della sezione del layout. Per altre informazioni sull'Elenco campi e su come ridisporre i campi, vedere Panoramica dei rapporti di tabella pivot e di grafico pivot e Eseguire il pivot dei dati in un rapporto di tabella pivot o di grafico pivot su Office.com.

  8. Le modifiche apportate ai dati di origine dopo la creazione del rapporto di tabella pivot vengono applicate al rapporto quando si aggiorna il rapporto di tabella pivot selezionato (Strumenti tabella pivot, scheda Opzioni, gruppo Dati, pulsante Aggiorna).

  9. Se si aggiungono righe all'intervallo di dati di origine, è possibile includere tali righe nella tabella pivot modificando i dati di origine (Strumenti tabella pivot, scheda Opzioni, gruppo Dati, pulsante Cambia origine dati). Se i dati di origine si trovano in una tabella di Excel, le righe aggiuntive vengono visualizzate automaticamente quando si aggiorna il rapporto di tabella pivot.

Inizio pagina

Creare una tabella pivot da un'origine dati esterna

Quando si crea un rapporto di tabella pivot da dati esterni, si crea una connessione ai dati di origine memorizzati all'esterno di Excel, ad esempio in un programma di database come Microsoft Access o Microsoft SQL Server o in un cubo OLAP (Online Analytical Processing).

  1. Fare clic su una cella nel foglio di lavoro.

  2. Nel gruppo Tabelle della scheda Inserisci fare clic su Tabella pivot oppure fare clic sulla freccia sotto Tabella pivot e scegliere Tabella pivot.

    immagine della barra multifunzione di excel

    Verrà visualizzata la finestra di dialogo Crea tabella pivot.

    Suggerimento    Per creare contemporaneamente un rapporto di tabella pivot e di grafico pivot, nel gruppo Tabelle della scheda Inserisci fare clic sulla freccia sotto Tabella pivot e scegliere Grafico pivot. Verrà visualizzata la finestra di dialogo Crea tabella pivot con grafico pivot.

  3. Fare clic su Origine dati esterna in Specificare i dati da analizzare.

  4. Fare clic su Seleziona connessione.

  5. Nella casella Mostra nella parte superiore della finestra di dialogo Connessioni esistenti selezionare la categoria di connessioni per cui si vuole specificare una connessione oppure selezionare Tutte le connessioni (impostazione predefinita).

  6. Selezionare una connessione in Selezionare una connessione e quindi fare clic su Apri.

    Nota    Se si seleziona una connessione nella categoria Connessioni nella cartella di lavoro, verrà riutilizzata o condivisa una connessione esistente. Se si seleziona una connessione nella categoria File di connessione in rete o File di connessione nel computer, Excel copia il file di connessione nella cartella di lavoro come nuova connessione di cartella di lavoro e quindi usa quel file (con estensione odc) come nuova connessione per il rapporto di tabella pivot.

  7. In Specificare dove collocare il rapporto di tabella pivot selezionare una posizione in uno dei modi seguenti:

    • Per inserire il rapporto di tabella pivot in un nuovo foglio di lavoro a partire dalla cella A1, fare clic su Nuovo foglio di lavoro.

    • Per inserire il rapporto di tabella pivot in un foglio di lavoro esistente, selezionare Foglio di lavoro esistente e quindi, nella casella Posizione, specificare la prima cella dell'intervallo in cui posizionare il rapporto.

  8. Fare clic su OK.

    Excel aggiunge un rapporto di tabella pivot vuoto nella posizione specificata e visualizza l'opzione Elenco campi tabella pivot, che consente di aggiungere campi, creare un layout e personalizzare il rapporto.

    Nota    Se si creano contemporaneamente un rapporto di grafico pivot e un rapporto di tabella pivot, il grafico verrà automaticamente visualizzato sopra il rapporto di tabella pivot associato. Il rapporto di grafico pivot e il rapporto di tabella pivot associato devono sempre trovarsi nella stessa cartella di lavoro.

  9. Per aggiungere campi al rapporto, eseguire una o più delle operazioni seguenti:

    • Selezionare la casella di controllo accanto al nome di ogni campo nella sezione dei campi. Il campo viene posizionato in un'area predefinita della sezione del layout, ma è possibile ridisporre i campi, se necessario.

      Per impostazione predefinita, i campi non numerici vengono aggiunti all'area Etichette di riga, i campi numerici vengono aggiunti all'area Valori e le gerarchie di data e ora OLAP (Online Analytical Processing) vengono aggiunte all'area Etichette di colonna.

    • Fare clic con il pulsante destro del mouse sul nome del campo e quindi scegliere il comando appropriato, Aggiungi a filtro rapporto, Aggiungi a etichette di colonna, Aggiungi a etichette di riga o Aggiungi a valori, per posizionare il campo in un'area specifica della sezione del layout.

      Suggerimento    È anche possibile fare clic e tenere premuto il pulsante del mouse sul nome di un campo e quindi trascinare il campo tra la sezione dei campi e un'area della sezione del layout.

Suggerimento    È possibile usare Elenco campi tabella pivot per ridisporre i campi in qualsiasi momento. A questo scopo, fare clic con il pulsante destro del mouse sui campi nella sezione del layout e quindi scegliere l'area desiderata oppure trascinare i campi tra le aree della sezione del layout. Per altre informazioni sull'Elenco campi e su come ridisporre i campi, vedere Panoramica dei rapporti di tabella pivot e di grafico pivot e Eseguire il pivot dei dati in un rapporto di tabella pivot o di grafico pivot su Office.com.

Inizio pagina

Creare un rapporto di grafico pivot da un rapporto di tabella pivot esistente

  1. Fare clic sul rapporto di tabella pivot.

    Verrà visualizzato il gruppo Strumenti tabella pivot con le schede Opzioni e Progettazione.

  2. Nel gruppo Strumenti della scheda Opzioni fare clic su Tabella pivot.

    immagine della barra multifunzione di excel

  3. Nella finestra di dialogo Inserisci grafico fare clic sul tipo e sottotipo di grafico desiderati. È possibile usare qualsiasi tipo di grafico ad eccezione di un grafico xy (a dispersione), un grafico azionario o un grafico a bolle.

    Per ulteriori informazioni sui tipi di grafico, vedere tipi di grafico disponibili.

  4. Fare clic su OK.

    Nel rapporto di grafico pivot che viene visualizzato sono presenti filtri che è possibile usare per modificare i dati presenti nel grafico.

Note    

  • Il rapporto di grafico pivot e il rapporto di tabella pivot associato associato devono sempre trovarsi nella stessa cartella di lavoro.

  • Se si inserisce un grafico standard per i dati della tabella pivot (scheda Inserisci, gruppo Grafici), il grafico sarà un grafico pivot associato al rapporto di tabella pivot.

Inizio pagina

Convertire un rapporto di grafico pivot in un grafico standard

È possibile convertire un rapporto di grafico pivot in un grafico standard eliminando il relativo rapporto di tabella pivot associato. Se nella cartella di lavoro sono presenti più rapporti di tabella pivot e di grafico pivot, può essere necessario individuare innanzitutto il rapporto di tabella pivot associato che ha lo stesso nome del rapporto di grafico pivot.

  1. Eseguire una delle operazioni seguenti:

    • Se si conosce il rapporto di tabella pivot associato al rapporto di grafico pivot che si vuole modificare, fare clic su quel rapporto di tabella pivot.

    • Se non si conosce il rapporto di tabella pivot associato al rapporto di grafico pivot che si vuole modificare, procedere nel modo seguente:

      1. Fare clic sul rapporto di grafico pivot da modificare.

        Verrà visualizzato Strumenti grafico pivot, con la scheda Progettazione, Layout, Formato e Analizza.

      2. Per trovare il nome del rapporto di tabella pivot associato, eseguire una delle operazioni seguenti:

    • Nel gruppo Dati della scheda Progettazione fare clic su Seleziona dati.

      immagine della barra multifunzione di excel

    • Nella casella Intervallo dati grafico della finestra di dialogo Seleziona origine dati notare il nome della tabella pivot associata, ovvero il testo che segue il punto esclamativo (!), quindi fare clic su OK.

      1. Per trovare il rapporto di tabella pivot associato, eseguire una delle operazioni seguenti:

    • Fare clic su un rapporto di tabella pivot nella cartella di lavoro.

    • Nel gruppo Tabella pivot della scheda Opzioni fare clic su Opzioni, quindi fare clic su Opzioni.

      Gruppo Tabella pivot nella scheda Opzioni in Strumenti tabella pivot

    • Nella casella Nome verificare che il nome corrisponda a quello del rapporto di tabella pivot associato.

    • Ripetere i passaggi da 1 a 3 di questa procedura per ogni rapporto di tabella pivot nella cartella di lavoro, finché non si trova lo stesso nome nella casella Nome.

    • Fare clic su OK, quindi selezionare il rapporto di tabella pivot associato con lo stesso nome del rapporto di grafico pivot che si vuole modificare.

      Verrà visualizzato il gruppo Strumenti tabella pivot con le schede Opzioni e Progettazione.

  2. Nel gruppo Azioni della scheda Opzioni fare clic su Seleziona, quindi su Intera tabella pivot.

    immagine della barra multifunzione di excel

  3. Premere CANC.

Inizio pagina

Creare un grafico standard da alcuni o tutti i dati presenti in un rapporto di tabella pivot

  1. Selezionare nel rapporto di tabella pivot i dati da usare nel grafico.

    Suggerimento    Per includere pulsanti di campo e dei dati nella prima riga e nella prima colonna del rapporto, iniziare a trascinare dall'angolo inferiore destro dei dati da selezionare.

  2. Nel gruppo Appunti della scheda Home fare clic su Copia.

    immagine della barra multifunzione di excel

    Scelta rapida da tastiera  È anche possibile premere CTRL+C.

  3. Fare clic su una cella vuota all'esterno del rapporto di tabella pivot.

  4. Nel gruppo Appunti della scheda Home fare clic sulla freccia sotto Incolla, quindi in Incolla valori fare clic su Valori, Formattazione valori e numeri o Formattazione valori e origine.

    immagine della barra multifunzione di excel

  5. Nel gruppo Grafici della scheda Inserisci selezionare il tipo di grafico che si preferisce e quindi scegliere un sottotipo di grafico.

    immagine della barra multifunzione di excel

    Per ulteriori informazioni sui tipi di grafico, vedere tipi di grafico disponibili.

Inizio pagina

Eliminare un rapporto di tabella pivot o di grafico pivot

Eliminare un rapporto di tabella pivot

  1. Fare clic in un punto qualsiasi del rapporto di tabella pivot che si vuole eliminare.

    Verrà visualizzato il gruppo Strumenti tabella pivot con le schede Opzioni e Progettazione.

  2. Nel gruppo Azioni della scheda Opzioni fare clic sulla freccia sotto Seleziona, quindi scegliere Intera tabella pivot.

    immagine della barra multifunzione di excel

  3. Premere CANC.

Nota    Eliminando un rapporto di tabella pivot associato a un rapporto di grafico pivot, quest'ultimo viene convertito in un grafico standard che non può più essere trasformato in grafico pivot o aggiornato.

Eliminare un rapporto di grafico pivot

  1. Fare clic in un punto qualsiasi del rapporto di grafico pivot che si vuole eliminare.

  2. Premere CANC.

Nota    Eliminando un rapporto di grafico pivot non viene eliminato il rapporto di tabella pivot associato.

Inizio pagina

Nota : Dichiarazione di non responsabilità per la traduzione automatica: Il presente articolo è stato tradotto tramite un software di traduzione automatica e non da una persona. Microsoft offre le traduzioni automatiche per consentire a coloro che non conoscono la lingua inglese di leggere gli articoli sui prodotti, sui servizi e sulle tecnologie Microsoft. Dal momento che l'articolo è stato tradotto automaticamente, potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli.

Queste informazioni sono risultate utili?

Ottimo! Altri commenti?

Cosa possiamo migliorare?

Grazie per i tuoi commenti e suggerimenti

×