Creare maschere e report di Access da un elenco SharePoint

Importante :  Il presente articolo è stato tradotto automaticamente, vedere la dichiarazione di non responsabilità. Per visualizzare la versione inglese dell'articolo, fare clic qui.

È possibile creare maschere e report da un elenco SharePoint e usarli come visualizzazioni. Gli utenti del sito di SharePoint che hanno installato Access 2007 è possono aprire le maschere e report utilizzando il menu di visualizzazione dell'elenco di SharePoint. È possibile effettuare un accesso alla visualizzazione predefinita per un elenco.

Le visualizzazioni create usando Access 2007 sono archiviate in un file di database nel server Windows SharePoint Services. Quando si apre una visualizzazione di Access di un elenco di SharePoint, verrà avviato di Access e viene visualizzato sulla maschera o report. Poiché il database è archiviato nel sito di SharePoint, è possibile aprire la visualizzazione da altri utenti del sito. Un utente non è necessario conoscere la posizione nel sito di SharePoint, del file di database che contiene la visualizzazione di Access per usare la visualizzazione. Inoltre, l'utente non anche è necessario sapere come eseguire l'avvio di Access, questo viene gestito automaticamente dal sito di SharePoint.

Nota : Per creare, utilizzare o modificare una visualizzazione di Access in un sito di SharePoint, è necessario che Access 2007 sia installato nel computer dell'utente.

Per saperne di più

Creare una visualizzazione di Access di un elenco SharePoint

Effettuare un accesso alla visualizzazione predefinita per l'elenco di SharePoint

Utilizzare una visualizzazione di Access di un elenco SharePoint

Modificare una visualizzazione di Access di un elenco SharePoint

Creare una visualizzazione di Access di un elenco SharePoint

Quando si crea una visualizzazione di Access di un elenco SharePoint, Access viene avviato automaticamente. In Access è possibile basare la visualizzazione su una serie di modelli di maschere e report ed è quindi possibile personalizzare la visualizzazione. Tramite la pubblicazione della visualizzazione sul sito di SharePoint, è possibile rendere disponibile la pubblicazione per altri utenti.

Nota : Per creare una visualizzazione di un elenco SharePoint, è necessario disporre dell'autorizzazione Gestione elenchi di Windows SharePoint Services, inclusa per impostazione predefinita nel livello di autorizzazione Progettazione.

Utilizzare la procedura seguente per creare una visualizzazione di Access dell'elenco SharePoint che si sta visualizzando nel browser.

  1. Nel sito di SharePoint scegliere Crea visualizzazione dal menu Visualizza Menu a discesa .

  2. Nella pagina Crea visualizzazione fare clic su Visualizzazione di Access.

    Verrà avviato Access e richiesto di salvare una copia locale del database che conterrà la nuova visualizzazione.

  3. Nella finestra di dialogo Salva copia locale, selezionare la posizione nel computer in cui si desidera salvare la copia, digitare un nome per la copia locale nella casella Nome file, quindi fare clic su Salva.

    La copia locale verrà salvata e aperta, quindi verrà visualizzata la finestra di dialogo Crea visualizzazione di Access.

  4. Nella finestra di dialogo Crea visualizzazione di Access fare doppio clic sul tipo di visualizzazione che si desidera creare.

    La nuova visualizzazione verrà creata da Access e aperta in visualizzazione Layout.

  5. È possibile personalizzare la nuova visualizzazione in visualizzazione Layout oppure passare alla visualizzazione Struttura.

    In visualizzazione Layout è possibile ridimensionare e ridisporre i controlli nella visualizzazione, ad esempio etichette e campi, ma non è possibile aggiungere ulteriori controlli alla visualizzazione. La visualizzazione Layout offre un'anteprima dei dati che rende più facile osservare il modo in cui le modifiche appariranno nella visualizzazione finale.

    In visualizzazione Struttura è possibile ridimensionare e ridisporre i controlli, nonché aggiungere ulteriori controlli alla visualizzazione. La visualizzazione Struttura non consente tuttavia di visualizzare un'anteprima dei dati.

    È possibile passare dalla visualizzazione Struttura alla visualizzazione Layout, e viceversa, ogni volta che lo si desidera. Se si utilizza la visualizzazione Struttura per aggiungere controlli alla visualizzazione, sarà poi possibile passare alla visualizzazione Layout e ridisporre tali controlli nella visualizzazione durante l'anteprima dei dati.

  6. Dopo aver apportato le personalizzazioni desiderate, fare clic su Pubblica su sito di SharePoint sulla barra messaggi.

    Barra degli strumenti

    Verrà visualizzata la finestra di dialogo Pubblica su server Web.

    Se la barra messaggi non è visualizzata, visualizzarla effettuando le seguenti operazioni:

    • Nel gruppo Mostra/Nascondi della scheda Strumenti database, fare clic su Barra messaggi.

  7. Per impostazione predefinita, la visualizzazione viene salvata in un file di database nella raccolta Documenti condivisi del sito di SharePoint, sito contenente l'elenco dal quale è stata creata la visualizzazione. Nella maggior parte dei casi si tratta della raccolta desiderata, ma è possibile modificare la raccolta documenti in cui memorizzare il database scegliendo una raccolta diversa nella casella Salva in della finestra di dialogo Pubblica su server Web. È possibile scegliere di eseguire questa operazione per controllare in modo più specifico gli utenti che hanno accesso alla visualizzazione e consentire agli utenti di aprire la visualizzazione in modalità di sola lettura o in modalità di modifica. È inoltre possibile impostare raccolte specifiche del sito di SharePoint per la pubblicazione delle visualizzazioni di Access. In tal caso potrebbe essere necessario modificare la posizione impostata nella casella Salva in in modo da selezionare la posizione corretta.

    Per selezionare la raccolta corretta, rivolgersi all'amministratore del sito di SharePoint.

  8. In Access viene suggerito un nome per il database nella casella Nome file della finestra di dialogo Pubblica su server Web. Questo nome corrisponde al nome del database salvato come copia locale. È possibile modificare il nome, sebbene nella maggior parte dei casi sia consigliabile accettare il nome suggerito poiché in questo modo sarà più facile ricordare quale database locale corrisponde al database pubblicato sul sito di SharePoint.

  9. Fare clic su Pubblica per salvare il database nel sito di SharePoint.

Inizio pagina

Effettuare un accesso alla visualizzazione predefinita per l'elenco di SharePoint

Quando si effettua l'accesso predefinita la visualizzazione per un elenco di SharePoint, la visualizzazione di Access viene aperto automaticamente quando si apre l'elenco, se gli utenti hanno accesso installata nei propri computer.

Importante : Se si apportata una visualizzazione di Access la visualizzazione predefinita, i visitatori di elenco che non hanno installato Access 2007 non saranno in grado di utilizzare l'elenco.

  1. Con l'elenco di SharePoint aperto, nel menu Impostazioni, fare clic su Impostazioni elenco.

  2. Nella pagina Impostazioni elenco in visualizzazioni, fare clic sul nome della visualizzazione di Access che si desidera impostare la visualizzazione predefinita.

  3. Nella pagina Modifica visualizzazione selezionare Imposta come visualizzazione predefinita e quindi fare clic su OK.

Inizio pagina

Utilizzare una visualizzazione di Access di un elenco SharePoint

Per utilizzare una visualizzazione di Access di un elenco SharePoint, scegliere la visualizzazione di Access dal menu Visualizza dell'elenco.

  • Dal menu Visualizza Menu a discesa scegliere il nome della visualizzazione di Access. Verrà avviato Access, quindi verrà mostrata la visualizzazione in modalità di sola lettura.

    In modalità di sola lettura si sarà in grado di modificare i dati nella visualizzazione e di stampare la visualizzazione, ma non sarà possibile modificare la struttura della visualizzazione. Se si desidera modificare la struttura della visualizzazione, vedere la sezione Modificare una visualizzazione di Access di un elenco SharePoint di questo articolo.

Inizio pagina

Modificare una visualizzazione di Access di un elenco SharePoint

Per modificare la struttura di una visualizzazione di Access, salvare una copia locale del database che contiene la visualizzazione di Access, quindi apportare le modifiche. Sarà quindi possibile utilizzare la copia locale della visualizzazione oppure, se si dispone delle autorizzazioni necessarie nel sito di SharePoint, pubblicare la nuova visualizzazione.

Nota : È possibile modificare una copia locale di una visualizzazione di Access indipendentemente dal livello di autorizzazione di Windows SharePoint Services di cui si dispone. Per pubblicare la visualizzazione modificata sul sito di SharePoint, è tuttavia necessario disporre dell'autorizzazione Gestione elenchi di Windows SharePoint Services, inclusa per impostazione predefinita nel livello di autorizzazione Progettazione. Se è stato possibile creare la visualizzazione di Access, significa che si dispone già dell'autorizzazione Gestione elenchi. In caso di dubbi, rivolgersi all'amministratore del sito di SharePoint per stabilire se si dispone delle autorizzazioni necessarie.

  1. Con la visualizzazione di Access aperta, fare clic su Salva con nome sulla barra messaggi.

    Pulsante Salva con nome sulla barra messaggi

    Nota : Se la barra messaggi non è visualizzata, visualizzarla effettuando le seguenti operazioni:

    • Nel gruppo Mostra/Nascondi della scheda Strumenti database, fare clic su Barra messaggi.

  2. Scegliere alla richiesta di Access di chiudere la visualizzazione e tutti gli altri oggetti aperti.

    Verrà visualizzata la finestra di dialogo Salva con nome.

  3. Nella casella Salva in specificare la posizione in cui si desidera salvare la copia locale, digitare un nome per la copia locale nella casella Nome file, quindi fare clic su Salva.

    La copia locale del database verrà salvata e aperta da Access.

  4. Effettuare una delle seguenti operazioni:

    • Per modificare il layout della visualizzazione senza aggiungere nuovi controlli, nel riquadro di spostamento fare clic con il pulsante destro del mouse sulla visualizzazione, quindi scegliere Visualizzazione Layout dal menu di scelta rapida.

      In visualizzazione Layout è possibile ridimensionare e ridisporre i controlli nella visualizzazione, ad esempio etichette e campi, ma non è possibile aggiungere ulteriori controlli alla visualizzazione. La visualizzazione Layout offre un'anteprima dei dati che rende più facile osservare il modo in cui le modifiche appariranno nella visualizzazione finale.

    • Per aggiungere o rimuovere controlli nella visualizzazione, ad esempio etichette o campi, nel riquadro di spostamento fare clic con il pulsante destro del mouse sulla visualizzazione, quindi scegliere Visualizzazione Struttura dal menu di scelta rapida.

      In visualizzazione Struttura è possibile ridimensionare e ridisporre i controlli, nonché aggiungere ulteriori controlli alla visualizzazione. La visualizzazione Struttura non consente tuttavia di visualizzare un'anteprima dei dati.

      Nota : Se si sceglie di modificare la visualizzazione in visualizzazione Struttura e si prevede di pubblicare la visualizzazione modificata sul sito di SharePoint, non aggiungere alla visualizzazione campi non appartenenti all'elenco SharePoint.

  5. È possibile passare dalla visualizzazione Struttura alla visualizzazione Layout, e viceversa, ogni volta che lo si desidera. Se si utilizza la visualizzazione Struttura per aggiungere controlli alla visualizzazione, sarà poi possibile passare alla visualizzazione Layout e ridisporre tali controlli nella visualizzazione durante l'anteprima dei dati.

Pubblicare la visualizzazione di Access modificata sul sito di SharePoint

Dopo aver modificato la visualizzazione, se si dispone dell'autorizzazione Gestione elenchi nel sito di SharePoint, sarà possibile pubblicare la visualizzazione modificata utilizzando la procedura seguente.

Per ottenere l'autorizzazione Gestione elenchi, rivolgersi all'amministratore del sito di SharePoint.

  1. Salvare la visualizzazione nella copia locale del database.

  2. Sulla barra messaggi fare clic su Pubblica su sito di SharePoint.

    Barra degli strumenti

    Nota : Se non si dispone dell'autorizzazione Gestione elenchi, sulla barra messaggi non verrà visualizzato il pulsante Pubblica su sito di SharePoint. Se la barra messaggi non è visualizzata, visualizzarla effettuando le seguenti operazioni:

    • Nel gruppo Mostra/Nascondi della scheda Strumenti database, fare clic su Barra messaggi.

  3. Nella finestra di dialogo Pubblica su server Web fare clic su Pubblica.

Inizio pagina

Nota : Dichiarazione di non responsabilità per la traduzione automatica: Il presente articolo è stato tradotto tramite un software di traduzione automatica e non da una persona. Microsoft offre le traduzioni automatiche per consentire a coloro che non conoscono la lingua inglese di leggere gli articoli sui prodotti, sui servizi e sulle tecnologie Microsoft. Dal momento che l'articolo è stato tradotto automaticamente, potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli.

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×