Creare manualmente un rapporto di tabella pivot

Il browser in uso non supporta le funzionalità video. Installare Microsoft Silverlight, Adobe Flash Player o Internet Explorer 9.

Questa tabella contiene dati sulle vendite di libri.

Include colonne per il genere dei libri, la data di vendita, l'importo di vendita e il negozio in cui sono stati acquistati.

Prima di creare una tabella pivot, devi disporre in modo corretto i dati da usare, definiti dati di origine.

Tutte le colonne devono avere un'intestazione, perché le intestazioni sono usate come nome dei campi per la tabella pivot.

Ogni colonna deve includere lo stesso tipo di dati, ad esempio

testo in una colonna e valuta in un'altra, e non devono essere presenti righe o colonne vuote.

Per questa tabella pivot useremo i dati di origine presenti nella tabella.

I dati non devono trovarsi obbligatoriamente in una tabella: si può usare anche un intervallo di celle.

Per informazioni sull'uso di dati esterni, vedi l'articolo Creare una tabella pivot per analizzare dati esterni.

Per informazioni sull'uso di più tabelle di database, vedi Creare una tabella pivot per analizzare i dati di più tabelle.

I collegamenti per entrambi gli articoli si trovano nel riepilogo del corso alla fine del corso.

Fai clic su una cella nei dati, quindi su Inserisci > Tabella pivot. Tutti i dati di origine vengono selezionati automaticamente.

In questo esempio si tratta dell'intera tabella SourceData.

Consigliamo di usare una tabella perché, se la tabella cresce,

i nuovi dati saranno inclusi automaticamente nella tabella pivot quando la si aggiorna.

Per informazioni sulla creazione di una tabella, seleziona il collegamento Creare o eliminare una tabella di Excel in un foglio di lavoro nel riepilogo del corso.

Per impostazione predefinita, la tabella pivot verrà creata in un nuovo foglio di lavoro.

Se vuoi, puoi crearla invece in un foglio di lavoro esistente,

facendo clic su Foglio di lavoro esistente e specificando il percorso.

Fai clic su OK. In questo esempio viene creato un nuovo foglio di lavoro con una tabella pivot vuota.

Nell'elenco dei campi della tabella pivot, in alto, si trovano i campi che useremo per creare la tabella pivot.

Sono uguali alle intestazioni delle colonne dei dati di origine.

In basso sono disponibili le quattro aree della tabella pivot a cui si possono aggiungere i campi, ovvero righe, colonne, valori e filtri.

Seleziono il campo relativo al genere per aggiungerlo alla tabella pivot come righe di etichette di testo.

Per impostazione predefinita, i campi di testo vengono aggiunti come righe e i numeri come valori.

Seleziono il campo relativo agli importi di vendita per aggiungerlo come colonna di valori, che vengono sommati tramite la funzione SOMMA.

Faccio clic con il pulsante destro del mouse su una cella nella colonna relativa alla somma degli importi di vendita, scelgo Formato numero e infine Valuta.

Non voglio visualizzare cifre dopo la virgola decimale, quindi imposto Posizioni decimali su 0, faccio clic su OK

e ora possiamo vedere le vendite totali per i diversi generi letterari.

Faccio clic e trascino il campo relativo al negozio su COLONNE per visualizzare le vendite dei diversi generi per ogni negozio insieme ai totali complessivi.

Un elemento importante non ancora presente nella tabella pivot sono le date. Per verificare le differenze nel tempo a livello di vendita,

seleziono il campo relativo alla data per aggiungerlo all'area RIGHE. Un numero così elevato di righe di date rende però la tabella pivot difficile da usare.

Raggruppiamo l'elenco di date. Faccio clic con il pulsante di destro del mouse su una data e scelgo Raggruppa.

Uso l'impostazione predefinita, Mesi, ma puoi selezionare una o più opzioni, ad esempio Trimestri e Anni. Faccio clic su OK.

Le date sono raggruppate per mese sotto i generi e sono più semplici da usare.

Possiamo anche vedere le vendite dei diversi generi nel tempo per ogni negozio.

Quando fai clic su una cella in una tabella pivot, compaiono l'elenco dei campi della tabella pivot e la scheda Strumenti tabella pivot,

che scompaiono quando fai clic all'esterno della tabella.

In Strumenti tabella pivot, fai clic sulla scheda Progettazione per modificare l'aspetto della tabella pivot.

Ad esempio, fai clic su Layout rapporto, quindi su Mostra in formato struttura per visualizzare il genere e la data in colonne distinte.

Seleziona Righe alternate evidenziate per semplificare la lettura delle righe della tabella pivot.

Fai clic sulla freccia GIÙ accanto a Stili tabella pivot per vedere le opzioni disponibili.

Se posizioni il mouse sulle diverse opzioni potrai vedere un'anteprima dell'aspetto finale della tabella pivot.

Per cambiare l'aspetto della tabella pivot, fai clic sullo stile da applicare.

La scheda Analizza sarà esaminata nei video successivi.

Video successivo: Ordinare, filtrare, riepilogare e calcolare i dati della tabella pivot.

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×