Creare il layout e il formato di un rapporto di tabella pivot

Dopo aver creato un rapporto di tabella pivot e avere aggiunto i campi da analizzare, è possibile ottimizzare il layout e il formato del report per facilitare la lettura e l'analisi approfondita dei dati. Per modificare il layout di un rapporto di tabella pivot, è possibile modificare la maschera con tabella pivot e la modalità di visualizzazione di campi, colonne, righe, subtotali, celle vuote e righe. Per modificare il formato del rapporto di tabella pivot, è possibile applicare uno stile predefinito, righe alternate evidenziate e la formattazione condizionale.

Importante : La scheda Strumenti tabella pivot sulla barra multifunzione contiene due schede: Analizza (Excel 2016 e Excel 2013) o Opzioni (Excel 2010 e Excel 2010) e Progettazione. Le procedure descritte in questo argomento menzionano entrambe le schede Analizza e Opzioni, ove applicabile.

Modificare il layout e il formato di un rapporto di tabella pivot

Per apportare modifiche sostanziali al layout di un rapporto di tabella pivot o ai campi che contiene, è possibile usare uno dei formati seguenti:

  • Formato compatto   : gli elementi di diversi campi dell'area delle righe vengono mostrati in una colonna e vengono usati i rientri per distinguere gli elementi di diversi campi. Le etichette di riga occupano meno spazio nel formato compatto, lasciando più spazio per i dati numerici. Vengono visualizzati i pulsanti Espandi e Comprimi che consentono di visualizzare o nascondere i dettagli nel formato compatto. Il formato compatto consente di risparmiare spazio e rende più leggibile il rapporto di tabella pivot, pertanto è specificato come formato di layout predefinito per le tabelle pivot.

    Tabella pivot in formato compatto

  • Formato tabella   : visualizza una colonna per campo e fornisce spazio per le intestazioni dei campi.

    Tabella pivot in formato tabella

  • Formato struttura   : è simile al formato tabella, ma consente di visualizzare i subtotali nella parte superiore di ogni gruppo perché gli elementi nella colonna successiva sono visualizzati una riga sotto l'elemento corrente.

    Immagine esercitazione

Applicare il formato compatto, struttura o tabella a un rapporto di tabella pivot

  1. Fare clic in un punto qualsiasi della tabella pivot.

    Viene visualizzata la scheda Strumenti tabella pivot sulla barra multifunzione.

  2. Nel gruppo Layout della scheda Progettazione fare clic su Layout rapporto e quindi eseguire una delle operazioni seguenti:

    • Per evitare che i dati correlati si estendano in orizzontale fino all'esterno della schermata e per ridurre al minimo la necessità di scorrimento, fare clic su Mostra in formato compatto.

      Nel formato compatto i campi sono contenuti in una colonna e rientrati in modo da visualizzare la relazione di colonna annidata.

    • Per strutturare i dati usando lo stile classico della tabella pivot, fare clic su Mostra in formato struttura.

    • Per visualizzare tutti i dati in un formato tabella tradizionale e copiare facilmente le celle in un altro foglio di lavoro, fare clic su click Mostra in formato tabella.

      immagine della barra multifunzione di excel

Modificare la visualizzazione delle etichette degli elementi in un formato di layout

  1. Nel rapporto di tabella pivot selezionare un campo riga.

    Viene visualizzata la scheda Strumenti tabella pivot sulla barra multifunzione.

    È anche possibile fare doppio clic sul campo riga in formato struttura o tabella e procedere al passaggio 3.

  2. Nel gruppo Campo attivo della scheda Analizza o Opzioni fare clic su Impostazioni campo.

    immagine della barra multifunzione di excel

  3. Nella finestra di dialogo Impostazioni campo fare clic sulla scheda Layout e stampa e quindi in Layout eseguire una delle operazioni seguenti:

    • Per visualizzare gli elementi di campo in formato struttura, fare clic su Mostra etichette degli elementi sotto forma di struttura.

    • Per visualizzare o nascondere le etichette dal campo successivo nella stessa colonna in formato ridotto, fare clic su Mostra etichette degli elementi sotto forma di struttura e quindi selezionare Visualizza etichette del campo successivo nella stessa colonna (formato ridotto).

    • Per visualizzare gli elementi di campo in un formato analogo a una tabella, fare clic su Mostra etichette degli elementi sotto forma di tabella.

Modificare la disposizione dei campi in un rapporto di tabella pivot

Per ottenere il layout desiderato, è possibile aggiungere, riorganizzare e rimuovere campi usando Elenco campi tabella pivot.

Se la finestra Elenco campi tabella pivot non è visibile, verificare che il rapporto di tabella pivot sia selezionato. Se continua a non essere visibile, fare clic su Elenco campi nel gruppo Mostra/Nascondi della scheda Opzioni.

Se in Elenco campi tabella pivot non sono visualizzati i campi da usare, può essere necessario aggiornare il rapporto di tabella pivot per visualizzare eventuali nuovi campi, campi calcolati, misure, misure calcolate o dimensioni aggiunte dall'ultima operazione. Fare clic su Aggiorna nel gruppo Dati della scheda Opzioni.

Per altre informazioni sull'uso di Elenco campi tabella pivot, vedere Usare Elenco campi per disporre i campi in una tabella pivot.

Aggiungere campi a un rapporto di tabella pivot

Eseguire una o più delle operazioni seguenti:

  • Selezionare la casella di controllo accanto al nome di ogni campo nella sezione campi. Il campo viene posizionato in un'area predefinita della sezione layout, ma è possibile ridisporre i campi se lo si desidera.

    Per impostazione predefinita, i campi di testo vengono aggiunti all'area Etichette di riga, i campi numerici vengono aggiunti all'area Valori e le gerarchie di data e ora OLAP vengono aggiunte all'area Etichette di colonna.

  • Fare clic con il pulsante destro del mouse sul nome del campo e quindi scegliere il comando appropriato tra Aggiungi a filtro rapporto, Aggiungi a etichette di colonna, Aggiungi a etichette di riga e Aggiungi a valori per posizionare il campo in un'area specifica della sezione layout.

  • Fare clic e tenere premuto il pulsante del mouse su un nome di campo e quindi trascinare il campo tra la sezione campo e un'area nella sezione layout.

Copiare campi in un rapporto di tabella pivot

In un rapporto di tabella pivot basato su dati in un foglio di lavoro di Excel o su dati esterni di un'dati di origine non OLAP è possibile aggiungere più volte uno stesso campo all'area Valori, in modo da poter visualizzare calcoli diversi usando Mostra valori come. Ad esempio, può essere utile confrontare calcoli affiancati, quali margini di profitto lordi e netti, vendite minime e massime o numero di clienti e percentuale di clienti totali. Per altre informazioni, vedere Visualizzare calcoli diversi nei campi valore di una tabella pivot.

  1. Fare clic e tenere premuto il pulsante del mouse su un nome di campo nella sezione campo e quindi trascinare il campo nell'area Valori nella sezione layout.

  2. Ripetere il passaggio 1 per tutte le volte che si vuole copiare il campo.

  3. In ogni campo copiato apportare le modifiche desiderate alla funzione di riepilogo o al calcolo personalizzato.

    Note : 

    • Quando si aggiungono due o più campi all'area Valori, a prescindere dal fatto che si tratti di copie dello stesso campo o di campi diversi, viene aggiunta automaticamente un'etichetta di colonna Valori nell'area Valori. Questo campo può essere usato per spostare i campi verso l'alto o verso il basso nell'area Valori. È anche possibile spostare l'etichetta di colonna Valori nell'area Etichette di colonna o Etichette di riga, ma non nell'area Filtro rapporto.

    • Un campo può essere aggiunto una sola volta nell'area Filtro rapporto, Etichette di riga o Etichette di colonna, indipendentemente dal fatto che i dati siano di tipo numerico o non numerico. Se si tenta di aggiungere più volte lo stesso campo, ad esempio alle aree Etichette di riga ed Etichette di colonna nella sezione layout, il campo viene automaticamente rimosso dall'area originale e posizionato nella nuova area.

    • Un altro modo per aggiungere lo stesso campo all'area Valori consiste nell'utilizzo di una formula (detta anche colonna calcolata) in vui viene utilizzato lo stesso campo.

    • Non è possibile aggiungere lo stesso campo più volte in un rapporto di tabella pivot basato su un'origine dati OLAP.

Ridisporre i campi in un rapporto di tabella pivot

È possibile ridisporre o riposizionare i campi esistenti utilizzando una delle quattro aree nella parte inferiore della sezione layout:

Rapporto di tabella pivot

Descrizione

Grafico pivot

Descrizione

Valori    

Utilizzare questa opzione per visualizzare dati numerici di riepilogo.

Valori    

Utilizzare questa opzione per visualizzare dati numerici di riepilogo.

Etichette di riga   

Utilizzare questa opzione per visualizzare i campi come riga sul lato del rapporto. Una riga in una posizione inferiore viene nidificata all'interno di un'altra riga immediatamente superiore.

Campo asse (categorie)   

Utilizzare questa opzione per visualizzare i campi come un asse nel grafico.

Etichette di colonna   

Utilizzare quest'opzione per visualizzare i campi come colonne nella parte superiore del rapporto. Una colonna in una posizione inferiore viene nidificata all'interno di un'altra colonna immediatamente superiore.

Etichette Campi legenda (serie)   

Utilizzare quest'opzione per visualizzare i campi nella legenda del grafico.

Filtro rapporto   

Utilizzare questa opzione per filtrare l'intero rapporto in base all'elemento selezionato nel filtro per il rapporto.

Filtro rapporto   

Utilizzare questa opzione per filtrare l'intero rapporto in base all'elemento selezionato nel filtro per il rapporto.

Per ridisporre i campi, fare clic sul nome del campo in una delle aree e quindi selezionare uno dei comandi seguenti:

Selezionare

Per

Sposta su   

Spostare il campo una posizione più in alto nell'area.

Sposta giù   

Spostare il campo una posizione più in basso nell'area.

Sposta all'inizio   

Spostare il campo all'inizio dell'area.

Sposta alla fine   

Spostare il campo alla fine dell'area.

Sposta nel filtro per il rapporto   

Spostare il campo nell'area Filtro rapporto.

Sposta nelle etichette di riga   

Spostare il campo nell'area Etichette di riga.

Sposta nelle etichette di colonna   

Spostare il campo nell'area Etichette di colonna.

Sposta nei valori   

Spostare il campo nell'area Valori.

Impostazioni campo valore   , Impostazioni campo

Visualizzare la finestra di dialogo Impostazioni campo o Impostazioni campo valore. Per altre informazioni su ogni impostazione, fare clic sul pulsante della Guida Icona del pulsante nella parte superiore della finestra di dialogo.

È inoltre possibile fare clic e tenere premuto il pulsante del mouse su un nome di campo e quindi trascinare il campo tra le sezioni campo e layout e tra le diverse aree.

Rimuovere campi da un rapporto di tabella pivot

  1. Fare clic sul rapporto di tabella pivot.

    Viene visualizzata la scheda Strumenti tabella pivot sulla barra multifunzione.

  2. Per visualizzare Elenco campi della tabella pivot, se necessario, fare clic su Elenco campi nella scheda Analizza o Opzioni del gruppo Mostra.

    immagine della barra multifunzione di excel

  3. Per rimuovere un campo, in Elenco campi tabella pivot eseguire una delle operazioni seguenti:

    • In Elenco campi tabella pivot deselezionare la casella di controllo accanto al nome del campo.

      Nota : Se si deseleziona una casella di controllo nell'elenco dei campi, verranno rimosse dal rapporto tutte le istanze del campo.

    • In un'area layout fare clic sul nome del campo e quindi fare clic su Rimuovi campo.

    • Fare clic e tenere premuto il pulsante del mouse su un nome di campo nella sezione layout e quindi trascinarlo al di fuori di Elenco campi tabella pivot.

Modificare il layout di colonne, righe e subtotali

Per ottimizzare ulteriormente il layout di un rapporto di tabella pivot, è possibile modificare il layout di colonne, righe e subtotali, ad esempio visualizzando i subtotali al di sopra delle righe o disattivando le intestazioni di colonna. È anche possibile ridisporre i singoli elementi all'interno di una riga o colonna.

Attivare o disattivare le intestazioni di campo colonna e riga

  1. Fare clic sul rapporto di tabella pivot.

    Viene visualizzata la scheda Strumenti tabella pivot sulla barra multifunzione.

  2. Per visualizzare e nascondere le intestazioni di campo, fare clic su Intestazioni campi nella scheda Analizza o Opzioni del gruppo Mostra.

    immagine della barra multifunzione di excel

Visualizzare i subtotali sopra o sotto le rispettive righe

  1. Nel rapporto di tabella pivot selezionare il campo riga per cui si vuole visualizzare i subtotali.

    Viene visualizzata la scheda Strumenti tabella pivot sulla barra multifunzione.

    Suggerimento : In formato struttura o tabella è anche possibile fare doppio clic sul campo riga e procedere al passaggio 3.

  2. Nel gruppo Campo attivo della scheda Analizza o Opzioni fare clic su Impostazioni campo.

    immagine della barra multifunzione di excel

  3. Nella scheda Subtotali e filtri della finestra di dialogo Impostazioni campo fare clic su Automatico o Personalizzato in Subtotali.

    Nota :  Se è selezionata l'opzione Nessuno, i subtotali sono disattivati.

  4. Nella gruppo Layout della scheda Layout e stampa fare clic su Mostra etichette degli elementi sotto forma di struttura, quindi eseguire una delle operazioni seguenti:

    • Per visualizzare i subtotali sopra le rispettive righe, selezionare la casella di controllo Visualizza subtotali nella parte superiore di ogni gruppo. Questa opzione è selezionata per impostazione predefinita.

    • Per visualizzare i subtotali sotto le rispettive righe, de selezionare la casella di controllo Visualizza subtotali nella parte superiore di ogni gruppo.

Modificare l'ordine degli elementi di riga o colonna

Eseguire una delle operazioni seguenti:

  • Nel rapporto di tabella pivot fare clic con il pulsante destro del mouse sull'etichetta di riga o di colonna o sull'elemento in un'etichetta, scegliere Sposta e quindi usare uno dei comandi disponibili nel menu Sposta per spostare l'elemento.

  • Selezionare l'elemento etichetta di riga o di colonna da spostare e quindi posizionare il puntatore del mouse sul bordo inferiore della cella. Quando il puntatore si trasforma in una freccia a quattro punte, trascinare l'elemento in una nuova posizione. La figura seguente mostra come spostare un elemento riga mediante trascinamento:

    Annulla riunione

Adattare la larghezza delle colonne all'aggiornamento

  1. Fare clic in un punto qualsiasi della tabella pivot.

    Viene visualizzata la scheda Strumenti tabella pivot sulla barra multifunzione.

  2. Nel gruppo Tabella pivot della scheda Analizza o Opzioni fare clic su Opzioni.

    immagine della barra multifunzione di excel

  3. Nella scheda Layout e formato della finestra di dialogo Opzioni tabella pivot, in Formato eseguire una delle operazioni seguenti:

    • Per adattare automaticamente le colonne del rapporto di tabella pivot alla dimensione del testo o del valore numerico più lungo, selezionare la casella di controllo Adatta larghezza colonne all'aggiornamento.

    • Per mantenere la larghezza corrente per le colonne del rapporto di tabella pivot, deselezionare la casella di controllo Adatta larghezza colonne all'aggiornamento.

Spostare una colonna nell'area delle etichette di riga o una riga nell'area delle etichette di colonna

È possibile spostare un campo colonna nell'area dell'etichette di riga o un campo riga nell'area delle etichette di colonna per ottimizzare il layout e la leggibilità del rapporto di tabella pivot. Quando si sposta una colonna in una riga o una riga in una colonna, si effettua una trasposizione dell'orientamento verticale oppure orizzontale del campo. Tale operazione viene detta anche "calcolo pivot" di una riga o una colonna.

Eseguire una delle operazioni seguenti:

  • Fare clic con il pulsante destro del mouse su un campo riga, scegliere Sposta <nome campo>, quindi fare clic su Sposta <nome campo> nelle colonne.

  • Fare clic con il pulsante destro del mouse su un campo colonna e scegliere Sposta <nome campo> nelle righe.

  • Trascinare un campo riga o colonna in un'altra area. La figura seguente mostra come spostare un campo colonna nell'area delle etichette di riga.

    Grafico di Power BI

    1. Fare clic su un campo della colonna

    2. Trascinarlo sull'area delle righe

    3. Sport diventa un campo riga come Area

Unire o dividere celle per gli elementi di riga e colonna esterni

È possibile unire le celle per gli elementi di riga e colonna in modo da centrare tali elementi in senso orizzontale e verticale oppure dividere le celle per giustificare a sinistra gli elementi nei campi riga e colonna esterni all'inizio del gruppo di elementi.

  1. Fare clic in un punto qualsiasi della tabella pivot.

    Viene visualizzata la scheda Strumenti tabella pivot sulla barra multifunzione.

  2. Nel gruppo Tabella pivot della scheda Opzioni fare clic su Opzioni.

    immagine della barra multifunzione di excel

  3. Fare clic sulla scheda Layout e formato della finestra di dialogo Opzioni tabella pivot, quindi in Layout selezionare o deselezionare la casella di controllo Unisci e allinea al centro le celle con etichette.

Nota :  In un rapporto di tabella pivot non è possibile usare la casella di controllo Unisci celle della scheda Allineamento

Cambiare la visualizzazione delle celle e righe vuote e degli errori

In alcuni casi, quando nei dati della tabella pivot sono presenti errori oppure celle o righe vuote, può essere utile modificarne la visualizzazione predefinita.

Cambiare la modalità di visualizzazione degli errori e delle celle vuote

  1. Fare clic in un punto qualsiasi della tabella pivot.

    Viene visualizzata la scheda Strumenti tabella pivot sulla barra multifunzione.

  2. Nel gruppo Tabella pivot della scheda Analizza o Opzioni fare clic su Opzioni.

    immagine della barra multifunzione di excel

  3. Nella finestra di dialogo Opzioni tabella pivot fare clic sulla scheda Layout e formato, quindi in Formato eseguire una delle operazioni seguenti:

    • Per modificare la visualizzazione degli errori, selezionare la casella di controllo Per i valori di errore visualizza. Digitare nella casella il valore che si vuole visualizzare in sostituzione degli errori. Per visualizzare gli errori come celle vuote, eliminare eventuali caratteri presenti nella casella.

    • Per modificare la visualizzazione delle celle vuote, selezionare la casella di controllo Per le celle vuote visualizza, quindi digitare nella casella di testo il valore da visualizzare nelle celle vuote.

      Suggerimento : Per visualizzare celle vuote, eliminare eventuali caratteri presenti nella casella. Per visualizzare zeri, deselezionare la casella di controllo.

Visualizzare o nascondere le righe vuote dopo righe o elementi

Per le righe, procedere nel modo seguente:

  • Nel rapporto di tabella pivot selezionare un campo riga.

    Viene visualizzata la scheda Strumenti tabella pivot sulla barra multifunzione.

    Suggerimento : In formato struttura o tabella è anche possibile fare doppio clic sul campo riga e procedere al passaggio 3.

  • Nel gruppo Campo attivo della scheda Analizza o Opzioni fare clic su Impostazioni campo.

    immagine della barra multifunzione di excel

  • Nella finestra di dialogo Impostazioni campo fare clic sulla scheda Layout e stampa, quindi in Layout selezionare o deselezionare la casella di controllo Inserisci riga vuota dopo l'etichetta di ogni elemento.

Per gli elementi, procedere nel modo seguente:

  • Nel rapporto di tabella pivot selezionare l'elemento desiderato.

    Viene visualizzata la scheda Strumenti tabella pivot sulla barra multifunzione.

  • Nel gruppo Layout della scheda Progettazione fare clic su Righe vuote e quindi selezionare la casella di controllo Inserisci riga vuota dopo l'etichetta di ogni elemento o Rimuovi riga vuota dopo ogni elemento.

    immagine della barra multifunzione di excel

    Nota : È possibile applicare alle righe vuote la formattazione di celle e caratteri, ma non è possibile immettervi dati.

Cambiare la modalità di visualizzazione degli elementi e delle etichette senza dati

  1. Fare clic in un punto qualsiasi della tabella pivot.

    Viene visualizzata la scheda Strumenti tabella pivot sulla barra multifunzione.

  2. Nel gruppo Tabella pivot della scheda Analizza o Opzioni fare clic su Opzioni.

    immagine della barra multifunzione di excel

  3. Nella scheda Visualizza, in Visualizzazione, eseguire una o più delle operazioni seguenti:

    • Per visualizzare o nascondere gli elementi riga che non contengono valori, selezionare o deselezionare la casella di controllo Mostra elementi con righe prive di dati.

      Nota : Questa impostazione è disponibile solo per un'origine dati OLAP (Online Analytical Processing).

    • Per visualizzare o nascondere gli elementi colonna che non contengono valori, selezionare o deselezionare la casella di controllo Mostra elementi con colonne prive di dati.

      Nota : Questa impostazione è disponibile solo per un'origine dati OLAP.

    • Per visualizzare o nascondere le etichette degli elementi quando nell'area dei valori non è presente alcun campo, selezionare o deselezionare la casella di controllo Visualizza etichette degli elementi quando non sono presenti campi nell'area dei valori.

      Nota : Questa casella di controllo si applica solo ai rapporti di tabella pivot creati in versioni di Microsoft Office Excel precedenti a Office Excel 2007.

Modificare o rimuovere la formattazione

È possibile scegliere tra un'ampia gamma di stili di tabella pivot nella raccolta. È anche possibile modificare il comportamento delle righe/colonne alternate evidenziate in un rapporto. Cambiando il formato numero di un campo è possibile applicare rapidamente un formato uniforme all'intero rapporto. Si può anche aggiungere o rimuovere la formattazione delle righe e colonne con sfondo più scuro e più chiaro alternato. Questa formattazione rende i dati più facili da leggere e analizzare.

Applicare uno stile per formattare un rapporto di tabella pivot

È possibile modificare rapidamente l'aspetto e il formato di un rapporto di tabella pivot usando uno dei numerosi stili di tabella pivot predefiniti (o stili veloci).

  1. Fare clic in un punto qualsiasi della tabella pivot.

    Viene visualizzata la scheda Strumenti tabella pivot sulla barra multifunzione.

  2. Nel gruppo Stili veloci tabella pivot della scheda Progettazione eseguire una delle operazioni seguenti:

    • Fare clic su uno stile di tabella pivot visibile oppure scorrere la raccolta per visualizzare altri stili.

    • Per visualizzare tutti gli stili disponibili, fare clic sul pulsante Altro nella parte inferiore della barra di scorrimento.

      immagine della barra multifunzione di excel

      Se si vuole creare uno stile di rapporto di tabella pivot personalizzato, fare clic su Nuovo stile tabella pivot nella parte inferiore della raccolta per visualizzare la finestra di dialogo Nuovo stile tabella pivot.

Applicare righe/colonne alternate evidenziate per modificare il formato di un rapporto di tabella pivot

  1. Fare clic in un punto qualsiasi della tabella pivot.

    Viene visualizzata la scheda Strumenti tabella pivot sulla barra multifunzione.

  2. Nel gruppo Opzioni stile tabella pivot della scheda Progettazione eseguire una delle operazioni seguenti:

    • Per alternare righe di colore più chiaro e più scuro, fare clic su Righe alternate evidenziate.

    • Per alternare colonne di colore più chiaro e più scuro, fare clic su Colonne alternate evidenziate.

    • Per includere le intestazioni di riga in tale stile, selezionare la casella di controllo Intestazioni righe.

    • Per includere le intestazioni di colonna in tale stile, selezionare la casella di controllo Intestazioni colonne.

      immagine della barra multifunzione di excel

Rimuovere uno stile o il formato a righe/colonne alternate evidenziate da un rapporto di tabella pivot

  1. Fare clic in un punto qualsiasi della tabella pivot.

    Viene visualizzata la scheda Strumenti tabella pivot sulla barra multifunzione.

  2. Nel gruppo Stili veloci tabella pivot della scheda Progettazione fare clic sul pulsante Altro nella parte inferiore della barra di scorrimento per visualizzare tutti gli stili disponibili e quindi fare clic su Cancella nella parte inferiore della raccolta.

    immagine della barra multifunzione di excel

Applicare il formato condizionale ai dati in un rapporto di tabella pivot

Usare un formato condizionale per facilitare l'esplorazione e l'analisi visive dei dati, l'individuazione di problemi critici e l'identificazione di schemi e tendenze. La formattazione condizionale aiuta a fornire una risposta a domande specifiche sui dati. Quando si usa la formattazione condizionale in un rapporto di tabella pivot occorre tenere presenti alcune importanti differenze:

  • Se si modifica il layout del rapporto di tabella pivot applicandovi un filtro, nascondendo uno o più livelli, comprimendo o espandendo i livelli o spostando un campo, il formato condizionale verrà mantenuto fintanto che i campi nei dati sottostanti non vengono rimossi.

  • L'ambito del formato condizionale per i campi nell'area dei Valori può essere basato sulla gerarchia di dati ed è determinato da tutti gli elementi figlio visibili (il livello immediatamente inferiore nella gerarchia) di un elemento padre (il livello immediatamente superiore nella gerarchia) sulle righe per una o più colonne o sulle colonne per una o più righe.

    Nota : Nella gerarchia di dati l'elemento figlio non eredita la formattazione condizionale dall'elemento padre e l'elemento padre non eredita la formattazione condizionale dall'elemento figlio.

  • Ci sono tre modi per definire l'ambito della formattazione condizionale dei campi nell'area Valori: per selezione, per campo corrispondente e per campo valore.

Per altre informazioni, vedere Applicare la formattazione condizionale.

Cambiare il formato numero di un campo

  1. Nel rapporto di tabella pivot selezionare il campo desiderato.

    Viene visualizzata la scheda Strumenti tabella pivot sulla barra multifunzione.

  2. Nel gruppo Campo attivo della scheda Analizza o Opzioni fare clic su Impostazioni campo.

    immagine della barra multifunzione di excel

    Verrà visualizzata la finestra di dialogo Impostazioni campo relativa alle etichette e ai filtri del rapporto, mentre per i valori verrà visualizzata la finestra di dialogo Impostazioni campo valore.

  3. Fare clic su Formato numero nella parte inferiore della finestra di dialogo.

  4. Nella finestra di dialogo Formato celle, nell'elenco Categoria, fare clic sul formato numero da usare.

  5. Selezionare le opzioni da usare e quindi fare clic due volte su OK.

    È anche possibile fare clic con il pulsante destro del mouse su un campo valore e scegliere Formato numero.

Includere la formattazione server OLAP

Se si è connessi a un database OLAP (Online Analytical Processing) di Microsoft SQL Server Analysis Services, è possibile specificare i formati server OLAP da recuperare e visualizzare insieme ai dati.

  1. Fare clic in un punto qualsiasi della tabella pivot.

    Viene visualizzata la scheda Strumenti tabella pivot sulla barra multifunzione.

  2. Nel gruppo Dati della scheda Analizza o Opzioni fare clic su Cambia origine dati e quindi su Proprietà connessione.

    immagine della barra multifunzione di excel

  3. Nella finestra di dialogo Proprietà connessione fare clic sulla scheda Utilizzo e quindi nella sezione Formattazione server OLAP eseguire una delle operazioni seguenti:

    • Per abilitare o disabilitare la formattazione numero, ad esempio valuta, data e ora, selezionare o deselezionare la casella di controllo Formato numero

    • Per abilitare o disabilitare gli stili carattere, ad esempio grassetto, corsivo, sottolineato e barrato, selezionare o deselezionare la casella di controllo Stile carattere.

    • Per abilitare o disabilitare i colori di riempimento, selezionare o deselezionare la casella di controllo Colore riempimento.

    • Per abilitare o disabilitare i colori del testo, selezionare o deselezionare la casella di controllo Colore testo.

Mantenere o eliminare la formattazione

  1. Fare clic in un punto qualsiasi della tabella pivot.

    Viene visualizzata la scheda Strumenti tabella pivot sulla barra multifunzione.

  2. Nel gruppo Tabella pivot della scheda Analizza o Opzioni fare clic su Opzioni.

    immagine della barra multifunzione di excel

  3. Nella scheda Layout e formato, in Formato, eseguire una delle operazioni seguenti:

    • Per salvare il layout e il formato del rapporto di tabella pivot, in modo da utilizzarlo ogni volta che si esegue un'operazione nel rapporto di tabella pivot, selezionare la casella di controllo Mantieni formattazione celle all'aggiornamento.

    • Per eliminare il formato e il layout del rapporto di tabella pivot e ripristinare il layout e il formato predefinito ogni volta che si esegue un'operazione nella tabella pivot, deselezionare la casella di controllo Mantieni formattazione celle all'aggiornamento.

    Nota : Mentre questa opzione influisce anche sulla formattazione del rapporto di grafico pivot, non verranno mantenute le linee di tendenza, le etichette dati, le barre di errore e altre modifiche apportate alla serie di dati specifica.

Servono altre informazioni?

È sempre possibile rivolgersi a un esperto nella Tech Community di Excel, ottenere supporto nella community Microsoft o suggerire una nuova caratteristica o un miglioramento in Excel UserVoice.

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×