Creare formule condizionali

La verifica che le condizioni siano vere o false e l'esecuzione di confronti logici tra le espressioni sono operazioni comuni a molte attività. Per creare formule condizionali è possibile usare le funzioni E, O, NON e SE.

Ad esempio, la funzione SE usa gli argomenti seguenti.

Formula con la funzione SE

Formula che usa la funzione SE

Icona del pulsante  verifica_logica: condizione da verificare.

Immagine del pulsante  valore_se_vero: valore da restituire se la condizione è vera.

Icona del pulsante  valore_se_falso: valore da restituire se la condizione è falsa.

Per altre informazioni su come creare formule, vedere Creare o eliminare una formula.

Per saperne di più

Creare una formula condizionale che restituisce un valore logico (VERO o FALSO)

Creare una formula condizionale che restituisce un altro calcolo o valori diversi da VERO o FALSO

Creare una formula condizionale che restituisce un valore logico (VERO o FALSO)

Per eseguire questa attività, usare le funzioni e gli operatori E, O e NON, come illustrato nell'esempio seguente.

Esempio

L'esempio può risultare di comprensione più immediata se lo si copia in un foglio di lavoro nuovo.

Come si copia un esempio?

  1. Selezionare l'esempio in questo articolo.

    Importante : Non selezionare le intestazioni di riga o di colonna.

    Selezione di un esempio nella Guida di Excel 2013 per Windows

    Selezione di un esempio dalla Guida

  2. Premere CTRL+C.

  3. In Excel creare una cartella di lavoro o un foglio di lavoro vuoto.

  4. Nel foglio di lavoro selezionare la cella A1 e premere CTRL+V.

Importante : Per il corretto funzionamento dell'esempio, è necessario incollarlo nella cella A1 del foglio di lavoro.

  1. Per passare dalla visualizzazione dei risultati alla visualizzazione delle formule che restituiscono i risultati, premere CTRL+` (accento grave) oppure fare clic sul pulsante Mostra formule nel gruppo Verifica formule della scheda Formule.

Dopo aver copiato l'esempio in un foglio di lavoro vuoto, è possibile adattarlo in base alle proprie esigenze.

1

2

3

4

5

6

7



8



9


10


11



12

A

B

Dati

15

9

8

Ruote motrici

Congegni

Formula

Descrizione (risultato)

=E(A2>A3; A2<A4)

Determina se il valore nella cella A2 è maggiore del valore nella cella A3 e anche se il valore in A2 è minore del valore in A4. (FALSO)

=O(A2>A3; A2<A4)

Determina se il valore nella cella A2 è maggiore del valore nella cella A3 o se il valore in A2 è minore del valore in A4. (VERO)

=NON(A2+A3=24)

Determina se la somma dei valori nelle celle A2 e A3 non è uguale a 24. (FALSO)

=NON(A5="Ruote motrici")

Determina se il valore nella cella A5 non è uguale a "Ruote motrici". (FALSO)

=O(A5<>"Ruote motrici"; A6 = "Congegni")

Determina se il valore nella cella A5 non è uguale a "Ruote motrici" o se il valore nella cella A6 è uguale a "Congegni". (VERO)

Per altre informazioni sull'uso di queste funzioni, vedere Funzione E, Funzione O e Funzione NON.

Inizio pagina

Creare una formula condizionale che restituisce un altro calcolo o valori diversi da VERO o FALSO

Per eseguire questa attività, usare gli operatori e le funzioni SE, E e O, come illustrato nell'esempio seguente.

Esempio

L'esempio può risultare di comprensione più immediata se lo si copia in un foglio di lavoro nuovo.

Come si copia un esempio?

  1. Selezionare l'esempio in questo articolo.

Importante : Non selezionare le intestazioni di riga o di colonna.

Selezione di un esempio nella Guida di Excel 2013 per Windows

Selezione di un esempio dalla Guida

  1. Premere CTRL+C.

  2. In Excel creare una cartella di lavoro o un foglio di lavoro vuoto.

  3. Nel foglio di lavoro selezionare la cella A1 e premere CTRL+V.

Importante : Per il corretto funzionamento dell'esempio, è necessario incollarlo nella cella A1 del foglio di lavoro.

  1. Per passare dalla visualizzazione dei risultati alla visualizzazione delle formule che restituiscono i risultati, premere CTRL+` (accento grave) oppure fare clic sul pulsante Mostra formule nel gruppo Verifica formule della scheda Formule.

Dopo aver copiato l'esempio in un foglio di lavoro vuoto, è possibile adattarlo in base alle proprie esigenze.

1

2

3

4

5

6

7


8



9



10



11




12



13



14




15



16

A

B

Dati

15

9

8

Ruote motrici

Congegni

Formula

Descrizione (risultato)

=SE(A2=15; "OK"; "NO")

Se il valore nella cella A2 è uguale a 15, viene restituito "OK". Altrimenti viene restituito "NO". (OK)

=SE(A2<>15; "OK"; "NO")

Se il valore nella cella A2 non è uguale a 15, viene restituito "OK". Altrimenti viene restituito "NO". (NO)

=SE(NON(A2<=15); "OK"; "NO")

Se il valore nella A2 non è inferiore o uguale a 15, viene restituito "OK". Altrimenti viene restituito "NO". (NO)

=SE(A5<>"RUOTE MOTRICI"; "OK"; "NO")

Se il valore nella cella A5 non è uguale a "RUOTE MOTRICI", viene restituito "OK". Altrimenti viene restituito "NO". (NO)

=SE(E(A2>A3; A2<A4); "OK"; "NO")

Se il valore nella cella A2 è maggiore del valore nella cella A3 e se il valore in A2 è minore del valore in A4, viene restituito "OK". Altrimenti viene restituito "NO". (NO)

=SE(E(A2<>A3; A2<>A4); "OK"; "NO")

Se il valore nella cella A2 non è uguale al valore nella cella A3 e se il valore in A2 non è uguale al valore in A4, viene restituito "OK". Altrimenti viene restituito "NO". (OK)

=SE(O(A2>A3; A2<A4); "OK"; "NO")

Se il valore nella cella A2 è maggiore del valore nella cella A3 o se il valore in A2 è minore del valore in A4, viene restituito "OK". Altrimenti viene restituito "NO". (OK)

=SE(O(A5<>"Ruote motrici"; A6<>"Congegni"); "OK"; "NO")

Se il valore nella cella A5 non è uguale a "Ruote motrici" o il valore nella cella A6 non è uguale a "Congegni", viene restituito "OK". Altrimenti viene restituito "NO". (NO)

=SE(O(A2<>A3; A2<>A4); "OK"; "NO")

Se il valore nella cella A2 non è uguale al valore nella cella A3 o se il valore in A2 non è uguale al valore in A4, viene restituito "OK". Altrimenti viene restituito "NO". (OK)

Per altre informazioni sull'uso di queste funzioni, vedere Funzione SE, Funzione E e Funzione O.

Inizio pagina

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×