Creare, eseguire, modificare o eliminare una macro

Importante :  Il presente articolo è stato tradotto automaticamente, vedere la dichiarazione di non responsabilità. Per visualizzare la versione inglese dell'articolo, fare clic qui.

Per risparmiare tempo nelle attività eseguite di frequente, è possibile registrare i relativi passaggi come macro. Quindi, quando si vuole eseguire una di queste attività registrate, è possibile attivare la macro per eseguire automaticamente i passaggi.

Word

In Word 2016 per Mac, è possibile creare una macro che contiene una scelta rapida da tastiera, eseguire una macro ed eliminare una macro che non è più necessario.

  1. Fare clic su Visualizza > Macro > Registra macro.

    Nella scheda Visualizza fare clic su Macro e quindi su Registra macro per iniziare a creare una macro.
  2. Digitare un nome per la macro oppure accettare il nome predefinito suggerito da Word.

    Immettere un nome per la macro in Nome macro o accettare il nome generico fornito da Word.
  3. Per usare questa macro in tutti i nuovi documenti creati, assicurarsi che l'opzione Tutti i documenti (Normal) sia selezionata nell'elenco Memorizza la macro in.

  4. Fare clic su Tastiera per assegnare una combinazione di tasti alla macro.

    Word visualizza la finestra di dialogo Personalizza tastiera.

  5. Digitare una combinazione di tasti nella casella Premere la nuova scelta rapida da tastiera.

    Dopo la pressione di una combinazione di tasti, Word visualizza il comando o la macro eventualmente già assegnata alla combinazione.

    Quando si preme una combinazione di tasti, Word visualizza il comando o l'azione attualmente assegnata a tale combinazione di tasti, se presente.

  6. Se la combinazione di tasti specificata è già assegnata, eliminarla dalla casella Premere la nuova scelta rapida da tastiera e scegliere una nuova combinazione di tasti.

    Dopo aver trovato una combinazione di tasti non assegnata, andare al passaggio successivo.

    Word rileva la pressione di una combinazione di tasti non ancora assegnata a un comando o una macro.
  7. Per usare questa scelta rapida da tastiera in tutti i nuovi documenti creati, assicurarsi che il modello generale Normal.dotm sia selezionato nell'elencoSalva le modifiche in.

    Selezionare Normal.dotm per rendere una macro disponibile per l'uso nei nuovi documenti creati.
  8. Fare clic su Assegna.

  9. Quando si è pronti a registrare la macro, fare clic su OK.

  10. Fare clic sui comandi o premere i tasti per ogni passaggio dell'attività.

    Word registra i clic e le pressioni di tasti, ma non registra il testo selezionato con il mouse. Per selezionare testo durante la registrazione di una macro, usare la tastiera.

  11. Per interrompere la registrazione, fare clic su Visualizza > Macro > Interrompi registrazione.

    Per interrompere la registrazione di una macro, scegliere Interrompi registrazione dal menu Macro.

Per eseguire una macro, premere la scelta rapida da tastiera assegnata alla macro oppure selezionare la macro nell'elenco Macro.

  1. Fare clic su Visualizza > Macro > Visualizza macro.

    Fare clic su Visualizza macro per visualizzare e modificare le macro associate al documento corrente.
  2. Nell'elenco in Nome macro selezionare la macro da eseguire.

  3. Fare clic su Esegui.

    Dopo aver selezionato una macro in Nome macro, fare clic su Esegui per eseguirla.

  1. Fare clic su Visualizza > Macro > Visualizza macro.

    Fare clic su Visualizza macro per visualizzare e modificare le macro associate al documento corrente.
  2. Assicurarsi che la posizione specificata in Macro in includa la posizione della macro da eliminare.

    Selezionare la posizione da cui si vogliono visualizzare le macro nell'elenco Macro.

    L'elenco include il documento aperto nella finestra corrente, nonché il modello globale e i comandi di Word.

  3. In Nome macro selezionare la macro da eliminare e quindi fare clic sul segno meno sotto l'elenco.

    Selezionare la macro da eliminare e fare clic sul segno meno sotto l'elenco.
  4. Quando Word chiede di confermare l'eliminazione della macro, fare clic su .

Excel

In Excel 2016 per Mac, è possibile creare una macro che contiene una scelta rapida da tastiera, eseguire una macro ed eliminare una macro che non è più necessario.

Quando si registra una macro, i record registratore macro tutti i passaggi necessari per completare le azioni che si desidera che la macro da eseguire. Questa procedura è possibile includere a digitare testo o numeri, selezione di celle o i comandi sulla barra multifunzione o nei menu, formattazione, la selezione di celle, righe o colonne e trascinare il puntatore del mouse per selezionare le celle del foglio di calcolo.

Nota : I comandi per la registrazione, la creazione e l'eliminazione di macro, nonché altre caratteristiche avanzate, sono disponibili nella scheda sviluppo sulla barra multifunzione. Per ulteriori informazioni sull'utilizzo della scheda sviluppo, vedere utilizzare la scheda sviluppo per creare o eliminare una macro in Excel 2016 per Mac.

  1. Selezionare Strumenti > Macro > Registra nuovo.

    Selezionare Strumenti, quindi Macro, quindi Registra nuova Macro

  2. Immettere un nome per la macro nella casella Nome macro.

    Immettere una chiave di nome, percorso e scelta rapida di macro

  3. Per creare un tasto di scelta rapida per la macro, digitare una lettera nella casella opzione + Cmd.

  4. Selezionare un percorso per la macro nell'elenco a discesa.

    Per salvare la macro

    Fare clic su

    Nel documento in cui si sta creando una macro

    Questa cartella di lavoro

    In tutti i documenti aperti

    Nuova cartella di lavoro

    Per rendere la macro disponibile ogni volta che si usa Excel

    Cartella di lavoro Macro personale

  5. (Facoltativo) Aggiungere una descrizione della macro.

  6. Quando si è pronti a registrare, fare clic su OK.

  7. Fare clic sui comandi o premere i tasti per ogni passaggio dell'attività.

  8. Per interrompere la registrazione, selezionare Strumenti > Macro > Interrompi registrazione. (Questo passaggio non verrà registrato nella macro.)

    Selezionare Interrompi registrazione

Per eseguire una macro, premere il tasto di scelta rapida assegnato oppure eseguire la macro dalla finestra di dialogo macro.

  1. Nella scheda Visualizza fare clic su Visualizza macro.

  2. Fare clic su macro nel menu a comparsa e selezionare Questa cartella di lavoro.

  3. Selezionare la macro nell'elenco e fare clic su Esegui.

    Finestra di dialogo Macro di Excel per Mac

  1. Selezionare Strumenti > Macro > macro.

    Selezionare l'azione di Macro e quindi selezionare le macro

  2. Selezionare la macro da eliminare e quindi premere il segno meno.

    Selezionare il nome di macro e quindi selezionare il segno meno

  3. Verrà visualizzato un messaggio di conferma. Fare clic su per confermare l'eliminazione.

    Confermare l'eliminazione

È anche possibile eliminare una macro nella scheda sviluppo.

  1. Nella scheda Sviluppo fare clic su Macro.

  2. Nell'elenco selezionare la macro da eliminare e fare clic su Elimina.

    Selezionare una macro e fare clic sul segno meno per eliminarla

Word

Per automatizzare un'attività ripetitiva è possibile creare rapidamente una macro in Word. Si può anche usare Visual Basic Editor in Microsoft Visual Basic, Applications Edition per creare uno script macro personalizzato o per copiare una macro, o parte di essa, in una nuova macro.

Quando si registra una macro, vengono registrati tutti i passaggi necessari per completare le azioni che si desidera che la macro da eseguire. Tuttavia, tornare alla scheda per interrompere la registrazione non è incluso nella registrazione.

  1. Nella scheda Sviluppo, in Visual Basic, fare clic su Registra.

    Scheda Sviluppatore Word, gruppo Visual Basic

    Se la scheda Sviluppo non è disponibile

    1. Sul lato destro della barra multifunzione fare clic su Menu a comparsa Azione , quindi scegliere Preferenze barra multifunzione.

    2. In Personalizza selezionare la casella di controllo Sviluppo.

  2. Immettere un nome per la macro nella casella Nome macro.

  3. Nel menu a comparsa Memorizza la macro in eseguire una delle operazioni seguenti:

    Per salvare la macro

    Fare clic su

    Nel documento in cui si sta creando la macro

    [nome documento] (documento)

    In tutti i documenti aperti

    Tutti i documenti (Normale)

  4. Fare clic su OK e quindi eseguire le azioni da registrare.

  5. Nella scheda Sviluppo, in Visual Basic, fare clic su Interrompi.

Per creare una macro è possibile usare Visual Basic Editor incorporato.

  1. Nella scheda Sviluppo, in Visual Basic, fare clic su Editor.

    Scheda Sviluppatore Word, gruppo Visual Basic

    Se la scheda Sviluppo non è disponibile

    1. Sul lato destro della barra multifunzione fare clic su Menu a comparsa Azione , quindi scegliere Preferenze barra multifunzione.

    2. In Personalizza selezionare la casella di controllo Sviluppo.

  2. Se è necessario inserire un modulo, fare clic su Modulo nel menu Inserisci di Visual Basic Editor.

  3. Nella finestra del codice del modulo digitare o incollare il codice della macro che si vuole usare.

  4. Al termine dell'operazione, scegliere Chiudi e torna a Microsoft Word dal menu Word.

  1. Nella scheda Sviluppo, in Visual Basic, fare clic su Macro.

    Scheda Sviluppatore Word, gruppo Visual Basic

    Se la scheda Sviluppo non è disponibile

    1. Sul lato destro della barra multifunzione fare clic su Menu a comparsa Azione , quindi scegliere Preferenze barra multifunzione.

    2. In Personalizza selezionare la casella di controllo Sviluppo.

  2. Nell'elenco selezionare la macro da eseguire e fare clic su Esegui.

Per modificare una macro si usa Visual Basic Editor.

  1. Nella scheda Sviluppo, in Visual Basic, fare clic su Macro.

    Scheda Sviluppatore Word, gruppo Visual Basic

    Se la scheda Sviluppo non è disponibile

    1. Sul lato destro della barra multifunzione fare clic su Menu a comparsa Azione , quindi scegliere Preferenze barra multifunzione.

    2. In Personalizza selezionare la casella di controllo Sviluppo.

  2. Nell'elenco selezionare la macro da modificare e fare clic su Modifica.

    Viene aperto Visual Basic Editor.

  3. Apportare le modifiche desiderate.

  4. Al termine dell'operazione, scegliere Chiudi e torna a Microsoft Word dal menu Word.

  1. Nella scheda Sviluppo, in Visual Basic, fare clic su Macro.

    Scheda Sviluppatore Word, gruppo Visual Basic

    Se la scheda Sviluppo non è disponibile

    1. Sul lato destro della barra multifunzione fare clic su Menu a comparsa Azione , quindi scegliere Preferenze barra multifunzione.

    2. In Personalizza selezionare la casella di controllo Sviluppo.

  2. Nell'elenco selezionare la macro da copiare e fare clic su Modifica.

    Viene aperto Visual Basic Editor.

  3. Nella finestra del codice di Visual Basic Editor selezionare le righe della macro da copiare.

    Suggerimento : Per copiare l'intera macro, includere nella selezione le righe Sub ed End Sub.

  4. Scegliere Copia dal menu Modifica.

  5. Nella casella Progetto della finestra del codice fare clic sul modulo in cui si vuole inserire il codice.

  6. Scegliere Incolla dal menu Modifica.

  1. Nella scheda Sviluppo, in Visual Basic, fare clic su Macro.

    Scheda Sviluppatore Word, gruppo Visual Basic

    Se la scheda Sviluppo non è disponibile

    1. Sul lato destro della barra multifunzione fare clic su Menu a comparsa Azione , quindi scegliere Preferenze barra multifunzione.

    2. In Personalizza selezionare la casella di controllo Sviluppo.

  2. Nell'elenco selezionare la macro da eliminare e fare clic su Elimina.

PowerPoint

Per automatizzare le attività ripetitive, è possibile utilizzare Visual Basic, Applications Edition per creare un macro in PowerPoint.

Per creare una macro è possibile usare Visual Basic Editor incorporato.

  1. Nella scheda Sviluppo, in Visual Basic, fare clic su Editor.

    Scheda Sviluppatore di PowerPoint, gruppo Visual Basic

    Se la scheda Sviluppo non è disponibile

    1. Sul lato destro della barra multifunzione fare clic su Menu a comparsa Azione , quindi scegliere Preferenze barra multifunzione.

    2. In Personalizza selezionare la casella di controllo Sviluppo.

  2. Se è necessario inserire un modulo, fare clic su Modulo nel menu Inserisci di Visual Basic Editor.

  3. Nella finestra del codice del modulo digitare o incollare il codice della macro che si vuole usare.

  4. Al termine dell'operazione, scegliere Chiudi e torna a Microsoft PowerPoint dal menu PowerPoint.

  1. Nella scheda Sviluppo, in Visual Basic, fare clic su Macro.

    Scheda Sviluppatore di PowerPoint, gruppo Visual Basic

    Se la scheda Sviluppo non è disponibile

    1. Sul lato destro della barra multifunzione fare clic su Menu a comparsa Azione , quindi scegliere Preferenze barra multifunzione.

    2. In Personalizza selezionare la casella di controllo Sviluppo.

  2. Nell'elenco selezionare la macro da eseguire e fare clic su Esegui.

Per modificare una macro si usa Visual Basic Editor.

  1. Nella scheda Sviluppo, in Visual Basic, fare clic su Macro.

    Scheda Sviluppatore di PowerPoint, gruppo Visual Basic

    Se la scheda Sviluppo non è disponibile

    1. Sul lato destro della barra multifunzione fare clic su Menu a comparsa Azione , quindi scegliere Preferenze barra multifunzione.

    2. In Personalizza selezionare la casella di controllo Sviluppo.

  2. Nell'elenco selezionare la macro da modificare e fare clic su Modifica.

    Viene aperto Visual Basic Editor.

  3. Apportare le modifiche desiderate.

  4. Al termine dell'operazione, scegliere Chiudi e torna a Microsoft PowerPoint dal menu PowerPoint.

  1. Nella scheda Sviluppo, in Visual Basic, fare clic su Macro.

    Scheda Sviluppatore di PowerPoint, gruppo Visual Basic

    Se la scheda Sviluppo non è disponibile

    1. Sul lato destro della barra multifunzione fare clic su Menu a comparsa Azione , quindi scegliere Preferenze barra multifunzione.

    2. In Personalizza selezionare la casella di controllo Sviluppo.

  2. Nell'elenco selezionare la macro da copiare e fare clic su Modifica.

    Viene aperto Visual Basic Editor.

  3. Nella finestra del codice di Visual Basic Editor selezionare le righe della macro da copiare.

    Suggerimento : Per copiare l'intera macro, includere nella selezione le righe Sub ed End Sub.

  4. Scegliere Copia dal menu Modifica.

  5. Nella casella Progetto della finestra del codice fare clic sul modulo in cui si vuole inserire il codice.

  6. Scegliere Incolla dal menu Modifica.

  1. Nella scheda Sviluppo, in Visual Basic, fare clic su Macro.

    Scheda Sviluppatore di PowerPoint, gruppo Visual Basic

    Se la scheda Sviluppo non è disponibile

    1. Sul lato destro della barra multifunzione fare clic su Menu a comparsa Azione , quindi scegliere Preferenze barra multifunzione.

    2. In Personalizza selezionare la casella di controllo Sviluppo.

  2. Nell'elenco selezionare la macro da eliminare e fare clic su Elimina.

Excel

Per automatizzare un'attività ripetitiva è possibile creare rapidamente una macro in Excel. Si può anche usare Visual Basic Editor in Microsoft Visual Basic, Applications Edition per creare uno script macro personalizzato o per copiare una macro, o parte di essa, in una nuova macro.

Vengono registrati tutti i passaggi necessari per completare le azioni che si desidera eseguire mediante la macro, tranne lo spostamento all'indietro per tornare alla scheda e interrompere la registrazione.

  1. Nella scheda Sviluppo, in Visual Basic, fare clic su Registra.

    Scheda Sviluppatore Excel, gruppo Visual Basic

    Se la scheda Sviluppo non è disponibile

    1. Sul lato destro della barra multifunzione fare clic su Menu a comparsa Azione , quindi scegliere Preferenze barra multifunzione.

    2. In Personalizza selezionare la casella di controllo Sviluppo.

  2. Immettere un nome per la macro nella casella Nome macro.

    Suggerimento : Per creare una scelta rapida da tastiera per la macro, digitare una lettera nella casella Opzione+Cmd+.

  3. Nel menu a comparsa Memorizza la macro in eseguire una delle operazioni seguenti:

    Per salvare la macro

    Fare clic su

    Nel documento in cui si sta creando la macro

    Questa cartella di lavoro

    In tutti i documenti aperti

    Nuova cartella di lavoro

    Per rendere la macro disponibile ogni volta che si usa Excel

    Cartella macro personale

    La cartella di lavoro macro personale si trova in utenti / nomeutente/Library/Application supportano / Microsoft/Office/Excel.

  4. Fare clic su OK e quindi eseguire le azioni da registrare.

  5. Nella scheda Sviluppo, in Visual Basic, fare di nuovo clic su Registra.

Per creare una macro è possibile usare Visual Basic Editor incorporato.

  1. Nella scheda Sviluppo, in Visual Basic, fare clic su Editor.

    Scheda Sviluppatore Excel, gruppo Visual Basic

    Se la scheda Sviluppo non è disponibile

    1. Sul lato destro della barra multifunzione fare clic su Menu a comparsa Azione , quindi scegliere Preferenze barra multifunzione.

    2. In Personalizza selezionare la casella di controllo Sviluppo.

  2. Se è necessario inserire un modulo, fare clic su Modulo nel menu Inserisci di Visual Basic Editor.

  3. Nella finestra del codice del modulo digitare o incollare il codice della macro che si vuole usare.

  4. Al termine dell'operazione, scegliere Chiudi e torna a Microsoft Excel dal menu Excel.

  1. Nella scheda Sviluppo, in Visual Basic, fare clic su Macro.

    Scheda Sviluppatore Excel, gruppo Visual Basic

    Se la scheda Sviluppo non è disponibile

    1. Sul lato destro della barra multifunzione fare clic su Menu a comparsa Azione , quindi scegliere Preferenze barra multifunzione.

    2. In Personalizza selezionare la casella di controllo Sviluppo.

  2. Nell'elenco selezionare la macro da eseguire e fare clic su Esegui.

    Suggerimento : Per eseguire una macro usando una scelta rapida da tastiera, premere OPZIONE + COMANDO + la lettera digitata al momento della creazione della scelta rapida da tastiera.

Per modificare una macro si usa Visual Basic Editor.

  1. Nella scheda Sviluppo, in Visual Basic, fare clic su Macro.

    Scheda Sviluppatore Excel, gruppo Visual Basic

    Se la scheda Sviluppo non è disponibile

    1. Sul lato destro della barra multifunzione fare clic su Menu a comparsa Azione , quindi scegliere Preferenze barra multifunzione.

    2. In Personalizza selezionare la casella di controllo Sviluppo.

  2. Nell'elenco selezionare la macro da modificare e fare clic su Modifica.

    Viene aperto Visual Basic Editor.

  3. Apportare le modifiche desiderate.

  4. Al termine dell'operazione, scegliere Chiudi e torna a Microsoft Excel dal menu Excel.

Dopo il completamento di questa procedura, la macro verrà eseguita ogni volta che verrà aperta la cartella di lavoro che la contiene.

  1. Nella scheda Sviluppo, in Visual Basic, fare clic su Registra.

    Scheda Sviluppatore Excel, gruppo Visual Basic

    Se la scheda Sviluppo non è disponibile

    1. Sul lato destro della barra multifunzione fare clic su Menu a comparsa Azione , quindi scegliere Preferenze barra multifunzione.

    2. In Personalizza selezionare la casella di controllo Sviluppo.

  2. Nella casella Nome macro digitare Auto_apri.

  3. Nel menu a comparsa Memorizza la macro in eseguire una delle operazioni seguenti:

    Per salvare la macro

    Fare clic su

    Nel documento in cui si sta creando la macro

    Questa cartella di lavoro

    In tutti i documenti aperti

    Nuova cartella di lavoro

    Per rendere la macro disponibile ogni volta che si usa Excel

    Cartella macro personale

  4. Fare clic su OK e quindi eseguire le azioni da registrare.

  5. Nella scheda Sviluppo, in Visual Basic, fare di nuovo clic su Registra.

  6. Scegliere Salva con nome dal menu File.

  7. Nel menu a comparsa Formato fare clic su Cartella di lavoro con attivazione macro di Excel (*.xlsm) e scegliere Salva.

  1. Nella scheda Sviluppo, in Visual Basic, fare clic su Macro.

    Scheda Sviluppatore Excel, gruppo Visual Basic

    Se la scheda Sviluppo non è disponibile

    1. Sul lato destro della barra multifunzione fare clic su Menu a comparsa Azione , quindi scegliere Preferenze barra multifunzione.

    2. In Personalizza selezionare la casella di controllo Sviluppo.

  2. Nell'elenco selezionare la macro da copiare e fare clic su Modifica.

    Viene aperto Visual Basic Editor.

  3. Nella finestra del codice di Visual Basic Editor selezionare le righe della macro da copiare.

    Suggerimento : Per copiare l'intera macro, includere nella selezione le righe Sub ed End Sub.

  4. Scegliere Copia dal menu Modifica.

  5. Nella casella Progetto della finestra del codice fare clic sul modulo in cui si vuole inserire il codice.

  6. Scegliere Incolla dal menu Modifica.

  1. Nella scheda Sviluppo, in Visual Basic, fare clic su Macro.

    Scheda Sviluppatore Excel, gruppo Visual Basic

    Se la scheda Sviluppo non è disponibile

    1. Sul lato destro della barra multifunzione fare clic su Menu a comparsa Azione , quindi scegliere Preferenze barra multifunzione.

    2. In Personalizza selezionare la casella di controllo Sviluppo.

  2. Nell'elenco selezionare la macro da eliminare e fare clic su Elimina.

Nota : Dichiarazione di non responsabilità per la traduzione automatica: Il presente articolo è stato tradotto tramite un software di traduzione automatica e non da una persona. Microsoft offre le traduzioni automatiche per consentire a coloro che non conoscono la lingua inglese di leggere gli articoli sui prodotti, sui servizi e sulle tecnologie Microsoft. Dal momento che l'articolo è stato tradotto automaticamente, potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli.

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×