Creare e condividere un dashboard con Excel e Gruppi di Microsoft

Un dashboard è una rappresentazione visiva delle metriche principali che consentono di visualizzare e analizzare rapidamente i dati in un'unica posizione. I dashboard non forniscono solo visualizzazioni dati consolidate, ma anche un'opportunità di business intelligence in modalità self-service che consente agli utenti di filtrare i dati per visualizzare solo gli elementi più rilevanti. In passato, la creazione di rapporti di Excel spesso richiedeva la generazione di più rapporti per i diversi utenti o reparti, in base alle esigenze specifiche.

Esempio di un dashboard di Excel con filtri dei dati e sequenza temporale

Panoramica

In questo argomento verrà spiegato come usare più tabelle pivot, grafici pivot e Strumenti tabella pivot per creare un dashboard dinamico. Quindi gli utenti potranno filtrare rapidamente i dati desiderati con i filtri dei dati e una sequenza temporale, che consentono di espandere e comprimere automaticamente le tabelle pivot e i grafici per visualizzare solo le informazioni rilevanti. Inoltre, è possibile aggiornare rapidamente il dashboard quando si aggiungono o si aggiornano i dati. Si tratta di una funzionalità molto utile perché consente di creare il rapporto dashboard una sola volta.

In questo esempio verranno creati quattro grafici e tabelle pivot da un'unica origine dati.

Dopo aver creato il dashboard, verrà mostrato come condividerlo con altri utenti creando un gruppo di Microsoft. È disponibile anche una cartella di lavoro di Excel interattiva che può essere scaricata per eseguire la procedura autonomamente.

Scaricare la cartella di lavoro con esercitazione del dashboard di Excel.

Recuperare i dati

  1. È possibile copiare e incollare dati direttamente in Excel oppure configurare una query da un'origine dati. Per questo argomento è stata usata la query Analisi delle vendite del modello Northwind Traders per Microsoft Access. Per usarla, è possibile aprire Access e passare a File > Nuovo e cercare "Northwind" e creare il modello di database. Al termine, sarà possibile accedere a tutte le query incluse nel modello. Questi dati sono già predisposti nella cartella di lavoro di Excel, quindi non è necessario avere Access.

  2. Verificare che i dati siano strutturati correttamente, senza righe o colonne mancanti. Ogni riga deve rappresentare un singolo record o elemento. Per facilitare la configurazione di una query oppure se i dati devono essere modificati, vedere Recupera e trasforma in Excel.

    Dati di esempio in una tabella di Excel da usare come origine dati della tabella pivot
  3. Se non lo sono già, formattare i dati come tabella di Excel. Quando si importa da Access, i dati vengono importati automaticamente in una tabella.

Creare tabelle pivot

  1. Selezionare una cella nell'intervallo di dati e passare a Inserisci > Tabella pivot > Nuovo foglio di lavoro. Per altre informazioni, vedere Creare una tabella pivot per analizzare i dati di un foglio di lavoro.

  2. Aggiungere i campi desiderati della tabella pivot, quindi formattare secondo le proprie preferenze. Questa tabella pivot sarà la base per le altre tabelle, quindi è opportuno dedicare un po' di tempo per apportare tutte le modifiche necessarie a stile, layout del rapporto e formattazione generale in modo da non dover ripetere l'operazione successivamente. Per altri dettagli, vedere: Modificare il layout e il formato di un rapporto di tabella pivot.

    In questo caso, le vendite vengono inserite in un riepilogo principale in base alla categoria del prodotto e ordinate per il campo Vendite in ordine decrescente.

    Tabella pivot di esempio per Categoria, Vendite e % totale

    Per altri dettagli, vedere Ordinare i dati in una tabella pivot o in un grafico pivot.

  3. Dopo aver creato la tabella pivot master, selezionarla e quindi copiarla e incollarla tutte le volte necessarie nelle aree vuote del foglio di lavoro. Nell'esempio le tabelle pivot possono modificare le righe, ma non le colonne, che quindi vengono inserite sulla stessa riga con una colonna vuota a separarle. Tuttavia, potrebbe essere necessario inserire le tabelle pivot l'una sotto l'altra, se è possibile espandere le colonne.

    Importante : Le tabelle pivot non possono sovrapporsi tra loro, quindi assicurarsi che ci sia spazio sufficiente tra di esse per consentirne l'espansione e la compressione quando i valori vengono filtrati, aggiunti o rimossi.

    A questo punto è consigliabile assegnare nomi significativi alle tabelle pivot per indicare a cosa servono. In caso contrario, Excel assegna nomi come TabellaPivot1, TabellaPivot2 e così via. È possibile selezionare le singole tabelle, quindi passare a Strumenti tabella pivot > Analizza e immettere un nuovo nome nella casella Nome tabella pivot. Questo è un passaggio importante per la connessione delle tabelle pivot a Filtri dei dati e ai controlli di Sequenza temporale.

    Rinominare una tabella pivot da Strumenti tabella pivot > Analizza > casella Nome tabella pivot

Creare grafici pivot

  1. Fare clic in un punto qualsiasi della prima tabella pivot e passare a Strumenti tabella pivot > Analizza > Grafico pivot, quindi selezionare un tipo di grafico. Abbiamo scelto un grafico combinato con Vendite rappresentato in un istogramma a colonne raggruppate e % totale in un grafico a linee tracciato sull'asse secondario.

    Finestra di dialogo per la selezione del grafico per un grafico combinato con colonne raggruppate e grafico a linee
  2. Selezionare il grafico, quindi impostare le dimensioni e il formato desiderati nella scheda Strumenti grafico pivot. Per altre informazioni, vedere la serie sulla formattazione dei grafici.

  3. Ripetere per ognuna delle tabelle pivot rimanenti.

  4. È ora possibile rinominare anche i grafici pivot. Passare a Strumenti grafico pivot > Analizza e immettere un nuovo nome per la casella Nome grafico.

Aggiungere i filtri dei dati e una sequenza temporale

I filtri dei dati e le sequenze temporali consentono di filtrare rapidamente le tabelle e i grafici pivot, in modo da visualizzare solo le informazioni rilevanti.

Visualizzazione esplosa di Filtri dei dati e di un controllo di Sequenza temporale in un dashboard
  1. Selezionare una tabella pivot e passare a Strumenti tabella pivot > Analizza > Filtro > Inserisci filtro dati, quindi selezionare tutti gli elementi da usare per un filtro dei dati. Per questo dashboard sono stati selezionati Categoria, Nome prodotto, Dipendente e Nome cliente. Quando si fa clic su OK, i filtri dei dati verranno aggiunti al centro dello schermo, disposti in pila l'uno sull'altro, quindi sarà necessario disporli e ridimensionarli in base alle esigenze.

    Opzione Inserisci filtro dati in Strumenti tabella pivot > Analizza > Filtro
  2. Opzioni del filtro dei dati: se si fa clic su un filtro dei dati, è possibile accedere a Strumenti filtro dati > Opzioni e selezionare varie opzioni, ad esempio lo Stile e il numero di colonne visualizzato. È possibile allineare più filtri dei dati selezionandoli con CTRL+clic, quindi usare gli strumenti di Allinea nella scheda Strumenti filtro dati.

  3. Connessioni filtro dati: i filtri dei dati vengono connessi solo alla tabella pivot usata per crearli, quindi è necessario selezionare i singoli filtri dei dati, passare a Strumenti filtro dati > Opzioni > Connessioni rapporto e quindi selezionare le tabelle pivot da connettere a ciascun filtro. I filtri dei dati e le sequenze temporali possono controllare le tabelle pivot in qualsiasi foglio di lavoro, anche se è nascosto.

    Connessioni rapporto del filtro dei dati da Strumenti filtro dati > Opzioni
  4. Aggiungere una sequenza temporale: selezionare una tabella pivot e passare a Strumenti tabella pivot > Analizza > Filtro > Inserisci sequenza temporale, quindi selezionare tutti gli elementi da usare. Per questo dashboard è selezionato Data ordine.

  5. Opzioni della sequenza temporale: fare clic su Sequenza temporale e passare a Strumenti sequenza temporale > Opzioni, selezionare opzioni come Stile, Intestazione e Didascalia. Selezionare l'opzione Connessioni rapporto per collegare la sequenza temporale alle tabelle pivot di propria scelta.

Altre informazioni su Filtri dei dati e i controlli di Sequenza temporale.

Passaggi successivi

Il dashboard ora ha tutte le funzionalità, ma è comunque necessario disporle secondo le proprie preferenze e apportare le modifiche finali. Ad esempio, è consigliabile aggiungere un titolo del rapporto o uno sfondo. Nel dashboard sono state aggiunte forme intorno alle tabelle pivot e disattivate intestazioni e linee della griglia dalla scheda Visualizza.

Testare ognuno dei filtri dei dati e delle sequenze temporali per verificare che le tabelle e i grafici pivot si comportino come previsto. Alcune selezioni causano problemi, ad esempio modifiche a una tabella pivot che comportano la sovrapposizione a un'altra tabella. Questo comportamento non è consentito e causa la visualizzazione di un messaggio di errore. Prima di distribuire il dashboard, è necessario correggere questi problemi.

Dopo aver configurato il dashboard, è possibile fare clic sulla scheda "Condividere il dashboard" nella parte superiore di questo argomento per informazioni su come distribuirlo.

Il dashboard è stato creato correttamente. In questo passaggio viene spiegato come configurare un gruppo di Microsoft per condividere il dashboard. Viene indicato come aggiungere il dashboard nella parte superiore della raccolta documenti del gruppo in SharePoint, in modo che gli utenti possano accedervi facilmente in qualsiasi momento.

Nota : Se il gruppo non è ancora stato configurato, vedere Creare un gruppo in Outlook

Archiviare il dashboard nel gruppo

Se la cartella di lavoro del dashboard non è stata ancora salvata nel gruppo, spostarla ora. Se invece si trova già nella raccolta file del gruppo, è possibile ignorare questo passaggio.

  1. Passare al gruppo in Outlook 2016 o Outlook sul Web.

  2. Fare clic su File sulla barra multifunzione per accedere alla raccolta documenti del gruppo.

  3. Fare clic sul pulsante Carica sulla barra multifunzione e caricare la cartella di lavoro del dashboard nella raccolta documenti.

Aggiungerlo al sito del team di SharePoint Online del gruppo

  1. Se la raccolta documenti è stata aperta da Outlook 2016, fare clic su Home nel riquadro di spostamento a sinistra. Se la raccolta documenti è stata aperta da Outlook sul Web, fare clic su Altro > Sito nell'estremità destra della barra multifunzione.

  2. Fare clic su Documenti nel riquadro di spostamento a sinistra.

  3. Trovare la cartella di lavoro del dashboard e fare clic sul cerchio di selezione a sinistra del nome.

  4. Con la cartella di lavoro del dashboard selezionata, scegliere Aggiungi in alto sulla barra multifunzione.

Selezionare il file e fare clic su Aggiungi in alto per renderlo facilmente accessibile nella raccolta documenti

Ora, ogni volta che gli utenti accedono alla pagina Documenti del sito del team di SharePoint Online, il foglio di lavoro del dashboard sarà facilmente accessibile nella parte superiore della pagina. Possono selezionarlo e accedere facilmente alla versione corrente del dashboard.

Suggerimento : Gli utenti possono anche accedere alla raccolta documenti del gruppo, che include la cartella di lavoro del dashboard, usando l'app Outlook Groups per dispositivi mobili. Per altre informazioni, vedere App Outlook Groups per dispositivi mobili.

Vedere anche

Se non sono state trovate risposte alle proprie domande,

visitare la community Microsoft Answers.

Feedback

Questo articolo è stato rivisto l'ultima volta da Ben e Chris il 16 marzo 2017 in seguito al feedback degli utenti. Se le informazioni presentate sono risultate utili, e a maggior ragione se non lo sono state, fare clic sui controlli relativi ai feedback riportati sotto e lasciare un commento costruttivo per aiutarci a migliorare costantemente. Grazie!

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×