Creare codici WBS

In breve, i codici WBS (Work Breakdown Structure, struttura di suddivisione del lavoro) sono numeri di struttura che è possibile applicare alle attività e modificare in base alle specifiche esigenze aziendali. I numeri di struttura di base vengono forniti automaticamente per ogni attività, tuttavia è possibile applicare in qualsiasi momento uno schema di struttura personalizzato al progetto.

La sezione seguente si applica solo a Microsoft Project 2016, 2013 e 2010.

Per saperne di più

Creare codici WBS personalizzati

Rinumerare i codici WBS

Utilizzare i numeri di struttura di base

Creare codici WBS personalizzati

  1. Fare clic su Visualizza, quindi scegliere una visualizzazione a elenco, ad esempio Elenco attività o Elenco risorse.

  2. Fare clic su Progetto. Nel gruppo Proprietà fare clic su WBS e quindi su Definisci codice.

    Immagine dell'opzione Definisci codice del pulsante WBS.

  3. È possibile creare un codice specifico del progetto nella casella Prefisso codice progetto utilizzando numeri, lettere maiuscole e minuscole e simboli.

Immagine della finestra di dialogo Definizione codice WBS

  1. Per impostare il codice per le attività di primo livello, nella prima riga della colonna Sequenza scegliere un tipo di carattere dall'elenco a discesa. È possibile scegliere tra numeri, lettere maiuscole o minuscole oppure utilizzare una combinazione di numeri, lettere e altri simboli.

  2. Nella colonna Lunghezza impostare il numero di caratteri per ogni livello dell'impostazione della stringa di codice. Scegliere Qualsiasi per consentire qualsiasi numero di caratteri per quel livello.

  3. Nella colonna Separatore scegliere un carattere per separare il codice per un livello da quello per il livello successivo.

    Il separatore predefinito è il punto. È possibile altri separatori oppure decidere di non utilizzarne alcuno.

    Nota :  Il carattere separatore non può anche essere utilizzato come parte di un codice.

  4. Impostare una stringa di codice per ogni livello di attività con rientro nella struttura.

    Per specificare singoli codici per ogni livello, fare clic sulla riga successiva e completare le colonne Sequenza, Lunghezza e Separatore.

  5. Per impedire l'assegnazione automatica di un codice WBS ogni volta che viene immessa una nuova attività, deselezionare la casella di controllo Genera codice WBS per nuova attività.

  6. Per consentire l'utilizzo dello stesso codice WBS per più attività, deselezionare la casella di controllo Verifica univocità dei nuovi codici WBS.

Rinumerare i codici WBS

Quando si spostano o eliminano attività, i codici WBS non vengono rinumerati automaticamente quando vengono utilizzati in documenti o altri sistemi non collegati al file di Project. Ciò significa che i codici per le attività rimanenti saranno con tutta probabilità errati. Di seguito viene illustrato come rinumerare i codici WBS per tutte le attività o solo quelle selezionate:

  1. Fare clic su Visualizza, quindi scegliere una visualizzazione ad elenco, ad esempio Elenco attività, contenente le attività che si desidera rinumerare.

  2. Selezionare le attività che si desidera rinumerare. La prima attività selezionata non verrà rinumerata.

    Per rinumerare i codici WBS per tutte le attività, non selezionare alcuna attività.

  3. Fare clic su Progetto. Nel gruppo Proprietà fare clic su WBS e quindi su Rinumera.

    Immagine della scheda Progetto, pulsante WBS, comando Rinumera nel menu a discesa.

  4. Fare clic su Attività selezionate per rinumerare i codici per le attività selezionate.

    Fare clic su Intero progetto per rinumerare i codici per tutte le attività nel progetto.

    Immagine della finestra di dialogo Rinumera WBS

Utilizzare i numeri di struttura di base

Se non si ritiene necessaria la struttura dettagliata fornita dai codici WBS, è possibile utilizzare una struttura di base.

Per ogni attività viene automaticamente creato un numero di struttura sulla base della posizione dell'attività nella struttura dell'elenco attività. La prima attività dell'elenco, ad esempio, verrà numerata 1. Se tale attività contiene tre sottoattività, esse verranno numerate 1.1, 1.2 e 1.3.

I numeri di struttura sono composti esclusivamente da cifre e non è possibile modificarli. Cambiano automaticamente quando si sposta un'attività verso l'alto o verso il basso nell'elenco e quando si applica un rientro o un rientro negativo alle attività.

Per mostrare i numeri di struttura, aggiungere il campo Numeri di struttura a una visualizzazione ad tabella o elenco. È anche possibile aggiungere numeri di struttura direttamente ai nomi delle attività:

  1. Accedere al Diagramma di Gantt o all'elenco attività.

  2. Fare clic su Formato e nel gruppo Mostra/Nascondi selezionare Numeri di struttura.

Inizio pagina

La sezione seguente si applica solo a Microsoft Project 2007.

Per saperne di più

Informazioni sui codici WBS

Definire codici WBS personalizzati

Rinumerare i codici WBS

Informazioni sui codici WBS

In Microsoft Office Project esistono due tipi di codici WBS: numeri di struttura e codici WBS personalizzati. Leggere le sezioni seguenti per altre informazioni.

Numeri di struttura

I numeri di struttura sono il tipo di codifica WBS più semplice. Microsoft Office Project calcola automaticamente un numero di struttura per ogni attività, in base alla relativa numerazione nella struttura dell'elenco attività. La prima attività dell'elenco, ad esempio, viene contrassegnata dal numero 1. Se l'attività contiene tre sottoattività, queste verranno contrassegnate dai numeri 1.1, 1.2 e 1.3.

I numeri di struttura sono composti esclusivamente da cifre (senza lettere) e non è possibile modificarli. Cambiano automaticamente quando si sposta un'attività verso l'alto o verso il basso nell'elenco e quando si applica un rientro o un rientro negativo alle attività. Ad esempio, se una sottoattività al momento ha il numero di struttura 3.5.4 e viene spostata verso l'alto di una riga nell'elenco, il numero di struttura viene automaticamente aggiornato a 3.5.3. Se si applica un rientro negativo alla stessa sottoattività, il numero di struttura viene automaticamente aggiornato a 3.6.

Suggerimento : Per visualizzare i numeri di struttura è possibile aggiungere il campo Numero di struttura a una visualizzazione tabella o elenco. In alternativa, si può scegliere di visualizzarli accanto ai nomi delle attività. Per visualizzare i numeri di struttura accanto ai nomi delle attività, scegliere Opzioni dal menu Strumenti e quindi fare clic sulla scheda Visualizza. Nella sezione Opzioni di struttura selezionare la casella di controllo Mostra numeri di struttura.

Codici WBS personalizzati

Se per il progetto sarebbe utile l'uso di codici WBS dettagliati, caratterizzati da lunghezze, sequenze o set di numeri e lettere specificati, è possibile definire un singolo formato di codice personalizzato per il progetto. Nessun progetto può avere più di un formato di codice personalizzato. Il codice WBS personalizzato viene registrato nel campo WBS.

Come per i numeri di struttura, ogni livello di un codice WBS personalizzato rappresenta un livello struttura nell'elenco attività. È possibile usare un formato univoco per ogni livello del codice. Ogni livello viene elencato nel codice in base alla gerarchia di attività, attività di riepilogo e sottoattività.

Ad esempio, se si stanno pianificando progetti in fasi allineati a direttive aziendali per il prossimo anno fiscale, è possibile creare un formato di codice WBS personalizzato che rappresenti ogni attività usando la direttiva, il trimestre e il progetto corrispondente. Usando questo codice, si può avere un'attività con il codice WBS personalizzato CustSat.Q3.StrumentiCS.11, che indica che si tratta dell'attività 11 del progetto Aggiornamento strumenti di Customer Satisfaction, che ha inizio durante il terzo trimestre e che supporta la direttiva aziendale per la Customer Satisfaction per l'anno fiscale pianificato.

Inizio pagina

Definire codici WBS personalizzati

  1. Nel menu Visualizza fare clic su una visualizzazione elenco, ad esempio la visualizzazione Elenco attività.

    Per usare una visualizzazione che non compare nel menu Visualizza, fare clic su Altre visualizzazioni, fare clic sulla visualizzazione che si vuole usare nell'elenco Visualizzazioni e quindi fare clic su Applica.

  2. Nel menu Progetto posizionare il puntatore su WBS e quindi fare clic su Definisci codice.

  3. Per distinguere le attività di questo progetto da quelle in altri progetti, digitare un prefisso del codice specifico del progetto nella casella Prefisso codice progetto.

    Il prefisso consente di identificare il progetto al livello più alto del codice WBS. Il prefisso può essere utile per identificare i sottoprogetti all'interno di un progetto principale oppure quando si creano relazioni tra attività di diversi progetti.

    Per il prefisso del codice progetto è possibile immettere qualsiasi combinazione di numeri, lettere maiuscole e minuscole e simboli.

  4. Per specificare la stringa di codice per le attività di primo livello, nella prima riga della colonna Sequenza fare clic sul tipo di carattere da usare per questo livello:

    • Fare clic su Numeri (in ordine) per mostrare un codice WBS numerico per questo livello (ad esempio 1, 2 e 3 per le prime tre attività di riepilogo del progetto).

    • Fare clic su Lettere maiuscole (in ordine) per mostrare codici WBS in caratteri alfabetici maiuscoli (ad esempio A, B e C per le prime tre attività di riepilogo del progetto).

    • Fare clic su Lettere minuscole (in ordine) per mostrare codici WBS in caratteri alfabetici minuscoli (ad esempio a, b e c per le prime tre attività di riepilogo del progetto).

    • Fare clic su Caratteri (non in ordine) (ad esempio Arch1, Cost1 e Isp1 per le prime tre attività di riepilogo del progetto).

      Questa opzione offre la massima flessibilità per l'inserimento di codici WBS personalizzati. Project visualizza un asterisco (*) nel campo WBS finché non si digita o non si immette una stringa di caratteri per questo livello del codice WBS.

  5. Nella colonna Lunghezza digitare o selezionare il numero di caratteri per ogni livello della stringa di codice. È possibile immettere il numero esatto di caratteri o selezionare Qualsiasi per consentire qualsiasi numero di caratteri per quel livello di codice.

    Ad esempio, si può digitare 3 per rendere obbligatorio l'inserimento di tre caratteri in un livello del codice WBS. La lunghezza totale di un codice WBS può variare da 1 a 255 caratteri.

  6. Nella colonna Separatore digitare o selezionare un carattere per separare la stringa di codice per un livello da quella per il livello successivo.

    Per impostazione predefinita, il carattere separatore è un punto. È possibile usare un carattere separatore diverso a ogni livello di codice.

    Si può anche scegliere di non usare alcun carattere separatore tra i livelli di codice. Nel campo Separatore eliminare il carattere separatore.

  7. Specificare una stringa di codice per ogni livello di attività con rientro nella struttura.

    Per specificare singole stringhe di codice per ogni livello, fare clic sulla riga successiva e completare le colonne Sequenza, Lunghezza e Separatore.

  8. Per impedire l'assegnazione automatica di un codice WBS ogni volta che viene immessa una nuova attività, deselezionare la casella di controllo Genera codice WBS per nuova attività.

  9. Per consentire l'uso dello stesso codice WBS per più attività, deselezionare la casella di controllo Verifica univocità dei nuovi codici WBS.

Nota : 

  • Il carattere usato come separatore non può essere usato anche come parte del codice. Ad esempio, se si usa un segno meno come separatore, non è possibile impiegarlo nel codice usato per rappresentare un'attività.

  • Non è possibile definire più di un set di codici WBS per progetto. Se è necessario visualizzare una struttura organizzativa aggiuntiva per le attività, è possibile usare campi personalizzati per creare o applicare un set di codici separato.

  • Per visualizzare i codici WBS è necessario aggiungere il campo WBS alla visualizzazione.

  • Per modificare il codice WBS per un'attività di riepilogo e le sottoattività corrispondenti, è necessario modificare il codice esistente, o il set di asterischi, nel codice WBS dell'attività di riepilogo impostando un altro set di caratteri.

    Ad esempio, il codice WBS di una specifica sottoattività è Fase3.Prog5.Arch.Attività3. "Attività3" rappresenta la sottoattività "Sviluppare piani" e "Arch" rappresenta l'attività di riepilogo "Architettare soluzione". Il nome dell'attività di riepilogo viene modificato in "Disegnare soluzione" ed è necessario aggiornare il codice per l'attività di riepilogo e le relative sottoattività. Si modifica il codice WBS in modo che l'attività di riepilogo sia rappresentata da "Dis" e il codice WBS per la sottoattività "Sviluppare piani" viene automaticamente aggiornato in Fase3.Prog5.Dis.Attività3.

Rinumerare i codici WBS

Dopo lo spostamento o l'eliminazione di attività, i codici WBS personalizzati potrebbero non essere più nella sequenza corretta. I codici WBS non vengono rinumerati automaticamente, visto che potrebbero essere usati in documenti o in altri sistemi non collegati al file di Project. È possibile rinumerare i codici WBS di tutte le attività o solo di attività selezionate:

  1. Nel menu Visualizza fare clic su una visualizzazione elenco contenente le attività da rinumerare, ad esempio Elenco attività.

    Per usare una visualizzazione che non compare nel menu Visualizza, fare clic su Altre visualizzazioni, fare clic sulla visualizzazione che si vuole usare nell'elenco Visualizzazioni e quindi fare clic su Applica.

  2. Selezionare le attività da rinumerare. La prima attività in una selezione non viene rinumerata. Viene usata come punto di riferimento per rinumerare le altre attività.

    Per rinumerare i codici WBS per tutte le attività, non selezionare alcuna attività.

  3. Nel menu Progetto posizionare il puntatore su WBS e quindi fare clic su Rinumera.

  4. Per correggere la sequenza del codice WBS solo per le attività adiacenti selezionate, fare clic su Attività selezionate.

    Per correggere la sequenza del codice WBS per tutte le attività del progetto, fare clic su Intero progetto.

Nota : 

  • Se il progetto contiene sottoprogetti, è possibile rinumerare alcune o tutte le attività in ogni sottoprogetto visualizzando tutte le sottoattività. Fare clic su Mostra Mostra e quindi fare clic su Tutte le sottoattività. Project non può rinumerare le attività dei sottoprogetti che non sono visualizzati.

  • Rinumerando i sottoprogetti inseriti in un progetto principale viene modificato anche il codice che rappresenta ogni sottoprogetto a livello di progetto.

  • Per visualizzare i codici WBS è possibile aggiungere una colonna WBS a una visualizzazione elenco.

  • Per modificare i codici WBS dopo il calcolo da parte di Project, nel menu Progetto posizionare il puntatore su WBS e quindi fare clic su Definisci codice. Nella colonna Sequenze cambiare il tipo di carattere di qualsiasi livello del formato di codice. Quando si aggiorna un codice a livello di un'attività di riepilogo, vengono aggiornate automaticamente tutte le relative sottoattività.

    Eventuali problemi con la modifica dei codici WBS potrebbero dipendere da uno dei motivi seguenti:

    • Si sta tentando di modificare un codice WBS che ha un formato di codice dopo che il codice è stato calcolato     Se è stato creato un formato di codice WBS e i codici WBS delle attività sono stati già calcolati, è possibile modificare il codice WBS solo ridefinendo i livelli del formato di codice. Dopo aver ridefinito i livelli del formato di codice, è possibile modificare qualsiasi livello del formato di codice da numeri in ordine, lettere maiuscole in ordine, lettere minuscole in ordine o caratteri non in ordine in un tipo diverso.

    • Si sta tentando di modificare i codici WBS a un livello inferiore dell'elenco attività     Non è possibile modificare i caratteri nel codice WBS per una sottoattività, ma solo per l'attività di riepilogo in cui è definito quel livello di codice WBS.

Inizio pagina

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×