Copiare una formula trascinando il quadratino di riempimento in Excel 2016 per Mac

È possibile copiare rapidamente le formule nelle celle adiacenti con il quadratino di riempimento

Quadratino di riempimento

Quando si trascina il quadratino in altre celle, Excel mostra risultati differenti in ognuna.

Copiare una formula trascinando il quadratino di riempimento

  1. Selezionare la cella contenente la formula da inserire nelle celle adiacenti.

  2. Posizionare il cursore sull'angolo inferiore destro finché non assume la forma di un segno più (+), come illustrato qui:

    Cursore posizionato sul quadratino di riempimento

  3. Trascinare il quadratino di riempimento verso il basso, verso l'alto o attraverso le celle da riempire. In questo esempio viene trascinato in basso:

    Cursore che trascina verso il basso il quadratino di riempimento

  4. Quando si rilascia il pulsante del mouse, la formula viene automaticamente inserita nelle altre celle:

    Visualizzazione dei valori per le celle riempite

  5. Per cambiare il modo in cui vengono riempite le celle, fare clic sul pulsante Opzioni riempimento automatico Pulsante Opzioni riempimento automatico visualizzato al termine del trascinamento e scegliere l'opzione desiderata.

Per altre informazioni sulla copia delle formule, vedere Copiare e incollare una formula in un'altra cella o un altro foglio di lavoro.

Suggerimenti : 

  • È possibile premere CTRL+D per ricopiare la formula verso il basso in una colonna. Selezionare prima la cella contenente la formula da ricopiare, poi selezionare le celle al di sotto e infine premere CTRL+D.

  • È anche possibile premere CTRL+R per ricopiare la formula verso destra in una riga. Selezionare prima la cella contenente la formula da ricopiare, poi selezionare le celle a destra e infine premere CTRL+R.

Se il riempimento non funziona

A volte il riempimento di celle funziona perfettamente, mentre in altri casi il risultato non è quello previsto. Ecco perché è importante controllare i riferimenti di cella della prima cella.

I riferimenti di cella non sono altro che puntatori ad altre celle. Si supponga ad esempio che la prima cella contenga questa formula:


=SOMMA(A1;B1)


A1 e B1 sono riferimenti relativi. Quando si copia la formula verso il basso, infatti, i riferimenti cambieranno in modo incrementale da A1, B1 a A2, B2 e così via, come illustrato di seguito:

=SOMMA(A1;B1)

=SOMMA(A2;B2)

=SOMMA(A3;B3)

In alcuni casi non si vuole che i riferimenti ad altre celle cambino. Si supponga ad esempio che il primo riferimento, A1, debba rimanere fisso, mentre B1 debba cambiare mentre si trascina il quadratino di riempimento. In questo caso, digitare il simbolo del dollaro nel primo riferimento: =SOMMA($A$1;B1). Il simbolo del dollaro forza Excel a continuare a puntare alla cella A1 mentre riempie le altre celle. Il risultato sarebbe il seguente:

=SOMMA($A$1;B1)

=SOMMA($A$1;B2)

=SOMMA($A$3;B3)

I riferimenti con il simbolo del dollaro ($) si chiamano riferimenti assoluti. Quando si riempie verso il basso, il riferimento alla cella A1 rimane fisso, mentre Excel cambia i riferimenti a B1, in B2 e B3.

Problemi a visualizzare il quadratino di riempimento?

Se il quadratino di riempimento non è visibile, potrebbe essere nascosto. Per visualizzarlo di nuovo:

  1. Nel menu Excel fare clic su Preferenze.

  2. Fare clic su Modifica.

  3. In Opzioni di modifica selezionare la casella Attiva quadratino di riempimento e trascinamento celle.

Se il calcolo automatico della cartella di lavoro non è attivato, quando si riempiono le celle non vengono eseguiti di nuovo i calcoli delle formule. Ecco come verificare ed eventualmente attivare il calcolo automatico:

  1. Nel menu Excel fare clic su Preferenze.

  2. Far clic su Calcolo.

  3. In Opzioni di calcolo verificare che sia selezionata l'opzione Automatico.

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×