Controllare un sito Web tramite Visio

Per gestire le operazioni di un sito Web giorno per giorno, è importante disporre di una chiara visione d'insieme della struttura globale del sito e del flusso, tenere traccia delle modifiche dello sviluppo e controllare e correggere i collegamenti ipertestuali interrotti. È possibile eseguire tutte queste attività e altro ancora tramite gli strumenti Mappa sito Web di Microsoft Office Visio.

Per saperne di più

Creare la mappa del contenuto del sito

Controllare automaticamente la presenza di errori nel sito

Tenere traccia delle modifiche al sito

Creare la mappa del contenuto del sito

La gestione di un sito parte dall'analisi dello stato corrente del sito stesso. Quando si crea una mappa di un sito, si crea una rappresentazione grafica aggiornata della struttura e dei contenuti del sito.

Mappa di sito Web indicante la struttura gerarchica effettiva dei collegamenti nel sito

Ciascuna forma nella mappa del sito rappresenta un collegamento nel sito Web e include informazioni sul tipo e la posizione del collegamento. Facendo clic con il pulsante destro del mouse su una forma, è possibile passare direttamente dalla forma alla relativa posizione Web.

  1. In Visio scegliere Nuovo dal menu File, quindi Software e database e infine Mappa sito Web.

  2. Nella finestra di dialogo Genera mappa sito immettere l'indirizzo di un sito per uno dei seguenti elementi:

    • Server HTTP. Nella casella Indirizzo immettere l'indirizzo del sito Web per il quale si desidera creare una mappa.

    • Server di rete o disco rigido locale. Fare clic su Sfoglia, cercare il file che si desidera utilizzare come origine della mappa del sito, quindi scegliere Apri.

  3. Nella finestra di dialogo Genera mappa sito fare clic su Impostazioni per controllare le impostazioni relative al numero massimo di livelli e di collegamenti che verranno individuati.

  4. Per modificare le impostazioni, eseguire una delle operazioni seguenti:

    • Nella scheda Layout modificare lo stile di layout della mappa del sito Web, per specificare ad esempio il numero di livelli che si desidera vengano rilevati oppure la visualizzazione di una Struttura compatta o di un Diagramma di flusso nel disegno.

    • Nella scheda Estensioni selezionare il tipo di file, ad esempio con estensione doc, jpg o exe, di cui si desidera creare una mappa.

    • Nella scheda Protocolli selezionare i protocolli, ad esempio mailto, ftp o NNTP, di cui si desidera creare una mappa.

    • Nella scheda Attributi selezionare gli attributi HTML, ad esempio HREF, SRC o CODE, tramite i quali si desidera trovare i collegamenti.

    • Nella scheda Avanzate selezionare le opzioni che consentono di ridefinire i criteri di ricerca.

    • Fare clic su OK.

  5. Nella finestra di dialogo Genera mappa sito fare clic su OK.

  6. Per salvare la mappa del sito, scegliere Salva dal menu File.

Torna all'inizio

Controllare automaticamente la presenza di errori nel sito

Per gestire il sito Web in modo efficiente è essenziale che i collegamenti del sito vengano mantenuti attivi e senza errori.

Quando si crea la mappa del sito, ogni collegamento viene verificato all'interno dei parametri specificati e viene tenuta traccia degli eventuali errori rilevati. I collegamenti che presentano errori vengono visualizzati nella mappa del sito, nella finestra Filtro e nella finestra Elenco come forme che racchiudono una X rossa. Se non è possibile visualizzare tali finestre, scegliere Finestre dal menu Mappa sito Web e quindi fare clic su Finestra Elenco o Finestra Filtro. È possibile generare rapidamente un elenco dei collegamenti interrotti con gli errori associati per tenere traccia del proprio lavoro e apportare le correzioni necessarie.

Mappa di sito Web indicante la struttura del sito. Le forme con una X rossa indicano un collegamento interrotto

Per creare un rapporto sui collegamenti che presentano errori nel sito

  1. Aprire la mappa del sito per la quale si desidera creare una segnalazione errori.

  2. Scegliere Rapporti dal menu Mappa sito Web, quindi fare clic su Mappa sito Web - Collegamenti con errori e infine su Esegui.

  3. Selezionare il tipo di file, ad esempio Excel o XML, in cui si desidera salvare le informazioni e quindi fare clic su OK.

    In Visio verrà creato un rapporto che elenca tutti i collegamenti in cui sono presenti collegamenti ipertestuali con errori.

  4. Se il rapporto viene aperto in un programma diverso da Visio, ad esempio Microsoft Office Excel, nominare e salvare il rapporto.

Correggere i collegamenti interrotti

Alcuni collegamenti interrotti sono causati da errori di timeout. Per risolvere tali errori, fare clic con il pulsante destro del mouse sul collegamento, quindi scegliere Aggiorna o Aggiorna elemento padre del collegamento ipertestuale.

Altri collegamenti interrotti sono provocati da messaggi Sito non trovato, Accesso negato o Password necessaria oppure da nomi di file non corretti, percorsi di file errati e file mancanti, che possono causare un messaggio di errore 404 o File non trovato. Qualsiasi errore di questo tipo dovrà essere corretto nel sito Web.

Il sito Web e la mappa del sito Web non sono collegati dinamicamente. La modifica del primo non influisce automaticamente sulla seconda e viceversa. Dopo avere corretto un collegamento interrotto nel sito Web, è possibile aggiornare la mappa del sito facendo clic con il pulsante destro del mouse sulla forma che rappresenta il collegamento interrotto, quindi scegliendo Aggiorna collegamento ipertestuale. La X rossa non verrà più visualizzata.

Torna all'inizio

Tenere traccia delle modifiche al sito

Se ci si avvale di più sviluppatori che lavorano sul sito, tenere traccia delle loro attività può diventare rapidamente un'attività a tempo pieno. Tramite il rapporto di confronto Mappa sito Web è possibile confrontare due versioni del sito per quantificare le modifiche apportate in un certo periodo di tempo. Il rapporto confronta le due versioni e genera un elenco di differenze, identificando non soltanto i collegamenti visualizzati soltanto in una delle mappe, ma elencando anche le seguenti modifiche ai collegamenti in entrambe le mappe:

  • Stato di errore

  • Titolo del file

  • Dimensione del file

  • Data di modifica del file

Si supponga ad esempio di dover quantificare il lavoro realizzato in un sito ogni settimana. Creare la mappa del sito all'inizio della settimana e una seconda volta alla fine. Quindi confrontare le due mappe per generare un rapporto delle modifiche. È inoltre possibile misurare il rapporto con riferimento a una pianificazione del lavoro programmato per la settimana per verificare la corretta realizzazione del progetto del sito Web.

Per confrontare le mappe del sito Web

  1. Aprire la mappa più recente del sito Web.

  2. Scegliere Confronta con documento precedente dal menu Mappa sito Web.

  3. Cercare la mappa del sito Web che si desidera confrontare con la mappa aperta, selezionare il file e quindi fare clic su Apri.

    Le mappe verranno confrontate e verrà generato un rapporto che elenca le differenze riscontrate.

  4. Assegnare un nome al rapporto e salvarlo.

Torna all'inizio

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×