Contare valori univoci tra duplicati

Importante :  Il presente articolo è stato tradotto automaticamente, vedere la dichiarazione di non responsabilità. Per visualizzare la versione inglese dell'articolo, fare clic qui.

Supponiamo che si vuole sapere quanti un testo o valori numerici sono disponibili in un intervallo. Ad esempio, se una colonna contiene il testo dei valori Bradley, Guaita, Guaita, Guaita, sono disponibili due valori univoci, ovvero Bradley e Guaita. Se l'intervallo contiene numeri 5, 6, 7 e 6, i valori univoci sono 5, 6 e 7.

Per contare solo i valori univoci, usare una combinazione delle funzioni seguenti, come illustrato nel foglio di lavoro di esempio riportato di seguito:

  • Usare la funzione SE per assegnare il valore 1 a ogni condizione vera.

  • Usare la funzione SOMMA per sommare tutti i valori univoci.

  • Usare la funzione FREQUENZA per contare il numero di valori univoci. Questa funzione ignora i valori uguali a zero e i valori di testo. Per la prima occorrenza di un valore specifico, restituisce un numero che corrisponde al numero di occorrenze del valore. Per ogni occorrenza dello stesso valore successiva alla prima, la funzione restituisce un valore 0 (zero).

  • Usare la funzione CONFRONTA affinché venga restituita la posizione di un valore di testo in un intervallo. La funzione FREQUENZA usa il valore del risultato per valutare i valori di testo corrispondenti.

  • Usare la funzione LUNGHEZZA per individuare le celle vuote. La lunghezza (conteggio caratteri) di una cella vuota corrisponde a 0.

Esempio

Per provare questi esempi di formule con funzioni, copiare la tabella nella cella A1 di un foglio di lavoro vuoto in Excel.

Dati

Dati

986

Barbariol

Guaita

563

67

789

235

Barbariol

Guaita

689

789

Guaita

143

56

237

67

235

Formula

Descrizione (risultato)

=SOMMA(SE(FREQUENZA(A2:A10;A2:A10)>0;1))

Conta il numero di valori numerici univoci nell'intervallo di celle A2:A10 senza contare le celle vuote o i valori di testo (4)

=SOMMA(SE(FREQUENZA(CONFRONTA(B2:B10;B2:B10;0);CONFRONTA(B2:B10;B2:B10;0))>0;1))

Conta il numero di valori di testo e numerici univoci nell'intervallo di celle B2:B10 (che non deve contenere celle vuote) (7)

=SOMMA(SE(FREQUENZA(SE(LUNGHEZZA(A2:A10)>0;CONFRONTA(A2:A10;A2:A10;0);""); SE(LUNGHEZZA(A2:A10)>0;CONFRONTA(A2:A10;A2:A10;0);""))>0;1))

Conta il numero di valori di testo e numerici univoci nell'intervallo di celle A2:A10 senza contare le celle vuote o i valori di testo (6)

Note : 

  • Le formule in questo esempio devono essere immesse come formule matrice. Selezionare ogni cella che contiene una formula, premere F2 e quindi premere Ctrl + MAIUSC + INVIO.

  • Per visualizzare la procedura di valutazione dettagliata di una funzione, selezionare la cella contenente la formula e quindi nel gruppo Verifica formule della scheda Formule fare clic su Valuta formula.

Nota : Dichiarazione di non responsabilità per la traduzione automatica: Il presente articolo è stato tradotto tramite un software di traduzione automatica e non da una persona. Microsoft offre le traduzioni automatiche per consentire a coloro che non conoscono la lingua inglese di leggere gli articoli sui prodotti, sui servizi e sulle tecnologie Microsoft. Dal momento che l'articolo è stato tradotto automaticamente, potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli.

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×