Contare valori univoci tra duplicati

Nota:  Riteniamo importante fornire il contenuto della Guida più recente non appena possibile, nella lingua dell'utente. Questa pagina è stata tradotta automaticamente e potrebbe contenere errori di grammatica o imprecisioni. L'intento è quello di rendere fruibile il contenuto. Nella parte inferiore della pagina è possibile indicare se le informazioni sono risultate utili. Questo è l' articolo in lingua inglese per riferimento.

Supponiamo che si vuole sapere quanti un testo o valori numerici sono disponibili in un intervallo. Ad esempio, se una colonna contiene il testo valori Barbariol, Guaita, Guaita, Guaita, sono disponibili due valori univoci, ovvero Barbariol e Guaita. Se l'intervallo contiene numeri 5, 6, 7 e 6, i valori univoci sono 5, 6 e 7.

Per contare solo i valori univoci, usare una combinazione delle funzioni seguenti, come illustrato nel foglio di lavoro di esempio riportato di seguito:

  • Utilizzare la funzione se per assegnare il valore 1 a ogni condizione vera.

  • Utilizzare la funzione somma per sommare tutti i valori univoci.

  • Utilizzare la funzione frequenza per contare il numero di valori univoci. Questa funzione Ignora testo e valori uguali a zero. Per la prima occorrenza di un valore specifico, restituisce un numero in base al numero di occorrenze di tale valore. Per ogni occorrenza dello stesso valore dopo il primo, questa funzione restituisce il valore 0.

  • Per restituire la posizione di un valore di testo in un intervallo, utilizzare la funzione Confronta . La funzione frequenza utilizzato il valore risultante per valutare i corrispondenti valori di testo.

  • Utilizzare la funzione lunghezza per trovare le celle vuote. Celle vuote hanno una lunghezza (il numero dei caratteri) pari a 0.

Esempio

Per provare questi esempi di formule con funzioni, copiare la tabella nella cella A1 di un foglio di lavoro vuoto in Excel.

Dati

Dati

986

Barbariol

Guaita

563

67

789

235

Barbariol

Guaita

689

789

Guaita

143

56

237

67

235

Formula

Descrizione (risultato)

=SOMMA(SE(FREQUENZA(A2:A10;A2:A10)>0;1))

Conta il numero di valori numerici univoci nell'intervallo di celle A2:A10 senza contare le celle vuote o i valori di testo (4)

=SOMMA(SE(FREQUENZA(CONFRONTA(B2:B10;B2:B10;0);CONFRONTA(B2:B10;B2:B10;0))>0;1))

Conta il numero di valori di testo e numerici univoci nell'intervallo di celle B2:B10 (che non deve contenere celle vuote) (7)

=SOMMA(SE(FREQUENZA(SE(LUNGHEZZA(A2:A10)>0;CONFRONTA(A2:A10;A2:A10;0);""); SE(LUNGHEZZA(A2:A10)>0;CONFRONTA(A2:A10;A2:A10;0);""))>0;1))

Conta il numero di valori di testo e numerici univoci nell'intervallo di celle A2:A10 senza contare le celle vuote o i valori di testo (6)

Note: 

  • Le formule in questo esempio devono essere immesse come formule matrice. Selezionare ogni cella che contiene una formula, premere F2 e quindi premere Ctrl + MAIUSC + INVIO.

  • Per visualizzare la procedura di valutazione dettagliata di una funzione, selezionare la cella contenente la formula e quindi nel gruppo Verifica formule della scheda Formule fare clic su Valuta formula.

Amplia le tue competenze su Office
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per il feedback!

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×