Contare quante volte si presenta un valore

Numerose funzioni del foglio di lavoro possono risultare utili per contare quante volte un determinato testo o valore numerico si presenta in un intervallo ci celle. È ad esempio possibile usare la funzione COUNTA.SE per contare quante volte ricorre un valore singolo, come illustrato nell'esempio seguente.

Esempio

Venditore

Fattura

Barbariol

15.000

Barbariol

9.000

Pica

8.000

Pica

20.000

Barbariol

5.000

Giussani

22.500

Formula

Descrizione

Risultato

=CONTA.SE(A2:A7;"Barbariol")

Numero di voci per Barbariol (3)

3

=CONTA.SE(A2:A7;A4)

Numero di voci per Pica (2)

2

=CONTA.SE(B2:B7;"< 20000")

Numero degli importi di fattura inferiori a 20.000 (4)

4

=CONTA.SE(B2:B7;">="&B5)

Numero degli importi di fattura superiori o uguali a 20.000 (2)

2

Usare COUNTA.SE per contare i valori in base a più criteri

La funzione CONTA.PIÙ.SE è analoga alla funzione CONTA.SE, con una importante differenza: CONTA.PIÙ.SE applica criteri alle celle di più intervalli e conta il numero di volte in cui tutti i criteri vengono soddisfatti. Con la funzione CONTA.PIÙ.SE è possibile usare fino a 127 coppie di intervalli/criteri. La sintassi della funzione è simile alla seguente:

CONTA.PIÙ.SE(intervallo_criteri1; criteri1; [intervallo_criteri2; criteri2];…)

Esempio

ID dipendente

Numero area

Reparto

20552

2

Vendite

21268

2

Finanze

23949

1

Amministrazione

24522

4

Amministrazione

28010

3

IT

29546

4

Vendite

31634

3

IT

32131

1

IT

35106

4

Finanze

40499

1

Risorse umane

42051

1

Vendite

43068

2

Risorse umane

45382

2

Finanze

47971

1

IT

Formula

Descrizione

Risultato

=CONTA.PIÙ.SE(B2:B15;"2";C2:C15;"Finanze")

Numero di dipendenti presenti nell'area 2 e nel reparto Finanze

2

Il primo intervallo di criteri include tutti i numeri di area, mentre il secondo intervallo di criteri include tutti i nomi di reparto. Il criterio applicato al primo intervallo è "2", mentre il criterio applicato al secondo intervallo è "Finanze". La funzione CONTA.PIÙ.SE verifica se vengono soddisfatti entrambi i criteri.

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×