Contare numeri o date in base a una condizione

Per contare i numeri o le date che soddisfano una singola condizione, ad esempio uguale a, maggiore di, minore di, maggiore o uguale a o minore o uguale a, usare la funzione CONTA.SE. Per contare i numeri o le date che rientrano in un intervallo, ad esempio maggiore di 9000 e allo stesso tempo minore di 22500, è possibile usare la funzione CONTA.PIÙ.SE. In alternativa, è possibile usare anche la funzione MATR.SOMMA.PRODOTTO.

Esempio

1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

A

B

Agente di vendita

Fattura

Barbariol

15.000

Barbariol

9.000

Sason

8.000

Sason

20.000

Milanesi

5.000

Giussani

22.500

Formula

Descrizione (risultato)

=CONTA.SE(B2:B7;">9000")

La funzione CONTA.SE conta il numero di celle nell'intervallo B2:B7 che contengono numeri maggiori di 9000 (4)

=CONTA.SE(B2:B7;"<=9000")

La funzione CONTA.SE conta il numero di celle nell'intervallo B2:B7 che contengono numeri minori di 9000 (4)

=CONTA.PIÙ.SE (B2:B7;">=9000";B2:B7;"<=22500")

La funzione CONTA.PIÙ.SE (disponibile in Excel 2007 e versioni successive) conta il numero di celle nell'intervallo B2:B7 che contengono numeri maggiori uguali a 9000 e minori o uguali a 22500 (4)

=MATR.SOMMA.PRODOTTO((B2:B7>=9000)*(B2:B7<=22500))

La funzione MATR.SOMMA.PRODOTTOconta il numero di celle nell'intervallo B2:B7 che contengono numeri maggiori o uguali a 9000 e minori o uguali a 22500 (4). È possibile usare questa funzione in Excel 2003 e versioni precedenti, in cui CONTA.PIÙ.SE non è disponibile.

Data

11/03/2011

01/01/2010

31/12/2010

30/06/2010

Formula

Descrizione (risultato)

=CONTA.SE(B14:B17;">01/03/2010")

Conta il numero di celle nell'intervallo B14:B17 con una data maggiore di 01/03/2010 (3)

=CONTA.SE(B14:B17;"31/12/2010")

Conta il numero di celle nell'intervallo B14:B17 che contengono date uguali a 31/12/2010 (1). Il segno di uguale non è necessario nei criteri, quindi non viene incluso qui. La formula funziona lo stesso se viene incluso ("=31/12/2010").

=CONTA.PIÙ.SE(B14:B17;">=01/01/2010";B14:B17;"<=31/12/2010")

Conta il numero di celle nell'intervallo B14:B17 comprese tra 01/01/2010 e 12/31/2010 incluse (3).

=MATR.SOMMA.PRODOTTO((B14:B17>=DATA.VALORE("01/01/2010"))*(B14:B17<=DATA.VALORE("31/12/2010")))

Conta il numero di celle nell'intervallo B14:B17 comprese tra 01/01/2010 e 12/31/2010 incluse (3). Questo esempio viene fornito in sostituzione della funzione CONTA.PIÙ.SE, che è stata introdotta per la prima volta in Excel 2007. La funzione DATA.VALORE converte le date in un valore numerico, che è compatibile con la funzione MATR.SOMMA.PRODOTTO.

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×