Contare i caratteri nelle celle con Excel 2016 per Mac

Per contare i caratteri nelle celle, usare la funzione LUNGHEZZA. La funzione conta lettere, numeri, caratteri e tutti gli spazi. Ad esempio, la lunghezza del testo "Oggi ci sono 30 gradi, quindi vado al mare" (escluse le virgolette) è 42 caratteri, 32 lettere, 2 numeri, 8 spazi e una virgola.

  • Per usare la funzione, immettere =LUNGHEZZA(cella) nella barra della formula e premere INVIO. In questi esempi cella è la cella che si desidera contare, ad esempio B1.

  • Per contare i caratteri in più celle, immettere la formula e quindi copiarla e incollarla in altre celle.

  • Per contare un numero totale di caratteri in più celle, usare la funzione SOMMA insieme a LUNGHEZZA, ad esempio =SOMMA((LUNGHEZZA(cella1);LUNGHEZZA(cella2);(LUNGHEZZA(cella3)))). In questo esempio la funzione LUNGHEZZA conta i caratteri in ogni cella e la funzione SOMMA aggiunge i conteggi.

  • Per contare determinati caratteri specifici all'interno delle celle, usare la funzione LUNGHEZZA con la funzione SOSTITUISCI. Se ad esempio si vuole sapere quante P in minuscolo ci sono all'interno di una cella, usare la formula seguente: =LUNGHEZZA(cella1)-LUNGHEZZA(SOSTITUISCI(cella1;"p";""))

Prova pratica

Digitare i dati seguenti in un nuovo foglio di lavoro di Excel. Iniziare dalla cella A1.

Stringhe di testo

Formule

Cantami o Diva del

Cantami o Diva del pelide

Cantami o Diva del pelide Achille l'ira funesta

Contare i caratteri in una cella

  1. Fare clic sulla cella B2.

  2. Nella cella immettere =LUNGHEZZA(A2) e premere INVIO.

La formula conta i caratteri nella cella A2 e il risultato è 18, inclusi gli spazi. Se sono presenti spazi dopo il punto finale, la formula conta anche questi.

Contare i caratteri in più celle

  1. Premere CTRL+C per copiare la cella B2.

  2. Premere CTRL+V per incollare la formula nelle celle B3:B4.

La formula viene copiata nelle celle B3 e B4 e la funzione conta i caratteri in ogni cella (25 e 47).

Contare un numero totale di caratteri

  1. Fare clic sulla cella B6.

  2. Nella cella immettere =SOMMA(LUNGHEZZA(A2);LUNGHEZZA(A3);LUNGHEZZA(A4)) e premere INVIO.

La formula conta i caratteri in ognuna delle tre celle e li somma (90).

Per contare determinati caratteri specifici all'interno delle celle

  1. Fare clic sulla cella C4.

  2. Nella cella immettere =LUNGHEZZA(A4)-LUNGHEZZA(SOSTITUISCI(A4;"p";"")) e premere INVIO.

In breve, questa formula conta tutte le P in minuscolo della cella A4 e il risultato è 1.

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×