Contare caratteri nelle celle

Per contare i caratteri nelle celle, usare la funzione LUNGHEZZA. La funzione conta lettere, numeri, caratteri e tutti gli spazi. Ad esempio, la lunghezza del testo "Oggi ci sono 30 gradi, quindi vado al mare" (escluse le virgolette) è 42 caratteri, 32 lettere, 2 numeri, 8 spazi e una virgola.

  • Per usare la funzione, immettere =LUNGHEZZA(cella) nella barra della formula e premere INVIO. In questi esempi cella è la cella che si desidera contare, ad esempio B1.

  • Per contare i caratteri in più di una cella, immettere la formula, quindi trascinare il quadratino di riempimento sull'intervallo di celle da usare.

Immissione di più funzioni LUNGHEZZA in a foglio di lavoro

  • Per contare un numero totale di caratteri in più celle, usare la funzione SOMMA insieme a LUNGHEZZA, ad esempio =SOMMA((LUNGHEZZA(cella1);LUNGHEZZA(cella2);(LUNGHEZZA(cella3)))). In questo esempio la funzione LUNGHEZZA conta i caratteri in ogni cella e la funzione SOMMA aggiunge i conteggi.

Esercitazione

Usare gli esempi nella cartella di lavoro riportata sotto per indicazioni su come usare la funzione LUNGHEZZA.

Copiare la tabella di seguito e incollarla nella cella A1 in un foglio di lavoro di Excel. Trascinare la formula da B2 a B3:B4 per vedere la lunghezza del testo nelle celle della colonna A.

Stringhe di testo

Formule

Il tetto della casa

=LUNGHEZZA(A2)

Il tetto della casa crollò

Il tetto della casa crollò sul prato bagnato.

Contare i caratteri in una cella

  1. Nel Foglio1 di questa cartella di lavoro di esempio fare clic sulla cella B2.

  2. Nella cella immettere =LUNGHEZZA(A2) e premere INVIO.

La formula conta i caratteri nella cella A1, 45 e questo numero include tutti gli spazi. Se sono presenti spazi dopo il punto finale, la formula li conta.

Contare i caratteri in più celle

  1. Nella cartella di lavoro di esempio fare clic sulla cella B2.

  2. Nella cella immettere =LUNGHEZZA(A2).

  3. Premere CTRL+C per copiare la cella B2 quindi premere CTRL+V per incollare la rispettiva formula nelle celle B3:B4.

La formula viene copiata nelle celle B3 e B4 e la funzione conta i caratteri in ogni cella (19, 26 e 45).

Contare un numero totale di caratteri

  1. Nella cartella di lavoro di esempio fare clic sulla cella B6.

  2. Nella cella immettere =SOMMA(LUNGHEZZA(A2);LUNGHEZZA(A3);LUNGHEZZA(A4)) e premere INVIO.

La formula conta i caratteri in ognuna delle tre celle e li somma (90).

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×