Come evitare errori nelle formule

Importante :  Il presente articolo è stato tradotto automaticamente, vedere la dichiarazione di non responsabilità. Per visualizzare la versione inglese dell'articolo, fare clic qui.

Quando le formule presentano risultati imprevisti o errori può essere molto frustrante, soprattutto se non si sa come correggere l'errore.

Gli errori possibili sono numerosi. Ad esempio, potrebbero essere presenti parentesi non corrispondenti, errori di digitazione e riferimenti a dati in intervalli che inesistenti. Le procedure consigliate riportate di seguito consentono di prevenire o risolvere gli errori comuni durante la creazione o la correzione delle formule.

Procedura consigliata da seguire:

Per evitare questo errore comune:

Iniziare ogni formula con un segno di uguale (=)

Se la voce immessa non inizia con un segno di uguale, non si tratta di una formula e pertanto non verrà calcolata. Si tratta di un errore comune.

Ad esempio, quando si digita SOMMA(A1:A10), in Excel Online viene visualizzata la stringa di testo SOMMA(A1:A10) anziché il risultato di una formula. Se si digita 11/2, verrà visualizzata una data, ad esempio 02-nov o 02/11/2009, anziché dividere 2 per 11.

Per evitare questi risultati imprevisti, iniziare sempre con un segno di uguale. Ad esempio, digitare =SOMMA(A1:A10) e =2/11

Far corrispondere tutte le parentesi di apertura e chiusura

Verificare che a una parentesi aperta corrisponda sempre una parentesi chiusa. In una formula che usa una funzione, per ogni parentesi aperta è necessaria una parentesi chiusa affinché la formula funzioni correttamente.

La formula =SE(B5<0),"Non valido",B5*1,05) ad esempio non funzionerà poiché sono presenti due parentesi di chiusura e una sola di apertura.

La formula corretta sarà analoga alla seguente: =SE=SE(B5<0,"Non valido",B5*1,05).

Immettere tutti gli argomenti obbligatori

Per la maggior parte delle funzioni sono previsti argomenti obbligatori, ovvero valori che è necessario immettere affinché la funzione abbia esito positivo. Solo per alcune funzioni, ad esempio PI.GRECO o OGGI, non sono previsti argomenti. Verificare la sintassi della formula visualizzata quando si inizia a digitare un segno di uguale seguito da una funzione per assicurarsi di immettere tutti gli argomenti necessari.

La funzione MAIUSC, ad esempio, accetta solo una stringa di testo o riferimento di cella come argomento: =MAIUSC("salve") o =MAIUSC(C2)

Inoltre, alcune funzioni, come SOMMA, richiedono solo argomenti numerici, mentre altre, come SOSTIT, richiedono un valore di testo per almeno uno degli argomenti. Se si usa il tipo di dati non corretto, è possibile che vengano restituiti risultati imprevisti o che venga visualizzato un errore di tipo #VALORE!.

Usare numeri non formattati nelle formule

Non immettere numeri formattati con il segno di dollaro ($) o separatori decimali (,) nelle formule, in quanto il segno di dollaro indica riferimenti assoluti e le virgole rappresentano i separatori degli argomenti. I numeri formattati non vengono usati per i calcoli delle formule. Invece di immettere $1.000 nella formula, immettere 1000.

Se negli argomenti vengono usati numeri formattati verrà restituito un risultato di calcolo imprevisto oppure l'errore #NUM!. Se, ad esempio, si immette la formula =ASS(-2,134) per trovare il valore assoluto di -2134, in Excel Online verrà visualizzato l'errore #NUM! in quanto la funzione ASS accetta un solo argomento.

È possibile formattare il risultato della formula con separatori decimali e simboli di valuta dopo avere immesso la formula usando numeri non formattati e applicando un formato numerico.

Usare il tipo di dati della cella corretto

La formula potrebbe non restituire il risultato previsto se non è possibile usare il tipo di dati della cella per i calcoli.

Se, ad esempio, si immette la formula =2+3 in una cella formattata come testo, Excel Online non sarà in grado di calcolare il risultato. Nella cella verrà semplicemente visualizzato =2+3.

Per correggere l'errore, modificare il tipo di dati della cella da Testo a Generale, come illustrato di seguito:

  1. Selezionare la cella.

  2. Fare clic su Home > freccia Formato numero e selezionare Generale.

  3. Premere F2 per attivare la modalità di modifica per la cella e premere INVIO per accettare la formula.

Quando si immette una data in una cella per la quale è impostato il tipo di dati Numero, questa potrebbe essere visualizzata come valore di data numerico anziché come una data. Per visualizzare il numero come una data, selezionare un formato Data nella raccolta di Formato numero.

Usare il simbolo * per la moltiplicazione dei numeri

L'operatore per la moltiplicazione dei numeri in una formula non è x ma il simbolo asterisco (*).

Se nella formula si usa una x, Excel Online non è in grado di calcolare il risultato e visualizza la formula nella cella, mostrando un bordo rosso punteggiato intorno alla cella per indicare che è presente un errore.

Racchiudere il testo tra virgolette nelle formule

Per creare una formula che include testo, è necessario racchiudere il testo tra virgolette.

La formula ="Oggi è " & TESTO(OGGI(),"gggg mmmm gg") combina il testo "Oggi è " con i risultati delle funzioni TESTO e OGGI per restituire la stringa seguente Oggi è lunedì 30 maggio nella cella.

Nella formula, "Oggi è " include un spazio prima delle virgolette di chiusura per fornire lo spazio vuoto necessario tra Oggi è e lunedì 30 maggio. Se non si racchiude il testo tra virgolette, la formula potrebbe restituire un errore #NOME?.

Non annidare più di 64 funzioni in una formula

È possibile combinare (o annidare) fino a 64 livelli di funzioni in una formula.

La formula =SE(RADQ(PI.GRECO())<2,"Minore di due!","Maggiore di due!") ad esempio, presenta 3 livelli di funzioni: La funzione PI.GRECO è annidata all'interno della funzione RADQ, che, a sua volta, è annidata all'interno della funzione SE.

Evitare di dividere valori numerici per zero

La divisone di una cella per un'altra cella che contiene il valore zero (0) o nessun valore restituisce l'errore #DIV/0!.

Per evitare questo errore, annidare l'operazione di divisione all'interno della funzione SE.ERRORE. Immettere ad esempio le due formule seguenti nelle celle di un foglio di lavoro:

=SE.ERRORE(3/0,0)

=SE.ERRORE(3/7,0)

La prima formula restituisce 0 dal momento che la funzione SE.ERRORE riconosce che dividendo per zero si ottiene un errore. La seconda formula restituisce il valore 3/7 senza alcun errore, in quanto non si divide per zero.

Per semplificare la creazione delle formule, vedere anche questi trucchi e suggerimenti relativi alle formule.

Nota : Dichiarazione di non responsabilità per la traduzione automatica: Il presente articolo è stato tradotto tramite un software di traduzione automatica e non da una persona. Microsoft offre le traduzioni automatiche per consentire a coloro che non conoscono la lingua inglese di leggere gli articoli sui prodotti, sui servizi e sulle tecnologie Microsoft. Dal momento che l'articolo è stato tradotto automaticamente, potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli.

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×