Come correggere un errore #VALORE! nelle funzioni INDICE/CONFRONTA

Questo argomento illustra gli scenari comuni in cui viene restituito l'errore #VALORE! quando si usano le funzioni INDICE E CONFRONTA contemporaneamente in una formula. La combinazione di INDICE e CONFRONTA viene usata spesso quando si vuole cercare un valore in uno scenario in cui non è possibile usare CERCA.VERT, ad esempio quando il valore di ricerca ha più di 255 caratteri.

Problema: La formula non è stata immessa come matrice

Se si usa INDICE come formula di matrice insieme a CONFRONTA per recuperare un valore, è necessario convertire la formula in una formula di matrice, in caso contrario viene visualizzato un errore #VALORE!.

Soluzione: INDICE e CONFRONTA devono essere usati come una formula di matrice, quindi è necessario premere CTRL+MAIUSC+INVIO. La formula viene inserita automaticamente tra parentesi graffe {}. Se si prova a immettere la formula manualmente, Excel la visualizza come testo.

Se si usa INDICE/CONFRONTA quando si ha un valore di ricerca con più di 255 caratteri, è necessario immetterlo come formula di matrice.  La formula nella cella F3 è =INDICE(B2:B4,CONFRONTA(VERO,A2:A4=F2,0),0) e viene immessa premendo Ctrl+MAIUSC+INVIO
INDICE e CONFRONTA devono essere usati come una formula di matrice

Domande su funzioni specifiche?

Pubblicare una domanda nel forum della community di Excel

Suggerimenti per migliorare Excel

Si hanno suggerimenti su come migliorare la prossima versione di Excel? In questo caso, guardare gli argomenti in Excel User Voice.

Vedere anche

Correggere un errore #VALORE!

Funzione INDICE

Funzione CONFRONTA

Cercare i valori con CERCA.VERT, INDICE o CONFRONTA

Panoramica delle formule in Excel

Come evitare errori nelle formule

Usare il controllo degli errori per correggere errori comuni nelle formule

Tutte le funzioni di Excel (in ordine alfabetico)

Tutte le funzioni di Excel (per categoria)

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×