Come correggere un errore #VALORE! nella funzione SOMMA.SE/SOMMA.PIÙ.SE

Questo argomento elenca le cause più comuni dell'errore #VALORE! nelle funzioni SOMMA.SE e SOMMA.PIÙ.SE e descrive come risolverle.

Problema: La formula fa riferimento alle celle in una cartella di lavoro chiusa

Le funzioni SOMMA.SE/SOMMA.PIÙ.SE che fanno riferimento a una cella o a un intervallo in una cartella di lavoro chiusa restituiscono un errore #VALORE!.

Nota: Si tratta di un problema già riscontrato in diverse altre funzioni di Excel, ad esempio CONTA.SE, CONTA.PIÙ.SE e CONTA.VUOTE. Per altre informazioni, vedere l'articolo Le funzioni SOMMA.SE, CONTA.SE e CONTA.VUOTE restituiscono un errore "#VALORE!".

Soluzione: Aprire la cartella di lavoro indicata nella formula, quindi premere F9 per aggiornare la formula.

Per risolvere il problema si possono usare anche le funzioni SOMMA e SE insieme in una formula di matrice. Per altre informazioni, vedere l'articolo Le funzioni SOMMA.SE, CONTA.SE e CONTA.VUOTE restituiscono un errore #VALORE!.

Problema: La stringa criteri contiene più di 255 caratteri

Le funzioni SOMMA.SE/SOMMA.PIÙ.SE restituisce risultati non corretti se viene usata per la corrispondenza di stringhe lunghe più di 255 caratteri.

Soluzione: Se possibile, accorciare la stringa. Se non può essere accorciata, usare la funzione CONCATENA o l'operatore e commerciale (&) per suddividere il valore in più stringhe. Ad esempio:

=SOMMA.SE(B2:B12;"stringa lunga"&"altra stringa lunga")

Problema: in SOMMA.PIÙ.SE l'argomento intervallo_criteri non è coerente con l'argomento int_somma.

Gli argomenti di intervallo devono essere sempre gli stessi in SOMMA.PIÙ.SE. Ciò significa che gli argomenti intervallo_criteri e int_somma devono fare riferimento allo stesso numero di righe e colonne.

Nell'esempio seguente la formula deve restituire la somma delle vendite giornaliere di "mele" a Bellevue. L'argomento int_somma (C2: C10) però non corrisponde al numero di righe e colonne negli argomenti intervallo_criteri (A2: A12 & B2:B12). L'uso della sintassi =SOMMA.PIÙ.SE(C2:C10,A2:A12,A14,B2:B12,B14) restituisce l'errore #VALORE!.

La formula non corretta è =SOMMA.PIÙ.SE(C2:C10,A2:A12,A14,B2:B12,B14), dove C2:C10 deve essere C2:C12
Nella funzione SOMMA.PIÙ.SE intervallo_criteri deve essere coerente con int_somma

Soluzione: In base a questo esempio, cambiare int_somma in C2:C12 e riprovare la formula.

Nota :  SOMMA.SE può usare intervalli di dimensioni diverse.

Domande su funzioni specifiche?

Pubblicare una domanda nel forum della community di Excel

Suggerimenti per migliorare Excel

Si hanno suggerimenti su come migliorare la prossima versione di Excel? In questo caso, guardare gli argomenti in Excel User Voice.

Vedere anche

Correggere un errore #VALORE!

Funzione SOMMA.SE

Funzione SOMMA.PIÙ.SE

Video sulle funzioni SE avanzate

Panoramica delle formule in Excel

Come evitare errori nelle formule

Usare il controllo degli errori per correggere errori comuni nelle formule

Tutte le funzioni di Excel (in ordine alfabetico)

Tutte le funzioni di Excel (per categoria)

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×