Come correggere un errore #VALORE! nella funzione MEDIA o SOMMA

Se MEDIA o SOMMA fa riferimento a celle che contengono errori #VALORE!, le formule restituiscono un errore #VALORE!.

Errore #VALORE! in MEDIA

Per ignorare i valori di errore, viene costruita una formula che ignora gli errori nell'intervallo riferimento durante il calcolo della media con i valori "normali" restanti.

Per risolvere questo scenario, viene usata una combinazione di MEDIA e SE più VAL.ERROREper determinare se è presente un errore nell'intervallo specificato. Questo specifico scenario richiede una formula di matrice:

=MEDIA(SE(VAL.ERRORE(B2:D2),"",B2:D2))

Nota : Si tratta di una formula di matrice e deve essere immessa con CTRL+MAIUSC+INVIO. Excel inserisce automaticamente la formula tra parentesi graffe {}. Se si prova a immettere la formula manualmente, Excel la visualizza come testo.

Funzione di matrice in MEDIA per risolvere l'errore #VALORE!

Nota : La funzione precedente non funziona solo per #VALORE!, ma anche per #N/D, #NULLO, #DIV/0! e altre funzioni.

È possibile usare SOMMA in modo analogo:

=SOMMA(SE(VAL.ERRORE(B2:D2),"",B2:D2))

Domande su funzioni specifiche?

Pubblicare una domanda nel forum della community di Excel

Suggerimenti per migliorare Excel

Si hanno suggerimenti su come migliorare la prossima versione di Excel? In questo caso, guardare gli argomenti in Excel User Voice.

Vedere anche

Correggere un errore #VALORE!

Funzione MEDIA

Funzione SOMMA

Panoramica delle formule in Excel

Come evitare errori nelle formule

Usare il controllo degli errori per correggere errori comuni nelle formule

Tutte le funzioni di Excel (in ordine alfabetico)

Tutte le funzioni di Excel (per categoria)

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa al programma Office Insider

Queste informazioni sono risultate utili?

Grazie per i tuoi commenti e suggerimenti

Grazie per il tuo feedback! Potrebbe essere utile metterti in contatto con uno dei nostri operatori del supporto di Office.

×